Subject: Re: [Apn] The official instructions on the next step of APN

From: [email-masked]<[email-masked]>
Date: Thu, 4 Feb 2021 11:32:32 +0800 (GMT+08:00)

It's good news that APN can be fully discussed in rtg and intarea' meetings.

There have been many drafts of APN technology and scenarios. As an operator, we think APN is valuable and worthy of discussion and progress.

Regards,

Peng Liu(CMCC)

---Original---

From: "Pengshuping (Peng Shuping)"<[email-masked]>

Date: Thu, Feb 4, 2021 09:39 AM

To: "[email-masked]"<[email-masked]>;

Cc: "[email-masked]"<[email-masked]>;"[email-masked]"<[email-masked]>;

Subject: [Apn] The official instructions on the next step of APN

Dear all,

You may have seen the BoF announcement
https://www.ietf.org/blog/ietf110-bofs/.

The instructions on the next step of APN are officially confirmed,

1.
Presentations and discussions in the RTGWG and INTAREA meetings at IETF110.

2.
A virtual interim meeting of the RTGWG to be scheduled after IETF110 to
go into more depth on this topic.

Any suggestions on how to have fruitful discussions and progress the work in IETF are very welcomed. Thank you!

“The Application-Aware Networking (APN) BOF proposal was focused on developing a framework and set of mechanisms to derive, convey, and use an identifier to allow for the signaling
of fine-grained user-, application-, and service-level requirements at the network layer. This proposal was made for several previous IETF meetings and will benefit from further focused discussion at IETF 110 during the Routing Area Working Group (RTGWG)
and Internet Area Working Group (INTAREA) meetings. A virtual interim
meeting of the RTGWG to be scheduled after IETF 110 will go into more depth on this topic. Discussion continues on the Application-aware
Networking mailing list. ”

Best regards,

Shuping

---

From: Gyan Mishra <[email-masked]>
Date: Wed, 3 Feb 2021 23:16:23 -0500

Hi Shuping

I agree that APN has critical applicability for operators for 5G, DETNET
and even any public or private multicast MVPN streaming video content so
does have quite extensive applicability for operators.
There also maybe private SR  use cases for special SLA application flows
value added service.

As for productive discussions to move the ball forward with APN BOF, I do
agree with having discussions where network operators can share their
experiences and how APN can benefit so in that light as you stated IntArea
and RTGWG are a good start.
GROW maybe useful for in the global internet routing context and how APN
can play a role.

I think DETNET would be good for applicability statement,  and Spring, 6MAN
and TEAS maybe good from a APN architecture and design framework as APN
leverages IPv6 data plane EH headers and utilizes traffic steering SRv6
forwarding plane and also gets into 5G network slicing so then TEAS comes
into play and NS network slicing architecture.

I would be happy to present APN architecture and applicability at IETF 110.

Kind Regards

Gyan

On Wed, Feb 3, 2021 at 10:34 PM [email-masked] <
[email-masked]> wrote:

> There have been many drafts of APN technology and scenarios. As an
> operator, we think APN is valuable and worthy of discussion and progress.
>
> Regards,
> Peng Liu(CMCC)
>
> ---Original---
> *From:* "Pengshuping (Peng Shuping)"<[email-masked]>
> *Date:* Thu, Feb 4, 2021 09:39 AM
> *To:* "[email-masked]"<[email-masked]>;
> *Cc:* "[email-masked]"<[email-masked]>;"[email-masked]"<
> [email-masked]>;
> *Subject:* [Apn] The official instructions on the next step of APN
>
> Dear all,
>
>
>
> 1.      Presentations and discussions in the RTGWG and INTAREA meetings
> at IETF110.
>
> 2.      A virtual interim meeting of the RTGWG to be scheduled after
> IETF110 to go into more depth on this topic.
>
>
>
> “The Application-Aware Networking (APN) BOF proposal was focused on
> developing a framework and set of mechanisms to derive, convey, and use an
> identifier to allow for the signaling of fine-grained user-, application-,
> and service-level requirements at the network layer. This proposal was made
> for several previous IETF meetings and will benefit from further focused
> discussion at IETF 110 during the Routing Area Working Group (RTGWG
> <https://datatracker.ietf.org/wg/rtgwg/about/>) and Internet Area Working
> Group (INTAREA <https://datatracker.ietf.org/wg/intarea/about/>)
> meetings. A virtual interim meeting of the RTGWG to be scheduled after IETF
> 110 will go into more depth on this topic. Discussion continues on the Application-aware
> Networking <https://www.ietf.org/mailman/listinfo/apn> mailing list. ”
>
>
>
> Best regards,
>
> Shuping
>
>
> --
> Apn mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/apn
>
-- 

<http://www.verizon.com/>

*Gyan Mishra*

*Network Solutions A**rchitect *

*M 301 502-134713101 Columbia Pike *Silver Spring, MD

---

From: "Pengshuping (Peng Shuping)" <[email-masked]>
Date: Fri, 5 Feb 2021 10:15:04 +0000

Dear Gyan,

Truly appreciate your support on APN! It has been great to have you on board. Thank you very much!

We would need to discuss more on how to have productive discussions in these groups and collect feedback so to keep this work progressing.

What would be desired to be heard in these presentations and discussed in the meetings? Suggestions are very welcomed.

Best regards,
Shuping

From: Gyan Mishra [mailto:[email-masked]]
Sent: Thursday, February 4, 2021 12:16 PM
To: [email-masked]
Cc: Pengshuping (Peng Shuping) <[email-masked]>; [email-masked]; [email-masked]; [email-masked]
Subject: Re: [Apn] The official instructions on the next step of APN

Hi Shuping

I agree that APN has critical applicability for operators for 5G, DETNET and even any public or private multicast MVPN streaming video content so does have quite extensive applicability for operators.
There also maybe private SR  use cases for special SLA application flows value added service.

As for productive discussions to move the ball forward with APN BOF, I do agree with having discussions where network operators can share their experiences and how APN can benefit so in that light as you stated IntArea and RTGWG are a good start.
GROW maybe useful for in the global internet routing context and how APN can play a role.

I think DETNET would be good for applicability statement,  and Spring, 6MAN and TEAS maybe good from a APN architecture and design framework as APN leverages IPv6 data plane EH headers and utilizes traffic steering SRv6 forwarding plane and also gets into 5G network slicing so then TEAS comes into play and NS network slicing architecture.

Kind Regards

Gyan

On Wed, Feb 3, 2021 at 10:34 PM [email-masked]<mailto:[email-masked]> <[email-masked]<mailto:[email-masked]>> wrote:
It's good news that APN can be fully discussed in rtg and intarea' meetings.

Regards,
Peng Liu(CMCC)

---Original---
From: "Pengshuping (Peng Shuping)"<[email-masked]<mailto:[email-masked]>>
Date: Thu, Feb 4, 2021 09:39 AM
To: "[email-masked]<mailto:[email-masked]>"<[email-masked]<mailto:[email-masked]>>;
Cc: "[email-masked]<mailto:[email-masked]>"<[email-masked]<mailto:[email-masked]>>;"[email-masked]<mailto:[email-masked]>"<[email-masked]<mailto:[email-masked]>>;
Subject: [Apn] The official instructions on the next step of APN

Dear all,

You may have seen the BoF announcement https://www.ietf.org/blog/ietf110-bofs/.

1.      Presentations and discussions in the RTGWG and INTAREA meetings at IETF110.

2.      A virtual interim meeting of the RTGWG to be scheduled after IETF110 to go into more depth on this topic.

“The Application-Aware Networking (APN) BOF proposal was focused on developing a framework and set of mechanisms to derive, convey, and use an identifier to allow for the signaling of fine-grained user-, application-, and service-level requirements at the network layer. This proposal was made for several previous IETF meetings and will benefit from further focused discussion at IETF 110 during the Routing Area Working Group (RTGWG<https://datatracker.ietf.org/wg/rtgwg/about/>) and Internet Area Working Group (INTAREA<https://datatracker.ietf.org/wg/intarea/about/>) meetings. A virtual interim meeting of the RTGWG to be scheduled after IETF 110 will go into more depth on this topic. Discussion continues on the Application-aware Networking<https://www.ietf.org/mailman/listinfo/apn> mailing list. ”

Best regards,
Shuping

--
Apn mailing list
[email-masked]<mailto:[email-masked]>
https://www.ietf.org/mailman/listinfo/apn
--

[图像已被发件人删除。]<http://www.verizon.com/>

Gyan Mishra

Network Solutions Architect

M 301 502-1347
13101 Columbia Pike
Silver Spring, MD

---

From: Gyan Mishra <[email-masked]>
Date: Tue, 9 Feb 2021 22:48:12 -0500

Hi Shuping

Welcome and much obliged to be part of the APN team!!

My throughs are that we would cater each
presentation based on the WG audience so let’s say for 6MAN we delve deep
into APN use of extension headers.

For Spring it would be about SR-TE steering path instantiation and related
caveats and maybe how to manage or extent trust for inter provider SR-TE
for network slice.

For TEAS we would discuss details of 5G and network slicing framework using
APN ID and steering.

Just a few examples

Kind Regards

Gyan

On Fri, Feb 5, 2021 at 5:15 AM Pengshuping (Peng Shuping) <
[email-masked]> wrote:

> We would need to discuss more on how to have productive discussions in
> these groups and collect feedback so to keep this work progressing.
>
>
>
> What would be desired to be heard in these presentations and discussed in
> the meetings? Suggestions are very welcomed.
>
>
>
> Best regards,
>
> Shuping
>
>
>
>
>
> *From:* Gyan Mishra [mailto:[email-masked]]
> *Sent:* Thursday, February 4, 2021 12:16 PM
> *To:* [email-masked]
> *Cc:* Pengshuping (Peng Shuping) <[email-masked]>; [email-masked];
> [email-masked]; [email-masked]
> *Subject:* Re: [Apn] The official instructions on the next step of APN
>
>
>
>
>
> Hi Shuping
>
>
>
> I think DETNET would be good for applicability statement,  and Spring,
> 6MAN and TEAS maybe good from a APN architecture and design framework as
> APN leverages IPv6 data plane EH headers and utilizes traffic steering SRv6
> *Network Solutions Architect *
>
>
>
> *M 301 502-1347 13101 Columbia Pike
> <https://www.google.com/maps/search/13101+Columbia+Pike?entry=gmail&source=g>
> *Silver Spring, MD
>
>
>
-- 

*Gyan Mishra*