Subject: The official instructions on the next step of APN

From: "Pengshuping (Peng Shuping)" <[email-masked]>
Date: Thu, 4 Feb 2021 01:39:59 +0000

Dear all,

You may have seen the BoF announcement https://www.ietf.org/blog/ietf110-bofs/.

The instructions on the next step of APN are officially confirmed,

1.      Presentations and discussions in the RTGWG and INTAREA meetings at IETF110.

2.      A virtual interim meeting of the RTGWG to be scheduled after IETF110 to go into more depth on this topic.

Any suggestions on how to have fruitful discussions and progress the work in IETF are very welcomed. Thank you!

"The Application-Aware Networking (APN) BOF proposal was focused on developing a framework and set of mechanisms to derive, convey, and use an identifier to allow for the signaling of fine-grained user-, application-, and service-level requirements at the network layer. This proposal was made for several previous IETF meetings and will benefit from further focused discussion at IETF 110 during the Routing Area Working Group (RTGWG<https://datatracker.ietf.org/wg/rtgwg/about/>) and Internet Area Working Group (INTAREA<https://datatracker.ietf.org/wg/intarea/about/>) meetings. A virtual interim meeting of the RTGWG to be scheduled after IETF 110 will go into more depth on this topic. Discussion continues on the Application-aware Networking<https://www.ietf.org/mailman/listinfo/apn> mailing list. "

Best regards,
Shuping

---

From: Linda Dunbar <[email-masked]>
Date: Thu, 4 Feb 2021 16:33:48 +0000

In my honor opinion, there are substantial solid work that IETF can tackle  in the control plane to securely coordinate labels between different network domains to ensure end to end services: such as between 5G Core to N6 IP network, between SDWAN to SR domain, etc.
 https://tools.ietf.org/html/draft-yiakoumis-network-tokens-02<https://nam11.safelinks.protection.outlook.com/?url=https%3A%2F%2Ftools.ietf.org%2Fhtml%2Fdraft-yiakoumis-network-tokens-02&data=04%7C01%7Clinda.dunbar%40futurewei.com%7C23dc952c0f004fca44f108d8c7ea2489%7C0fee8ff2a3b240189c753a1d5591fedc%7C1%7C0%7C637479155755370770%7CUnknown%7CTWFpbGZsb3d8eyJWIjoiMC4wLjAwMDAiLCJQIjoiV2luMzIiLCJBTiI6Ik1haWwiLCJXVCI6Mn0%3D%7C1000&sdata=IpJKDbh0yGT9FHdmdSckzds7DLZ%2F0Gc54EmcP%2BqPhqs%3D&reserved=0> is a good example. The approach proposed by the Network Tokens (JSON based Web token) might be overkill, but something along the line (but simpler) would be beneficial for end to end services.

If APN only wants to focus on the Data Plane, as suggested in the charter of construct another layer of label to data packets, then you have to utilize some existing control plane methods to negotiate the new label added between domains, such as  using the IPsec IKE method between controllers of the two domains to negotiate the labels used in the data plane

My two cents,

Linda Dunbar

From: Apn <[email-masked]> On Behalf Of Pengshuping (Peng Shuping)
Sent: Wednesday, February 3, 2021 7:40 PM
To: [email-masked]
Cc: [email-masked]; [email-masked]
Subject: [Apn] The official instructions on the next step of APN

Dear all,

You may have seen the BoF announcement https://www.ietf.org/blog/ietf110-bofs/<https://nam11.safelinks.protection.outlook.com/?url=https%3A%2F%2Fwww.ietf.org%2Fblog%2Fietf110-bofs%2F&data=04%7C01%7Clinda.dunbar%40futurewei.com%7C998966795ad742395fef08d8c8add1b4%7C0fee8ff2a3b240189c753a1d5591fedc%7C1%7C0%7C637479996194394347%7CUnknown%7CTWFpbGZsb3d8eyJWIjoiMC4wLjAwMDAiLCJQIjoiV2luMzIiLCJBTiI6Ik1haWwiLCJXVCI6Mn0%3D%7C2000&sdata=vYjunysuIAErFot%2BYXsykNTj%2Fqvgk5oQWhj2bWcU8Pg%3D&reserved=0>.

"The Application-Aware Networking (APN) BOF proposal was focused on developing a framework and set of mechanisms to derive, convey, and use an identifier to allow for the signaling of fine-grained user-, application-, and service-level requirements at the network layer. This proposal was made for several previous IETF meetings and will benefit from further focused discussion at IETF 110 during the Routing Area Working Group (RTGWG<https://nam11.safelinks.protection.outlook.com/?url=https%3A%2F%2Fdatatracker.ietf.org%2Fwg%2Frtgwg%2Fabout%2F&data=04%7C01%7Clinda.dunbar%40futurewei.com%7C998966795ad742395fef08d8c8add1b4%7C0fee8ff2a3b240189c753a1d5591fedc%7C1%7C0%7C637479996194404343%7CUnknown%7CTWFpbGZsb3d8eyJWIjoiMC4wLjAwMDAiLCJQIjoiV2luMzIiLCJBTiI6Ik1haWwiLCJXVCI6Mn0%3D%7C2000&sdata=hzWsSNh5BxKL1rLb0Wpd7R2tBeSQGKEWZLSIJKR24Q4%3D&reserved=0>) and Internet Area Working Group (INTAREA<https://nam11.safelinks.protection.outlook.com/?url=https%3A%2F%2Fdatatracker.ietf.org%2Fwg%2Fintarea%2Fabout%2F&data=04%7C01%7Clinda.dunbar%40futurewei.com%7C998966795ad742395fef08d8c8add1b4%7C0fee8ff2a3b240189c753a1d5591fedc%7C1%7C0%7C637479996194414329%7CUnknown%7CTWFpbGZsb3d8eyJWIjoiMC4wLjAwMDAiLCJQIjoiV2luMzIiLCJBTiI6Ik1haWwiLCJXVCI6Mn0%3D%7C2000&sdata=Sq9D5m8ys%2Bgz45%2BfHe5UBV%2FrE%2BB1LCOtu6zz3O6Bl4M%3D&reserved=0>) meetings. A virtual interim meeting of the RTGWG to be scheduled after IETF 110 will go into more depth on this topic. Discussion continues on the Application-aware Networking<https://nam11.safelinks.protection.outlook.com/?url=https%3A%2F%2Fwww.ietf.org%2Fmailman%2Flistinfo%2Fapn&data=04%7C01%7Clinda.dunbar%40futurewei.com%7C998966795ad742395fef08d8c8add1b4%7C0fee8ff2a3b240189c753a1d5591fedc%7C1%7C0%7C637479996194414329%7CUnknown%7CTWFpbGZsb3d8eyJWIjoiMC4wLjAwMDAiLCJQIjoiV2luMzIiLCJBTiI6Ik1haWwiLCJXVCI6Mn0%3D%7C2000&sdata=N3UPU12AAtzIxbi145KaIGoAqIdfO1JPQFuDyVBacFQ%3D&reserved=0> mailing list. "

Best regards,
Shuping