Subject: Application-Aware Networking (APN) focused interim

From: Jeff Tantsura <[email-masked]>
Date: Thu, 6 May 2021 15:37:44 -0700

Dear RTGWG,

We have scheduled Application-Aware Networking (APN) focused interim (agenda to be published), June 3rd, 2021, 7:00AM PST

Looking forward to seeing you,

Cheers,
Jeff and Chris
>
>
> When it's time, start your Webex meeting here.
>
>
> Thursday, June 3, 2021
> 7:00 AM  |  (UTC-07:00) Pacific Time (US & Canada)  |  2 hrs
>
> Start meeting
>
> More ways to join:
>
> Join from the meeting link
> https://ietf.webex.com/ietf/j.php?MTID=mc8ee2b80cb0fdd92745199a121f452db
>
> Join by meeting number
> Meeting number (access code): 161 149 3477
> Meeting password: gpN26drAet4
>
> Tap to join from a mobile device (attendees only)
> +1-650-479-3208,,1611493477## Call-in toll number (US/Canada)
>
> Join by phone
> 1-650-479-3208 Call-in toll number (US/Canada)
> Global call-in numbers
>
> Join from a video system or application
> Dial [email-masked]
> You can also dial 173.243.2.68 and enter your meeting number.
>
> Join using Microsoft Lync or Microsoft Skype for Business
> Dial [email-masked]
>
> If you are a host, click here to view host information.
>
> Need help? Go to https://help.webex.com
>

---

From: "Pengshuping (Peng Shuping)" <[email-masked]>
Date: Tue, 25 May 2021 03:56:42 +0000

Hi Gyan, folks,

Thank you for your suggestions! Besides the guiding slides for the solution discussions, we will also have a set of slides for the problem statement to clarify the WHY.

According to the feedback we have received so far, we have updated the main drafts to sync the information.

The main changes we have made to the drafts are as follows:

1. Removed the application-side solution, only keep the network-side solution

2. The APN attribute is acquired based on the existing information in the packet header such as 5-tuple and QinQ (S-VLAN and C-VLAN) at the edge devices of the APN domain, added to the data packets along with the tunnel encapsulation.

3. When the packets leave the APN domain, the attribute will be removed together with the tunnel encapsulation header.

4. APN aims to apply various policies in different nodes along a network path onto a traffic flow altogether, for example, at the headend to steer into corresponding path, at the midpoint to collect corresponding performance measurement data, and at the service function to execute particular policies.

https://datatracker.ietf.org/doc/html/draft-li-apn-framework-03

https://datatracker.ietf.org/doc/html/draft-li-apn-problem-statement-usecases-02

https://datatracker.ietf.org/doc/html/draft-peng-apn-scope-gap-analysis-02

https://datatracker.ietf.org/doc/html/draft-peng-apn-security-privacy-consideration-01

Your reviews and comments are very welcomed. Thank you!

Best regards,
Shuping

From: Apn [mailto:[email-masked]] On Behalf Of Gyan Mishra
Sent: Saturday, May 22, 2021 6:39 AM
To: Pengshuping (Peng Shuping) <[email-masked]>
Cc: [email-masked]; 6MAN <[email-masked]>; Routing Area Working Group <[email-masked]>; [email-masked]
Subject: Re: [Apn] FW: Application-Aware Networking (APN) focused interim

Hi Shuping & APN WG

I agree as well that the agenda looks good and many thanks to the RTGWG for providing a time slot to host the discussion.

I support the basic concept of the gap APN is trying to solve and provide fine grain SLA for primary use case of 5G network slicing.

Traditionally and historically customer SLA been provided using Diffserv QOS Marking and PHB scheduling as well as customer application layer SLA using RSVP TE class or path based tunnel selection DS TE RFC 4124 and RFC 3270 MPLS Diffserv uniform and pipe mode explicit null framework to meet customer SLA requirements.  Also ALTO / SDN PCE / PCE CC based network based application flow optimizations of flows as well as ACTN abstraction framework for underlay path resource provisioning.

As an agenda item I think it maybe a good idea to briefly touch on the problem statement and the gap that requires a solution based on  existing technologies and solutions that exist today.

Also applicability of the APN ID fine grain SLA for 5G network slicing, DETNET, SD WAN as well as any other use cases.

As we have discussed caveats and complexity related to host to network signaling that it makes sense to update the existing drafts to reflect application edge CE based network marking of the APN ID.   Also, as the APN ID marking as we have discussed will change  to network layer marking on the application edge CE, how does the marking closely or not resemble the VTN ID marking in the data packet for VPN+ E2E network slicing.

This will help facilitate the discussion so we don’t get stuck on the complexity of host to network signaling.

Kind Regards

Gyan

On Thu, May 13, 2021 at 8:55 PM Pengshuping (Peng Shuping) <[email-masked]<mailto:[email-masked]>> wrote:
Dear all,

The APN Interim meeting has been scheduled on June 3rd. Please find the meeting information shared by the Chairs of the RTG WG below.

In this APN Interim meeting, we are going to focus more on the discussions of the solutions (more overview than details), including
1.       the design of the APN attribute itself
2.       the encapsulation of the APN attribute on the various data planes (the encapsulation on the IPv6 data plane is an example)
3.       the control plane protocols extensions for exchanging the APN attribute
4.       NETCONF/YANG models for the NBI and SBI

You are very welcomed to join the discussions, and your comments and suggestions are very much appreciated.

Thank you!

Best regards,
Shuping

From: rtgwg [mailto:[email-masked]<mailto:[email-masked]>] On Behalf Of Jeff Tantsura
Sent: Friday, May 7, 2021 6:38 AM
To: Routing WG <[email-masked]<mailto:[email-masked]>>; RTGWG <[email-masked]<mailto:[email-masked]>>
Subject: Application-Aware Networking (APN) focused interim

Dear RTGWG,

Cheers,
Jeff and Chris

Thursday, June 3, 2021

Start meeting<https://ietf.webex.com/ietf/j.php?MTID=mc8ee2b80cb0fdd92745199a121f452db>

More ways to join:

Join by meeting number

+1-650-479-3208,,1611493477##<tel:%2B1-650-479-3208,,*01*1611493477%23%23*01*> Call-in toll number (US/Canada)

Join by phone

Global call-in numbers<https://ietf.webex.com/ietf/globalcallin.php?MTID=m8fc024386f16ac264aaa306eeb5dff0c>

If you are a host, click here<https://ietf.webex.com/ietf/j.php?MTID=m6b0d9545f1c064a6aa8f7739e2d4c763> to view host information.

--
Apn mailing list
[email-masked]<mailto:[email-masked]>
https://www.ietf.org/mailman/listinfo/apn
--

[图像已被发件人删除。]<http://www.verizon.com/>

Gyan Mishra

Network Solutions Architect

Email [email-masked]<mailto:[email-masked]>

M 301 502-1347

---

From: Linda Dunbar <[email-masked]>
Date: Thu, 27 May 2021 17:02:46 +0000

Shuping and APN proponents,

https://datatracker.ietf.org/doc/draft-mcd-rtgwg-extension-tn-aware-mobility/ describes a framework to enable the IP network (over the 5G N6 interface) to be aware of the 5G UE traffic to achieve optimized transport aligning with the 5G Slices characteristics .
The proposed framework aligns with the APN scope of work described in the APN BoF description. Do you think it is worthwhile to add this draft to the APN interim meeting?

Thank you very much.
Linda Dunbar

From: Apn <[email-masked]> On Behalf Of Pengshuping (Peng Shuping)
Sent: Monday, May 24, 2021 10:57 PM
To: Gyan Mishra <[email-masked]>
Cc: [email-masked]; RTGWG <[email-masked]>; 6MAN <[email-masked]>; Routing Area Working Group <[email-masked]>; [email-masked]
Subject: Re: [Apn] FW: Application-Aware Networking (APN) focused interim

Hi Gyan, folks,

https://datatracker.ietf.org/doc/html/draft-li-apn-framework-03<https://nam11.safelinks.protection.outlook.com/?url=https%3A%2F%2Fdatatracker.ietf.org%2Fdoc%2Fhtml%2Fdraft-li-apn-framework-03&data=04%7C01%7Clinda.dunbar%40futurewei.com%7C2135160315e4459f633f08d91f312652%7C0fee8ff2a3b240189c753a1d5591fedc%7C1%7C0%7C637575118239682662%7CUnknown%7CTWFpbGZsb3d8eyJWIjoiMC4wLjAwMDAiLCJQIjoiV2luMzIiLCJBTiI6Ik1haWwiLCJXVCI6Mn0%3D%7C1000&sdata=NGn3A8uQEesRTdgDQK8R%2BrVUkMNquU3aDBmmes3WrCY%3D&reserved=0>

https://datatracker.ietf.org/doc/html/draft-li-apn-problem-statement-usecases-02<https://nam11.safelinks.protection.outlook.com/?url=https%3A%2F%2Fdatatracker.ietf.org%2Fdoc%2Fhtml%2Fdraft-li-apn-problem-statement-usecases-02&data=04%7C01%7Clinda.dunbar%40futurewei.com%7C2135160315e4459f633f08d91f312652%7C0fee8ff2a3b240189c753a1d5591fedc%7C1%7C0%7C637575118239682662%7CUnknown%7CTWFpbGZsb3d8eyJWIjoiMC4wLjAwMDAiLCJQIjoiV2luMzIiLCJBTiI6Ik1haWwiLCJXVCI6Mn0%3D%7C1000&sdata=734J6KBv7Hc3RqqaBCUVKaqPjAs9gwtbfilyntCPVy4%3D&reserved=0>

https://datatracker.ietf.org/doc/html/draft-peng-apn-scope-gap-analysis-02<https://nam11.safelinks.protection.outlook.com/?url=https%3A%2F%2Fdatatracker.ietf.org%2Fdoc%2Fhtml%2Fdraft-peng-apn-scope-gap-analysis-02&data=04%7C01%7Clinda.dunbar%40futurewei.com%7C2135160315e4459f633f08d91f312652%7C0fee8ff2a3b240189c753a1d5591fedc%7C1%7C0%7C637575118239692621%7CUnknown%7CTWFpbGZsb3d8eyJWIjoiMC4wLjAwMDAiLCJQIjoiV2luMzIiLCJBTiI6Ik1haWwiLCJXVCI6Mn0%3D%7C1000&sdata=KFh4OhC07Z5X9RkaNY%2FkQtyMQ1H6xNa19q8SLwEuF%2FY%3D&reserved=0>

https://datatracker.ietf.org/doc/html/draft-peng-apn-security-privacy-consideration-01<https://nam11.safelinks.protection.outlook.com/?url=https%3A%2F%2Fdatatracker.ietf.org%2Fdoc%2Fhtml%2Fdraft-peng-apn-security-privacy-consideration-01&data=04%7C01%7Clinda.dunbar%40futurewei.com%7C2135160315e4459f633f08d91f312652%7C0fee8ff2a3b240189c753a1d5591fedc%7C1%7C0%7C637575118239692621%7CUnknown%7CTWFpbGZsb3d8eyJWIjoiMC4wLjAwMDAiLCJQIjoiV2luMzIiLCJBTiI6Ik1haWwiLCJXVCI6Mn0%3D%7C1000&sdata=oA6OkUf04E6uKIQY2hDYNPgAqta0TeyRYHxcmoQNUJM%3D&reserved=0>

Best regards,
Shuping

From: Apn [mailto:[email-masked]] On Behalf Of Gyan Mishra
Sent: Saturday, May 22, 2021 6:39 AM
To: Pengshuping (Peng Shuping) <[email-masked]<mailto:[email-masked]>>
Cc: [email-masked]<mailto:[email-masked]>; 6MAN <[email-masked]<mailto:[email-masked]>>; Routing Area Working Group <[email-masked]<mailto:[email-masked]>>; [email-masked]<mailto:[email-masked]>
Subject: Re: [Apn] FW: Application-Aware Networking (APN) focused interim

Hi Shuping & APN WG

This will help facilitate the discussion so we don't get stuck on the complexity of host to network signaling.

Kind Regards

Gyan

Thank you!

Best regards,
Shuping

Dear RTGWG,

Cheers,
Jeff and Chris

Thursday, June 3, 2021

Start meeting<https://nam11.safelinks.protection.outlook.com/?url=https%3A%2F%2Fietf.webex.com%2Fietf%2Fj.php%3FMTID%3Dmc8ee2b80cb0fdd92745199a121f452db&data=04%7C01%7Clinda.dunbar%40futurewei.com%7C2135160315e4459f633f08d91f312652%7C0fee8ff2a3b240189c753a1d5591fedc%7C1%7C0%7C637575118239692621%7CUnknown%7CTWFpbGZsb3d8eyJWIjoiMC4wLjAwMDAiLCJQIjoiV2luMzIiLCJBTiI6Ik1haWwiLCJXVCI6Mn0%3D%7C1000&sdata=ezf9qTDC7bUS%2BpO1kN8I%2B%2BfS5t5hxUgI0uu2mBGU6Y8%3D&reserved=0>

More ways to join:

Join from the meeting link
https://ietf.webex.com/ietf/j.php?MTID=mc8ee2b80cb0fdd92745199a121f452db<https://nam11.safelinks.protection.outlook.com/?url=https%3A%2F%2Fietf.webex.com%2Fietf%2Fj.php%3FMTID%3Dmc8ee2b80cb0fdd92745199a121f452db&data=04%7C01%7Clinda.dunbar%40futurewei.com%7C2135160315e4459f633f08d91f312652%7C0fee8ff2a3b240189c753a1d5591fedc%7C1%7C0%7C637575118239702578%7CUnknown%7CTWFpbGZsb3d8eyJWIjoiMC4wLjAwMDAiLCJQIjoiV2luMzIiLCJBTiI6Ik1haWwiLCJXVCI6Mn0%3D%7C1000&sdata=ZcGHZwMbAl87dhDV6krdBTGBO%2F5n5P3kA33xRN8tBUs%3D&reserved=0>

Join by meeting number

Join by phone
1-650-479-3208 Call-in toll number (US/Canada)
Global call-in numbers<https://nam11.safelinks.protection.outlook.com/?url=https%3A%2F%2Fietf.webex.com%2Fietf%2Fglobalcallin.php%3FMTID%3Dm8fc024386f16ac264aaa306eeb5dff0c&data=04%7C01%7Clinda.dunbar%40futurewei.com%7C2135160315e4459f633f08d91f312652%7C0fee8ff2a3b240189c753a1d5591fedc%7C1%7C0%7C637575118239702578%7CUnknown%7CTWFpbGZsb3d8eyJWIjoiMC4wLjAwMDAiLCJQIjoiV2luMzIiLCJBTiI6Ik1haWwiLCJXVCI6Mn0%3D%7C1000&sdata=JLdqvHmkDVDqrFzS6cZF6YU0MC7rsIvdgwayi1JbgEA%3D&reserved=0>

Join from a video system or application
Dial [email-masked]<mailto:[email-masked]>
You can also dial 173.243.2.68 and enter your meeting number.

Join using Microsoft Lync or Microsoft Skype for Business
Dial [email-masked]<mailto:[email-masked]>

If you are a host, click here<https://nam11.safelinks.protection.outlook.com/?url=https%3A%2F%2Fietf.webex.com%2Fietf%2Fj.php%3FMTID%3Dm6b0d9545f1c064a6aa8f7739e2d4c763&data=04%7C01%7Clinda.dunbar%40futurewei.com%7C2135160315e4459f633f08d91f312652%7C0fee8ff2a3b240189c753a1d5591fedc%7C1%7C0%7C637575118239702578%7CUnknown%7CTWFpbGZsb3d8eyJWIjoiMC4wLjAwMDAiLCJQIjoiV2luMzIiLCJBTiI6Ik1haWwiLCJXVCI6Mn0%3D%7C1000&sdata=m%2B7PX7dQ2j42%2FkurgECqI0dPYtasuIQ4hoTiEniOE30%3D&reserved=0> to view host information.

Need help? Go to https://help.webex.com<https://nam11.safelinks.protection.outlook.com/?url=https%3A%2F%2Fhelp.webex.com%2F&data=04%7C01%7Clinda.dunbar%40futurewei.com%7C2135160315e4459f633f08d91f312652%7C0fee8ff2a3b240189c753a1d5591fedc%7C1%7C0%7C637575118239712535%7CUnknown%7CTWFpbGZsb3d8eyJWIjoiMC4wLjAwMDAiLCJQIjoiV2luMzIiLCJBTiI6Ik1haWwiLCJXVCI6Mn0%3D%7C1000&sdata=76kh2QvvAO6d9pnfHXcj54X3Iv%2FR2mAd5Gyj08Y7uLo%3D&reserved=0>

--
Apn mailing list
[email-masked]<mailto:[email-masked]>
https://www.ietf.org/mailman/listinfo/apn<https://nam11.safelinks.protection.outlook.com/?url=https%3A%2F%2Fwww.ietf.org%2Fmailman%2Flistinfo%2Fapn&data=04%7C01%7Clinda.dunbar%40futurewei.com%7C2135160315e4459f633f08d91f312652%7C0fee8ff2a3b240189c753a1d5591fedc%7C1%7C0%7C637575118239712535%7CUnknown%7CTWFpbGZsb3d8eyJWIjoiMC4wLjAwMDAiLCJQIjoiV2luMzIiLCJBTiI6Ik1haWwiLCJXVCI6Mn0%3D%7C1000&sdata=0irNAbnOJtZ7a9mN%2BbBMYFaEVmM6iGSIf5uIw4rZTKY%3D&reserved=0>
--

[??????????]<https://nam11.safelinks.protection.outlook.com/?url=http%3A%2F%2Fwww.verizon.com%2F&data=04%7C01%7Clinda.dunbar%40futurewei.com%7C2135160315e4459f633f08d91f312652%7C0fee8ff2a3b240189c753a1d5591fedc%7C1%7C0%7C637575118239722487%7CUnknown%7CTWFpbGZsb3d8eyJWIjoiMC4wLjAwMDAiLCJQIjoiV2luMzIiLCJBTiI6Ik1haWwiLCJXVCI6Mn0%3D%7C1000&sdata=PDZnAGGzpo7DUlRbK2m12WK5cHXTinPaVCSxvRxOycM%3D&reserved=0>

Gyan Mishra

M 301 502-1347

---

From: Michael Richardson <[email-masked]>
Date: Thu, 27 May 2021 12:33:46 -0400

On 2021-05-06 6:37 p.m., Jeff Tantsura wrote:
> Dear RTGWG,
> 
> We have scheduled Application-Aware Networking (APN) focused interim 
> (agenda to be published), June 3rd, 2021, 7:00AM PST

Hi, I'm glad that we are having this meeting.
I saw the APN presentations (in recording) at the SECDISPATCH and SAAG, 
I think it was.

I've been through the documents, and I think that they get lost in the 
weeds.  What is confusing people, particularly security people, is that 
we simply don't have a model as to how any of this is supposed to work.
As someone who has mostly ignored "5G", but who survived the 
"revolution" that was ATM, then diffserv/diffedge, then the MPLS 
revolution, I feel justified in ignoring the huge oversell that is 5G.

Let me explain why all these things failed to increase operator incomes.
(Did they reduce complexity for some entities? Sure. Did it offer new 
ways of provisioning networks that weren't available before? Sometimes)

Lack of financial model.  Inherit with this is a TRUST MODEL that 
includes senders, receivers, requestors and responders.
(Senders transmit data. Requestors ask for data to be sent)
In my relationship with, for instance, Netflix, I'm:
   a) the receiver of the data
   b) the requestor of the data
Netflix is:
   c) the sender of the data
   d) the responder to my request

For the operator to get more revenue from me, I have to have a way to 
give them more money, or a way for me to indicate to the sender of the 
data that I requested, a way to give the operator money for new 
services.  (Netflix never pays for the traffic in the end, because I pay 
them.  This is far more obvious if this is e2e game traffic, or webrtc 
pandemic conference traffic)

Most of the security questions about whether the *application* or the 
*kernel* (of the smartphone), or the Home/LTE/5G router or the 5G tower, 
etc. is doing some signaling into some 5G thingy... (I'll call it a "VC" 
in ATM speak, because really, it shows why this is a 25+ year failure)

It has all failed due to layer-9 issues.

I still can't ask, (during pandemic) for my carrier or ISP to prioritize 
traffic that *I* care about for an extra fee.  Anything that involves 
the ISP or carrier "guessing" is a fail thanks to
   1) invasion or privacy
   2) Net Neutrality
   3) QUIC <-- largely a response to failures of (1) and (2)

Diffserv's "diffedge" (never published as an RFC, alas) got closest to 
being real.  Windows2000 had an API apparently.  Specifically, it had a 
way for an application to ask the kernel for additional services.  That 
failed in the market, because really it had no place to connect to an 
"operator" ...

Fundamentally, this goes back to the fact that we continue to design 
networks which are either anonymous or stateful.  The end-to-end 
principal says keep the state out of the core, and this keeps winning 
each time we add a zero to core network speed (now with Gbps at the 
end).  Meanwhile, the telco/mobile space keeps adding more and more 
state that has to be connected to some identity. (IMEI/SIM/etc.)

We need a situation in the middle where the network actually says who it 
is to the end-systems, and indicates, via authenticated communication 
between "middle box"en and end system that the middle box exists, and 
what services it can offer... "for you my friend? special deal!"

Said middle boxes are in quote, because they aren't NATs, and they don't 
throttle or firewall traffic, but they can be taught to remark in 
various directions.

diffedge did this with RSVP, but back in 1998, the secure communication 
on top of that that is required to establish trust sufficient to enable 
exchange of currency was just too much for people.

I'm writing this now, a week ahead of the virtual interim in the hope 
that the proponents will go back to their slides and refocus their 
effort into explaining to the security and routing people what your 
goals are.

---

From: "Pengshuping (Peng Shuping)" <[email-masked]>
Date: Fri, 28 May 2021 03:08:14 +0000

Hi Michael, 

Thank you for your insights shared and comments although these comments seem to be for the presentations in the last IETF and the old versions of the drafts. Thanks to the feedback we received from the presentations last time, we have further updated the drafts and narrowed down the scope. 

1. We have removed the application-side solution, only keep the network-side solution. This should have solved your concerns. Basically we are only focusing on the network. 

The latest version of the drafts:
https://datatracker.ietf.org/doc/html/draft-li-apn-framework-03 
https://datatracker.ietf.org/doc/html/draft-li-apn-problem-statement-usecases-03
https://datatracker.ietf.org/doc/html/draft-peng-apn-scope-gap-analysis-02 
https://datatracker.ietf.org/doc/html/draft-peng-apn-security-privacy-consideration-01 

Best regards, 
Shuping 

> -----Original Message-----
> From: rtgwg [mailto:[email-masked]] On Behalf Of Michael
> Richardson
> Sent: Friday, May 28, 2021 12:34 AM
> To: [email-masked]
> Subject: Re: Application-Aware Networking (APN) focused interim
> 
> I saw the APN presentations (in recording) at the SECDISPATCH and SAAG, I
> think it was.
> 
> I've been through the documents, and I think that they get lost in the weeds.
> What is confusing people, particularly security people, is that we simply
> don't have a model as to how any of this is supposed to work.
> As someone who has mostly ignored "5G", but who survived the "revolution"
> that was ATM, then diffserv/diffedge, then the MPLS revolution, I feel
> justified in ignoring the huge oversell that is 5G.
> 
> (Did they reduce complexity for some entities? Sure. Did it offer new ways of
> provisioning networks that weren't available before? Sometimes)
> 
> Lack of financial model.  Inherit with this is a TRUST MODEL that includes
> senders, receivers, requestors and responders.
> (Senders transmit data. Requestors ask for data to be sent) In my
> relationship with, for instance, Netflix, I'm:
> For the operator to get more revenue from me, I have to have a way to give
> them more money, or a way for me to indicate to the sender of the data that
> I requested, a way to give the operator money for new services.  (Netflix
> never pays for the traffic in the end, because I pay them.  This is far more
> obvious if this is e2e game traffic, or webrtc pandemic conference traffic)
> 
> I still can't ask, (during pandemic) for my carrier or ISP to prioritize traffic
> that *I* care about for an extra fee.  Anything that involves the ISP or
> carrier "guessing" is a fail thanks to
>    1) invasion or privacy
>    2) Net Neutrality
> Diffserv's "diffedge" (never published as an RFC, alas) got closest to being
> real.  Windows2000 had an API apparently.  Specifically, it had a way for
> an application to ask the kernel for additional services.  That failed in the
> market, because really it had no place to connect to an "operator" ...
> 
> networks which are either anonymous or stateful.  The end-to-end principal
> says keep the state out of the core, and this keeps winning each time we add
> a zero to core network speed (now with Gbps at the end).  Meanwhile, the
> telco/mobile space keeps adding more and more state that has to be
> connected to some identity. (IMEI/SIM/etc.)
> 
> We need a situation in the middle where the network actually says who it is
> to the end-systems, and indicates, via authenticated communication
> throttle or firewall traffic, but they can be taught to remark in various
> directions.
> 
> diffedge did this with RSVP, but back in 1998, the secure communication on
> top of that that is required to establish trust sufficient to enable exchange of
> currency was just too much for people.
> 
> I'm writing this now, a week ahead of the virtual interim in the hope that the
> proponents will go back to their slides and refocus their effort into
> explaining to the security and routing people what your goals are.
> 
> _______________________________________________
> rtgwg mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/rtgwg

---

From: Lizhenbin <[email-masked]>
Date: Fri, 28 May 2021 04:10:15 +0000

Hi Linda,
Thanks very much for your proposal. I have following comments for your reference:
1. The coming APN interim meeting will focus on the solution discussion including the forwarding plane (IPv6-based and MPLS-based) encapsulation, the possible control protocols (IGP/BGP/PCEP) extension and YANG models.
2. We have changed the scope of APN to focus on the network-side solution and updates the related drafts accordingly. I am a little doubtful that the solution in your draft is still related with the case to tag the information in the application side. Even if not, because most of the GTP-u work is under the scope of 3GPP instead of IETF, it may be not a right time to discuss the encapsulation of APN attributes with the GTP-u tunnel now. We should focus on the IETF-based tunnel technologies firstly.

Best Regards,
Robin

From: Linda Dunbar [mailto:[email-masked]]
Sent: Friday, May 28, 2021 1:03 AM
To: Pengshuping (Peng Shuping) <[email-masked]>; Gyan Mishra <[email-masked]>
Cc: [email-masked]; RTGWG <[email-masked]>; 6MAN <[email-masked]>; Routing Area Working Group <[email-masked]>; [email-masked]
Subject: RE: [Apn] FW: Application-Aware Networking (APN) focused interim

Thank you very much.
Linda Dunbar

From: Apn <[email-masked]<mailto:[email-masked]>> On Behalf Of Pengshuping (Peng Shuping)
Sent: Monday, May 24, 2021 10:57 PM
To: Gyan Mishra <[email-masked]<mailto:[email-masked]>>
Cc: [email-masked]<mailto:[email-masked]>; RTGWG <[email-masked]<mailto:[email-masked]>>; 6MAN <[email-masked]<mailto:[email-masked]>>; Routing Area Working Group <[email-masked]<mailto:[email-masked]>>; [email-masked]<mailto:[email-masked]>
Subject: Re: [Apn] FW: Application-Aware Networking (APN) focused interim

Hi Gyan, folks,

Best regards,
Shuping

Hi Shuping & APN WG

Kind Regards

Gyan

Thank you!

Best regards,
Shuping

Dear RTGWG,

Cheers,
Jeff and Chris

Thursday, June 3, 2021

More ways to join:

Join by meeting number

Join by phone

Gyan Mishra

M 301 502-1347

---

From: "Majumdar, Kausik" <[email-masked]>
Date: Fri, 28 May 2021 06:41:05 +0000

Hi Robin,

Sure, make sense you & the team focus more on the APN specific items in the RTG interim meeting. Anyway, the draft Linda pointed out - that we have presented in IETF 109 and the next revision we are going to present in the upcoming IETF 111. Hence we don't a slot in the interim meeting, you can focus on the APN specific agenda.

Though, let me clarify your second comment regarding the draft-mcd-rtgwg-extension-tn-aware-mobility draft that Linda pointed earlier. This draft purely focuses on the Data Network side. Yes, it does extend the network characteristics (based on the DMM draft draft-ietf-dmm-tn-aware-mobility-00) from the Mobile Network to the Data Network. But the focus for this draft is mainly Data Network.

This draft extends the different network slices corresponding to the different SSTs (like EMBB, URLLC, MIOT) from the Mobile Network to the Data Network based on the UDP Source Port range. It defines the control and data plane mapping well for different SSTs with different SR-TE-based mechanisms (like BGP SR-TE, PCEP, SR FlowSpec, SR-TE RestConf/GRPC, etc.). Besides that, it extends the framework for the Enterprise 5G specific SD-WAN use cases as well.

I guess where we think there is some synergy between this solution and the APN framework on how we bring UE/user or application-specific slice/flow within each of the different SSTs mentioned above.

Think about it this way, the different SSTs/Network Characteristics map to Fat Network slices or Highways in the Data Network. But once UE starts using different UDP Source Ports from the Slice specific range it is pretty much the same way you are planning to insert User/Application traffic from the APN Edge Node. You are planning to approach based on 5-tuple, VLAN tagging whereas original dmm-tn-aware-mobility draft can use UDP Source Port can to define User/Application traffic. Either approach will finally create several lanes within each Network Slice Highway created by the rtgwg-extension-tn-aware-mobility Draft.

Hope it clarifies any confusion on what Linda pointed out earlier. In that sense, there might be some synergy to work together between what has been defined in our draft with your current APN work. We would be happy to work with you and the team offline if you think that might be useful down the road. Either way, in this interim please go ahead based on your plan. We can connect to explore further the collaboration of both works.

Regards,
Kausik

From: Apn <[email-masked]> On Behalf Of Lizhenbin
Sent: Thursday, May 27, 2021 9:10 PM
To: Linda Dunbar <[email-masked]>; Pengshuping (Peng Shuping) <[email-masked]>; Gyan Mishra <[email-masked]>
Cc: [email-masked]; 6MAN <[email-masked]>; Routing Area Working Group <[email-masked]>; [email-masked]; RTGWG <[email-masked]>
Subject: Re: [Apn] FW: Application-Aware Networking (APN) focused interim

Hi Linda, Thanks very much for your proposal. I have following comments for your reference: 1. The coming APN interim meeting will focus on the solution discussion including the forwarding plane (IPv6
External ([email-masked]<mailto:[email-masked]>)
  Report This Email<https://shared.outlook.inky.com/report?id=Y29tbXNjb3BlL2thdXNpay5tYWp1bWRhckBjb21tc2NvcGUuY29tL2JkZTczYWE1YzRjOTdlYzUxY2I4NTgwYjdhNGMyMWZmLzE2MjIxNzUwNDEuOTg=#key=d23efd1c7b3ec6823bb0ae52c737a5a0>  FAQ<https://www.inky.com/banner-faq/>  Protection by INKY<https://www.inky.com>

Hi Linda,

Best Regards,
Robin

To: Pengshuping (Peng Shuping) <[email-masked]<mailto:[email-masked]>>; Gyan Mishra <[email-masked]<mailto:[email-masked]>>

https://datatracker.ietf.org/doc/draft-mcd-rtgwg-extension-tn-aware-mobility/<https://secure-web.cisco.com/1Ly8sIyYWhXsB_NV2gTmaM87sW0zAgNJwMNtFcPt5-TtcWGncq0Pb1ySWpT5KZY5yeB5PUn3bEsbAQeyhXbpmKM6YWagPm2GDPgS1fsBrzaDdaY-00ECU0QxeJtK8AeVas7kJWjMrT29ixHMEmOBH2ioFYVil0H_sRrceHvmklSMZ7rvCq3lbPVwS7FXcFmpuVnKoX-HrMHkfWSDg_zxzcYvKAkHRlVKEeJ8-6phIdMTy_GIctX6MFYbLICn3kKaMcdFP4JRrTv4MthYZXNyQhojVuhBgBpQT0fT7do5bNJIuiC6SA4YqDmjg2oKAcfQZ/https%3A%2F%2Fdatatracker.ietf.org%2Fdoc%2Fdraft-mcd-rtgwg-extension-tn-aware-mobility%2F> describes a framework to enable the IP network (over the 5G N6 interface) to be aware of the 5G UE traffic to achieve optimized transport aligning with the 5G Slices characteristics .
The proposed framework aligns with the APN scope of work described in the APN BoF description. Do you think it is worthwhile to add this draft to the APN interim meeting?

Thank you very much.
Linda Dunbar

Hi Gyan, folks,

Best regards,
Shuping

Hi Shuping & APN WG

Kind Regards

Gyan

Thank you!

Best regards,
Shuping

Dear RTGWG,

Cheers,
Jeff and Chris

Thursday, June 3, 2021

More ways to join:

Join by meeting number

Join by phone

Gyan Mishra

M 301 502-1347

---

From: Linda Dunbar <[email-masked]>
Date: Fri, 28 May 2021 15:17:53 +0000

Robin,

No problem.

Just to clarify that the draft is about IPv6/MPLS forwarding and BGP control of the IP network outside the 3GPP network (circled by the RED dotted line), but utilizing the traffic marking (such as UDP port or others) carried out by the UPF, as depicted in below. But it is totally okay not to include this discussion at the APN  BOF.

Linda

From: Lizhenbin <[email-masked]>
Sent: Thursday, May 27, 2021 11:10 PM
To: Linda Dunbar <[email-masked]>; Pengshuping (Peng Shuping) <[email-masked]>; Gyan Mishra <[email-masked]>
Cc: [email-masked]; RTGWG <[email-masked]>; 6MAN <[email-masked]>; Routing Area Working Group <[email-masked]>; [email-masked]
Subject: RE: [Apn] FW: Application-Aware Networking (APN) focused interim

Hi Linda,

Best Regards,
Robin

https://datatracker.ietf.org/doc/draft-mcd-rtgwg-extension-tn-aware-mobility/<https://nam11.safelinks.protection.outlook.com/?url=https%3A%2F%2Fdatatracker.ietf.org%2Fdoc%2Fdraft-mcd-rtgwg-extension-tn-aware-mobility%2F&data=04%7C01%7Cldunbar%40futurewei.com%7C5bb653a80a95469a16e008d9218e8201%7C0fee8ff2a3b240189c753a1d5591fedc%7C1%7C0%7C637577718234489185%7CUnknown%7CTWFpbGZsb3d8eyJWIjoiMC4wLjAwMDAiLCJQIjoiV2luMzIiLCJBTiI6Ik1haWwiLCJXVCI6Mn0%3D%7C1000&sdata=vgVz3HbwUgsDYIoerglRbDuHb4aLfdBRBb71LaCOE4A%3D&reserved=0> describes a framework to enable the IP network (over the 5G N6 interface) to be aware of the 5G UE traffic to achieve optimized transport aligning with the 5G Slices characteristics .
The proposed framework aligns with the APN scope of work described in the APN BoF description. Do you think it is worthwhile to add this draft to the APN interim meeting?

Thank you very much.
Linda Dunbar

Hi Gyan, folks,

https://datatracker.ietf.org/doc/html/draft-li-apn-framework-03<https://nam11.safelinks.protection.outlook.com/?url=https%3A%2F%2Fdatatracker.ietf.org%2Fdoc%2Fhtml%2Fdraft-li-apn-framework-03&data=04%7C01%7Cldunbar%40futurewei.com%7C5bb653a80a95469a16e008d9218e8201%7C0fee8ff2a3b240189c753a1d5591fedc%7C1%7C0%7C637577718234494159%7CUnknown%7CTWFpbGZsb3d8eyJWIjoiMC4wLjAwMDAiLCJQIjoiV2luMzIiLCJBTiI6Ik1haWwiLCJXVCI6Mn0%3D%7C1000&sdata=P%2B7NBuHagyKSe7G02ftvC4Ax0K7Hx69seEWlvEpILJk%3D&reserved=0>

https://datatracker.ietf.org/doc/html/draft-li-apn-problem-statement-usecases-02<https://nam11.safelinks.protection.outlook.com/?url=https%3A%2F%2Fdatatracker.ietf.org%2Fdoc%2Fhtml%2Fdraft-li-apn-problem-statement-usecases-02&data=04%7C01%7Cldunbar%40futurewei.com%7C5bb653a80a95469a16e008d9218e8201%7C0fee8ff2a3b240189c753a1d5591fedc%7C1%7C0%7C637577718234499138%7CUnknown%7CTWFpbGZsb3d8eyJWIjoiMC4wLjAwMDAiLCJQIjoiV2luMzIiLCJBTiI6Ik1haWwiLCJXVCI6Mn0%3D%7C1000&sdata=O26sC8FiMrFfozH07MVudeKrou8Be8b7o%2FGj7PJo5aw%3D&reserved=0>

https://datatracker.ietf.org/doc/html/draft-peng-apn-scope-gap-analysis-02<https://nam11.safelinks.protection.outlook.com/?url=https%3A%2F%2Fdatatracker.ietf.org%2Fdoc%2Fhtml%2Fdraft-peng-apn-scope-gap-analysis-02&data=04%7C01%7Cldunbar%40futurewei.com%7C5bb653a80a95469a16e008d9218e8201%7C0fee8ff2a3b240189c753a1d5591fedc%7C1%7C0%7C637577718234504118%7CUnknown%7CTWFpbGZsb3d8eyJWIjoiMC4wLjAwMDAiLCJQIjoiV2luMzIiLCJBTiI6Ik1haWwiLCJXVCI6Mn0%3D%7C1000&sdata=hWe2a9CtNC6rZ6CrE20HcCGi%2B7Rk1odEft93MRqVI4I%3D&reserved=0>

https://datatracker.ietf.org/doc/html/draft-peng-apn-security-privacy-consideration-01<https://nam11.safelinks.protection.outlook.com/?url=https%3A%2F%2Fdatatracker.ietf.org%2Fdoc%2Fhtml%2Fdraft-peng-apn-security-privacy-consideration-01&data=04%7C01%7Cldunbar%40futurewei.com%7C5bb653a80a95469a16e008d9218e8201%7C0fee8ff2a3b240189c753a1d5591fedc%7C1%7C0%7C637577718234509093%7CUnknown%7CTWFpbGZsb3d8eyJWIjoiMC4wLjAwMDAiLCJQIjoiV2luMzIiLCJBTiI6Ik1haWwiLCJXVCI6Mn0%3D%7C1000&sdata=HgbAaQdeIhNDIzCeuUpUxz0Z4s9ypC9%2BVCYj6C9PIs0%3D&reserved=0>

Best regards,
Shuping

Hi Shuping & APN WG

Kind Regards

Gyan

Thank you!

Best regards,
Shuping

Dear RTGWG,

Cheers,
Jeff and Chris

Thursday, June 3, 2021

Start meeting<https://nam11.safelinks.protection.outlook.com/?url=https%3A%2F%2Fietf.webex.com%2Fietf%2Fj.php%3FMTID%3Dmc8ee2b80cb0fdd92745199a121f452db&data=04%7C01%7Cldunbar%40futurewei.com%7C5bb653a80a95469a16e008d9218e8201%7C0fee8ff2a3b240189c753a1d5591fedc%7C1%7C0%7C637577718234514069%7CUnknown%7CTWFpbGZsb3d8eyJWIjoiMC4wLjAwMDAiLCJQIjoiV2luMzIiLCJBTiI6Ik1haWwiLCJXVCI6Mn0%3D%7C1000&sdata=ib1w3fnHp6beI%2B7wo9xu7ZAxImJmcxGB5Npn69U9w4I%3D&reserved=0>

More ways to join:

Join from the meeting link
https://ietf.webex.com/ietf/j.php?MTID=mc8ee2b80cb0fdd92745199a121f452db<https://nam11.safelinks.protection.outlook.com/?url=https%3A%2F%2Fietf.webex.com%2Fietf%2Fj.php%3FMTID%3Dmc8ee2b80cb0fdd92745199a121f452db&data=04%7C01%7Cldunbar%40futurewei.com%7C5bb653a80a95469a16e008d9218e8201%7C0fee8ff2a3b240189c753a1d5591fedc%7C1%7C0%7C637577718234519051%7CUnknown%7CTWFpbGZsb3d8eyJWIjoiMC4wLjAwMDAiLCJQIjoiV2luMzIiLCJBTiI6Ik1haWwiLCJXVCI6Mn0%3D%7C1000&sdata=kFqROIqVrh1I8mU9%2FZIzmQS0%2BSjzVAHBP9VNYLZaXzY%3D&reserved=0>

Join by meeting number

Join by phone
1-650-479-3208 Call-in toll number (US/Canada)
Global call-in numbers<https://nam11.safelinks.protection.outlook.com/?url=https%3A%2F%2Fietf.webex.com%2Fietf%2Fglobalcallin.php%3FMTID%3Dm8fc024386f16ac264aaa306eeb5dff0c&data=04%7C01%7Cldunbar%40futurewei.com%7C5bb653a80a95469a16e008d9218e8201%7C0fee8ff2a3b240189c753a1d5591fedc%7C1%7C0%7C637577718234524026%7CUnknown%7CTWFpbGZsb3d8eyJWIjoiMC4wLjAwMDAiLCJQIjoiV2luMzIiLCJBTiI6Ik1haWwiLCJXVCI6Mn0%3D%7C1000&sdata=hrFOik2qU5O9HcIu5sNMNwBkrXBdnia1IRGz67K3OlU%3D&reserved=0>

If you are a host, click here<https://nam11.safelinks.protection.outlook.com/?url=https%3A%2F%2Fietf.webex.com%2Fietf%2Fj.php%3FMTID%3Dm6b0d9545f1c064a6aa8f7739e2d4c763&data=04%7C01%7Cldunbar%40futurewei.com%7C5bb653a80a95469a16e008d9218e8201%7C0fee8ff2a3b240189c753a1d5591fedc%7C1%7C0%7C637577718234524026%7CUnknown%7CTWFpbGZsb3d8eyJWIjoiMC4wLjAwMDAiLCJQIjoiV2luMzIiLCJBTiI6Ik1haWwiLCJXVCI6Mn0%3D%7C1000&sdata=JO%2Fv6jcGJgsocsQD%2FB6ge9uS0GnlXEno43%2BizPNXVpI%3D&reserved=0> to view host information.

Need help? Go to https://help.webex.com<https://nam11.safelinks.protection.outlook.com/?url=https%3A%2F%2Fhelp.webex.com%2F&data=04%7C01%7Cldunbar%40futurewei.com%7C5bb653a80a95469a16e008d9218e8201%7C0fee8ff2a3b240189c753a1d5591fedc%7C1%7C0%7C637577718234529004%7CUnknown%7CTWFpbGZsb3d8eyJWIjoiMC4wLjAwMDAiLCJQIjoiV2luMzIiLCJBTiI6Ik1haWwiLCJXVCI6Mn0%3D%7C1000&sdata=o%2BevfpwU9nXxAVgsYjEfhTCUW%2BBaEEd7p%2BKJMyXFZgc%3D&reserved=0>

--
Apn mailing list
[email-masked]<mailto:[email-masked]>
https://www.ietf.org/mailman/listinfo/apn<https://nam11.safelinks.protection.outlook.com/?url=https%3A%2F%2Fwww.ietf.org%2Fmailman%2Flistinfo%2Fapn&data=04%7C01%7Cldunbar%40futurewei.com%7C5bb653a80a95469a16e008d9218e8201%7C0fee8ff2a3b240189c753a1d5591fedc%7C1%7C0%7C637577718234533985%7CUnknown%7CTWFpbGZsb3d8eyJWIjoiMC4wLjAwMDAiLCJQIjoiV2luMzIiLCJBTiI6Ik1haWwiLCJXVCI6Mn0%3D%7C1000&sdata=t3ezIPobJx%2F0wAuWf5JDqNYpN9bSuTzxVoWVYmROvrI%3D&reserved=0>
--

[??????????]<https://nam11.safelinks.protection.outlook.com/?url=http%3A%2F%2Fwww.verizon.com%2F&data=04%7C01%7Cldunbar%40futurewei.com%7C5bb653a80a95469a16e008d9218e8201%7C0fee8ff2a3b240189c753a1d5591fedc%7C1%7C0%7C637577718234538962%7CUnknown%7CTWFpbGZsb3d8eyJWIjoiMC4wLjAwMDAiLCJQIjoiV2luMzIiLCJBTiI6Ik1haWwiLCJXVCI6Mn0%3D%7C1000&sdata=i4LHBMFKH%2F7Yzw3l0QX6%2BtHeH1aRQcRSAbvKdaaI3zI%3D&reserved=0>

Gyan Mishra

M 301 502-1347

---

From: "Pengshuping (Peng Shuping)" <[email-masked]>
Date: Sat, 29 May 2021 00:50:38 +0000

Hi Linda, Kausik,

Many thanks for the clarifications. Let's have a dedicated discussion to clear things out.

Just a few quick points regarding the key updates on the scope of the APN work,

1.       The APN attribute is NOT tagged by the applications.

2.       The APN attribute is tagged at the edge devices of an APN domain, called as APN-Edge.

3.       The APN attribute is constructed based on the existing information in the packet header, such as QinQ and/or 5-tuple, and encapsulated in the tunnel header. Once the tunnel is terminated, the APN attribute will be removed together with the tunnel header at the tunnel endpoint.

4.       The GTP-u is one of the use cases of APN, please see the latest version of the problem statement draft. Just the encapsulation extensions of itself belongs to 3GPP, so we may first focus on the IETF encapsulation technologies.

Hope these points help.

Thank you for your interest and support of the work! Please continue to joining the discussions and your contributions are really appreciated.

Best regards,
Shuping

From: Linda Dunbar [mailto:[email-masked]]
Sent: Friday, May 28, 2021 11:18 PM
To: Lizhenbin <[email-masked]>; Pengshuping (Peng Shuping) <[email-masked]>; Gyan Mishra <[email-masked]>
Cc: [email-masked]; RTGWG <[email-masked]>; 6MAN <[email-masked]>; Routing Area Working Group <[email-masked]>; [email-masked]
Subject: RE: [Apn] FW: Application-Aware Networking (APN) focused interim

Robin,

No problem.

Linda

From: Lizhenbin <[email-masked]<mailto:[email-masked]>>
Sent: Thursday, May 27, 2021 11:10 PM
To: Linda Dunbar <[email-masked]<mailto:[email-masked]>>; Pengshuping (Peng Shuping) <[email-masked]<mailto:[email-masked]>>; Gyan Mishra <[email-masked]<mailto:[email-masked]>>
Cc: [email-masked]<mailto:[email-masked]>; RTGWG <[email-masked]<mailto:[email-masked]>>; 6MAN <[email-masked]<mailto:[email-masked]>>; Routing Area Working Group <[email-masked]<mailto:[email-masked]>>; [email-masked]<mailto:[email-masked]>
Subject: RE: [Apn] FW: Application-Aware Networking (APN) focused interim

Hi Linda,

Best Regards,
Robin

Thank you very much.
Linda Dunbar

Hi Gyan, folks,

Best regards,
Shuping

Hi Shuping & APN WG

Kind Regards

Gyan

Thank you!

Best regards,
Shuping

Dear RTGWG,

Cheers,
Jeff and Chris

Thursday, June 3, 2021

More ways to join:

Join by meeting number

Join by phone

Gyan Mishra

M 301 502-1347