Subject: Re: [Scsn] IEEE-1588v2.1 performance monitoring

From: Jiangyuanlong <[email-masked]>
Date: Wed, 2 Mar 2016 07:45:40 +0000

Hi Rodney,

It is great that IEEE 1588 has begun to consider the problem in the performance monitoring and diagnostics. It is definitely an important topic for a large scale synchronization network.
One interesting problem may arise, does SyncE have the same issue? If yes, do we need to consider a universal solution?

Thanks,
Yuanlong

Dear SCSN members,

There is an ongoing revision to the IEEE-1588 standard in progress, which is projected to be v2.1 (i.e. compatible to 1588-2008, aka 2.0). The 1588 revision is still in an early draft stage, with several proposals under discussion.

At least three proposals for 1588 v2.1 relate to the topic of performance monitoring and diagnostics. Subscribers to this mailing list may be interested in those proposals, so I am posting information to SCSN.

If you are not already a member of IEEE-1588, you will need to join in order to view draft proposals. The process is simple, described in:
            https://ieee-sa.imeetcentral.com/1588public

Some proposals under discussion in 1588 include:

Proposal for performance statistics that are accessed using management:
            https://ieee-sa.imeetcentral.com/1588/file/43837060
Proposal for clock to send its local performance measurements in a Signaling message
            https://ieee-sa.imeetcentral.com/1588/file/43739452
Proposal for a TLV that accumulates accuracy information along path from GM to slave
            https://ieee-sa.imeetcentral.com/1588/folder/3240750/#folder:7032049

Thanks
Rodney Cummings
IEEE-1588 Architecture Subcommittee Co-chair

Yuanlong

---

From: "Romascanu, Dan (Dan)" <[email-masked]>
Date: Wed, 2 Mar 2016 10:17:15 +0000

Hi,

If we are considering 'a universal solution' it may be good to involve the IPPM and BMWG working groups as well. 

Regards,

Dan

> -----Original Message-----
> From: Scsn [mailto:[email-masked]] On Behalf Of Jiangyuanlong
> Sent: Wednesday, March 02, 2016 9:46 AM
> To: [email-masked]
> Cc: [email-masked]
> Subject: Re: [Scsn] IEEE-1588v2.1 performance monitoring
> 
> Hi Rodney,
> 
> It is great that IEEE 1588 has begun to consider the problem in the
> performance monitoring and diagnostics. It is definitely an important topic
> for a large scale synchronization network.
> One interesting problem may arise, does SyncE have the same issue? If yes,
> do we need to consider a universal solution?
> 
> Thanks,
> Yuanlong
> 
> 
> >>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>
> Dear SCSN members,
> 
> There is an ongoing revision to the IEEE-1588 standard in progress, which is
> projected to be v2.1 (i.e. compatible to 1588-2008, aka 2.0). The 1588 revision
> is still in an early draft stage, with several proposals under discussion.
> 
> At least three proposals for 1588 v2.1 relate to the topic of performance
> monitoring and diagnostics. Subscribers to this mailing list may be interested
> in those proposals, so I am posting information to SCSN.
>

---

From: Jiangyuanlong <[email-masked]>
Date: Wed, 2 Mar 2016 13:42:56 +0000

Hi Dan,

Thanks for following up this discussion. Actually we are open to any solutions that make sense.
If sync info can be regarded as IP flow, yes, IPPM and BMWG seem to be good candidate protocols.

Cheers,
Yuanlong

> From: Romascanu, Dan (Dan) [mailto:[email-masked]]
> Sent: Wednesday, March 02, 2016 6:17 PM
> To: Jiangyuanlong; [email-masked]
> Cc: [email-masked]
> Subject: RE: [Scsn] IEEE-1588v2.1 performance monitoring
> 
> Hi,
>