Subject: Does SSH run over NAT??

From: Charles Chen <[email-masked]>
Date: Fri, 27 Apr 2001 12:18:30 -0700

I have a question with regard to SSH.
Assume that we have a gateway which does
network address and port translation (NAT).
The gateway works for telnet. Is there any 
problem if we run SSH on top of a telnet session
in this case?

Charles

---

From: [email-masked] (Niels M�ller)
Date: 30 Apr 2001 15:17:12 +0200

> problem if we run SSH on top of a telnet session

It should work fine, I'm doing it right now.

(Of course there are lots of ways to shoot oneself or others in the
feet when using NAT, but SSH shouldn't be harder than telnet or http).

/Niels