Subject: Re: new sftp draft gotta come soon: summary

From: Steve Suehring <[email-masked]>
Date: Tue, 28 Sep 2004 08:12:44 -0500

Was this draft ever released?  I don't see it on the WG's page on 
ietf.org.  

I'd like to get a new URI draft out there since it expired but would like 
to refer to the SFTP draft as well.

Steve

On Thu, Feb 05, 2004 at 07:59:10AM -0700, Jeff P. Van Dyke wrote:
> Mats,
> 
> I spoke to Joseph this week and I believe he's planning to have the
> revised draft out next week.
> 
> --Jeff
> 
> ----- Original Message ----- 
> From: "Mats Gustafsson C (LI/EAB)" <[email-masked]>
> To: "'Joseph Galbraith'" <[email-masked]>; <[email-masked]>
> Sent: Thursday, February 05, 2004 7:04 AM
> Subject: RE: new sftp draft gotta come soon: summary
> 
> 
> > Hi all,
> >
> > >From what I can see in the IETF archives, the SFTP draft is still expired. Is anyone working on getting an SFTP draft
> re-submitted? Right now we've got a situation where we have a widely deployed and used protocol but no specification to refer to ...
> >
> > BR
> > //Mats
> >
> > -----Original Message-----
> > From: Joseph Galbraith [mailto:[email-masked]]
> > Sent: den 5 september 2003 19:04
> > To: [email-masked]
> > Subject: new sftp draft gotta come soon: summary
> >
> > Well, the sftp draft has expired, so I guess I
> > can't let the priority of a revision keep getting
> > bumped down anymore :-)
> >
> > So, here are what I think of as open issues:
> >
> > - A bit or flag in the attribs to reflect if the
> >    file should be hidden.  (I was supposed to put
> >    this in last time, but didn't-- )
> >
> > - A bit or flag in the attribs to reflect 'readonly'
> >    status -- this readonly status is an advisory as
> >    opposed enforced readonly.  (Windows is the operating
> >    system that does this.)
> >
> > - A way to specify how to access the file during file
> >    open  (should match up with access modes in ACLs.)
> >
> >    Currently, it is hard to know with what access a file
> >    should be opened-- what if the client comes back and
> >    does a fsetstat and tries to write an ACL?
> >
> > - A way to control file sharing during file open (operating
> >    systems that don't support it ignore it?)
> >
> > - We never reached consensus about case-sensitivity.
> >    (See next email for details.)
> >
> > - Performance enhancments.  (See next email for details.)
> >
> > - Security considerations section
> >
> > - Normative vs. non-normative references
> >
> > - Change of sftp rename command (see next email for details)
> >
> > Are there any other issues that anyone wants fixed or flogged
> > to death to make sure everyone agrees?
> >
> > You are implementing and sftp server on the latest and greatest
> > bi-endian 1024-bit super-opper-dupper computer running your very
> > own custom operating system and you users want to be able to x
> > when they transfer files and sftp doesn't make it possible.
> >
> > You are implementing a filesystem redirector for you super-dupper
> > operating system and SFTP makes Z a very big pain for you.
> >
> > This is your last chance :-)  We're gonna ship this one and do last
> > call.
> >
> > Thanks,
> >
> > Joseph
> >
> > This communication is confidential and intended solely for the addressee(s). Any unauthorized review, use, disclosure or
> distribution is prohibited. If you believe this message has been sent to you in error, please notify the sender by replying to this
> transmission and delete the message without disclosing it. Thank you.
> >
> > E-mail including attachments is susceptible to data corruption, interruption, unauthorized amendment, tampering and viruses, and
> we only send and receive e-mails on the basis that we are not liable for any such corruption, interception, amendment, tampering or
> viruses or any consequences thereof.
> >
> >
> >

---

From: Joseph Galbraith <[email-masked]>
Date: Wed, 29 Sep 2004 08:44:47 -0600

I believe this was published and has since expired.  There
is a new draft on the horizon.

- Joseph