Subject: Re: Who's at fault here?

From: Jacob Nevins <[email-masked]>
Date: Sun, 13 Nov 2005 18:32:20 +0000

der Mouse writes:
> I'm seeing some logged gripes when using my client to connect to
> another implementation, and I think it's not my fault - but I want to
> check before treating this as someone else's bug.
  [snip]

FWIW, your reading looks fine to me.

---

From: Nicolas Williams <[email-masked]>
Date: Wed, 30 Nov 2005 19:29:39 -0600

On Fri, Oct 21, 2005 at 12:26:29AM -0400, der Mouse wrote:
> The thing is, the implementation I'm talking to (which is bannering as
> "SSH-1.99-OpenSSH_3.4 NetBSD_Secure_Shell-20020626") is logging
> "Received window adjust for non-open channel 0." in response to this.

This sort of thing can happen with "window-change" channel requests
received before the shell/exec/subsystem channel requests on the same
channel.

---

From: Joseph Galbraith <[email-masked]>
Date: Wed, 30 Nov 2005 21:30:51 -0700

> received before the shell/exec/subsystem channel requests on the same

But it shouldn't, should it?

My reading of the draft has always been it is legal to send a
window adjust any time the channel is open.

Wait... did you say "window-change" ?  As in the size of the
screen changed message.  Are you saying the error is ...
unclear ... and should really read "Received window-change
for non-open channel 0?" and it occurs because a "window-change"
was sent before pty has been allocated?

Thanks,

Joseph