Subject: Re: [Sigtran] (M2PA) LSPO and LSPR sent on stream 1 and LSPR used to re-synch resolves PO issue?

From: [email-masked]
Date: Wed, 15 Oct 2003 15:30:30 -0400

Hello Tom,

Don't let me stand in the way of 'progress'. By all means, proceed toward
RFC!

Regards,

Jeff

                      Tom George                                                                                                  
                      <Tom.George@alca         To:      [email-masked]                                                          
                      tel.com>                 cc:                                                                                
                      Sent by:                 Subject: Re: [Sigtran] (M2PA) LSPO and LSPR sent on stream 1 and LSPR used to      
                      sigtran-admin@ie         re-synch resolves PO issue?                                                        
                      tf.org                                                                                                      

                      10/15/03 10:49                                                                                              
                      AM                                                                                                          

Jeff,

The difference is that M2PA can ack messages during PO with empty User
Data messages. So a data ack message sent after other data ack messages
is not a good way to re-synch.

I intended for LS PO, LS PR, and LS Ready (after PO) to be sent on
stream 1.

Going back to the example I posted. If B does not send the LS Ready,
then after A sends the LS PR:

           LS PR FSN=6 BSN=13
           ------------------------->

A might then receive:

               User Data FSN=16 BSN=5  (empty) (1)
           <-------------------------
               User Data FSN=14 BSN=5          (2)
           <-------------------------

How does A know whether message (1) was sent before or after the LS PR?
How does A know whether message (2) is the resynch message, or is (1)
the resynch message and (2) just an out of order message? More to the
point, how does A decide what to do when it receives message (1) and it
has not had the chance to see (2) yet?

Having a different kind of message makes it easier for A to figure out
when B has resynched.

There is no periodic LSR or Ack. LSR is not sent until after LSPR, so it
would not be sent at all during PO. An Ack can be used to ack any
received messages, but there is no need for a periodic ack.

tomG.

[email-masked] wrote:
> Hello Tom,
>
> I don't see any distinction between FISU and MSU in the Q.703 SDLs
> for Processor Outage (Figure 8 sheets 12, 13, and 14).
>
> Can you explain why M2PA must be able to distinguish the LSR from an ACK?
> Will the LSR be sent on stream 0 or 1?
> Will the side receiving LSPO periodically send LSR/ACK until LSPR is
> received?
>
> Regards,
>
> Jeff
>
>
>
>
>                       Tom George
>                       <Tom.George@alca         To:      [email-masked]
>                       tel.com>                 cc:
>                       Sent by:                 Subject: Re: [Sigtran]
(M2PA) LSPO and LSPR sent on stream 1 and LSPR used to
>                       sigtran-admin@ie         re-synch resolves PO
issue?
>                       tf.org
>
>
>                       10/10/03 11:47
>                       AM
>
>
>
>
>
>
> Jeff,
>
> I think you need a different kind of message than the data ack message.
> If we used the data ack, how would the receiving M2PA tell the
> difference between a pre-resynch and post-resynch data ack? The example
> does not show them, but there can be data ack messages straggling in
> during the time between LS PR and the end of the resynch. If M2PA just
> looks for a different message type, it is relatively easy. There is no
> reason it _has_ to be the LS Ready message, but that one was handy. Or
> we could have made up a new one (Link Status Resynch?).
>
> M2PA can indeed ack during RPO. And M2PA can continue transmitting data
> (and acks) during LPO. I did not show this in the example, but I could
> modify it to show this.
>
> tomG.
>
> [email-masked] wrote:
>
>>Hello Tom,
>>
>>I suggest we use ACKs instead of LSRs, since the re-synch needs
>>to occur on the data stream (1). User data can also be used to re-synch.
>>Do you plan to address Andrew's suggestion that upon receiving LSPO,
>>M2PA begins to periodically send ACKs until receiving LSPR, thereby
>>hastening the re-synch?
>>
>>Regards,
>
>    [...]

--
* Tom George       PB7-24001 (near B-21)      [email-masked]  *
* 972-519-3168   Intranet:  http://www.ssd.usa.alcatel.com/~tgeorge/  *
*   I actively disclaim speaking for Alcatel.  I do not purport to    *
*   advertise or represent its position, operations, or activities.   *

_______________________________________________
Sigtran mailing list
[email-masked]
 https://www1.ietf.org/mailman/listinfo/sigtran

_______________________________________________
Sigtran mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/sigtran

---

From: Tom George <[email-masked]>
Date: Wed, 15 Oct 2003 15:05:42 -0500

Jeff,

Thanks. I will go ahead and insert the example in section 5, and release 
version 10.

tomG.