Subject: RE: [Sigtran] SUA v15: Parameter tags

From: "Barry Nagelberg" <[email-masked]>
Date: Thu, 2 Oct 2003 10:01:50 -0400

Hi Christophe,

It would be useful so that functionality that is common to SUA and M3UA -
for example handling of Network Appearance - could use the same subroutine,
without having to worry about the different param value.

Barry Nagelberg

-----Original Message-----
From: Anzile, Christophe [mailto:[email-masked]]
Sent: Thursday, October 02, 2003 9:30 AM
To: Barry Nagelberg; [email-masked]
Cc: [email-masked]
Subject: RE: [Sigtran] SUA v15: Parameter tags

Hi,

I totally disagree on this "would be helpful" one.
It is clear that :
- SUA has specific params mapped on 0x01??
- M3UA has specific params mapped on 0x02??
- M2UA has specific params mapped on 0x03??
and so on.

Why would it be useful to map SUA params on M3UA specific values ?

Note that xUA have general params mapped on 0x00?? (for the mo.)...
except that for instance :
Registration Result is 0x14 for SUA (and others UAs not RFCed yet) but
0x208 for M3UA (RFC!) and 0x30d for M2UA (RFC!)

So, what's the point to align SUA params on M3UA ones, as they are
not aligned to M2UA params (for instance) so far ?

Regards,
Christophe.

-----Original Message-----
From: Barry Nagelberg [mailto:[email-masked]]
Sent: Thursday, October 02, 2003 2:54 PM
To: [email-masked]
Subject: RE: [Sigtran] SUA v15: Parameter tags

John,

I agree with Brian that because M3UA is already an RFC, we probably don't
want to change the param values in M3UA. Thus it "would be helpful" if SUA
could conform to the M3UA values.

Barry Nagelberg

-----Original Message-----
From: [email-masked] [mailto:[email-masked]]
Sent: Thursday, October 02, 2003 5:57 AM
To: [email-masked]; [email-masked]
Cc: [email-masked]
Subject: RE: [Sigtran] SUA v15: Parameter tags

Hi all,

I am unsure what people want done for SUA.

John

> -----Original Message-----
> From: ext Brian F. G. Bidulock [mailto:[email-masked]]
> Sent: 16 September, 2003 21:22
> To: Barry Nagelberg
> Cc: SIGTRAN Mailing List
> Subject: Re: [Sigtran] SUA v15: Parameter tags
>
>
> Barry,
>
> M3UA wouldn't change and its a little late to change M3UA now.
>
> --brian
>
> Barry Nagelberg wrote:
>                        (Tue, 16 Sep 2003 14:13:21)
> > Can we standardize the parameter tag values across SUA and M3UA?
> > There are several common parameters that have different tag
> values, causing
> > unnecessary processing:
> >
> >                                  M3UA                 SUA
> >
> > Network Appearance               0x200                0x10d
> > User/Cause                       0x204                0x10c
> > Congestion Indications           0x205                0x118
> > Routing Key                      0x207                0x10e
> > Registration Result              0x208                0x0014
> > Deregistration Result            0x209                0x0015
> > Local Routing Key Identifier     0x20a		    0x0018
> > Registration Status              0x212                0x0016
> > Deregistration Status            0x213                0x0017
> >
> >

_______________________________________________
Sigtran mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/sigtran

---

From: "Anzile, Christophe" <[email-masked]>
Date: Thu, 2 Oct 2003 15:30:26 +0200

Hi,

Regards,
Christophe.

-----Original Message-----
From: Barry Nagelberg [mailto:[email-masked]]
Sent: Thursday, October 02, 2003 2:54 PM
To: [email-masked]
Subject: RE: [Sigtran] SUA v15: Parameter tags

John,

Barry Nagelberg

-----Original Message-----
From: [email-masked] [mailto:[email-masked]]
Sent: Thursday, October 02, 2003 5:57 AM
To: [email-masked]; [email-masked]
Cc: [email-masked]
Subject: RE: [Sigtran] SUA v15: Parameter tags

Hi all,

John

> --
> Brian F. G. Bidulock
> [email-masked]
> http://www.openss7.org/