Subject: Re: [siprec] #24: Can we defer specifying RS establishment in direction SRS to SRC?

From: Deepanshu Gautam <[email-masked]>
Date: Mon, 05 Jul 2010 17:52:19 +0800

Raj,

How do you define ownership? Does it mean SRC beloging to SRS? I'm sorry I
don’t quite understand the notion of master/sleve either in context of
SIPREC.
I was just trying to mention that RS establishment from SRS to SRC is
required, and addressing (which seems to be the concern) may be doable
considering the intra-domain deployments (which is the current systems
design) of SRS and SRC.

Regards
Deepanshu

-----Original Message-----
From: Jain, Rajnish [mailto:[email-masked]]
Sent: 2010年6月27日 18:29
To: Deepanshu Gautam; 'Paul Kyzivat'; 'siprec issue tracker'
Cc: [email-masked]
Subject: RE: [siprec] #24: Can we defer specifying RS establishment in
direction SRS to SRC?

Deepanshu,

The address resolution issue is not unique to SIPREC. We should be able to
leverage existing SIP mechanisms for that.

A fundamental premise behind SIPREC design is that SRC and SRS are peers
(not master/slave). SRC registering to SRS implies ownership. I think that
doesn't quite fit the problem space.

Raj

________________________________________
From: [email-masked] [[email-masked]] On Behalf Of
Deepanshu Gautam [[email-masked]]
Sent: Friday, June 25, 2010 10:56 PM
To: 'Paul Kyzivat'; 'siprec issue tracker'
Cc: [email-masked]
Subject: Re: [siprec] #24: Can we defer specifying RS establishment in
direction SRS to SRC?

Can SRC register (REGISTER) with SRS, irrespective of it location, while
loggin into the service?

Regards
Deepanshu

-----Original Message-----
From: [email-masked] [mailto:[email-masked]] On Behalf Of
Paul Kyzivat
Sent: 2010年6月25日 21:31
To: siprec issue tracker
Cc: [email-masked]
Subject: Re: [siprec] #24: Can we defer specifying RS establishment in
direction SRS to SRC?

Another complication of SRS establishing RC with SRC is that the SRS must
then know the address of the SRC. That may be easy in cases where the SRC is
collocated with a CS participant, but whether that is true depends how the
network is constructed.

(Of course going in the other direction requires the SRC to know the address
of the SRS. But that seems an easier problem.)

        Thanks,
        Paul

siprec issue tracker wrote:
> #24: Can we defer specifying RS establishment in direction SRS to SRC?
> ------------------------------------------------+---------------------
> ------------------------------------------------+------
>  Reporter:  john.elwell@…                       |       Owner:  krehor@…

>      Type:  defect                              |      Status:  new

>  Priority:  major                               |   Milestone:

> Component:  Requirements                        |     Version:

>  Severity:  Active WG Document                  |    Keywords:

> ------------------------------------------------+---------------------
> ------------------------------------------------+------
>  We have a requirement that it be possible to establish an RS in the
> direction SRS to SRC. This assumes that the SRS has access to data on
> which it can make a decision whether or not to record a CS (see
> ticket#23). Is it sufficient, at least for the first phase, to assume
> that  the same out-of-band (outside scope of SIPREC) means by which
> the SRS  learns about CSs being established can also be used to
> instruct the SRC to  initiate an RS? Or do we instead need to be able
> to initiate the RS from  SRS to SRC?
>
>  John
>
_______________________________________________
siprec mailing list
[email-masked]
https://www.ietf.org/mailman/listinfo/siprec

_______________________________________________
siprec mailing list
[email-masked]
https://www.ietf.org/mailman/listinfo/siprec

DISCLAIMER: This e-mail may contain information that is confidential,
privileged or otherwise protected from disclosure. If you are not an
intended recipient of this e-mail, do not duplicate or redistribute it by
any means. Please delete it and any attachments and notify the sender that
you have received it in error. Unintended recipients are prohibited from
taking action on the basis of information in this e-mail.E-mail messages may
contain computer viruses or other defects, may not be accurately replicated
on other systems, or may be intercepted, deleted or interfered with without
the knowledge of the sender or the intended recipient. If you are not
comfortable with the risks associated with e-mail messages, you may decide
not to use e-mail to communicate with IPC. IPC reserves the right, to the
extent and under circumstances permitted by applicable law, to retain,
monitor and intercept e-mail messages to and from its systems.

---

From: "Henry Lum" <[email-masked]>
Date: Mon, 5 Jul 2010 07:31:55 -0700

While I don't quite understand what ownership means, I do agree that SRC should not be registering with the SRS. This is the role of a registrar and routing already defined in SIP; I don't think we should be explicit about how we locate SRC/SRS and registration.

Henry

> From: [email-masked] [mailto:[email-masked]] On Behalf
> Of Deepanshu Gautam
> Sent: July-05-10 5:52 AM
> To: 'Jain, Rajnish'; 'Paul Kyzivat'; 'siprec issue tracker'
> Cc: [email-masked]
> Can SRC register (REGISTER) with SRS, irrespective of it location, while loggin
> into the service?
> 
> Regards
> Deepanshu
> 
> 
> 
> From: [email-masked] [mailto:[email-masked]] On Behalf
> Of Paul Kyzivat
> Sent: 2010年6月25日 21:31
> To: siprec issue tracker
> Cc: [email-masked]
> then know the address of the SRC. That may be easy in cases where the SRC
> is collocated with a CS participant, but whether that is true depends how the
> network is constructed.
> 
> privileged or otherwise protected from disclosure. If you are not an intended
> recipient of this e-mail, do not duplicate or redistribute it by any means.
> Please delete it and any attachments and notify the sender that you have
> received it in error. Unintended recipients are prohibited from taking action
> on the basis of information in this e-mail.E-mail messages may contain
> computer viruses or other defects, may not be accurately replicated on other
> systems, or may be intercepted, deleted or interfered with without the
> knowledge of the sender or the intended recipient. If you are not

-------------------------------------------------------------------------------------------------------------------
CONFIDENTIALITY NOTICE: This e-mail and any files attached may contain confidential and proprietary information of Alcatel-Lucent and/or its affiliated entities. Access by the intended recipient only is authorized. Any liability arising from any party acting, or refraining from acting, on any information contained in this e-mail is hereby excluded. If you are not the intended recipient, please notify the sender immediately, destroy the original transmission and its attachments and do not disclose the contents to any other person, use it for any purpose, or store or copy the information in any medium. Copyright in this e-mail and any attachments belongs to Alcatel-Lucent and/or its affiliated entities.

---

From: "Jain, Rajnish" <[email-masked]>
Date: Tue, 6 Jul 2010 11:26:21 -0400

> considering the intra-domain deployments (which is the current systems

I think the current approach doesn't refrain RS establishment from SRS to SRC. I think the consensus is to differ that particular use case from a requirements point of view to the next phase.

Raj

> >  Severity:  Active WG Document                  |    Keywords:

DISCLAIMER: This e-mail may contain information that is confidential, privileged or otherwise protected from disclosure. If you are not an intended recipient of this e-mail, do not duplicate or redistribute it by any means. Please delete it and any attachments and notify the sender that you have received it in error. Unintended recipients are prohibited from taking action on the basis of information in this e-mail.E-mail messages may contain computer viruses or other defects, may not be accurately replicated on other systems, or may be intercepted, deleted or interfered with without the knowledge of the sender or the intended recipient. If you are not comfortable with the risks associated with e-mail messages, you may decide not to use e-mail to communicate with IPC. IPC reserves the right, to the extent and under circumstances permitted by applicable law, to retain, monitor and intercept e-mail messages to and from its systems.

---

From: "Jain, Rajnish" <[email-masked]>
Date: Tue, 6 Jul 2010 11:42:06 -0400

Perhaps *ownership* was the wrong word, but I meant to imply the UA-Registrar relationship that a SIP registration creates.

Raj

> From: [email-masked] [mailto:[email-masked]] On
> Behalf Of Henry Lum
> Sent: Monday, July 05, 2010 10:32 AM
> To: Deepanshu Gautam; Jain, Rajnish; Paul Kyzivat; siprec issue tracker
> Cc: [email-masked]
> While I don't quite understand what ownership means, I do agree that
> SRC should not be registering with the SRS. This is the role of a
> registrar and routing already defined in SIP; I don't think we should
> be explicit about how we locate SRC/SRS and registration.
>
> Henry
>
> intended
> -----------------------------------------------------------------------
> --------------------------------------------
> CONFIDENTIALITY NOTICE: This e-mail and any files attached may contain
> confidential and proprietary information of Alcatel-Lucent and/or its
> affiliated entities. Access by the intended recipient only is
> authorized. Any liability arising from any party acting, or refraining
> from acting, on any information contained in this e-mail is hereby
> excluded. If you are not the intended recipient, please notify the
> sender immediately, destroy the original transmission and its
> attachments and do not disclose the contents to any other person, use
> it for any purpose, or store or copy the information in any medium.
> Copyright in this e-mail and any attachments belongs to Alcatel-Lucent
> and/or its affiliated entities.
>