Subject: Re: [siprec] IETF 88 - SIPREC Draft Agenda

From: "Ram Mohan R (rmohanr)" <[email-masked]>
Date: Wed, 4 Dec 2013 06:39:13 +0000

Hi Michael,

Please see inline

-----Original Message-----
From: Michael Smith <[email-masked]>
Date: Thursday, 28 November 2013 3:43 AM
To: "'Hutton, Andrew'" <[email-masked]>
Cc: "[email-masked]" <[email-masked]>
Subject: Re: [siprec] IETF 88 - SIPREC Draft Agenda

>I've only gotten one written comment (attached, from Matt Daughtrey of
>Eventide). This may be because of the Thanksgiving holiday - others made
>verbal comments, and I'll keep prodding them.

Thanks for your efforts to get some feedback for the drafts.

>
>Matt's comments reference metadata-13. Perhaps that's a typo - we tested
>against metadata-12. His point is about whether the drafts are clear on
>whether multiple CS could be recorded in one RS. The Call and Incident IDs
>he talks about are NENA specific, and carried in call-info headers, in
>case
>you wonder about that.

The metadata allows a RS to have zero or more CS and so you could have
more than one CS in a RS.

>
>One other comment I heard from many was that the language of the metadata
>drafts was hard to follow, due to usage and grammar issues - but that
>generally you could understand the intent. Cleaning up the language
>without
>changing the intent is doable, and would help. I don't recall anyone
>saying
>they had issues with the protocol draft.

I will get the draft reviewed and edited by a native speaker and fix the
grammar issues in it.

>
>I'll ping the ICE 8 group again next week to provide written feedback
>ASAP.

Thanks,

Ram

> 
>
>Michael Smith
>Chief Technologist, DSS Corp.
>Ph: 606.877.2788 | Mobile: 606.231.0243
>
>-----Original Message-----
>From: Hutton, Andrew [mailto:[email-masked]]
>Sent: Wednesday, November 27, 2013 12:57 PM
>To: Michael Smith
>Cc: [email-masked]; 'Parthasarathi R'; 'Brian Rosen'
>Subject: RE: [siprec] IETF 88 - SIPREC Draft Agenda
>
>Hi Michael,
>
>Do you have any information on the ICE 8 event relevant to SIPREC that you
>could provide us?
>
>Regards
>Andy
>
>> -----Original Message-----
>> From: Michael Smith [mailto:[email-masked]]
>> Sent: 28 October 2013 17:41
>> To: Hutton, Andrew; 'Parthasarathi R'; 'Brian Rosen'
>> Cc: [email-masked]
>> Subject: RE: [siprec] IETF 88 - SIPREC Draft Agenda
>> 
>> About the NENA interop event (ICE 8) - it is indeed next week. We have
>> about
>> 17 companies that have implemented siprec (either SRC or SRS
>> functionality).
>> We are testing metadata too. I think that those of us who are also on
>> this list will be more than happy to provide feedback based on our own
>> experiences with the drafts.
>> 
>> I think we're all swamped right now getting ready for the event, so
>> bear with us, and I'm sure we'll have some comments once the smoke has
>> cleared.
>> 
>> - Michael Smith, ICE 8 Planning Committee chair
>> 
>> Michael Smith
>> Chief Technologist, DSS Corp.
>> Ph: 606.877.2788 | Mobile: 606.231.0243
>> 
>> -----Original Message-----
>> From: [email-masked] [mailto:[email-masked]] On
>> Behalf Of Hutton, Andrew
>> Sent: Monday, October 28, 2013 1:28 PM
>> To: Parthasarathi R; 'Brian Rosen'
>> Cc: [email-masked]
>> Subject: Re: [siprec] IETF 88 - SIPREC Draft Agenda
>> 
>> Hi Partha,
>> 
>> I understand and share your concern on the lack of progress regarding
>> the metadata draft.
>> 
>> However the following is taken from the minutes of the last IETF
>> meeting in Berlin.
>> 
>> >Metadata draft needs more review there is no presentation during this
>> meeting on metadata.
>> >Companies implementing SIPREC for NENA are expected to be at an
>> interop
>> event for NG911 implementations scheduled for fall (Nov.?>). 3-4
>> Implementations expected to be there. Brian will ask the implementers
>> for a review. An experienced IETF reviewer is also >needed. Biggest
>> concern is if all necessary semantic are defined.
>> >Targeting interop events to look for reviewers.
>> >- Brian Rosen: NENA (Next Generation 911)
>> >- Charles Eckel: IMTC SIP Parity groups
>> >ACTION: Need to find reviewers for metadata draft.
>> 
>> The NENA interop event appears to be planned for next week (Same week
>> as
>> IETF88) maybe Brian can update us this.
>> 
>> The IMTC event will not take place until next May and might not test
>> SIPREC stuff so probably we should not wait for that.
>> 
>> I would really like to encourage those that have implemented the
>> metadata draft to provide feedback on the SIPREC mailing list.
>> 
>> Regards
>> Andy (SIPREC Co-Chair).
>> 
>> 
>> 
>> > -----Original Message-----
>> > From: Parthasarathi R [mailto:[email-masked]]
>> > Sent: 28 October 2013 16:17
>> > To: Hutton, Andrew; 'Brian Rosen'
>> > Cc: 'Ram Mohan R (rmohanr)'; [email-masked]
>> > Subject: RE: [siprec] IETF 88 - SIPREC Draft Agenda
>> >
>> > Hi Andy/Brian,
>> >
>> > I had raised my concern regarding Metadata draft status
>> > (http://www.ietf.org/mail-archive/web/siprec/current/msg03771.html)
>> > as there is no much progress for 1 years 3 months (from last
>> Vancouver
>> > meeting)
>> > without any changes. The multiple SIPREC implementation exists from
>> > different vendors namely ACME, NICE, AudioCodec, ORCx, HP, Broadsoft
>> > (http://www.linkedin.com/groups/Who-is-using-SIPREC-
>> > 4263898.S.176535181)
>> > already. The comments from ACME & NICE are already incorporated in
>> the
>> > latest draft. This clearly indicates that the metadata draft is
>> > matured enough to implement. AFAIK, each implementation would have
>> > gone through the draft carefully before implementing and it shall be
>> > considered as the review. Could you please let us know when is the
>> > plan to start WGLC for the metadata drafts or any other blocking
>> draft
>> > for this draft.
>> >
>> > I'm also interested in knowing whether the new charter will have the
>> > impact in metadata draft. IMO, the new use case has to be considered
>> > as an extension to the metadata drafts.
>> >
>> > Thanks
>> > Partha
>> >
>> > > -----Original Message-----
>> > > From: [email-masked] [mailto:[email-masked]] On
>> > > Behalf Of Ram Mohan R (rmohanr)
>> > > Sent: Wednesday, October 23, 2013 9:26 PM
>> > > To: Hutton, Andrew; [email-masked]
>> > > Subject: Re: [siprec] IETF 88 - SIPREC Draft Agenda
>> > >
>> > > The agenda looks great. One thing I would like to hear is -
>> > >
>> > > Discuss on how to progress these two WG drafts:
>> > > http://tools.ietf.org/wg/siprec/draft-ietf-siprec-metadata/
>> > > http://tools.ietf.org/wg/siprec/draft-ietf-siprec-callflows/
>> > >
>> > > We have not had much progress on either of these drafts  for quite
>> > some
>> > > time now due to lack of reviews. Can we get some help here ?
>> > >
>> > > Regards,
>> > > Ram
>> > >
>> > > -----Original Message-----
>> > > From: <Hutton>, Andrew <[email-masked]>
>> > > Date: Wednesday, 23 October 2013 9:08 PM
>> > > To: "[email-masked]" <[email-masked]>
>> > > Subject: [siprec] IETF 88 - SIPREC Draft Agenda
>> > >
>> > > >Hi All,
>> > > >
>> > > >I posted a draft agenda which can be found at:
>> > > >https://datatracker.ietf.org/meeting/88/agenda/siprec/.
>> > > >
>> > > >Please let me have any requests for changes/additions by Sunday
>> > > >27th
>> > > of
>> > > >October.
>> > > >
>> > > >Regards
>> > > >Andy
>> > > >_______________________________________________
>> > > >siprec mailing list
>> > > >[email-masked]
>> > > >https://www.ietf.org/mailman/listinfo/siprec
>> > >
>> > > _______________________________________________
>> > > siprec mailing list
>> > > [email-masked]
>> > > https://www.ietf.org/mailman/listinfo/siprec
>> 
>> _______________________________________________
>> siprec mailing list
>> [email-masked]
>> https://www.ietf.org/mailman/listinfo/siprec
>

---

From: Paul Kyzivat <[email-masked]>
Date: Wed, 04 Dec 2013 11:08:37 -0500

> I will get the draft reviewed and edited by a native speaker and fix the

I'll do that. I'm a native (American) English speaker.

(That doesn't guarantee that what I write will be more intelligible.)

Ultimately, as it is published as an RFC it will be edited again by a 
professional editor.

	Thanks,
	Paul

---

From: Brian Rosen <[email-masked]>
Date: Wed, 4 Dec 2013 11:24:45 -0500

Matt’s comments imply that we wanted to always have persistent RS connections and reuse them.  We should make sure he understands that creating a new RS for every CS that is recorded is a normal, expected use of the protocol, but that there were use cases where the relationship between RS and CS is more complex.

Adding the NENA IDs doesn’t force 1:1 RS to CS.  We save the IDs with the recording, but it’s metadata.

Brian

On Dec 4, 2013, at 11:08 AM, Paul Kyzivat <[email-masked]> wrote:

> Ultimately, as it is published as an RFC it will be edited again by a professional editor.
> 
> 	Thanks,
> 	Paul
>