Subject: RE: New SMime Capabilities item

From: "Jim Schaad (Exchange)" <[email-masked]>
Date: Tue, 25 May 1999 16:39:31 -0700

Russ,

I think the question you are asking is what is the OID for
sMIMECapabilities?  It is already defined as:
sMIMECapabilities OBJECT IDENTIFIER ::= {iso(1) member-body(2)
--    us(840) rsadsi(113549) pkcs(1) pkcs-9(9) 15}  -- -- [MSG]

If this is not the question you are asking, please be more explicit.

jim

-----Original Message-----
From: Russ Housley [mailto:[email-masked]]
Sent: Tuesday, May 25, 1999 1:52 PM
To: Jim Schaad (Exchange)
Cc: Ietf-Smime (E-mail)
Subject: Re: New SMime Capabilities item

Jim:

What OID are you using?

Russ

At 07:59 PM 5/11/99 -0700, Jim Schaad (Exchange) wrote:
>Please add the following to the SMimeCapabilities section of the OIDs
>document on IMC.ORG.
>
>sMIMECapabilitiesVersions ::= {sMIMECapabilities 3}
>SMIMECapabilitiesVersions ::= SEQUENCE OF INTEGER
>--     SMime Capabilities Versions holds the sequence of S/MIME V3
>specifications
>--     understood by the client.   Currently the only two items legal
values
>are
>--     v2 (S/MIME version 2) and v3 (S/MIME version 3).   If the item is
>missing from a
>--     capabilities list then V2 only should be assumed.
>
>
>The current justification for this is that S/MIME V2 clients will probably
>not understand the CMS encrypted data objects.  Specifically receipient
>infos other than key transport and may not be able to decrypt the message
at
>all if other key managment algorithms are used in the message.
>
>jim
>

---

From: Russ Housley <[email-masked]>
Date: Wed, 26 May 1999 17:05:14 -0400

Jim:

Yes.  MSG-07 includes the follwoing ASN.1.  Which OID are you using for
capabilityID to express S/MIME version preference?

-- S/MIME Capabilities provides a method of broadcasting the symetric
capabilities
--      understood.  Algorithms should be ordered by preference and grouped
by type

smimeCapabilities OBJECT IDENTIFIER ::=
   {iso(1) member-body(2) us(840) rsadsi(113549) pkcs(1) pkcs-9(9) 15}

SMIMECapability ::= SEQUENCE {
   capabilityID OBJECT IDENTIFIER,
   parameters ANY DEFINED BY capabilityID OPTIONAL }

SMIMECapabilities ::= SEQUENCE OF SMIMECapability

Russ