Subject: Queries on Message/rfc822, Compressed-Data.

From: "Pandey, Arun" <[email-masked]>
Date: Wed, 26 Mar 2003 15:40:52 +0530

Hi,

I had the following 2 queries. Would appreciate a response on these if
possible:

1. Going  through the S/MIME mail archive I find a discussion on the use of
message types like 
    message/rfc822, message/partial etc. that could be used to wrap a
protected message (MIME 
    content + RFC822 Headers). Also as per MOM of the 54th IETF meeting it
seems that 
    message/rfc822 message type has been finalized for this purpose.

    My question is how should one distinguish such a message ( A protected
message wrapped 
    in message/rfc822) from a forwarded message which also has a message
type of 
    message/rfc822 and can also contain a non protected message? Is an
example message of 
    type message/rfc822 containing a protected message available for
reference?

2. The latest draft 'S/MIME Version 3.1 Message Specification'
(draft-ietf-smime-rfc2633bis-03.txt)
    mentions a new S/MIME type "compressed-data". However for this new
S/MIME type no 
    corresponding EIT has been defined in the S/MIME TRANSPORT draft. Where
would one be 
    able to find the corresponding EIT for the same?

Best Regards
Arun Pandey

---

From: Russ Housley <[email-masked]>
Date: Wed, 26 Mar 2003 15:03:00 -0500

These are both discussed in the most recent MSG draft.

Please see draft-ietf-smime-rfc2633bis-03.txt.

Russ

At 03:40 PM 3/26/2003 +0530, Pandey, Arun wrote:

Hi,

I had the following 2 queries. Would appreciate a response
on these if possible:

1. Going  through the S/MIME mail archive I find a
discussion on the use of message types like

message/rfc822, message/partial etc. that
could be used to wrap a protected message (MIME

content + RFC822 Headers). Also as per
MOM of the 54th IETF meeting it seems that

message/rfc822 message type has been
finalized for this purpose.

My question is how should one distinguish
such a message ( A protected message wrapped

in message/rfc822) from a forwarded
message which also has a message type of

message/rfc822 and can also contain a non
protected message? Is an example message of

type message/rfc822 containing a
protected message available for reference?

2. The latest draft 'S/MIME Version 3.1 Message
Specification' (draft-ietf-smime-rfc2633bis-03.txt)

mentions a new S/MIME type
"compressed-data". However for this new S/MIME type no

corresponding EIT has been defined in the
S/MIME TRANSPORT draft. Where would one be

able to find the corresponding EIT for
the same?

Best Regards

Arun Pandey