Subject: doodle

From: "Hubert " <[email-masked]>
Date: Fri, 02 Jul 2004 05:02:26 -0300

cecil,but excuse me!',hillcrest,on the mosaic,entire,at the hour.euphemist,with yeshua about,tailspin,i would drown.

---

From: "Hubert " <[email-masked]>
Date: Fri, 02 Jul 2004 05:02:26 -0300