Subject: Error in draft-ietf-smime-escertid-06.txt

From: "Denis Pinkas" <[email-masked]>
Date: Mon, 14 May 2007 15:57:46 +0200

The current text is:

        ESSCertIDv2 ::=  SEQUENCE {
            hashAlgorithm           AlgorithmIdentifier
                   DEFAULT {algorithm id-sha256 parameters NULL},
            certHash                 Hash,
            issuerSerial             IssuerSerial OPTIONAL
        }

whereas it should be:

    ESSCertIDv2 ::=  SEQUENCE {
            hashAlgorithm           AlgorithmIdentifier
                   DEFAULT {algorithm id-sha256 },
            certHash                 Hash,
            issuerSerial             IssuerSerial OPTIONAL
        }

Denis

---

From: Russ Housley <[email-masked]>
Date: Mon, 14 May 2007 11:36:38 -0400

I agree.

---

From: Blake Ramsdell <[email-masked]>
Date: Mon, 14 May 2007 20:50:18 -0700

>             issuerSerial             IssuerSerial OPTIONAL

Out of curiosity, what purpose does a DEFAULT value have for a 
non-OPTIONAL element?

Blake
-- 
Blake Ramsdell | Sendmail, Inc. | http://www.sendmail.com

---

From: Blake Ramsdell <[email-masked]>
Date: Tue, 15 May 2007 01:38:04 -0700

> Out of curiosity, what purpose does a DEFAULT value have for a 

OK, never mind -- I think I figured that out (DEFAULT implies OPTIONAL).

I was also concerned that the absence of hashAlgorithm would be hard to 
figure out, but Hash is an OCTET STRING not a SEQUENCE.

Carry on. Nothing to see here.

Blake