Subject: Web-based ASN.1 decoding tool available

From: "Peter Hesse" <[email-masked]>
Date: Wed, 4 Jun 2008 09:53:10 -0400

All,

We have recently made available a web-based tool for doing an ASN.1 dump.
It displays the ASCII HEX and the ASN structure, and when you hover over the
structure, it highlights the relevant portion of the hex.  (Clicking makes
the highlight stick.)

Due to PHP's inefficiency and memory usage during parsing, we have limited
it to files 64K and smaller.  Still, it is useful for displaying smaller
objects when you don't have dumpasn1 installed or available.

It can be found here:
http://geminisecurity.com/features-downloads/tools#fd_5

Click on "Click to try the application" under PHPdumpASN.

Enjoy!  Please send me any feedback.

--Peter Hesse

  _____  

 Peter Hesse                       [email-masked]

 Phone: 703-378-5808 x105      Gemini Security Solutions, Inc.

    Visit our relaunched website!  <http://geminisecurity.com/>
http://geminisecurity.com

"A good programmer is someone who always looks both ways before
 crossing a one-way street." --Doug Linder

---

From: "Perez, Aram" <[email-masked]>
Date: Wed, 4 Jun 2008 09:03:47 -0700

On 6/4/08 6:53 AM, Peter Hesse  wrote:

> All,
>
> We have recently made available a web-based tool for doing an ASN.1 dump.  It
> displays the ASCII HEX and the ASN structure, and when you hover over the
> structure, it highlights the relevant portion of the hex. (Clicking makes the
> highlight stick.)
>
> Due to PHP's inefficiency and memory usage during parsing, we have limited it
> to files 64K and smaller.  Still, it is useful for displaying smaller objects
> when you don't have dumpasn1 installed or available.
>
> It can be found here: http://geminisecurity.com/features-downloads/tools#fd_5

For Windows, you can also try BERViewer <http://homepage.mac.com/aramperez/berviewer.html><http://homepage.mac.com/aramperez/berviewer.html>. I haven't had time to remove the nag dialog box from the Mac version.

Regards,
Aram Perez

---

From: "Peter Rybar" <[email-masked]>
Date: Thu, 5 Jun 2008 15:24:46 +0200

Hi,

Have you any free tools which are not the simple dump of asn1 DER/BER but which also can read a data according the 1988, 93 ASN.1 Syntax? 
Like default values from DER...

Peter

-----Original Message-----
From: [email-masked] [mailto:[email-masked]] On Behalf Of Perez, Aram
Sent: Wednesday, June 04, 2008 6:04 PM
To: PKIX; [email-masked]
Subject: Re: Web-based ASN.1 decoding tool available

On 6/4/08 6:53 AM, Peter Hesse  wrote:

> Due to PHP’s inefficiency and memory usage during parsing, we have limited it 
> when you don’t have dumpasn1 installed or available.
>  
> Click on “Click to try the application” under PHPdumpASN.

For Windows, you can also try BERViewer <http://homepage.mac.com/aramperez/berviewer.html> <http://homepage.mac.com/aramperez/berviewer.html> . I haven’t had time to remove the nag dialog box from the Mac version.

Regards,
Aram Perez

---

From: Aram Perez <[email-masked]>
Date: Thu, 05 Jun 2008 07:03:12 -0700

Hi Peter,
>
> Have you any free tools which are not the simple dump of asn1 DER/ 
> BER but which also can read a data according the 1988, 93 ASN.1  
> Syntax?

I'm afraid I do not and I'm not aware of any such tool. To get the  
default values, you would need the actual ASN.1 (which provides the  
default values) and the BER/DER data.

BERViewer, Peter Hesse's web tool, Peter Gutmann's dumpasn1 and others  
similar tools just decode the BER/DER and present it in a "more" human  
readable form.

Regards,
Aram

> For Windows, you can also try BERViewer <http://homepage.mac.com/aramperez/berviewer.html 
> > <http://homepage.mac.com/aramperez/berviewer.html> . I haven’t had  
> time to remove the nag dialog box from the Mac version.
>
> Regards,
> Aram Perez
>
>
>

---

From: "Peter Rybar" <[email-masked]>
Date: Thu, 5 Jun 2008 16:35:43 +0200

Hi all,

This one is also nice... 
And somebody could try to use it in online PHP :-) with at least ASN.1 modules which are described in PKIX, SMIME RFCs.

http://lionet.info/asn1c/

Peter

-----Original Message-----
From: [email-masked] [mailto:[email-masked]] On Behalf Of Aram Perez
Sent: Thursday, June 05, 2008 4:03 PM
To: PKIX; [email-masked]
Subject: Re: Web-based ASN.1 decoding tool available

Hi Peter,

I'm afraid I do not and I'm not aware of any such tool. To get the default values, you would need the actual ASN.1 (which provides the default values) and the BER/DER data.

BERViewer, Peter Hesse's web tool, Peter Gutmann's dumpasn1 and others similar tools just decode the BER/DER and present it in a "more" human readable form.

Regards,
Aram

	Peter

	-----Original Message-----
	From: [email-masked] [mailto:[email-masked]] On Behalf Of Perez, Aram
	Sent: Wednesday, June 04, 2008 6:04 PM
	To: PKIX; [email-masked]
	Subject: Re: Web-based ASN.1 decoding tool available

		All,

		highlight stick.)

	
	Regards,
	Aram Perez

---

From: Ricardo Barroso <[email-masked]>
Date: Thu, 05 Jun 2008 18:14:46 +0100

Hi all!

I would like to mention ASN.1 Editor 
<http://lipingshare.com/Asn1Editor/> (for Windows) which is not a 
web-based tool and although it can't provide default values from DER,
it lets you:
    - inspect ASN.1 structures and encapsulate parts of the structures 
in a more user-friendly way than simple dump tools;
    - edit ASN.1 structures;
    - save sub-parts/structures to a new file;
    - etc.

It also includes a simple but nice data converter between PEM, HEX and 
BASE64 formats.

Best regards,
Ricardo Barroso

Aram Perez wrote:
> Hi Peter,
>>
>> Have you any free tools which are not the simple dump of asn1 DER/BER 
>> but which also can read a data according the 1988, 93 ASN.1 Syntax?
>> From: [email-masked] 
>> [mailto:[email-masked]] On Behalf Of Perez, Aram
>> To: PKIX; [email-masked] <mailto:[email-masked]>
>> For Windows, you can also try BERViewer 
>> <http://homepage.mac.com/aramperez/berviewer.html> 

-- 
*    Ricardo Barroso* 	

*Telefone:* +351 217 123 010
*Telemóvel:* +351 968 332 327
*Fax:* +351 217 123 011 	*Email:*
[email-masked] <mailto:[email-masked]> 
*MULTICERT S.A.*
<http://www.multicert.com>Estrada do Casal do Canas, 
<http://maps.google.com/maps?f=q&hl=pt-PT&geocode=&q=Estrada+do+Casal+do+Canas,+Lote+6,+Alfragide+1600-546+Amadora,+Portugal&sll=38.734536,-9.217379&sspn=0.009239,0.023518&ie=UTF8&ll=38.733933,-9.211607&spn=0.073916,0.188141&z=13>
<http://maps.google.com/maps?f=q&hl=pt-PT&geocode=&q=Estrada+do+Casal+do+Canas,+Lote+6,+Alfragide+1600-546+Amadora,+Portugal&sll=38.734536,-9.217379&sspn=0.009239,0.023518&ie=UTF8&ll=38.733933,-9.211607&spn=0.073916,0.188141&z=13> 
Lote 6, Alfragide 
<http://maps.google.com/maps?f=q&hl=pt-PT&geocode=&q=Estrada+do+Casal+do+Canas,+Lote+6,+Alfragide+1600-546+Amadora,+Portugal&sll=38.734536,-9.217379&sspn=0.009239,0.023518&ie=UTF8&ll=38.733933,-9.211607&spn=0.073916,0.188141&z=13>
2720-092 Amadora - Portugal 
<http://maps.google.com/maps?f=q&hl=pt-PT&geocode=&q=Estrada+do+Casal+do+Canas,+Lote+6,+Alfragide+1600-546+Amadora,+Portugal&sll=38.734536,-9.217379&sspn=0.009239,0.023518&ie=UTF8&ll=38.733933,-9.211607&spn=0.073916,0.188141&z=13>