Subject: Certified email: comment on draft-gennai-smime-cnipa-pec-00.text

From: "Pietro Romanazzi" <[email-masked]>
Date: Tue, 28 Oct 2008 17:35:07 +0100

Hi all,

I have two comments to the draft in subject.

In my personal opinion there is a weakness in the notification of problems
occurring at the Incoming point.
With the only exception of the "Virus detection notification", there is no message
of "not taken in charge"  to the sender PEC system (could it be
better called CEM system? PEC is the acronim of the Italian original name.).
Consequently the user will receive Timeout delivery error notification(s) with no info
about the reason why the mail has not been delivered.
Yust to make an example: the user sends a big message which is accepted
by his PEC system but the destination PEC system imposed a different limit
for the message size and it rejects the message. There is no PEC message to
kick this "non acceptance" back to the origin. 
A proposal could be to have a sort of "not taken in charge notification" message,
with the "Virus detection notification" as one possible case.
Similar behaviour could be obtained at the delivery point but, as the previous example,
the PEC system should not be happy to elaborate a message, outside the SLA rules, any 
longer.

A more general comment is about the use of italian word throughout the draft.
It could be better to use the translation of Appendix A and obtain a document
in full english. It will improve the readability of the document which is now intended
for international readers.

Regards,

Pietro Romanazzi

---

From: Shahin Alba <[email-masked]>
Date: Wed, 29 Oct 2008 18:52:49 +0100

Pietro,

Error notifications at the Incoming Point do take place. All incoming  
messages must always be accepted by the receiving PEC provider , which 
will send a take in charge notification to the sender. Only after that 
does it do the formal checks. If anything doesn't add up, such as the 
message exceeding the size limit, it sends a non-delivery notification 
with a brief description of the error to the sender.

As for removing all Italian terms, this document describes PEC as it 
exists today. If anyone inside or outside Italy wishes to implement PEC, 
they will need to use those Italian terms in order to be compatible with 
the already existing and operating implementations.
Changing them to English could be done in future improvements of PEC itself.

--Alba