Subject: [smime] Secure e-Mail NG?

From: Anders Rundgren <[email-masked]>
Date: Fri, 11 Mar 2011 08:27:32 +0100

As an active e-mail user I have always found email indispensable.
That e-mail also is the least secure messaging system there is of course a nuisance.

Although e-mail hast lost some of its importance to other communication systems,
I still think it is worth an upgrade.

STARTTLS is nice but its key handling and integration in e-mail clients is not
particularly useful.  Sending non-encrypted messages should be an exception.

IMHO, STARTTLS, DOMKEY and email clients could be combined so that we
get domain-secured e-mail as default.

Or is it better to create an entirely new messaging system to get rid of the legacy?

I believe the update frequency of today makes client upgrades a no-issue.

Anders

---

From: Francesco Gennai <[email-masked]>
Date: Fri, 11 Mar 2011 15:16:37 +0100 (MET)

Hi Anders,

also if it doesn't represent an answer to your points of interest it could
be interesting to have a look at the following draft:

http://datatracker.ietf.org/doc/draft-gennai-smime-cnipa-pec/

that describes a system currently used in Italy.

It is more oriented to "certified email" than "secured email".

Francesco 

> Although e-mail hast lost some of its importance to other communication 
> systems, I still think it is worth an upgrade.

> STARTTLS is nice but its key handling and integration in e-mail clients is 
> not particularly useful.  Sending non-encrypted messages should be an 
> exception.

> Anders
> _______________________________________________
> smime mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/smime

---

From: Patrick Patterson <[email-masked]>
Date: Fri, 11 Mar 2011 09:35:55 -0500

Hi Anders:

You may be interested in PLASMA - the draft is:

http://www.ietf.org/id/draft-freeman-message-access-control-req-00.txt

I believe there will be a BOF at the upcoming meeting in Prague.

Best Regards,

Patrick.

> I believe the update frequency of today makes client upgrades a no-issue.

---
Patrick Patterson
President and Chief PKI Architect
Carillon Information Security Inc.
http://www.carillon.ca

tel: +1 514 485 0789
mobile: +1 514 994 8699
fax: +1 450 424 9559

---

From: Anders Rundgren <[email-masked]>
Date: Fri, 11 Mar 2011 15:53:10 +0100

Hi Francesco,

Yes, "certified mail" is pretty much what I would like to see
on a major scale.  It seems that you also pushed TLS rather
than S/MIME encryption.

Good Luck BTW!

Anders