Subject: [smime] [Technical Errata Reported] RFC5752 (4444)

From: RFC Errata System <[email-masked]>
Date: Tue, 11 Aug 2015 16:41:16 -0700 (PDT)

The following errata report has been submitted for RFC5752,
"Multiple Signatures in Cryptographic Message Syntax (CMS)".

--------------------------------------
You may review the report below and at:
http://www.rfc-editor.org/errata_search.php?rfc=5752&eid=4444

--------------------------------------
Type: Technical
Reported by: Derek Edson <[email-masked]>

Section: 3

Original Text
-------------
id-aa-multipleSignatures OBJECT IDENTIFIER ::= {
        iso(1) member-body(2) us(840) rsadsi(113549) pkcs(1) pkcs9(9)
        id-aa(16) 51 }

Corrected Text
--------------
id-aa-multipleSignatures OBJECT IDENTIFIER ::= { 
       iso(1) member-body(2) us(840) rsadsi(113549) pkcs(1) pkcs9(9) 
       smime(16) id-aa(2) 51 }

Notes
-----
The definition in Appendix A (ASN.1 module) is also incorrect, and inconsistent with section 3, which defines

id-aa-multipleSignatures OBJECT IDENTIFIER ::= { iso(1) member-body(2)
        us(840) rsadsi(113549) pkcs(1) pkcs9(9) id-aa(2) 51 }

Under 1.2.840.113549.1.9, 16 is smime, not id-aa.  id-aa(2) exists under smime(16)

Instructions:
-------------
This erratum is currently posted as "Reported". If necessary, please
use "Reply All" to discuss whether it should be verified or
rejected. When a decision is reached, the verifying party (IESG)
can log in to change the status and edit the report, if necessary. 

--------------------------------------
RFC5752 (draft-ietf-smime-multisig-05)
--------------------------------------
Title               : Multiple Signatures in Cryptographic Message Syntax (CMS)
Publication Date    : January 2010
Author(s)           : S. Turner, J. Schaad
Category            : PROPOSED STANDARD
Source              : S/MIME Mail Security
Area                : Security
Stream              : IETF
Verifying Party     : IESG

---

From: Russ Housley <[email-masked]>
Date: Wed, 12 Aug 2015 11:52:15 -0400

This is correct ...

  id-smime OBJECT IDENTIFIER ::= { iso(1) member-body(2) 
            us(840) rsadsi(113549) pkcs(1) pkcs9(9) 16 }

  id-aa   OBJECT IDENTIFIER ::= { id-smime  2 }  -- attributes

  id-aa-multipleSignatures   OBJECT IDENTIFIER ::= { id-aa 51 }  -- RFC 5752

Russ

On Aug 11, 2015, at 7:41 PM, RFC Errata System wrote:

> _______________________________________________
> smime mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/smime

---

From: "jimsch" <[email-masked]>
Date: Thu, 13 Aug 2015 16:20:15 -0700

Totally agree.

> -----Original Message-----
> From: Russ Housley [mailto:[email-masked]]
> Sent: Wednesday, August 12, 2015 8:52 AM
> To: Kathleen Moriarty; Stephen Farrell
> Cc: Sean Turner; Jim Schaad; Paul Hoffman; Blake Ramsdell;
> [email-masked]; IETF SMIME
> Subject: Re: [smime] [Technical Errata Reported] RFC5752 (4444)
> 
> This is correct ...
> 
> > The following errata report has been submitted for RFC5752, "Multiple
> > Signatures in Cryptographic Message Syntax (CMS)".
> >
> > The definition in Appendix A (ASN.1 module) is also incorrect, and
> > inconsistent with section 3, which defines
> >
> > use "Reply All" to discuss whether it should be verified or rejected.
> > When a decision is reached, the verifying party (IESG) can log in to
> > change the status and edit the report, if necessary.
> >

---

From: Stephen Farrell <[email-masked]>
Date: Fri, 14 Aug 2015 12:11:02 +0100

Done,
S.