Subject: [smime] [Technical Errata Reported] RFC5035 (6735)

From: RFC Errata System <[email-masked]>
Date: Fri, 12 Nov 2021 07:01:08 -0800 (PST)

The following errata report has been submitted for RFC5035,
"Enhanced Security Services (ESS) Update: Adding CertID Algorithm Agility".

--------------------------------------
You may review the report below and at:
https://www.rfc-editor.org/errata/eid6735

--------------------------------------
Type: Technical
Reported by: Ernst Lawende <[email-masked]>

Section: 4

Original Text
-------------
        ESSCertIDv2 ::=  SEQUENCE {
            hashAlgorithm           AlgorithmIdentifier
                   DEFAULT {algorithm id-sha256},
            certHash                 Hash,
            issuerSerial             IssuerSerial OPTIONAL
        }

Corrected Text
--------------
        ESSCertIDv2 ::=  SEQUENCE {
            hashAlgorithm           AlgorithmIdentifier
                   DEFAULT {id-sha256},
            certHash                 Hash,
            issuerSerial             IssuerSerial OPTIONAL
        }

Notes
-----
No value assignment for 'algorithm' exists, and the definition of id-sha256 already contains the full object identifier.

Instructions:
-------------
This erratum is currently posted as "Reported". If necessary, please
use "Reply All" to discuss whether it should be verified or
rejected. When a decision is reached, the verifying party  
can log in to change the status and edit the report, if necessary. 

--------------------------------------
RFC5035 (draft-ietf-smime-escertid-06)
--------------------------------------
Title               : Enhanced Security Services (ESS) Update: Adding CertID Algorithm Agility
Publication Date    : August 2007
Author(s)           : J. Schaad
Category            : PROPOSED STANDARD
Source              : S/MIME Mail Security
Area                : Security
Stream              : IETF
Verifying Party     : IESG

---

From: Russ Housley <[email-masked]>
Date: Fri, 12 Nov 2021 14:22:07 -0500

RFC Editor, please reject this errata report.

The AlgorithmIdentifier is defined as:

   AlgorithmIdentifier  ::=  SEQUENCE  {
        algorithm               OBJECT IDENTIFIER,
        parameters              ANY DEFINED BY algorithm OPTIONAL  }

The syntax is saying that the DEFAULT value for the is algorithm field is  id-sha256 and the optional parameters are absent.

Russ

> On Nov 12, 2021, at 10:01 AM, RFC Errata System <[email-masked]> wrote:
> 
> _______________________________________________
> smime mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/smime

---

From: Chris Smiley <[email-masked]>
Date: Fri, 12 Nov 2021 14:44:12 -0800

Hi Russ,

Per your request, errata 6735 has been rejected.

Thank you.

RFC Editor/cs

> On Nov 12, 2021, at 11:22 AM, Russ Housley <[email-masked]> wrote:
>