Subject: RE: draft-ietf-snmpv3-coex-v2-04.txt

From: "Frye, Rob" <[email-masked]>
Date: Tue, 20 May 2003 20:43:15 -0400

IHMO: No.  They are warnings, and Coex is about bridging the gap between
old-SMI/SNMP and new.  There are bound to be some complaints with
compilers that expect new syntax when dealing with something "on the
boundary" between the two.

-- Rob.

-----Original Message-----
From: Wijnen, Bert (Bert) [mailto:[email-masked]] 
Sent: Tuesday, May 20, 2003 6:23 PM
To: SNMPv3 (E-mail)
Subject: RE: draft-ietf-snmpv3-coex-v2-04.txt

DO we worry at all about two SMICng warnings:
W: f(coex.mi2), (178,24) Item "snmpCommunityName" should have SIZE
specified
W: f(coex.mi2), (396,23) Item "snmpTrapCommunity" should have SIZE
specified

We could add a SIZE of (1..0xffff) I would think

Thanks,
Bert 

> -----Original Message-----
> From: C. M. Heard [mailto:[email-masked]]
> Sent: woensdag 7 mei 2003 15:08
> To: SNMPv3 (E-mail)
> Subject: draft-ietf-snmpv3-coex-v2-04.txt
> 
> 
> Colleagues,
> 
> Although the announcement hasn't yet been sent,
> 
> http://www.ietf.org/internet-drafts/draft-ietf-snmpv3-coex-v2-04.txt
> 
> is now available in the repository.  It matches the version posted to 
> this list on 15 April 2003.  As previously noted, that version fixed 
> all outstanding comments except the following one:
> 
> On Tue, 8 Apr 2003, Wijnen, Bert (Bert) wrote:
> > I see (In the MIB REVISION clause)
> >                    Changed the name of 'snmpCommunityGroup'
> to a name
> >                    conflict with the SNMPv2-MIB.
> > Should that be:
> >                    Changed the name of 'snmpCommunityGroup' to 
> >                    snmpCommunityTableGroup to avoid a name conflict
> >                    with the SNMPv2-MIB.
> 
> So this error still needs to be fixed before publication (note that a 
> similar error was was fixed in the revision log in appendix B).
> 
> //cmh
>

---

From: Juergen Schoenwaelder <[email-masked]>
Date: Wed, 21 May 2003 09:05:58 +0200

>>>>> Frye, Rob writes:

Rob> IHMO: No.  They are warnings, and Coex is about bridging the gap
Rob> between old-SMI/SNMP and new.  There are bound to be some
Rob> complaints with compilers that expect new syntax when dealing
Rob> with something "on the boundary" between the two.

I think Dave Perkins wants people to be explicit that there is a size
constraint for all octet strings in SNMP. Personally, I would leave it
to the discretion of the authors whether they add an explicit size
constraint of (0..65535) or not.

/js

-- 
Juergen Schoenwaelder		International University Bremen
Phone: +49 421 200 3587		P.O. Box 750 561, 28725 Bremen, Germany
Fax:   +49 421 200 3103		<http://www.iu-bremen.de/>