Subject: [Softwires] RE: bi-directional

From: "[email-masked]" <[email-masked]>
Date: Thu, 10 Nov 2005 13:55:26 -0500

Hi Shin,

   I included mutual authentication on the deployment slide
that contained an illustration for roaming outside of the 
provider network.  Mutual authentication may be used here
inorder for the client to authenticate that the softwire
concentrator is the one desired.

   I agree with Francis that this is not a hard requirement
(MUST) but we SHOULD have such a requirement for our softwire
security requirements.

   Shu, Florent and I are working on security analysis draft
to fret out security landscape and requirements for these
softwire deployments.  While there were previous versions of this draft,
we meet this past week and determined based on the discussions
at the Paris interim meeting that it requires updating - which
we will do rather quickly so that discussion can take place in
parallel with problem statement work. 

Carl

To: Shin Miyakawa <miyakawa at nttv6.jp> 
Subject: Re: [Softwires] bi-directional ? 
From: Francis Dupont <Francis.Dupont at enst-bretagne.fr> 
Date: Thu, 10 Nov 2005 03:49:28 +0100 
Cc: softwires at ietf.org 
In-reply-to: Your message of Thu, 10 Nov 2005 11:10:03 +0900.
<[email-masked]> 
List-archive: <http://www1.ietf.org/pipermail/softwires> 
List-help: <mailto:[email-masked]?subject=help> 
List-id: softwires wg discussion list <softwires.ietf.org> 
List-post: <mailto:[email-masked]> 
List-subscribe: <https://www1.ietf.org/mailman/listinfo/softwires>,
<mailto:[email-masked]?subject=subscribe> 
List-unsubscribe: <https://www1.ietf.org/mailman/listinfo/softwires>,
<mailto:[email-masked]?subject=unsubscribe> 
Sender: softwires-bounces at ietf.org 

----------------------------------------------------------------------------
----

 In your previous mail you wrote:

   At the meeting, I think that Carl talked that 
   bi-directional authentication will be needed. 

=> I prefer the term "mutual" to "bi-directional".

   However I understand that it is "preferable",
   still I think uni-directional authentication is "acceptable"
   (just like today's dial-up ppp).
   
=> IMHO the big new thing with CHAP was the possible mutual
authentication...
but I agree that today we use mainly client authentication only.
In term of keywords I vote for a SHOULD for mutual authentication
(so you still may use client authentication only but should not complain
if the bad guy proves it is not enough :-).

   (Espcecially, Carl please answer...) 
   So, I'd like to know about opinions of the people on this ML about this.
   
=> should be the same than yours about me.

Thanks

Francis.Dupont at enst-bretagne.fr

--------------------------------------------------------------------
mail2web - Check your email from the web at
http://mail2web.com/ .

_______________________________________________
Softwires mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/softwires

---

From: Shin Miyakawa <[email-masked]>
Date: Fri, 11 Nov 2005 06:52:22 +0900 (JST)

Hello, 

Thank you for your comments.
Then, I think that we can treat this is a kind of consensus we have made :-)

Shin Miyakawa

From: "[email-masked]" <[email-masked]>
Subject: [Softwires] RE: bi-directional 
Date: Thu, 10 Nov 2005 13:55:26 -0500