Subject: Re: [Softwires] BGP TE attr last call by softwires WG (2nd question)

From: Igor Bryskin <[email-masked]>
Date: Wed, 3 Sep 2008 07:37:42 -0700 (PDT)

Yaokov,

Please,  see in-line.

----- Original Message ----
From: Yakov Rekhter <[email-masked]>
To: Igor Bryskin <[email-masked]>
Cc: "Drake, John E" <[email-masked]>; Lou Berger <[email-masked]>; Adrian Farrel <[email-masked]>; [email-masked]; [email-masked]
Sent: Wednesday, September 3, 2008 9:55:49 AM
Subject: Re: [Softwires] BGP TE attr last call by softwires WG (2nd question) 

Igor,

> And I am not arguing that sufficient redundancy must be provided. However you
> said:
> >For your suggested approach to work with sufficient 
> >redundancy, the topology of the overlay needs to be configured 
> >such that every selected P router is connected to at least two 
> >other selected P routers and every PE router needs to be 
> >connected to at least two selected P routers.
> 
> If you just simply interconnect all VPN-aware PEs into a single
> ring via IPin IP tunnels and run an instance of OSPF to distribute
> VPN-related information between them, it will provide sufficient
> redundancy and involve exactly *zero* Ps.
>
> So, I want you to drop your lecturing tone for a minute and simply
> tell in what respect in your opinion this approach is not perfect
> fo the L1VPN application. Otherwise, I am not interested in this
> discussion any longer. I do like to hear comments from other people.

Since you asked, one problem with using OSPF, as John correctly
pointed out, is that you are left with a situation in which *every* PE 
router will have *all* L1VPN routes for all the L1VPNs. Of course, 
this is "perfect" in a sense that you can do no worse than that :-)

IB>> Ok. Several points here. Note that neither Ps nor VPN-unaware PEs participate in the distribution/maintenance of VPN information, which is already significantly better than what you said about the OSPF solution in your previous mail:

>... And while on the subject of scaling, please keep in mind that BGP
>   only stores L1VPN routes on PEs that have sites of that VPN
>   connected to them, and on an RR if used, but *not* on any of the P 
>   routers. In contrast, rfc5252 (OSPF for L1VPN
>   autodiscovery) results in storing *all VPN TE information 
>   for all the VPNs* on *all* the IGP nodes, both P and PE. So, clearly BGP-based 
>   approach scales better than OSPF-based approach.

> >>>>Yakov.

I do agree that if you use a single ring overlay interconnecting all VPN aware PEs you will have LSDBs at all PEs contain VPN info about all VPNs. However, in case of L1VPN this is not VPN routes, rather VPN Provider-To-Customer port mappings which I believe will prove to be sugnifficantly smaller, so I am not sure yet how bad is that. In any case, if it does present a problem on a network with large number of VPNs, who said that it has to be a single overlay? Why not to configure several overlays - each containing a single ring that interconnects PEs participating in a common sub-set of VPNs, and run a seperate instance of OSPF in each overlay?

Igor

> 
> 
> 
> 
> ----- Original Message ----
> From: "Drake, John E" <[email-masked]>
> To: Igor Bryskin <[email-masked]>; Yakov Rekhter <[email-masked]>; Lo
u Berger <[email-masked]>
> Cc: Yakov Rekhter <[email-masked]>; Adrian Farrel <[email-masked]>; c
[email-masked]; [email-masked]
> Sent: Wednesday, September 3, 2008 8:10:07 AM
> Subject: RE: [Softwires] BGP TE attr last call by softwires WG (2nd question)
> 
> Igor,
> 
> Actually, I am not sure that you do understand what I wrote, because you
> are providing examples of the redundancy that I specified - every PE
> router needs to have connectivity to two other routers in the IGP
> instance.
> 
> Thanks,
> 
> John 
> 
> >-----Original Message-----
> >From: Igor Bryskin [mailto:[email-masked]] 
> >Sent: Tuesday, September 02, 2008 3:06 PM
> >To: Drake, John E; Yakov Rekhter; Lou Berger
> >Cc: Yakov Rekhter; Adrian Farrel; [email-masked]; 
> >[email-masked]
> >Subject: Re: [Softwires] BGP TE attr last call by softwires WG 
> >(2nd question)
> >
> >Hi John,
> >
> >I understand what you are saying and disagree. The overlay I 
> >am talking about logically is a separate network and as any 
> >network it should be sufficiently redundant to function. There 
> >is a number of ways how you can address the redundancy 
> >concerns. Look at the examples below:
> >
> >a) interconnect all VPN-aware PEs into a single ring: 
> >PE=======PE
> > ||                  ||
> >PE               PE 
> >||                   ||
> >PE               PE 
> >||                   ||
> >...                ....
> >PE=======PE
> >
> >b) connect each PE to two interconnected Ps 
> >
> >PE               P                 PE
> >                    ||                  
> >PE               ||                  PE 
> >                    ||                  
> >PE               ||                  PE 
> >                    ||                  
> >...                 ||                   ....
> >PE               P                 PE
> >
> >
> >Note that tunnels can traverse any number of VPN-unaware Ps and PEs.
> >
> >Igor
> >
> >
> >----- Original Message ----
> >From: "Drake, John E" <[email-masked]>
> >To: Igor Bryskin <[email-masked]>; Yakov Rekhter 
> ><[email-masked]>; Lou Berger <[email-masked]>
> >Cc: Yakov Rekhter <[email-masked]>; Adrian Farrel 
> ><[email-masked]>; [email-masked]; [email-masked]
> >Sent: Tuesday, September 2, 2008 2:24:26 PM
> >Subject: RE: [Softwires] BGP TE attr last call by softwires WG 
> >(2nd question)
> >
> >Igor,
> >
> >Several years ago when OSPF was first proposed as an 
> >autodiscovery mechanism for L1VPNs, you were told that it was 
> >a bad idea due to its scaling properties and impact on the IGP.
> >
> >You are now tacitly agreeing with those who told you it was a bad idea.
> >
> >For your suggested approach to work with sufficient 
> >redundancy, the topology of the overlay needs to be configured 
> >such that every selected P router is connected to at least two 
> >other selected P routers and every PE router needs to be 
> >connected to at least two selected P routers.
> >
> >When you are done with this configuration, you are left with a 
> >situation in which *every* PE and selected P router will have 
> >*all* L1VPN routes.
> >
> >Thanks,
> >
> >John 
> >
> >>-----Original Message-----
> >>From: Igor Bryskin [mailto:[email-masked]]
> >>Sent: Friday, August 29, 2008 12:10 PM
> >>To: Drake, John E; Yakov Rekhter; Lou Berger
> >>Cc: Yakov Rekhter; Adrian Farrel; [email-masked]; 
> >>[email-masked]
> >>Subject: Re: [Softwires] BGP TE attr last call by softwires WG (2nd 
> >>question)
> >>
> >>Are you calling me silly? Are you coming to Minneapolis? :=)
> >>
> >>Seriously, what is wrong in your opinion with this approach? 
> >>Many people are talking about multi-instance IGPs. What they have in 
> >>mind is improving the IGP scalability:
> >>a) by removing non-IP advertisements from the instance of IGP that 
> >>manages IP routing/forwarding tables into separate IGP instance(s);
> >>b) by distributing non-IP information only to and via 
> >inerested parties 
> >>leaving the bulk of Ps out of the process.
> >>
> >>In my opinion this is exactly what is needed for the OSPF-based L1VPN 
> >>application.
> >>
> >>Igor
> >>
> >>
> >>
> >>
> >>
> >>
> >>----- Original Message ----
> >>From: "Drake, John E" <[email-masked]>
> >>To: Igor Bryskin <[email-masked]>; Yakov Rekhter 
> >><[email-masked]>; Lou Berger <[email-masked]>
> >>Cc: Yakov Rekhter <[email-masked]>; Adrian Farrel 
> >><[email-masked]>; [email-masked]; [email-masked]
> >>Sent: Friday, August 29, 2008 2:31:36 PM
> >>Subject: RE: [Softwires] BGP TE attr last call by softwires WG (2nd 
> >>question)
> >>
> >>So you are proposing an OSPF route reflector?  At what point does the 
> >>silliness stop?
> >>
> >>>-----Original Message-----
> >>>From: Igor Bryskin [mailto:[email-masked]]
> >>>Sent: Friday, August 29, 2008 11:29 AM
> >>>To: Drake, John E; Yakov Rekhter; Lou Berger
> >>>Cc: Yakov Rekhter; Adrian Farrel; [email-masked]; 
> >>>[email-masked]
> >>>Subject: Re: [Softwires] BGP TE attr last call by softwires WG (2nd
> >>>question)
> >>>
> >>>Hi John,
> >>>
> >>>No, not really. When you add a PE you configure local
> >>interfaces, local
> >>>VPN port mappings, stuff like that. While doing this you will also 
> >>>configure an IPinIP tunnel to one of your spoke Ps and enable L1VPN 
> >>>OSPF instance on the tunnel.
> >>>Once you did that the local VPN information will be flooded
> >>accross the
> >>>overlay, likewise, the new PE will get all the necessary information 
> >>>from other PEs.
> >>>
> >>>Cheers,
> >>>Igor
> >>>
> >>>
> >>>----- Original Message ----
> >>>From: "Drake, John E" <[email-masked]>
> >>>To: Igor Bryskin <[email-masked]>; Yakov Rekhter 
> >>><[email-masked]>; Lou Berger <[email-masked]>
> >>>Cc: Yakov Rekhter <[email-masked]>; Adrian Farrel 
> >>><[email-masked]>; [email-masked]; [email-masked]
> >>>Sent: Friday, August 29, 2008 11:20:16 AM
> >>>Subject: RE: [Softwires] BGP TE attr last call by softwires WG (2nd
> >>>question)
> >>>
> >>>Igor,
> >>>
> >>>Doesn't this defeat auto-discovery?  I.e., how is a new PE 
> >added to a 
> >>>given L1VPN?
> >>>
> >>>Thanks,
> >>>
> >>>John
> >>>
> >>>>-----Original Message-----
> >>>>From: Igor Bryskin [mailto:[email-masked]]
> >>>>Sent: Friday, August 29, 2008 5:51 AM
> >>>>To: Yakov Rekhter; Lou Berger
> >>>>Cc: Yakov Rekhter; Adrian Farrel; [email-masked]; 
> >>>>[email-masked]
> >>>>Subject: Re: [Softwires] BGP TE attr last call by softwires WG (2nd
> >>>>question)
> >>>>
> >>>>Yakov,
> >>>>
> >>>>You said:
> >>>>
> >>>>
> >>>>... And while on the subject of scaling, please keep in mind
> >>that BGP
> >>>>only stores L1VPN routes on PEs that have sites of that VPN
> >>connected
> >>>>to them, and on an RR if used, but *not* on any of the P 
> >routers. In 
> >>>>contrast, rfc5252 (OSPF for L1VPN
> >>>>autodiscovery) results in storing *all VPN TE information 
> >for all the
> >>>>VPNs* on *all* the IGP nodes, both P and PE. So, clearly BGP-based 
> >>>>approach scales better than OSPF-based approach.
> >>>>
> >>>>Yakov.
> >>>>
> >>>>This is not true in case of multi-instance OSPF: one can build an 
> >>>>overlay interconnecting PEs via one or small number of Ps
> >>>using IPinIP
> >>>>tunnels and run in this overlay an instance of OSPF specifically 
> >>>>designated for distribution of L1VPN information. In this
> >>>case the OSPF
> >>>>solution won't scale any worse than the BGP approach. Note. 
> >>>that rfc252
> >>>>never said that the instance of OSPF used for flooding of the L1VPN 
> >>>>information must be the same instance that is used for the
> >>>distribution
> >>>>of IP-related LSAs.
> >>>>
> >>>>Regards,
> >>>>Igor
> >>>>
> >>>>
> >>>>
> >>>>
> >>>
> >>>
> >>>
> >>>
> >>
> >>
> >>
> >
> >
> >
> >
> 
> 
>      
> --0-1141253910-1220449648=:97601
> Content-Type: text/html; charset=us-ascii
> 
> <html><head><style type="text/css"><!-- DIV {margin:0px;} --></style></head><
body><div style="font-family:times new roman, new york, times, serif;font-size:
12pt"><div>And I am not arguing that sufficient redundancy must be provided. Ho
wever you said:<br>&gt;For your suggested approach to work with sufficient <br>
&gt;redundancy, the topology of the overlay needs to be configured <br>&gt;such
that every selected P router is connected to at least two <br>&gt;other select
ed P routers and every PE router needs to be <br>&gt;connected to at least two 
selected P routers.<br><br>If you just simply interconnect all VPN-aware PEs in
to a single ring via IPinIP tunnels and run an instance of OSPF to distribute V
PN-related information between them, it will provide sufficient redundancy and 
involve exactly *zero* Ps.<br>So, I want you to drop your lecturing tone for a 
minute and simply tell in what respect in your opinion this approach is not per
fect fo the L1VPN
>  application. Otherwise, I am not interested in this discussion any longer. I
do like to hear comments from other people.<br><br>Igor <br><br></div><div sty
le="font-family: times new roman,new york,times,serif; font-size: 12pt;"><br><d
iv style="font-family: arial,helvetica,sans-serif; font-size: 13px;">----- Orig
inal Message ----<br>From: "Drake, John E" &lt;[email-masked]&gt;<br>
To: Igor Bryskin &lt;[email-masked]&gt;; Yakov Rekhter &lt;[email-masked]
et&gt;; Lou Berger &lt;[email-masked]&gt;<br>Cc: Yakov Rekhter &lt;yakov@juni
per.net&gt;; Adrian Farrel &lt;[email-masked]&gt;; [email-masked]; sof
[email-masked]<br>Sent: Wednesday, September 3, 2008 8:10:07 AM<br>Subject: RE
: [Softwires] BGP TE attr last call by softwires WG (2nd question)<br><br>
> Igor,<br><br>Actually, I am not sure that you do understand what I wrote, bec
ause you<br>are providing examples of the redundancy that I specified - every P
E<br>router needs to have connectivity to two other routers in the IGP<br>insta
nce.<br><br>Thanks,<br><br>John <br><br>&gt;-----Original Message-----<br>&gt;F
rom: Igor Bryskin [mailto:<a ymailto="mailto:[email-masked]" href="mailto:
[email-masked]">[email-masked]</a>] <br>&gt;Sent: Tuesday, September 
02, 2008 3:06 PM<br>&gt;To: Drake, John E; Yakov Rekhter; Lou Berger<br>&gt;Cc:
Yakov Rekhter; Adrian Farrel; <a ymailto="mailto:[email-masked]" href="mai
lto:[email-masked]">[email-masked]</a>; <br>&gt;<a ymailto="mailto:soft
[email-masked]" href="mailto:[email-masked]">[email-masked]</a><br>&gt;
Subject: Re: [Softwires] BGP TE attr last call by softwires WG <br>&gt;(2nd que
stion)<br>&gt;<br>&gt;Hi John,<br>&gt;<br>&gt;I understand what you are saying 
and disagree. The
>  overlay I <br>&gt;am talking about logically is a separate network and as an
y <br>&gt;network it should be sufficiently redundant to function. There <br>&g
t;is a number of ways how you can address the redundancy <br>&gt;concerns. Look
at the examples below:<br>&gt;<br>&gt;a) interconnect all VPN-aware PEs into a
single ring: <br>&gt;PE=======PE<br>&gt; ||&nbsp; &nbsp; &nbsp; &nbsp; &nbsp; 
&nbsp; &nbsp; &nbsp; &nbsp; ||<br>&gt;PE&nbsp; &nbsp; &nbsp; &nbsp; &nbsp; &nbs
p; &nbsp;  PE <br>&gt;||&nbsp; &nbsp; &nbsp; &nbsp; &nbsp; &nbsp; &nbsp; &nbsp;
&nbsp;  ||<br>&gt;PE&nbsp; &nbsp; &nbsp; &nbsp; &nbsp; &nbsp; &nbsp;  PE <br>&
gt;||&nbsp; &nbsp; &nbsp; &nbsp; &nbsp; &nbsp; &nbsp; &nbsp; &nbsp;  ||<br>&gt;
...&nbsp; &nbsp; &nbsp; &nbsp; &nbsp; &nbsp; &nbsp; &nbsp; ....<br>&gt;PE======
=PE<br>&gt;<br>&gt;b) connect each PE to two interconnected Ps <br>&gt;<br>&gt;
PE&nbsp; &nbsp; &nbsp; &nbsp; &nbsp; &nbsp; &nbsp;  P&nbsp; &nbsp; &nbsp; &nbsp
; &nbsp; &nbsp; &nbsp;
>  &nbsp;  PE<br>&gt;&nbsp; &nbsp; &nbsp; &nbsp; &nbsp; &nbsp; &nbsp; &nbsp; &n
bsp; &nbsp; ||&nbsp; &nbsp; &nbsp; &nbsp; &nbsp; &nbsp; &nbsp; &nbsp; &nbsp;  <
br>&gt;PE&nbsp; &nbsp; &nbsp; &nbsp; &nbsp; &nbsp; &nbsp;  ||&nbsp; &nbsp; &nbs
p; &nbsp; &nbsp; &nbsp; &nbsp; &nbsp; &nbsp; PE <br>&gt;&nbsp; &nbsp; &nbsp; &n
bsp; &nbsp; &nbsp; &nbsp; &nbsp; &nbsp; &nbsp; ||&nbsp; &nbsp; &nbsp; &nbsp; &n
bsp; &nbsp; &nbsp; &nbsp; &nbsp; <br>&gt;PE&nbsp; &nbsp; &nbsp; &nbsp; &nbsp; &
nbsp; &nbsp;  ||&nbsp; &nbsp; &nbsp; &nbsp; &nbsp; &nbsp; &nbsp; &nbsp; &nbsp; 
PE <br>&gt;&nbsp; &nbsp; &nbsp; &nbsp; &nbsp; &nbsp; &nbsp; &nbsp; &nbsp; &nbsp
; ||&nbsp; &nbsp; &nbsp; &nbsp; &nbsp; &nbsp; &nbsp; &nbsp; &nbsp; <br>&gt;...&
nbsp; &nbsp; &nbsp; &nbsp; &nbsp; &nbsp; &nbsp; &nbsp;  ||&nbsp; &nbsp; &nbsp; 
&nbsp; &nbsp; &nbsp; &nbsp; &nbsp; &nbsp;  ....<br>&gt;PE&nbsp; &nbsp; &nbsp; &
nbsp; &nbsp; &nbsp; &nbsp;  P&nbsp; &nbsp; &nbsp; &nbsp; &nbsp; &nbsp; &nbsp; &
nbsp; 
>  PE<br>&gt;<br>&gt;<br>&gt;Note that tunnels can traverse any number of VPN-u
naware Ps and PEs.<br>&gt;<br>&gt;Igor<br>&gt;<br>&gt;<br>&gt;----- Original Me
ssage ----<br>&gt;From: "Drake, John E" &lt;<a ymailto="mailto:John.E.Drake2@bo
eing.com" href="mailto:[email-masked]">[email-masked]</a>&g
t;<br>&gt;To: Igor Bryskin &lt;<a ymailto="mailto:[email-masked]" href="ma
ilto:[email-masked]">[email-masked]</a>&gt;; Yakov Rekhter <br>&gt;&l
t;<a ymailto="mailto:[email-masked]" href="mailto:[email-masked]">yakov@j
uniper.net</a>&gt;; Lou Berger &lt;<a ymailto="mailto:[email-masked]" href="m
ailto:[email-masked]">[email-masked]</a>&gt;<br>&gt;Cc: Yakov Rekhter &lt;<
a ymailto="mailto:[email-masked]" href="mailto:[email-masked]">yakov@juni
per.net</a>&gt;; Adrian Farrel <br>&gt;&lt;<a ymailto="mailto:[email-masked].
uk" href="mailto:[email-masked]">[email-masked]</a>&gt;; <a
>  ymailto="mailto:[email-masked]" href="mailto:[email-masked]">ccamp@o
ps.ietf.org</a>; <a ymailto="mailto:[email-masked]" href="mailto:softwires@
ietf.org">[email-masked]</a><br>&gt;Sent: Tuesday, September 2, 2008 2:24:2
6 PM<br>&gt;Subject: RE: [Softwires] BGP TE attr last call by softwires WG <br>
&gt;(2nd question)<br>&gt;<br>&gt;Igor,<br>&gt;<br>&gt;Several years ago when O
SPF was first proposed as an <br>&gt;autodiscovery mechanism for L1VPNs, you we
re told that it was <br>&gt;a bad idea due to its scaling properties and impact
on the IGP.<br>&gt;<br>&gt;You are now tacitly agreeing with those who told yo
u it was a bad idea.<br>&gt;<br>&gt;For your suggested approach to work with su
fficient <br>&gt;redundancy, the topology of the overlay needs to be configured
<br>&gt;such that every selected P router is connected to at least two <br>&gt
;other selected P routers and every PE router needs to be <br>&gt;connected to 
at least two selected
>  P routers.<br>&gt;<br>&gt;When you are done with this configuration, you are
left with a <br>&gt;situation in which *every* PE and selected P router will h
ave <br>&gt;*all* L1VPN routes.<br>&gt;<br>&gt;Thanks,<br>&gt;<br>&gt;John <br>
&gt;<br>&gt;&gt;-----Original Message-----<br>&gt;&gt;From: Igor Bryskin [mailt
o:<a ymailto="mailto:[email-masked]" href="mailto:[email-masked]">i_b
[email-masked]</a>]<br>&gt;&gt;Sent: Friday, August 29, 2008 12:10 PM<br>&gt;
&gt;To: Drake, John E; Yakov Rekhter; Lou Berger<br>&gt;&gt;Cc: Yakov Rekhter; 
Adrian Farrel; <a ymailto="mailto:[email-masked]" href="mailto:[email-masked]
tf.org">[email-masked]</a>; <br>&gt;&gt;<a ymailto="mailto:[email-masked]
rg" href="mailto:[email-masked]">[email-masked]</a><br>&gt;&gt;Subject:
Re: [Softwires] BGP TE attr last call by softwires WG (2nd <br>&gt;&gt;questio
n)<br>&gt;&gt;<br>&gt;&gt;Are you calling me silly? Are you coming to Minneapol
is?
>  :=)<br>&gt;&gt;<br>&gt;&gt;Seriously, what is wrong in your opinion with thi
s approach? <br>&gt;&gt;Many people are talking about multi-instance IGPs. What
they have in <br>&gt;&gt;mind is improving the IGP scalability:<br>&gt;&gt;a) 
by removing non-IP advertisements from the instance of IGP that <br>&gt;&gt;man
ages IP routing/forwarding tables into separate IGP instance(s);<br>&gt;&gt;b) 
by distributing non-IP information only to and via <br>&gt;inerested parties <b
r>&gt;&gt;leaving the bulk of Ps out of the process.<br>&gt;&gt;<br>&gt;&gt;In 
my opinion this is exactly what is needed for the OSPF-based L1VPN <br>&gt;&gt;
application.<br>&gt;&gt;<br>&gt;&gt;Igor<br>&gt;&gt;<br>&gt;&gt;<br>&gt;&gt;<br
>&gt;&gt;<br>&gt;&gt;<br>&gt;&gt;<br>&gt;&gt;----- Original Message ----<br>&gt
;&gt;From: "Drake, John E" &lt;<a ymailto="mailto:[email-masked]" hre
f="mailto:[email-masked]">[email-masked]</a>&gt;<br>&gt;&gt
;To: Igor Bryskin
>  &lt;<a ymailto="mailto:[email-masked]" href="mailto:[email-masked]
">[email-masked]</a>&gt;; Yakov Rekhter <br>&gt;&gt;&lt;<a ymailto="mailto
:[email-masked]" href="mailto:[email-masked]">[email-masked]</a>&gt;; 
Lou Berger &lt;<a ymailto="mailto:[email-masked]" href="mailto:[email-masked]
et">[email-masked]</a>&gt;<br>&gt;&gt;Cc: Yakov Rekhter &lt;<a ymailto="mailt
o:[email-masked]" href="mailto:[email-masked]">[email-masked]</a>&gt;;
Adrian Farrel <br>&gt;&gt;&lt;<a ymailto="mailto:[email-masked]" href="ma
ilto:[email-masked]">[email-masked]</a>&gt;; <a ymailto="mailto:ccamp
@ops.ietf.org" href="mailto:[email-masked]">[email-masked]</a>; <a ymai
lto="mailto:[email-masked]" href="mailto:[email-masked]">softwires@ietf
.org</a><br>&gt;&gt;Sent: Friday, August 29, 2008 2:31:36 PM<br>&gt;&gt;Subject
: RE: [Softwires] BGP TE attr last call by softwires WG (2nd
>  <br>&gt;&gt;question)<br>&gt;&gt;<br>&gt;&gt;So you are proposing an OSPF ro
ute reflector?&nbsp; At what point does the <br>&gt;&gt;silliness stop?<br>&gt;
&gt;<br>&gt;&gt;&gt;-----Original Message-----<br>&gt;&gt;&gt;From: Igor Bryski
n [mailto:<a ymailto="mailto:[email-masked]" href="mailto:i_bryskin@yahoo.
com">[email-masked]</a>]<br>&gt;&gt;&gt;Sent: Friday, August 29, 2008 11:2
9 AM<br>&gt;&gt;&gt;To: Drake, John E; Yakov Rekhter; Lou Berger<br>&gt;&gt;&gt
;Cc: Yakov Rekhter; Adrian Farrel; <a ymailto="mailto:[email-masked]" href=
"mailto:[email-masked]">[email-masked]</a>; <br>&gt;&gt;&gt;<a ymailto=
"mailto:[email-masked]" href="mailto:[email-masked]">[email-masked]
</a><br>&gt;&gt;&gt;Subject: Re: [Softwires] BGP TE attr last call by softwires
WG (2nd<br>&gt;&gt;&gt;question)<br>&gt;&gt;&gt;<br>&gt;&gt;&gt;Hi John,<br>&g
t;&gt;&gt;<br>&gt;&gt;&gt;No, not really. When you add a PE you configure
>  local<br>&gt;&gt;interfaces, local<br>&gt;&gt;&gt;VPN port mappings, stuff l
ike that. While doing this you will also <br>&gt;&gt;&gt;configure an IPinIP tu
nnel to one of your spoke Ps and enable L1VPN <br>&gt;&gt;&gt;OSPF instance on 
the tunnel.<br>&gt;&gt;&gt;Once you did that the local VPN information will be 
flooded<br>&gt;&gt;accross the<br>&gt;&gt;&gt;overlay, likewise, the new PE wil
l get all the necessary information <br>&gt;&gt;&gt;from other PEs.<br>&gt;&gt;
&gt;<br>&gt;&gt;&gt;Cheers,<br>&gt;&gt;&gt;Igor<br>&gt;&gt;&gt;<br>&gt;&gt;&gt;
<br>&gt;&gt;&gt;----- Original Message ----<br>&gt;&gt;&gt;From: "Drake, John E
" &lt;<a ymailto="mailto:[email-masked]" href="mailto:John.E.Drake2@b
oeing.com">[email-masked]</a>&gt;<br>&gt;&gt;&gt;To: Igor Bryskin &lt
;<a ymailto="mailto:[email-masked]" href="mailto:[email-masked]">i_br
[email-masked]</a>&gt;; Yakov Rekhter <br>&gt;&gt;&gt;&lt;<a ymailto="mailto:y
[email-masked]"
>  href="mailto:[email-masked]">[email-masked]</a>&gt;; Lou Berger &lt;<a
ymailto="mailto:[email-masked]" href="mailto:[email-masked]">lberger@labn.
net</a>&gt;<br>&gt;&gt;&gt;Cc: Yakov Rekhter &lt;<a ymailto="mailto:yakov@junip
er.net" href="mailto:[email-masked]">[email-masked]</a>&gt;; Adrian Farre
l <br>&gt;&gt;&gt;&lt;<a ymailto="mailto:[email-masked]" href="mailto:adri
[email-masked]">[email-masked]</a>&gt;; <a ymailto="mailto:[email-masked]
.org" href="mailto:[email-masked]">[email-masked]</a>; <a ymailto="mail
to:[email-masked]" href="mailto:[email-masked]">[email-masked]</a><
br>&gt;&gt;&gt;Sent: Friday, August 29, 2008 11:20:16 AM<br>&gt;&gt;&gt;Subject
: RE: [Softwires] BGP TE attr last call by softwires WG (2nd<br>&gt;&gt;&gt;que
stion)<br>&gt;&gt;&gt;<br>&gt;&gt;&gt;Igor,<br>&gt;&gt;&gt;<br>&gt;&gt;&gt;Does
n't this defeat auto-discovery?&nbsp; I.e., how is a new PE <br>&gt;added to a 
<br>&gt;&gt;&gt;given
>  L1VPN?<br>&gt;&gt;&gt;<br>&gt;&gt;&gt;Thanks,<br>&gt;&gt;&gt;<br>&gt;&gt;&gt
;John<br>&gt;&gt;&gt;<br>&gt;&gt;&gt;&gt;-----Original Message-----<br>&gt;&gt;
&gt;&gt;From: Igor Bryskin [mailto:<a ymailto="mailto:[email-masked]" href
="mailto:[email-masked]">[email-masked]</a>]<br>&gt;&gt;&gt;&gt;Sent:
Friday, August 29, 2008 5:51 AM<br>&gt;&gt;&gt;&gt;To: Yakov Rekhter; Lou Berg
er<br>&gt;&gt;&gt;&gt;Cc: Yakov Rekhter; Adrian Farrel; <a ymailto="mailto:ccam
[email-masked]" href="mailto:[email-masked]">[email-masked]</a>; <br>&g
t;&gt;&gt;&gt;<a ymailto="mailto:[email-masked]" href="mailto:softwires@iet
f.org">[email-masked]</a><br>&gt;&gt;&gt;&gt;Subject: Re: [Softwires] BGP T
E attr last call by softwires WG (2nd<br>&gt;&gt;&gt;&gt;question)<br>&gt;&gt;&
gt;&gt;<br>&gt;&gt;&gt;&gt;Yakov,<br>&gt;&gt;&gt;&gt;<br>&gt;&gt;&gt;&gt;You sa
id:<br>&gt;&gt;&gt;&gt;<br>&gt;&gt;&gt;&gt;<br>&gt;&gt;&gt;&gt;... And while on
the subject of
>  scaling, please keep in mind<br>&gt;&gt;that BGP<br>&gt;&gt;&gt;&gt;only sto
res L1VPN routes on PEs that have sites of that VPN<br>&gt;&gt;connected<br>&gt
;&gt;&gt;&gt;to them, and on an RR if used, but *not* on any of the P <br>&gt;r
outers. In <br>&gt;&gt;&gt;&gt;contrast, rfc5252 (OSPF for L1VPN<br>&gt;&gt;&gt
;&gt;autodiscovery) results in storing *all VPN TE information <br>&gt;for all 
the<br>&gt;&gt;&gt;&gt;VPNs* on *all* the IGP nodes, both P and PE. So, clearly
BGP-based <br>&gt;&gt;&gt;&gt;approach scales better than OSPF-based approach.
<br>&gt;&gt;&gt;&gt;<br>&gt;&gt;&gt;&gt;Yakov.<br>&gt;&gt;&gt;&gt;<br>&gt;&gt;&
gt;&gt;This is not true in case of multi-instance OSPF: one can build an <br>&g
t;&gt;&gt;&gt;overlay interconnecting PEs via one or small number of Ps<br>&gt;
&gt;&gt;using IPinIP<br>&gt;&gt;&gt;&gt;tunnels and run in this overlay an inst
ance of OSPF specifically <br>&gt;&gt;&gt;&gt;designated for distribution of L1
VPN information. In
>  this<br>&gt;&gt;&gt;case the OSPF<br>&gt;&gt;&gt;&gt;solution won't scale an
y worse than the BGP approach. Note. <br>&gt;&gt;&gt;that rfc252<br>&gt;&gt;&gt
;&gt;never said that the instance of OSPF used for flooding of the L1VPN <br>&g
t;&gt;&gt;&gt;information must be the same instance that is used for the<br>&gt
;&gt;&gt;distribution<br>&gt;&gt;&gt;&gt;of IP-related LSAs.<br>&gt;&gt;&gt;&gt
;<br>&gt;&gt;&gt;&gt;Regards,<br>&gt;&gt;&gt;&gt;Igor<br>&gt;&gt;&gt;&gt;<br>&g
t;&gt;&gt;&gt;<br>&gt;&gt;&gt;&gt;<br>&gt;&gt;&gt;&gt;<br>&gt;&gt;&gt;<br>&gt;&
gt;&gt;<br>&gt;&gt;&gt;<br>&gt;&gt;&gt;<br>&gt;&gt;<br>&gt;&gt;<br>&gt;&gt;<br>
&gt;<br>&gt;<br>&gt;<br>&gt;<br><br></div></div></div><br>
> 
>       </body></html>
> --0-1141253910-1220449648=:97601--

_______________________________________________
Softwires mailing list
[email-masked]
https://www.ietf.org/mailman/listinfo/softwires

---

From: Yakov Rekhter <[email-masked]>
Date: Wed, 03 Sep 2008 08:13:04 -0700

Igor,

> Please,  see in-line.

see in-line...

> Cc: "Drake, John E" <[email-masked]>; Lou Berger <[email-masked]>
; Adrian Farrel <[email-masked]>; [email-masked]; [email-masked]
 
> 
> Igor,
> 
> > And I am not arguing that sufficient redundancy must be provided. However 
> > you said:
> IB>> Ok. Several points here. Note that neither Ps nor VPN-unaware PEs 
> IB>> participate in the distribution/maintenance of VPN information, 
> IB>> which is already significantly better than what you said about 
> IB>> the OSPF solution in your previous mail:
> 
> >   for all the VPNs* on *all* the IGP nodes, both P and PE. So, clearly 
> >
> >   BGP-based approach scales better than OSPF-based approach.
> > >>>>Yakov.
> 
> I do agree that if you use a single ring overlay interconnecting
> all VPN aware PEs you will have LSDBs at all PEs contain VPN info
> about all VPNs. However, in case of L1VPN this is not VPN routes,
> rather VPN Provider-To-Customer port mappings which I believe will
> prove to be significantly smaller, so I am not sure yet how bad
> is that. In any case, if it does present a problem on a network
> with large number of VPNs, who said that it has to be a single
> overlay? Why not to configure several overlays - each containing a
> single ring that interconnects PEs participating in a common sub-set
> of VPNs, and run a seperate instance o f OSPF in each overlay?

Sure. And this would be a good illustration of the fact that the
whole idea of using OSPF for L1VPN auto-discovery falls into the
paradigm of inherently flawed designs whose weakness can be solved
only by the usage of elaborate features, that, in turn, introduce 
a new set of problems.

Yakov.

> > <html><head><style type="text/css"><!-- DIV {margin:0px;} --></style></head
><

> to:[email-masked]" href="mailto:[email-masked]">[email-masked]</a
><
> --0-1852435290-1220452662=:19087
body><div style="font-family:times new roman, new york, times, serif;font-size:
12pt"><div>Yaokov,<br><br>Please,&nbsp; see in-line.<br></div><div style="font-
family: times new roman,new york,times,serif; font-size: 12pt;"><br><div style=
"font-family: arial,helvetica,sans-serif; font-size: 13px;">----- Original Mess
age ----<br>From: Yakov Rekhter &lt;[email-masked]&gt;<br>To: Igor Bryskin &
lt;[email-masked]&gt;<br>Cc: "Drake, John E" &lt;[email-masked]&
gt;; Lou Berger &lt;[email-masked]&gt;; Adrian Farrel &lt;[email-masked]
&gt;; [email-masked]; [email-masked]<br>Sent: Wednesday, September 3, 2
008 9:55:49 AM<br>Subject: Re: [Softwires] BGP TE attr last call by softwires W
G (2nd question) <br><br>
> Igor,<br><br>&gt; And I am not arguing that sufficient redundancy must be pro
vided. However you<br>&gt; said:<br>&gt; &gt;For your suggested approach to wor
k with sufficient <br>&gt; &gt;redundancy, the topology of the overlay needs to
 be configured <br>&gt; &gt;such that every selected P router is connected to a
t least two <br>&gt; &gt;other selected P routers and every PE router needs to 
be <br>&gt; &gt;connected to at least two selected P routers.<br>&gt; <br>&gt; 
If you just simply interconnect all VPN-aware PEs into a single<br>&gt; ring vi
a IPin IP tunnels and run an instance of OSPF to distribute<br>&gt; VPN-related
 information between them, it will provide sufficient<br>&gt; redundancy and in
volve exactly *zero* Ps.<br>&gt;<br>&gt; So, I want you to drop your lecturing 
tone for a minute and simply<br>&gt; tell in what respect in your opinion this 
approach is not perfect<br>&gt; fo the L1VPN application. Otherwise, I am not i
nterested in
>  this<br>&gt; discussion any longer. I do like to hear comments from other pe
ople.<br><br>Since you asked, one problem with using OSPF, as John correctly<br
>pointed out, is that you are left with a situation in which *every* PE <br>rou
ter will have *all* L1VPN routes for all the L1VPNs. Of course, <br>this is "pe
rfect" in a sense that you can do no worse than that :-)<br><br>IB&gt;&gt; Ok. 
Several points here. Note that neither Ps nor VPN-unaware PEs participate in th
e distribution/maintenance of VPN information, which is already significantly b
etter than what you said about the OSPF solution in your previous mail:<br><br>
&gt;... And while on the subject of scaling, please keep in mind that BGP<br>&g
t;&nbsp;&nbsp; only stores L1VPN routes on PEs that have sites of that VPN<br>&
gt;&nbsp;&nbsp; connected to them, and on an RR if used, but *not* on any of th
e P <br>&gt;&nbsp;&nbsp; routers. In contrast, rfc5252 (OSPF for L1VPN<br>&gt;&
nbsp;&nbsp;
>  autodiscovery) results in storing *all VPN TE information <br>&gt;&nbsp;&nbs
p; for all the VPNs* on *all* the IGP nodes, both P and PE. So, clearly BGP-bas
ed <br>&gt;&nbsp;&nbsp; approach scales better than OSPF-based approach.<br><br
>&gt; &gt;&gt;&gt;&gt;Yakov.<br><br>I do agree that if you use a single ring ov
erlay interconnecting all VPN aware PEs you will have LSDBs at all PEs contain 
VPN info about all VPNs. However, in case of L1VPN this is not VPN routes, rath
er VPN Provider-To-Customer port mappings which I believe will prove to be sugn
ifficantly smaller, so I am not sure yet how bad is that. In any case, if it do
es present a problem on a network with large number of VPNs, who said that it h
as to be a single overlay? Why not to configure several overlays - each contain
ing a single ring that interconnects PEs participating in a common sub-set of V
PNs, and run a seperate instance of OSPF in each overlay?<br><br>Igor<br><br><b
r>&nbsp;<br>&gt;
>  <br>&gt; <br>&gt; <br>&gt; <br>&gt; ----- Original Message ----<br>&gt; From
: "Drake, John E" &lt;<a ymailto="mailto:[email-masked]" href="mailto
:[email-masked]">[email-masked]</a>&gt;<br>&gt; To: Igor Br
yskin &lt;<a ymailto="mailto:[email-masked]" href="mailto:i_bryskin@yahoo.
com">[email-masked]</a>&gt;; Yakov Rekhter &lt;<a ymailto="mailto:yakov@ju
niper.net" href="mailto:[email-masked]">[email-masked]</a>&gt;; Lo<br>u B
erger &lt;<a ymailto="mailto:[email-masked]" href="mailto:[email-masked]">l
[email-masked]</a>&gt;<br>&gt; Cc: Yakov Rekhter &lt;<a ymailto="mailto:yakov@
juniper.net" href="mailto:[email-masked]">[email-masked]</a>&gt;; Adrian 
Farrel &lt;<a ymailto="mailto:[email-masked]" href="mailto:[email-masked]
o.uk">[email-masked]</a>&gt;; c<br><a ymailto="mailto:[email-masked]" h
ref="mailto:[email-masked]">[email-masked]</a>; <a ymailto="mailto:softwi
[email-masked]"
>  href="mailto:[email-masked]">[email-masked]</a><br>&gt; Sent: Wednes
day, September 3, 2008 8:10:07 AM<br>&gt; Subject: RE: [Softwires] BGP TE attr 
last call by softwires WG (2nd question)<br>&gt; <br>&gt; Igor,<br>&gt; <br>&gt
; Actually, I am not sure that you do understand what I wrote, because you<br>&
gt; are providing examples of the redundancy that I specified - every PE<br>&gt
; router needs to have connectivity to two other routers in the IGP<br>&gt; ins
tance.<br>&gt; <br>&gt; Thanks,<br>&gt; <br>&gt; John <br>&gt; <br>&gt; &gt;---
--Original Message-----<br>&gt; &gt;From: Igor Bryskin [mailto:<a ymailto="mail
to:[email-masked]" href="mailto:[email-masked]">[email-masked]</
a>] <br>&gt; &gt;Sent: Tuesday, September 02, 2008 3:06 PM<br>&gt; &gt;To: Drak
e, John E; Yakov Rekhter; Lou Berger<br>&gt; &gt;Cc: Yakov Rekhter; Adrian Farr
el; <a ymailto="mailto:[email-masked]" href="mailto:[email-masked]">cca
[email-masked]</a>;
>  <br>&gt; &gt;<a ymailto="mailto:[email-masked]" href="mailto:softwires@i
etf.org">[email-masked]</a><br>&gt; &gt;Subject: Re: [Softwires] BGP TE att
r last call by softwires WG <br>&gt; &gt;(2nd question)<br>&gt; &gt;<br>&gt; &g
t;Hi John,<br>&gt; &gt;<br>&gt; &gt;I understand what you are saying and disagr
ee. The overlay I <br>&gt; &gt;am talking about logically is a separate network
 and as any <br>&gt; &gt;network it should be sufficiently redundant to functio
n. There <br>&gt; &gt;is a number of ways how you can address the redundancy <b
r>&gt; &gt;concerns. Look at the examples below:<br>&gt; &gt;<br>&gt; &gt;a) in
terconnect all VPN-aware PEs into a single ring: <br>&gt; &gt;PE=======PE<br>&g
t; &gt; ||&nbsp; &nbsp; &nbsp; &nbsp; &nbsp; &nbsp; &nbsp; &nbsp; &nbsp; ||<br>
&gt; &gt;PE&nbsp; &nbsp; &nbsp; &nbsp; &nbsp; &nbsp; &nbsp;  PE <br>&gt; &gt;||
&nbsp; &nbsp; &nbsp; &nbsp; &nbsp; &nbsp; &nbsp; &nbsp; &nbsp;  ||<br>&gt; &gt;
PE&nbsp; &nbsp; &nbsp;
>  &nbsp; &nbsp; &nbsp; &nbsp;  PE <br>&gt; &gt;||&nbsp; &nbsp; &nbsp; &nbsp; &
nbsp; &nbsp; &nbsp; &nbsp; &nbsp;  ||<br>&gt; &gt;...&nbsp; &nbsp; &nbsp; &nbsp
; &nbsp; &nbsp; &nbsp; &nbsp; ....<br>&gt; &gt;PE=======PE<br>&gt; &gt;<br>&gt;
 &gt;b) connect each PE to two interconnected Ps <br>&gt; &gt;<br>&gt; &gt;PE&n
bsp; &nbsp; &nbsp; &nbsp; &nbsp; &nbsp; &nbsp;  P&nbsp; &nbsp; &nbsp; &nbsp; &n
bsp; &nbsp; &nbsp; &nbsp;  PE<br>&gt; &gt;&nbsp; &nbsp; &nbsp; &nbsp; &nbsp; &n
bsp; &nbsp; &nbsp; &nbsp; &nbsp; ||&nbsp; &nbsp; &nbsp; &nbsp; &nbsp; &nbsp; &n
bsp; &nbsp; &nbsp; <br>&gt; &gt;PE&nbsp; &nbsp; &nbsp; &nbsp; &nbsp; &nbsp; &nb
sp;  ||&nbsp; &nbsp; &nbsp; &nbsp; &nbsp; &nbsp; &nbsp; &nbsp; &nbsp; PE <br>&g
t; &gt;&nbsp; &nbsp; &nbsp; &nbsp; &nbsp; &nbsp; &nbsp; &nbsp; &nbsp; &nbsp; ||
&nbsp; &nbsp; &nbsp; &nbsp; &nbsp; &nbsp; &nbsp; &nbsp; &nbsp; <br>&gt; &gt;PE&
nbsp; &nbsp; &nbsp; &nbsp; &nbsp; &nbsp; &nbsp;  ||&nbsp; &nbsp; &nbsp; &nbsp; 
&nbsp; &nbsp; &nbsp;
>  &nbsp; &nbsp; PE <br>&gt; &gt;&nbsp; &nbsp; &nbsp; &nbsp; &nbsp; &nbsp; &nbs
p; &nbsp; &nbsp; &nbsp; ||&nbsp; &nbsp; &nbsp; &nbsp; &nbsp; &nbsp; &nbsp; &nbs
p; &nbsp; <br>&gt; &gt;...&nbsp; &nbsp; &nbsp; &nbsp; &nbsp; &nbsp; &nbsp; &nbs
p;  ||&nbsp; &nbsp; &nbsp; &nbsp; &nbsp; &nbsp; &nbsp; &nbsp; &nbsp;  ....<br>&
gt; &gt;PE&nbsp; &nbsp; &nbsp; &nbsp; &nbsp; &nbsp; &nbsp;  P&nbsp; &nbsp; &nbs
p; &nbsp; &nbsp; &nbsp; &nbsp; &nbsp;  PE<br>&gt; &gt;<br>&gt; &gt;<br>&gt; &gt
;Note that tunnels can traverse any number of VPN-unaware Ps and PEs.<br>&gt; &
gt;<br>&gt; &gt;Igor<br>&gt; &gt;<br>&gt; &gt;<br>&gt; &gt;----- Original Messa
ge ----<br>&gt; &gt;From: "Drake, John E" &lt;<a ymailto="mailto:John.E.Drake2@
boeing.com" href="mailto:[email-masked]">[email-masked]</a>
&gt;<br>&gt; &gt;To: Igor Bryskin &lt;<a ymailto="mailto:[email-masked]" h
ref="mailto:[email-masked]">[email-masked]</a>&gt;; Yakov Rekhter <br
>&gt; &gt;&lt;<a
>  ymailto="mailto:[email-masked]" href="mailto:[email-masked]">yakov@jun
iper.net</a>&gt;; Lou Berger &lt;<a ymailto="mailto:[email-masked]" href="mai
lto:[email-masked]">[email-masked]</a>&gt;<br>&gt; &gt;Cc: Yakov Rekhter &l
t;<a ymailto="mailto:[email-masked]" href="mailto:[email-masked]">yakov@j
uniper.net</a>&gt;; Adrian Farrel <br>&gt; &gt;&lt;<a ymailto="mailto:adrian@ol
ddog.co.uk" href="mailto:[email-masked]">[email-masked]</a>&gt;; <a y
mailto="mailto:[email-masked]" href="mailto:[email-masked]">[email-masked]
etf.org</a>; <a ymailto="mailto:[email-masked]" href="mailto:softwires@ietf
.org">[email-masked]</a><br>&gt; &gt;Sent: Tuesday, September 2, 2008 2:24:
26 PM<br>&gt; &gt;Subject: RE: [Softwires] BGP TE attr last call by softwires W
G <br>&gt; &gt;(2nd question)<br>&gt; &gt;<br>&gt; &gt;Igor,<br>&gt; &gt;<br>&g
t; &gt;Several years ago when OSPF was first proposed as an <br>&gt; &gt;autodi
scovery mechanism for
>  L1VPNs, you were told that it was <br>&gt; &gt;a bad idea due to its scaling
 properties and impact on the IGP.<br>&gt; &gt;<br>&gt; &gt;You are now tacitly
 agreeing with those who told you it was a bad idea.<br>&gt; &gt;<br>&gt; &gt;F
or your suggested approach to work with sufficient <br>&gt; &gt;redundancy, the
 topology of the overlay needs to be configured <br>&gt; &gt;such that every se
lected P router is connected to at least two <br>&gt; &gt;other selected P rout
ers and every PE router needs to be <br>&gt; &gt;connected to at least two sele
cted P routers.<br>&gt; &gt;<br>&gt; &gt;When you are done with this configurat
ion, you are left with a <br>&gt; &gt;situation in which *every* PE and selecte
d P router will have <br>&gt; &gt;*all* L1VPN routes.<br>&gt; &gt;<br>&gt; &gt;
Thanks,<br>&gt; &gt;<br>&gt; &gt;John <br>&gt; &gt;<br>&gt; &gt;&gt;-----Origin
al Message-----<br>&gt; &gt;&gt;From: Igor Bryskin [mailto:<a ymailto="mailto:i
[email-masked]"
>  href="mailto:[email-masked]">[email-masked]</a>]<br>&gt; &gt;&gt;S
ent: Friday, August 29, 2008 12:10 PM<br>&gt; &gt;&gt;To: Drake, John E; Yakov 
Rekhter; Lou Berger<br>&gt; &gt;&gt;Cc: Yakov Rekhter; Adrian Farrel; <a ymailt
o="mailto:[email-masked]" href="mailto:[email-masked]">[email-masked]
rg</a>; <br>&gt; &gt;&gt;<a ymailto="mailto:[email-masked]" href="mailto:so
[email-masked]">[email-masked]</a><br>&gt; &gt;&gt;Subject: Re: [Softwire
s] BGP TE attr last call by softwires WG (2nd <br>&gt; &gt;&gt;question)<br>&gt
; &gt;&gt;<br>&gt; &gt;&gt;Are you calling me silly? Are you coming to Minneapo
lis? :=)<br>&gt; &gt;&gt;<br>&gt; &gt;&gt;Seriously, what is wrong in your opin
ion with this approach? <br>&gt; &gt;&gt;Many people are talking about multi-in
stance IGPs. What they have in <br>&gt; &gt;&gt;mind is improving the IGP scala
bility:<br>&gt; &gt;&gt;a) by removing non-IP advertisements from the instance 
of IGP that <br>&gt;
>  &gt;&gt;manages IP routing/forwarding tables into separate IGP instance(s);<
br>&gt; &gt;&gt;b) by distributing non-IP information only to and via <br>&gt; 
&gt;inerested parties <br>&gt; &gt;&gt;leaving the bulk of Ps out of the proces
s.<br>&gt; &gt;&gt;<br>&gt; &gt;&gt;In my opinion this is exactly what is neede
d for the OSPF-based L1VPN <br>&gt; &gt;&gt;application.<br>&gt; &gt;&gt;<br>&g
t; &gt;&gt;Igor<br>&gt; &gt;&gt;<br>&gt; &gt;&gt;<br>&gt; &gt;&gt;<br>&gt; &gt;
&gt;<br>&gt; &gt;&gt;<br>&gt; &gt;&gt;<br>&gt; &gt;&gt;----- Original Message -
---<br>&gt; &gt;&gt;From: "Drake, John E" &lt;<a ymailto="mailto:John.E.Drake2@
boeing.com" href="mailto:[email-masked]">[email-masked]</a>
&gt;<br>&gt; &gt;&gt;To: Igor Bryskin &lt;<a ymailto="mailto:[email-masked]
m" href="mailto:[email-masked]">[email-masked]</a>&gt;; Yakov Rekhter
 <br>&gt; &gt;&gt;&lt;<a ymailto="mailto:[email-masked]"
 ymailto="mailto:[email-masked]" href="mailto:[email-masked]">lberger@labn.
net</a>&gt;<br>&gt; &gt;&gt;Cc: Yakov Rekhter &lt;<a ymailto="mailto:yakov@juni
per.net" href="mailto:[email-masked]">[email-masked]</a>&gt;; Adrian Farr
el <br>&gt; &gt;&gt;&lt;<a ymailto="mailto:[email-masked]" href="mailto:ad
[email-masked]">[email-masked]</a>&gt;; <a ymailto="mailto:[email-masked]
tf.org" href="mailto:[email-masked]">[email-masked]</a>; <a ymailto="ma
ilto:[email-masked]" href="mailto:[email-masked]">[email-masked]</a
><br>&gt; &gt;&gt;Sent: Friday, August 29, 2008 2:31:36 PM<br>&gt; &gt;&gt;Subj
ect: RE: [Softwires] BGP TE attr last call by softwires WG (2nd <br>&gt; &gt;&g
t;question)<br>&gt; &gt;&gt;<br>&gt; &gt;&gt;So you are proposing an OSPF route
 reflector?&nbsp; At what point does the <br>&gt; &gt;&gt;silliness stop?<br>&g
t; &gt;&gt;<br>&gt;
>  &gt;&gt;&gt;-----Original Message-----<br>&gt; &gt;&gt;&gt;From: Igor Bryski
n [mailto:<a ymailto="mailto:[email-masked]" href="mailto:i_bryskin@yahoo.
com">[email-masked]</a>]<br>&gt; &gt;&gt;&gt;Sent: Friday, August 29, 2008
 11:29 AM<br>&gt; &gt;&gt;&gt;To: Drake, John E; Yakov Rekhter; Lou Berger<br>&
gt; &gt;&gt;&gt;Cc: Yakov Rekhter; Adrian Farrel; <a ymailto="mailto:ccamp@ops.
ietf.org" href="mailto:[email-masked]">[email-masked]</a>; <br>&gt; &gt
;&gt;&gt;<a ymailto="mailto:[email-masked]" href="mailto:[email-masked]
">[email-masked]</a><br>&gt; &gt;&gt;&gt;Subject: Re: [Softwires] BGP TE at
tr last call by softwires WG (2nd<br>&gt; &gt;&gt;&gt;question)<br>&gt; &gt;&gt
;&gt;<br>&gt; &gt;&gt;&gt;Hi John,<br>&gt; &gt;&gt;&gt;<br>&gt; &gt;&gt;&gt;No,
 not really. When you add a PE you configure local<br>&gt; &gt;&gt;interfaces, 
local<br>&gt; &gt;&gt;&gt;VPN port mappings, stuff like that. While doing this 
you will also <br>&gt;
>  &gt;&gt;&gt;configure an IPinIP tunnel to one of your spoke Ps and enable L1
VPN <br>&gt; &gt;&gt;&gt;OSPF instance on the tunnel.<br>&gt; &gt;&gt;&gt;Once 
you did that the local VPN information will be flooded<br>&gt; &gt;&gt;accross 
the<br>&gt; &gt;&gt;&gt;overlay, likewise, the new PE will get all the necessar
y information <br>&gt; &gt;&gt;&gt;from other PEs.<br>&gt; &gt;&gt;&gt;<br>&gt;
 &gt;&gt;&gt;Cheers,<br>&gt; &gt;&gt;&gt;Igor<br>&gt; &gt;&gt;&gt;<br>&gt; &gt;
&gt;&gt;<br>&gt; &gt;&gt;&gt;----- Original Message ----<br>&gt; &gt;&gt;&gt;Fr
om: "Drake, John E" &lt;<a ymailto="mailto:[email-masked]" href="mail
to:[email-masked]">[email-masked]</a>&gt;<br>&gt; &gt;&gt;&
gt;To: Igor Bryskin &lt;<a ymailto="mailto:[email-masked]" href="mailto:i_
[email-masked]">[email-masked]</a>&gt;; Yakov Rekhter <br>&gt; &gt;&gt;
&gt;&lt;<a ymailto="mailto:[email-masked]"
 ymailto="mailto:[email-masked]" href="mailto:[email-masked]">lberger@labn.
net</a>&gt;<br>&gt; &gt;&gt;&gt;Cc: Yakov Rekhter &lt;<a ymailto="mailto:yakov@
juniper.net" href="mailto:[email-masked]">[email-masked]</a>&gt;; Adrian 
Farrel <br>&gt; &gt;&gt;&gt;&lt;<a ymailto="mailto:[email-masked]" href="m
ailto:[email-masked]">[email-masked]</a>&gt;; <a ymailto="mailto:ccam
[email-masked]" href="mailto:[email-masked]">[email-masked]</a>; <a yma
ilto="mailto:[email-masked]" href="mailto:[email-masked]">softwires@iet
f.org</a><br>&gt; &gt;&gt;&gt;Sent: Friday, August 29, 2008 11:20:16 AM<br>&gt;
 &gt;&gt;&gt;Subject: RE: [Softwires] BGP TE attr last call by softwires WG (2n
d<br>&gt; &gt;&gt;&gt;question)<br>&gt; &gt;&gt;&gt;<br>&gt; &gt;&gt;&gt;Igor,<
br>&gt; &gt;&gt;&gt;<br>&gt; &gt;&gt;&gt;Doesn't this defeat auto-discovery?&nb
sp; I.e., how is a new
>  PE <br>&gt; &gt;added to a <br>&gt; &gt;&gt;&gt;given L1VPN?<br>&gt; &gt;&gt
;&gt;<br>&gt; &gt;&gt;&gt;Thanks,<br>&gt; &gt;&gt;&gt;<br>&gt; &gt;&gt;&gt;John
<br>&gt; &gt;&gt;&gt;<br>&gt; &gt;&gt;&gt;&gt;-----Original Message-----<br>&gt
; &gt;&gt;&gt;&gt;From: Igor Bryskin [mailto:<a ymailto="mailto:i_bryskin@yahoo
.com" href="mailto:[email-masked]">[email-masked]</a>]<br>&gt; &gt;&g
t;&gt;&gt;Sent: Friday, August 29, 2008 5:51 AM<br>&gt; &gt;&gt;&gt;&gt;To: Yak
ov Rekhter; Lou Berger<br>&gt; &gt;&gt;&gt;&gt;Cc: Yakov Rekhter; Adrian Farrel
; <a ymailto="mailto:[email-masked]" href="mailto:[email-masked]">ccamp
@ops.ietf.org</a>; <br>&gt; &gt;&gt;&gt;&gt;<a ymailto="mailto:[email-masked]
rg" href="mailto:[email-masked]">[email-masked]</a><br>&gt; &gt;&gt;&gt
;&gt;Subject: Re: [Softwires] BGP TE attr last call by softwires WG (2nd<br>&gt
; &gt;&gt;&gt;&gt;question)<br>&gt; &gt;&gt;&gt;&gt;<br>&gt; &gt;&gt;&gt;&gt;Ya
kov,<br>&gt;
>  &gt;&gt;&gt;&gt;<br>&gt; &gt;&gt;&gt;&gt;You said:<br>&gt; &gt;&gt;&gt;&gt;<
br>&gt; &gt;&gt;&gt;&gt;<br>&gt; &gt;&gt;&gt;&gt;... And while on the subject o
f scaling, please keep in mind<br>&gt; &gt;&gt;that BGP<br>&gt; &gt;&gt;&gt;&gt
;only stores L1VPN routes on PEs that have sites of that VPN<br>&gt; &gt;&gt;co
nnected<br>&gt; &gt;&gt;&gt;&gt;to them, and on an RR if used, but *not* on any
 of the P <br>&gt; &gt;routers. In <br>&gt; &gt;&gt;&gt;&gt;contrast, rfc5252 (
OSPF for L1VPN<br>&gt; &gt;&gt;&gt;&gt;autodiscovery) results in storing *all V
PN TE information <br>&gt; &gt;for all the<br>&gt; &gt;&gt;&gt;&gt;VPNs* on *al
l* the IGP nodes, both P and PE. So, clearly BGP-based <br>&gt; &gt;&gt;&gt;&gt
;approach scales better than OSPF-based approach.<br>&gt; &gt;&gt;&gt;&gt;<br>&
gt; &gt;&gt;&gt;&gt;Yakov.<br>&gt; &gt;&gt;&gt;&gt;<br>&gt; &gt;&gt;&gt;&gt;Thi
s is not true in case of multi-instance OSPF: one can build an <br>&gt; &gt;&gt
;&gt;&gt;overlay
>  interconnecting PEs via one or small number of Ps<br>&gt; &gt;&gt;&gt;using 
IPinIP<br>&gt; &gt;&gt;&gt;&gt;tunnels and run in this overlay an instance of O
SPF specifically <br>&gt; &gt;&gt;&gt;&gt;designated for distribution of L1VPN 
information. In this<br>&gt; &gt;&gt;&gt;case the OSPF<br>&gt; &gt;&gt;&gt;&gt;
solution won't scale any worse than the BGP approach. Note. <br>&gt; &gt;&gt;&g
t;that rfc252<br>&gt; &gt;&gt;&gt;&gt;never said that the instance of OSPF used
 for flooding of the L1VPN <br>&gt; &gt;&gt;&gt;&gt;information must be the sam
e instance that is used for the<br>&gt; &gt;&gt;&gt;distribution<br>&gt; &gt;&g
t;&gt;&gt;of IP-related LSAs.<br>&gt; &gt;&gt;&gt;&gt;<br>&gt; &gt;&gt;&gt;&gt;
Regards,<br>&gt; &gt;&gt;&gt;&gt;Igor<br>&gt; &gt;&gt;&gt;&gt;<br>&gt; &gt;&gt;
&gt;&gt;<br>&gt; &gt;&gt;&gt;&gt;<br>&gt; &gt;&gt;&gt;&gt;<br>&gt; &gt;&gt;&gt;
<br>&gt; &gt;&gt;&gt;<br>&gt; &gt;&gt;&gt;<br>&gt; &gt;&gt;&gt;<br>&gt; &gt;&gt
;<br>&gt;
>  &gt;&gt;<br>&gt; &gt;&gt;<br>&gt; &gt;<br>&gt; &gt;<br>&gt; &gt;<br>&gt; &gt
;<br>&gt; <br>&gt; <br>&gt;&nbsp; &nbsp; &nbsp;  <br>&gt; --0-1141253910-122044
9648=:97601<br>&gt; Content-Type: text/html; charset=us-ascii<br>&gt; <br>&gt; 
&lt;html&gt;&lt;head&gt;&lt;style type="text/css"&gt;&lt;!-- DIV {margin:0px;} 
--&gt;&lt;/style&gt;&lt;/head&gt;&lt;<br>body&gt;&lt;div style="font-family:tim
es new roman, new york, times, serif;font-size:<br>12pt"&gt;&lt;div&gt;And I am
 not arguing that sufficient redundancy must be provided. Ho<br>wever you said:
&lt;br&gt;&amp;gt;For your suggested approach to work with sufficient &lt;br&gt
;<br>&amp;gt;redundancy, the topology of the overlay needs to be configured &lt
;br&gt;&amp;gt;such<br> that every selected P router is connected to at least t
wo &lt;br&gt;&amp;gt;other select<br>ed P routers and every PE router needs to 
be &lt;br&gt;&amp;gt;connected to at least two <br>selected P routers.&lt;br&gt
;&lt;br&gt;If you just
>  simply interconnect all VPN-aware PEs in<br>to a single ring via IPinIP tunn
els and run an instance of OSPF to distribute V<br>PN-related information betwe
en them, it will provide sufficient redundancy and <br>involve exactly *zero* P
s.&lt;br&gt;So, I want you to drop your lecturing tone for a <br>minute and sim
ply tell in what respect in your opinion this approach is not per<br>fect fo th
e L1VPN<br>&gt;&nbsp; application. Otherwise, I am not interested in this discu
ssion any longer. I<br> do like to hear comments from other people.&lt;br&gt;&l
t;br&gt;Igor &lt;br&gt;&lt;br&gt;&lt;/div&gt;&lt;div sty<br>le="font-family: ti
mes new roman,new york,times,serif; font-size: 12pt;"&gt;&lt;br&gt;&lt;d<br>iv 
style="font-family: arial,helvetica,sans-serif; font-size: 13px;"&gt;----- Orig
<br>inal Message ----&lt;br&gt;From: "Drake, John E" &amp;lt;<a ymailto="mailto
:[email-masked]"
>  href="mailto:[email-masked]">[email-masked]</a>&amp;gt;&
lt;br&gt;<br>To: Igor Bryskin &amp;lt;<a ymailto="mailto:[email-masked]" h
ref="mailto:[email-masked]">[email-masked]</a>&amp;gt;; Yakov Rekhter
 &amp;lt;<a ymailto="mailto:[email-masked]" href="mailto:[email-masked]">yako
[email-masked]</a><br>et&amp;gt;; Lou Berger &amp;lt;<a ymailto="mailto:lberger@la
bn.net" href="mailto:[email-masked]">[email-masked]</a>&amp;gt;&lt;br&gt;Cc
: Yakov Rekhter &amp;lt;yakov@juni<br>per.net&amp;gt;; Adrian Farrel &amp;lt;<a
 ymailto="mailto:[email-masked]" href="mailto:[email-masked]">adrian@
olddog.co.uk</a>&amp;gt;; <a ymailto="mailto:[email-masked]" href="mailto:c
[email-masked]">[email-masked]</a>; sof<br><a ymailto="mailto:twires@iet
f.org" href="mailto:[email-masked]">[email-masked]</a>&lt;br&gt;Sent: Wednesd
ay, September 3, 2008 8:10:07 AM&lt;br&gt;Subject: RE<br>: [Softwires] BGP TE a
ttr last call by
>  softwires WG (2nd question)&lt;br&gt;&lt;br&gt;<br>&gt; Igor,&lt;br&gt;&lt;b
r&gt;Actually, I am not sure that you do understand what I wrote, bec<br>ause y
ou&lt;br&gt;are providing examples of the redundancy that I specified - every P
<br>E&lt;br&gt;router needs to have connectivity to two other routers in the IG
P&lt;br&gt;insta<br>nce.&lt;br&gt;&lt;br&gt;Thanks,&lt;br&gt;&lt;br&gt;John &lt
;br&gt;&lt;br&gt;&amp;gt;-----Original Message-----&lt;br&gt;&amp;gt;F<br>rom: 
Igor Bryskin [mailto:&lt;a ymailto="mailto:<a ymailto="mailto:[email-masked]
om" href="mailto:[email-masked]">[email-masked]</a>" href="mailto:<br
><a ymailto="mailto:[email-masked]" href="mailto:[email-masked]">i_br
[email-masked]</a>"&gt;<a ymailto="mailto:[email-masked]" href="mailto:i_
[email-masked]">[email-masked]</a>&lt;/a&gt;] &lt;br&gt;&amp;gt;Sent: T
uesday, September <br>02, 2008 3:06 PM&lt;br&gt;&amp;gt;To: Drake, John E; Yako
v Rekhter; Lou
>  Berger&lt;br&gt;&amp;gt;Cc:<br> Yakov Rekhter; Adrian Farrel; &lt;a ymailto=
"mailto:<a ymailto="mailto:[email-masked]" href="mailto:[email-masked]"
>[email-masked]</a>" href="mai<br>lto:<a ymailto="mailto:[email-masked]
" href="mailto:[email-masked]">[email-masked]</a>"&gt;<a ymailto="mailt
o:[email-masked]" href="mailto:[email-masked]">[email-masked]</a>&l
t;/a&gt;; &lt;br&gt;&amp;gt;&lt;a ymailto="mailto:soft<br><a ymailto="mailto:wi
[email-masked]" href="mailto:[email-masked]">[email-masked]</a>" href="mailto:<a 
ymailto="mailto:[email-masked]" href="mailto:[email-masked]">softwires@
ietf.org</a>"&gt;<a ymailto="mailto:[email-masked]" href="mailto:softwires@
ietf.org">[email-masked]</a>&lt;/a&gt;&lt;br&gt;&amp;gt;<br>Subject: Re: [S
oftwires] BGP TE attr last call by softwires WG &lt;br&gt;&amp;gt;(2nd que<br>s
tion)&lt;br&gt;&amp;gt;&lt;br&gt;&amp;gt;Hi John,&lt;br&gt;&amp;gt;&lt;br&gt;&a
mp;gt;I understand
>  what you are saying <br>and disagree. The<br>&gt;&nbsp; overlay I &lt;br&gt;
&amp;gt;am talking about logically is a separate network and as an<br>y &lt;br&
gt;&amp;gt;network it should be sufficiently redundant to function. There &lt;b
r&gt;&amp;g<br>t;is a number of ways how you can address the redundancy &lt;br&
gt;&amp;gt;concerns. Look<br> at the examples below:&lt;br&gt;&amp;gt;&lt;br&gt
;&amp;gt;a) interconnect all VPN-aware PEs into a<br> single ring: &lt;br&gt;&a
mp;gt;PE=======PE&lt;br&gt;&amp;gt; ||&amp;nbsp; &amp;nbsp; &amp;nbsp; &amp;nbs
p; &amp;nbsp; <br>&amp;nbsp; &amp;nbsp; &amp;nbsp; &amp;nbsp; ||&lt;br&gt;&amp;
gt;PE&amp;nbsp; &amp;nbsp; &amp;nbsp; &amp;nbsp; &amp;nbsp; &amp;nbs<br>p; &amp
;nbsp;&nbsp; PE &lt;br&gt;&amp;gt;||&amp;nbsp; &amp;nbsp; &amp;nbsp; &amp;nbsp;
 &amp;nbsp; &amp;nbsp; &amp;nbsp; &amp;nbsp;<br> &amp;nbsp;&nbsp; ||&lt;br&gt;&
amp;gt;PE&amp;nbsp; &amp;nbsp; &amp;nbsp; &amp;nbsp; &amp;nbsp; &amp;nbsp; &amp
;nbsp;&nbsp; PE
>  &lt;br&gt;&amp;<br>gt;||&amp;nbsp; &amp;nbsp; &amp;nbsp; &amp;nbsp; &amp;nbs
p; &amp;nbsp; &amp;nbsp; &amp;nbsp; &amp;nbsp;&nbsp; ||&lt;br&gt;&amp;gt;<br>..
.&amp;nbsp; &amp;nbsp; &amp;nbsp; &amp;nbsp; &amp;nbsp; &amp;nbsp; &amp;nbsp; &
amp;nbsp; ....&lt;br&gt;&amp;gt;PE======<br>=PE&lt;br&gt;&amp;gt;&lt;br&gt;&amp
;gt;b) connect each PE to two interconnected Ps &lt;br&gt;&amp;gt;&lt;br&gt;&am
p;gt;<br>PE&amp;nbsp; &amp;nbsp; &amp;nbsp; &amp;nbsp; &amp;nbsp; &amp;nbsp; &a
mp;nbsp;&nbsp; P&amp;nbsp; &amp;nbsp; &amp;nbsp; &amp;nbsp<br>; &amp;nbsp; &amp
;nbsp; &amp;nbsp;<br>&gt;&nbsp; &amp;nbsp;&nbsp; PE&lt;br&gt;&amp;gt;&amp;nbsp;
 &amp;nbsp; &amp;nbsp; &amp;nbsp; &amp;nbsp; &amp;nbsp; &amp;nbsp; &amp;nbsp; &
amp;n<br>bsp; &amp;nbsp; ||&amp;nbsp; &amp;nbsp; &amp;nbsp; &amp;nbsp; &amp;nbs
p; &amp;nbsp; &amp;nbsp; &amp;nbsp; &amp;nbsp;&nbsp; &lt;<br>br&gt;&amp;gt;PE&a
mp;nbsp; &amp;nbsp; &amp;nbsp; &amp;nbsp; &amp;nbsp; &amp;nbsp; &amp;nbsp;&nbsp
; ||&amp;nbsp;
>  &amp;nbsp; &amp;nbs<br>p; &amp;nbsp; &amp;nbsp; &amp;nbsp; &amp;nbsp; &amp;n
bsp; &amp;nbsp; PE &lt;br&gt;&amp;gt;&amp;nbsp; &amp;nbsp; &amp;nbsp; &amp;n<br
>bsp; &amp;nbsp; &amp;nbsp; &amp;nbsp; &amp;nbsp; &amp;nbsp; &amp;nbsp; ||&amp;
nbsp; &amp;nbsp; &amp;nbsp; &amp;nbsp; &amp;n<br>bsp; &amp;nbsp; &amp;nbsp; &am
p;nbsp; &amp;nbsp; &lt;br&gt;&amp;gt;PE&amp;nbsp; &amp;nbsp; &amp;nbsp; &amp;nb
sp; &amp;nbsp; &amp;<br>nbsp; &amp;nbsp;&nbsp; ||&amp;nbsp; &amp;nbsp; &amp;nbs
p; &amp;nbsp; &amp;nbsp; &amp;nbsp; &amp;nbsp; &amp;nbsp; &amp;nbsp; <br>PE &lt
;br&gt;&amp;gt;&amp;nbsp; &amp;nbsp; &amp;nbsp; &amp;nbsp; &amp;nbsp; &amp;nbsp
; &amp;nbsp; &amp;nbsp; &amp;nbsp; &amp;nbsp<br>; ||&amp;nbsp; &amp;nbsp; &amp;
nbsp; &amp;nbsp; &amp;nbsp; &amp;nbsp; &amp;nbsp; &amp;nbsp; &amp;nbsp; &lt;br&
gt;&amp;gt;...&amp;<br>nbsp; &amp;nbsp; &amp;nbsp; &amp;nbsp; &amp;nbsp; &amp;n
bsp; &amp;nbsp; &amp;nbsp;&nbsp; ||&amp;nbsp; &amp;nbsp; &amp;nbsp; <br>&amp;nb
sp; &amp;nbsp;
>  &amp;nbsp; &amp;nbsp; &amp;nbsp; &amp;nbsp;&nbsp; ....&lt;br&gt;&amp;gt;PE&a
mp;nbsp; &amp;nbsp; &amp;nbsp; &amp;<br>nbsp; &amp;nbsp; &amp;nbsp; &amp;nbsp;&
nbsp; P&amp;nbsp; &amp;nbsp; &amp;nbsp; &amp;nbsp; &amp;nbsp; &amp;nbsp; &amp;n
bsp; &amp;<br>nbsp; <br>&gt;&nbsp; PE&lt;br&gt;&amp;gt;&lt;br&gt;&amp;gt;&lt;br
&gt;&amp;gt;Note that tunnels can traverse any number of VPN-u<br>naware Ps and
 PEs.&lt;br&gt;&amp;gt;&lt;br&gt;&amp;gt;Igor&lt;br&gt;&amp;gt;&lt;br&gt;&amp;g
t;&lt;br&gt;&amp;gt;----- Original Me<br>ssage ----&lt;br&gt;&amp;gt;From: "Dra
ke, John E" &amp;lt;&lt;a ymailto="mailto:John.E.Drake2@bo<br><a target="_blank
" href="http://eing.com">eing.com</a>" href="mailto:<a ymailto="mailto:John.E.D
[email-masked]" href="mailto:[email-masked]">[email-masked]
om</a>"&gt;<a ymailto="mailto:[email-masked]" href="mailto:John.E.Dra
[email-masked]">[email-masked]</a>&lt;/a&gt;&amp;g<br>t;&lt;br&gt;&am
p;gt;To: Igor Bryskin
>  &amp;lt;&lt;a ymailto="mailto:<a ymailto="mailto:[email-masked]" href="
mailto:[email-masked]">[email-masked]</a>" href="ma<br>ilto:<a ymailt
o="mailto:[email-masked]" href="mailto:[email-masked]">i_bryskin@yaho
o.com</a>"&gt;<a ymailto="mailto:[email-masked]" href="mailto:i_bryskin@ya
hoo.com">[email-masked]</a>&lt;/a&gt;&amp;gt;; Yakov Rekhter &lt;br&gt;&am
p;gt;&amp;l<br>t;&lt;a ymailto="mailto:<a ymailto="mailto:[email-masked]" hr
ef="mailto:[email-masked]">[email-masked]</a>" href="mailto:<a ymailto="m
ailto:[email-masked]" href="mailto:[email-masked]">[email-masked]</a>"
&gt;yakov@j<br><a target="_blank" href="http://uniper.net">uniper.net</a>&lt;/a
&gt;&amp;gt;; Lou Berger &amp;lt;&lt;a ymailto="mailto:<a ymailto="mailto:lberg
[email-masked]" href="mailto:[email-masked]">[email-masked]</a>" href="m<br>ai
lto:<a ymailto="mailto:[email-masked]" href="mailto:[email-masked]">lberger
@labn.net</a>"&gt;<a
>  ymailto="mailto:[email-masked]" href="mailto:[email-masked]">lberger@lab
n.net</a>&lt;/a&gt;&amp;gt;&lt;br&gt;&amp;gt;Cc: Yakov Rekhter &amp;lt;&lt;<br>
a ymailto="mailto:<a ymailto="mailto:[email-masked]" href="mailto:yakov@juni
per.net">[email-masked]</a>" href="mailto:<a ymailto="mailto:[email-masked]
et" href="mailto:[email-masked]">[email-masked]</a>"&gt;yakov@juni<br><a 
target="_blank" href="http://per.net">per.net</a>&lt;/a&gt;&amp;gt;; Adrian Far
rel &lt;br&gt;&amp;gt;&amp;lt;&lt;a ymailto="mailto:<a ymailto="mailto:adrian@o
lddog.co" href="mailto:[email-masked]">[email-masked]</a>.<br>uk" href="mai
lto:<a ymailto="mailto:[email-masked]" href="mailto:[email-masked]">a
[email-masked]</a>"&gt;<a ymailto="mailto:[email-masked]" href="mailto
:[email-masked]">[email-masked]</a>&lt;/a&gt;&amp;gt;; &lt;a<br>&gt;&
nbsp; ymailto="mailto:<a ymailto="mailto:[email-masked]"
>  href="mailto:[email-masked]">[email-masked]</a>" href="mailto:<a yma
ilto="mailto:[email-masked]" href="mailto:[email-masked]">[email-masked]
f.org</a>"&gt;ccamp@o<br><a target="_blank" href="http://ps.ietf.org">ps.ietf.o
rg</a>&lt;/a&gt;; &lt;a ymailto="mailto:<a ymailto="mailto:[email-masked]" 
href="mailto:[email-masked]">[email-masked]</a>" href="mailto:softwires
@<br><a target="_blank" href="http://ietf.org">ietf.org</a>"&gt;<a ymailto="mai
lto:[email-masked]" href="mailto:[email-masked]">[email-masked]</a>
&lt;/a&gt;&lt;br&gt;&amp;gt;Sent: Tuesday, September 2, 2008 2:24:2<br>6 PM&lt;
br&gt;&amp;gt;Subject: RE: [Softwires] BGP TE attr last call by softwires WG &l
t;br&gt;<br>&amp;gt;(2nd question)&lt;br&gt;&amp;gt;&lt;br&gt;&amp;gt;Igor,&lt;
br&gt;&amp;gt;&lt;br&gt;&amp;gt;Several years ago when O<br>SPF was first propo
sed as an &lt;br&gt;&amp;gt;autodiscovery mechanism for L1VPNs, you we<br>re to
ld that it was
>  &lt;br&gt;&amp;gt;a bad idea due to its scaling properties and impact<br> on
 the IGP.&lt;br&gt;&amp;gt;&lt;br&gt;&amp;gt;You are now tacitly agreeing with 
those who told yo<br>u it was a bad idea.&lt;br&gt;&amp;gt;&lt;br&gt;&amp;gt;Fo
r your suggested approach to work with su<br>fficient &lt;br&gt;&amp;gt;redunda
ncy, the topology of the overlay needs to be configured<br> &lt;br&gt;&amp;gt;s
uch that every selected P router is connected to at least two &lt;br&gt;&amp;gt
<br>;other selected P routers and every PE router needs to be &lt;br&gt;&amp;gt
;connected to <br>at least two selected<br>&gt;&nbsp; P routers.&lt;br&gt;&amp;
gt;&lt;br&gt;&amp;gt;When you are done with this configuration, you are<br> lef
t with a &lt;br&gt;&amp;gt;situation in which *every* PE and selected P router 
will h<br>ave &lt;br&gt;&amp;gt;*all* L1VPN routes.&lt;br&gt;&amp;gt;&lt;br&gt;
&amp;gt;Thanks,&lt;br&gt;&amp;gt;&lt;br&gt;&amp;gt;John
>  &lt;br&gt;<br>&amp;gt;&lt;br&gt;&amp;gt;&amp;gt;-----Original Message-----&l
t;br&gt;&amp;gt;&amp;gt;From: Igor Bryskin [mailt<br>o:&lt;a ymailto="mailto:<a
 ymailto="mailto:[email-masked]" href="mailto:[email-masked]">i_brysk
[email-masked]</a>" href="mailto:<a ymailto="mailto:[email-masked]" href="ma
ilto:[email-masked]">[email-masked]</a>"&gt;i_b<br><a ymailto="mailto
:[email-masked]" href="mailto:[email-masked]">[email-masked]</a>&lt;/a&gt
;]&lt;br&gt;&amp;gt;&amp;gt;Sent: Friday, August 29, 2008 12:10 PM&lt;br&gt;&am
p;gt;<br>&amp;gt;To: Drake, John E; Yakov Rekhter; Lou Berger&lt;br&gt;&amp;gt;
&amp;gt;Cc: Yakov Rekhter; <br>Adrian Farrel; &lt;a ymailto="mailto:<a ymailto=
"mailto:[email-masked]" href="mailto:[email-masked]">[email-masked]
</a>" href="mailto:<a ymailto="mailto:[email-masked]" href="mailto:[email-masked]">
[email-masked]</a><br><a target="_blank" href="http://tf.org">tf.org</a>"&gt;<a
>  ymailto="mailto:[email-masked]" href="mailto:[email-masked]">ccamp@o
ps.ietf.org</a>&lt;/a&gt;; &lt;br&gt;&amp;gt;&amp;gt;&lt;a ymailto="mailto:<a y
mailto="mailto:[email-masked]" href="mailto:[email-masked]">softwires@ietf.
o</a><br>rg" href="mailto:<a ymailto="mailto:[email-masked]" href="mailto:s
[email-masked]">[email-masked]</a>"&gt;<a ymailto="mailto:softwires@ietf
.org" href="mailto:[email-masked]">[email-masked]</a>&lt;/a&gt;&lt;br&g
t;&amp;gt;&amp;gt;Subject:<br> Re: [Softwires] BGP TE attr last call by softwir
es WG (2nd &lt;br&gt;&amp;gt;&amp;gt;questio<br>n)&lt;br&gt;&amp;gt;&amp;gt;&lt
;br&gt;&amp;gt;&amp;gt;Are you calling me silly? Are you coming to Minneapol<br
>is?<br>&gt;&nbsp; :=)&lt;br&gt;&amp;gt;&amp;gt;&lt;br&gt;&amp;gt;&amp;gt;Serio
usly, what is wrong in your opinion with thi<br>s approach? &lt;br&gt;&amp;gt;&
amp;gt;Many people are talking about multi-instance IGPs. What<br> they have in
>  &lt;br&gt;&amp;gt;&amp;gt;mind is improving the IGP scalability:&lt;br&gt;&a
mp;gt;&amp;gt;a) <br>by removing non-IP advertisements from the instance of IGP
 that &lt;br&gt;&amp;gt;&amp;gt;man<br>ages IP routing/forwarding tables into s
eparate IGP instance(s);&lt;br&gt;&amp;gt;&amp;gt;b) <br>by distributing non-IP
 information only to and via &lt;br&gt;&amp;gt;inerested parties &lt;b<br>r&gt;
&amp;gt;&amp;gt;leaving the bulk of Ps out of the process.&lt;br&gt;&amp;gt;&am
p;gt;&lt;br&gt;&amp;gt;&amp;gt;In <br>my opinion this is exactly what is needed
 for the OSPF-based L1VPN &lt;br&gt;&amp;gt;&amp;gt;<br>application.&lt;br&gt;&
amp;gt;&amp;gt;&lt;br&gt;&amp;gt;&amp;gt;Igor&lt;br&gt;&amp;gt;&amp;gt;&lt;br&g
t;&amp;gt;&amp;gt;&lt;br&gt;&amp;gt;&amp;gt;&lt;br<br>&gt;&amp;gt;&amp;gt;&lt;b
r&gt;&amp;gt;&amp;gt;&lt;br&gt;&amp;gt;&amp;gt;&lt;br&gt;&amp;gt;&amp;gt;----- 
Original Message ----&lt;br&gt;&amp;gt<br>;&amp;gt;From: "Drake, John E" &amp;l
t;&lt;a
>  ymailto="mailto:<a ymailto="mailto:[email-masked]" href="mailto:Jo
[email-masked]">[email-masked]</a>" hre<br>f="mailto:<a ymail
to="mailto:[email-masked]" href="mailto:[email-masked]">Joh
[email-masked]</a>"&gt;<a ymailto="mailto:[email-masked]" href
="mailto:[email-masked]">[email-masked]</a>&lt;/a&gt;&amp;g
t;&lt;br&gt;&amp;gt;&amp;gt<br>;To: Igor Bryskin<br>&gt;&nbsp; &amp;lt;&lt;a ym
ailto="mailto:<a ymailto="mailto:[email-masked]" href="mailto:i_bryskin@ya
hoo.com">[email-masked]</a>" href="mailto:<a ymailto="mailto:i_bryskin@yah
oo.com" href="mailto:[email-masked]">[email-masked]</a><br>"&gt;<a ym
ailto="mailto:[email-masked]" href="mailto:[email-masked]">i_bryskin@
yahoo.com</a>&lt;/a&gt;&amp;gt;; Yakov Rekhter &lt;br&gt;&amp;gt;&amp;gt;&amp;l
t;&lt;a ymailto="mailto<br>:<a ymailto="mailto:[email-masked]"
>  href="mailto:[email-masked]">[email-masked]</a>" href="mailto:<a ymail
to="mailto:[email-masked]" href="mailto:[email-masked]">[email-masked]
</a>"&gt;<a ymailto="mailto:[email-masked]" href="mailto:[email-masked]">
[email-masked]</a>&lt;/a&gt;&amp;gt;; <br>Lou Berger &amp;lt;&lt;a ymailto="
mailto:<a ymailto="mailto:[email-masked]" href="mailto:[email-masked]">lber
[email-masked]</a>" href="mailto:<a ymailto="mailto:[email-masked]" href="mailto:
[email-masked]">[email-masked]</a><br>et"&gt;<a ymailto="mailto:[email-masked]
t" href="mailto:[email-masked]">[email-masked]</a>&lt;/a&gt;&amp;gt;&lt;br&
gt;&amp;gt;&amp;gt;Cc: Yakov Rekhter &amp;lt;&lt;a ymailto="mailt<br>o:<a ymail
to="mailto:[email-masked]" href="mailto:[email-masked]">[email-masked]
</a>" href="mailto:<a ymailto="mailto:[email-masked]" href="mailto:yakov@jun
iper.net">[email-masked]</a>"&gt;<a ymailto="mailto:[email-masked]"
>  href="mailto:[email-masked]">[email-masked]</a>&lt;/a&gt;&amp;gt;;<br>
 Adrian Farrel &lt;br&gt;&amp;gt;&amp;gt;&amp;lt;&lt;a ymailto="mailto:<a ymail
to="mailto:[email-masked]" href="mailto:[email-masked]">adrian@olddog
.co.uk</a>" href="ma<br>ilto:<a ymailto="mailto:[email-masked]" href="mail
to:[email-masked]">[email-masked]</a>"&gt;<a ymailto="mailto:adrian@o
lddog.co.uk" href="mailto:[email-masked]">[email-masked]</a>&lt;/a&gt
;&amp;gt;; &lt;a ymailto="mailto:ccamp<br>@ops.ietf.org" href="mailto:<a ymailt
o="mailto:[email-masked]" href="mailto:[email-masked]">[email-masked]
rg</a>"&gt;<a ymailto="mailto:[email-masked]" href="mailto:[email-masked]
rg">[email-masked]</a>&lt;/a&gt;; &lt;a ymai<br>lto="mailto:<a ymailto="mai
lto:[email-masked]" href="mailto:[email-masked]">[email-masked]</a>
" href="mailto:<a ymailto="mailto:[email-masked]"
>  href="mailto:[email-masked]">[email-masked]</a>"&gt;softwires@ietf<b
r>.org&lt;/a&gt;&lt;br&gt;&amp;gt;&amp;gt;Sent: Friday, August 29, 2008 2:31:36
 PM&lt;br&gt;&amp;gt;&amp;gt;Subject<br>: RE: [Softwires] BGP TE attr last call
 by softwires WG (2nd<br>&gt;&nbsp; &lt;br&gt;&amp;gt;&amp;gt;question)&lt;br&g
t;&amp;gt;&amp;gt;&lt;br&gt;&amp;gt;&amp;gt;So you are proposing an OSPF ro<br>
ute reflector?&amp;nbsp; At what point does the &lt;br&gt;&amp;gt;&amp;gt;silli
ness stop?&lt;br&gt;&amp;gt;<br>&amp;gt;&lt;br&gt;&amp;gt;&amp;gt;&amp;gt;-----
Original Message-----&lt;br&gt;&amp;gt;&amp;gt;&amp;gt;From: Igor Bryski<br>n [
mailto:&lt;a ymailto="mailto:<a ymailto="mailto:[email-masked]" href="mail
to:[email-masked]">[email-masked]</a>" href="mailto:i_bryskin@yahoo.<
br>com"&gt;<a ymailto="mailto:[email-masked]" href="mailto:i_bryskin@yahoo
.com">[email-masked]</a>&lt;/a&gt;]&lt;br&gt;&amp;gt;&amp;gt;&amp;gt;Sent:
 Friday, August 29,
>  2008 11:2<br>9 AM&lt;br&gt;&amp;gt;&amp;gt;&amp;gt;To: Drake, John E; Yakov 
Rekhter; Lou Berger&lt;br&gt;&amp;gt;&amp;gt;&amp;gt<br>;Cc: Yakov Rekhter; Adr
ian Farrel; &lt;a ymailto="mailto:<a ymailto="mailto:[email-masked]" href="
mailto:[email-masked]">[email-masked]</a>" href=<br>"mailto:<a ymailto=
"mailto:[email-masked]" href="mailto:[email-masked]">[email-masked]
</a>"&gt;<a ymailto="mailto:[email-masked]" href="mailto:[email-masked]
">[email-masked]</a>&lt;/a&gt;; &lt;br&gt;&amp;gt;&amp;gt;&amp;gt;&lt;a yma
ilto=<br>"mailto:<a ymailto="mailto:[email-masked]" href="mailto:softwires@
ietf.org">[email-masked]</a>" href="mailto:<a ymailto="mailto:softwires@iet
f.org" href="mailto:[email-masked]">[email-masked]</a>"&gt;<a ymailto="
mailto:[email-masked]" href="mailto:[email-masked]">[email-masked]<
/a><br>&lt;/a&gt;&lt;br&gt;&amp;gt;&amp;gt;&amp;gt;Subject: Re: [Softwires] BGP
 TE attr last call by
>  softwires<br> WG (2nd&lt;br&gt;&amp;gt;&amp;gt;&amp;gt;question)&lt;br&gt;&a
mp;gt;&amp;gt;&amp;gt;&lt;br&gt;&amp;gt;&amp;gt;&amp;gt;Hi John,&lt;br&gt;&amp;
g<br>t;&amp;gt;&amp;gt;&lt;br&gt;&amp;gt;&amp;gt;&amp;gt;No, not really. When y
ou add a PE you configure<br>&gt;&nbsp; local&lt;br&gt;&amp;gt;&amp;gt;interfac
es, local&lt;br&gt;&amp;gt;&amp;gt;&amp;gt;VPN port mappings, stuff l<br>ike th
at. While doing this you will also &lt;br&gt;&amp;gt;&amp;gt;&amp;gt;configure 
an IPinIP tu<br>nnel to one of your spoke Ps and enable L1VPN &lt;br&gt;&amp;gt
;&amp;gt;&amp;gt;OSPF instance on <br>the tunnel.&lt;br&gt;&amp;gt;&amp;gt;&amp
;gt;Once you did that the local VPN information will be <br>flooded&lt;br&gt;&a
mp;gt;&amp;gt;accross the&lt;br&gt;&amp;gt;&amp;gt;&amp;gt;overlay, likewise, t
he new PE wil<br>l get all the necessary information &lt;br&gt;&amp;gt;&amp;gt;
&amp;gt;from other
>  PEs.&lt;br&gt;&amp;gt;&amp;gt;<br>&amp;gt;&lt;br&gt;&amp;gt;&amp;gt;&amp;gt;
Cheers,&lt;br&gt;&amp;gt;&amp;gt;&amp;gt;Igor&lt;br&gt;&amp;gt;&amp;gt;&amp;gt;
&lt;br&gt;&amp;gt;&amp;gt;&amp;gt;<br>&lt;br&gt;&amp;gt;&amp;gt;&amp;gt;----- O
riginal Message ----&lt;br&gt;&amp;gt;&amp;gt;&amp;gt;From: "Drake, John E<br>"
 &amp;lt;&lt;a ymailto="mailto:<a ymailto="mailto:[email-masked]" hre
f="mailto:[email-masked]">[email-masked]</a>" href="mailto:
John.E.Drake2@b<br><a target="_blank" href="http://oeing.com">oeing.com</a>"&gt
;<a ymailto="mailto:[email-masked]" href="mailto:John.E.Drake2@boeing
.com">[email-masked]</a>&lt;/a&gt;&amp;gt;&lt;br&gt;&amp;gt;&amp;gt;&
amp;gt;To: Igor Bryskin &amp;lt<br>;&lt;a ymailto="mailto:<a ymailto="mailto:i_
[email-masked]" href="mailto:[email-masked]">[email-masked]</a>" h
ref="mailto:<a ymailto="mailto:[email-masked]"
>  href="mailto:[email-masked]">[email-masked]</a>"&gt;i_br<br><a yma
ilto="mailto:[email-masked]" href="mailto:[email-masked]">[email-masked]</a>
&lt;/a&gt;&amp;gt;; Yakov Rekhter &lt;br&gt;&amp;gt;&amp;gt;&amp;gt;&amp;lt;&lt
;a ymailto="mailto:y<br><a ymailto="mailto:[email-masked]" href="mailto:akov@
juniper.net">[email-masked]</a>"<br>&gt;&nbsp; href="mailto:<a ymailto="mailt
o:[email-masked]" href="mailto:[email-masked]">[email-masked]</a>"&gt;
<a ymailto="mailto:[email-masked]" href="mailto:[email-masked]">yakov@jun
iper.net</a>&lt;/a&gt;&amp;gt;; Lou Berger &amp;lt;&lt;a<br> ymailto="mailto:<a
 ymailto="mailto:[email-masked]" href="mailto:[email-masked]">lberger@labn.
net</a>" href="mailto:<a ymailto="mailto:[email-masked]" href="mailto:lberger
@labn.net">[email-masked]</a>"&gt;lberger@labn.<br>net&lt;/a&gt;&amp;gt;&lt;b
r&gt;&amp;gt;&amp;gt;&amp;gt;Cc: Yakov Rekhter &amp;lt;&lt;a ymailto="mailto:ya
kov@junip<br><a
>  target="_blank" href="http://er.net">er.net</a>" href="mailto:<a ymailto="ma
ilto:[email-masked]" href="mailto:[email-masked]">[email-masked]</a>"&
gt;<a ymailto="mailto:[email-masked]" href="mailto:[email-masked]">yakov@
juniper.net</a>&lt;/a&gt;&amp;gt;; Adrian Farre<br>l &lt;br&gt;&amp;gt;&amp;gt;
&amp;gt;&amp;lt;&lt;a ymailto="mailto:<a ymailto="mailto:[email-masked]" h
ref="mailto:[email-masked]">[email-masked]</a>" href="mailto:adri<br>
<a ymailto="mailto:[email-masked]" href="mailto:[email-masked]">[email-masked].
uk</a>"&gt;<a ymailto="mailto:[email-masked]" href="mailto:[email-masked]
o.uk">[email-masked]</a>&lt;/a&gt;&amp;gt;; &lt;a ymailto="mailto:<a ymail
to="mailto:[email-masked]" href="mailto:[email-masked]">[email-masked]</a><br>.
org" href="mailto:<a ymailto="mailto:[email-masked]" href="mailto:ccamp@ops
.ietf.org">[email-masked]</a>"&gt;<a ymailto="mailto:[email-masked]"
>  href="mailto:[email-masked]">[email-masked]</a>&lt;/a&gt;; &lt;a yma
ilto="mail<br>to:<a ymailto="mailto:[email-masked]" href="mailto:softwires@
ietf.org">[email-masked]</a>" href="mailto:<a ymailto="mailto:softwires@iet
f.org" href="mailto:[email-masked]">[email-masked]</a>"&gt;<a ymailto="
mailto:[email-masked]" href="mailto:[email-masked]">[email-masked]<
/a>&lt;/a&gt;&lt;<br>br&gt;&amp;gt;&amp;gt;&amp;gt;Sent: Friday, August 29, 200
8 11:20:16 AM&lt;br&gt;&amp;gt;&amp;gt;&amp;gt;Subject<br>: RE: [Softwires] BGP
 TE attr last call by softwires WG (2nd&lt;br&gt;&amp;gt;&amp;gt;&amp;gt;que<br
>stion)&lt;br&gt;&amp;gt;&amp;gt;&amp;gt;&lt;br&gt;&amp;gt;&amp;gt;&amp;gt;Igor
,&lt;br&gt;&amp;gt;&amp;gt;&amp;gt;&lt;br&gt;&amp;gt;&amp;gt;&amp;gt;Does<br>n'
t this defeat auto-discovery?&amp;nbsp; I.e., how is a new PE &lt;br&gt;&amp;gt
;added to a <br>&lt;br&gt;&amp;gt;&amp;gt;&amp;gt;given<br>&gt;&nbsp;
>  L1VPN?&lt;br&gt;&amp;gt;&amp;gt;&amp;gt;&lt;br&gt;&amp;gt;&amp;gt;&amp;gt;Th
anks,&lt;br&gt;&amp;gt;&amp;gt;&amp;gt;&lt;br&gt;&amp;gt;&amp;gt;&amp;gt<br>;Jo
hn&lt;br&gt;&amp;gt;&amp;gt;&amp;gt;&lt;br&gt;&amp;gt;&amp;gt;&amp;gt;&amp;gt;-
----Original Message-----&lt;br&gt;&amp;gt;&amp;gt;<br>&amp;gt;&amp;gt;From: Ig
or Bryskin [mailto:&lt;a ymailto="mailto:<a ymailto="mailto:[email-masked]
" href="mailto:[email-masked]">[email-masked]</a>" href<br>="mailto:<
a ymailto="mailto:[email-masked]" href="mailto:[email-masked]">i_brys
[email-masked]</a>"&gt;<a ymailto="mailto:[email-masked]" href="mailto:i_br
[email-masked]">[email-masked]</a>&lt;/a&gt;]&lt;br&gt;&amp;gt;&amp;gt;&a
mp;gt;&amp;gt;Sent:<br> Friday, August 29, 2008 5:51 AM&lt;br&gt;&amp;gt;&amp;g
t;&amp;gt;&amp;gt;To: Yakov Rekhter; Lou Berg<br>er&lt;br&gt;&amp;gt;&amp;gt;&a
mp;gt;&amp;gt;Cc: Yakov Rekhter; Adrian Farrel; &lt;a ymailto="mailto:ccam<br><
a
>  ymailto="mailto:[email-masked]" href="mailto:[email-masked]">[email-masked]<
/a>" href="mailto:<a ymailto="mailto:[email-masked]" href="mailto:ccamp@ops
.ietf.org">[email-masked]</a>"&gt;<a ymailto="mailto:[email-masked]" hr
ef="mailto:[email-masked]">[email-masked]</a>&lt;/a&gt;; &lt;br&gt;&amp
;g<br>t;&amp;gt;&amp;gt;&amp;gt;&lt;a ymailto="mailto:<a ymailto="mailto:softwi
[email-masked]" href="mailto:[email-masked]">[email-masked]</a>" href="ma
ilto:softwires@iet<br><a target="_blank" href="http://f.org">f.org</a>"&gt;<a y
mailto="mailto:[email-masked]" href="mailto:[email-masked]">softwires@i
etf.org</a>&lt;/a&gt;&lt;br&gt;&amp;gt;&amp;gt;&amp;gt;&amp;gt;Subject: Re: [So
ftwires] BGP T<br>E attr last call by softwires WG
>  (2nd&lt;br&gt;&amp;gt;&amp;gt;&amp;gt;&amp;gt;question)&lt;br&gt;&amp;gt;&am
p;gt;&amp;<br>gt;&amp;gt;&lt;br&gt;&amp;gt;&amp;gt;&amp;gt;&amp;gt;Yakov,&lt;br
&gt;&amp;gt;&amp;gt;&amp;gt;&amp;gt;&lt;br&gt;&amp;gt;&amp;gt;&amp;gt;&amp;gt;Y
ou sa<br>id:&lt;br&gt;&amp;gt;&amp;gt;&amp;gt;&amp;gt;&lt;br&gt;&amp;gt;&amp;gt
;&amp;gt;&amp;gt;&lt;br&gt;&amp;gt;&amp;gt;&amp;gt;&amp;gt;... And while on<br>
 the subject of<br>&gt;&nbsp; scaling, please keep in mind&lt;br&gt;&amp;gt;&am
p;gt;that BGP&lt;br&gt;&amp;gt;&amp;gt;&amp;gt;&amp;gt;only sto<br>res L1VPN ro
utes on PEs that have sites of that VPN&lt;br&gt;&amp;gt;&amp;gt;connected&lt;b
r&gt;&amp;gt<br>;&amp;gt;&amp;gt;&amp;gt;to them, and on an RR if used, but *no
t* on any of the P &lt;br&gt;&amp;gt;r<br>outers. In &lt;br&gt;&amp;gt;&amp;gt;
&amp;gt;&amp;gt;contrast, rfc5252 (OSPF for L1VPN&lt;br&gt;&amp;gt;&amp;gt;&amp
;gt<br>;&amp;gt;autodiscovery) results in storing *all VPN TE information &lt;b
r&gt;&amp;gt;for all
>  <br>the&lt;br&gt;&amp;gt;&amp;gt;&amp;gt;&amp;gt;VPNs* on *all* the IGP node
s, both P and PE. So, clearly<br> BGP-based &lt;br&gt;&amp;gt;&amp;gt;&amp;gt;&
amp;gt;approach scales better than OSPF-based approach.<br>&lt;br&gt;&amp;gt;&a
mp;gt;&amp;gt;&amp;gt;&lt;br&gt;&amp;gt;&amp;gt;&amp;gt;&amp;gt;Yakov.&lt;br&gt
;&amp;gt;&amp;gt;&amp;gt;&amp;gt;&lt;br&gt;&amp;gt;&amp;gt;&amp;<br>gt;&amp;gt;
This is not true in case of multi-instance OSPF: one can build an &lt;br&gt;&am
p;g<br>t;&amp;gt;&amp;gt;&amp;gt;overlay interconnecting PEs via one or small n
umber of Ps&lt;br&gt;&amp;gt;<br>&amp;gt;&amp;gt;using IPinIP&lt;br&gt;&amp;gt;
&amp;gt;&amp;gt;&amp;gt;tunnels and run in this overlay an inst<br>ance of OSPF
 specifically &lt;br&gt;&amp;gt;&amp;gt;&amp;gt;&amp;gt;designated for distribu
tion of L1<br>VPN information. In<br>&gt;&nbsp; this&lt;br&gt;&amp;gt;&amp;gt;&
amp;gt;case the OSPF&lt;br&gt;&amp;gt;&amp;gt;&amp;gt;&amp;gt;solution won't sc
ale an<br>y worse than
>  the BGP approach. Note. &lt;br&gt;&amp;gt;&amp;gt;&amp;gt;that rfc252&lt;br&
gt;&amp;gt;&amp;gt;&amp;gt<br>;&amp;gt;never said that the instance of OSPF use
d for flooding of the L1VPN &lt;br&gt;&amp;g<br>t;&amp;gt;&amp;gt;&amp;gt;infor
mation must be the same instance that is used for the&lt;br&gt;&amp;gt<br>;&amp
;gt;&amp;gt;distribution&lt;br&gt;&amp;gt;&amp;gt;&amp;gt;&amp;gt;of IP-related
>  LSAs.&lt;br&gt;&amp;gt;&amp;gt;&amp;gt;&amp;gt<br>;&lt;br&gt;&amp;gt;&amp;gt
;&amp;gt;&amp;gt;Regards,&lt;br&gt;&amp;gt;&amp;gt;&amp;gt;&amp;gt;Igor&lt;br&g
t;&amp;gt;&amp;gt;&amp;gt;&amp;gt;&lt;br&gt;&amp;g<br>t;&amp;gt;&amp;gt;&amp;gt
;&lt;br&gt;&amp;gt;&amp;gt;&amp;gt;&amp;gt;&lt;br&gt;&amp;gt;&amp;gt;&amp;gt;&a
mp;gt;&lt;br&gt;&amp;gt;&amp;gt;&amp;gt;&lt;br&gt;&amp;gt;&amp;<br>gt;&amp;gt;&
lt;br&gt;&amp;gt;&amp;gt;&amp;gt;&lt;br&gt;&amp;gt;&amp;gt;&amp;gt;&lt;br&gt;&a
mp;gt;&amp;gt;&lt;br&gt;&amp;gt;&amp;gt;&lt;br&gt;&amp;gt;&amp;gt;&lt;br&gt;<br
>&amp;gt;&lt;br&gt;&amp;gt;&lt;br&gt;&amp;gt;&lt;br&gt;&amp;gt;&lt;br&gt;&lt;br
&gt;&lt;/div&gt;&lt;/div&gt;&lt;/div&gt;&lt;br&gt;<br>&gt; <br>&gt;&nbsp; &nbsp
; &nbsp;  &lt;/body&gt;&lt;/html&gt;<br>&gt; --0-1141253910-1220449648=:97601--
<br></div></div></div><br>
> 
> 
> 
>       </body></html>
> --0-1852435290-1220452662=:19087--
>