Subject: Re: [Softwires] Why not use AFTR IPv6 address for the new DHCPv6 option?

From: [email-masked]
Date: Tue, 5 Jul 2011 14:44:40 +0800

Two Points here.
1, For stateless 6rd, using anycast does provide BR redundancy, but not loadbalancing. Generally loadbalancing can not be achieved by anycast, see RFC4786 Operation of Anycast Services for more information. 

2, Using AFTR IPv6 address in the new DHCPv6 option does dot mean to use anycast for the stateful dslite loadbalancing. DHCPv6 server sends different IPv6 addresses of AFTRs to different B4s by some critera. Then, user traffic can be balanced among these AFTRs throngh these B4s.

I do not think stateless or stateful is the key point. Both FQDN and IP address can be used in the DHCP option to complete the gateway discovery. If the operators want, both FQDN and IP address can also be used to do the load balancing. However, according to the respective RFC, 6rd selects IP address, dslite selects FQDN. I am wondering why not use the same method?

Best Regards,
Zhenqiang Li

----- Original Message -----

Date: Mon, 4 Jul 2011 02:07:37 +0000
From: "Lee, Yiu" <[email-masked]>
To: "[email-masked]" <[email-masked]>
Subject: Re: [Softwires] Why not use AFTR IPv6 address for the new
 DHCPv6 option?
Message-ID: <[email-masked]>
Content-Type: text/plain; charset="us-ascii"

No disagreement here. However, we can't argue that using anycast for
stateless 6rd BR does provide redundancy if an ISP designs the network
properly. On the other hand, stateful dslite can't use anycast.

---

From: "Lee, Yiu" <[email-masked]>
Date: Tue, 5 Jul 2011 14:04:20 +0000

Hi Zhenqiang,

If you go back to the ML, it was the main concern of using ip address for
ds-lite. Yes, you can use FQDN for anycast address, but nobody asked for
it when 6rd was being standardized.

Cheers,
Yiu

On 7/5/11 2:44 AM, "[email-masked]"
<[email-masked]> wrote:

>I do not think stateless or stateful is the key point.

---

From: Mark Townsley <[email-masked]>
Date: Wed, 6 Jul 2011 15:13:13 +0200

> 1, For stateless 6rd, using anycast does provide BR redundancy, but not loadbalancing. Generally loadbalancing can not be achieved by anycast, see RFC4786 Operation of Anycast Services for more inf…

Many of the issues in RFC 4786 do not apply to 6rd. For example, RFC 4786 says:

   "Load-balancing between Anycast Nodes is typically difficult to
   achieve (load distribution between nodes is generally unbalanced in
   terms of request and traffic load)."

With 6rd, since the main purpose is forwarding traffic and not processing requests, the load distribution is actually quite balanced in terms of request and traffic load. 

> 2, Using AFTR IPv6 address in the new DHCPv6 option does dot mean to use anycast for the stateful dslite loadbalancing. DHCPv6 server sends different IPv6 addresses of AFTRs to different B4s by som…

One of the main operational advantages of a stateless solution is that you do not have to manage which CE (B4) gets what set of configuration data. 

> I do not think stateless or stateful is the key point.

This is a key point considering whether the system is deployable with a single BR address or not. 

> Both FQDN and IP address can be used in the DHCP option to complete the gateway discovery. If the operators want, both FQDN and IP address can also be used to do the load balancing. However, according to the respective RFC, 6rd selects IP address, dslite selects FQDN. I am wondering why not use the same method?

As there is no requirement that an operator which deploys 6rd to deploy ds-lite at some point or vice versa, I don't really see the operational benefit of using the same configuration. Further, any code-savings benefit is quite low as well since all we are talking about here is a DHCP option.

- Mark

> _______________________________________________
> Softwires mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/softwires