Subject: [Softwires] Comments on 4rd.

From: Jacni Qin <[email-masked]>
Date: Wed, 20 Jul 2011 11:07:58 +0800

hi Authors, all,

I skimed the draft and got a question on the "Domain IPv4 Prefix" involved
in the algorithm,

Since currently the IPv4 blocks used for accessing residential users are
probably fragmented (or not that continuous), I guess the there will be too
many domains, IMHO. During the later stage of phasing out IPv4, that might
be acceptable. Plus, it makes the algorithm complicated. So, how about
removing it, and just using the EA-bits? While, of cource the tradeoff will
be shorter IPv6 prefix is required.
Please correct me if I missed something. :-)

Thoughts?

Cheers,
Jacni

---

From: Satoru Matsushima <[email-masked]>
Date: Wed, 20 Jul 2011 17:07:28 +0900

Jacni,

On 2011/07/20, at 12:07, Jacni Qin wrote:

> hi Authors, all,
> 
> I skimed the draft and got a question on the "Domain IPv4 Prefix" involved in the algorithm,
> 
> Since currently the IPv4 blocks used for accessing residential users are probably fragmented (or not that continuous), I guess the there will be too many domains, IMHO. During the later stage of phasing out IPv4, that might be acceptable. Plus, it makes the algorithm complicated. So, how about removing it, and just using the EA-bits? While, of cource the tradeoff will be shorter IPv6 prefix is required.

4rd mapping rule allows '0/0' for a Domain IPv4 Prefix configuration.

cheers,
--satoru

---

From: Jacni Qin <[email-masked]>
Date: Wed, 20 Jul 2011 16:46:01 +0800

hi,

On Wed, Jul 20, 2011 at 4:07 PM, Satoru Matsushima <
[email-masked]> wrote:

> ...

Jacni>: Thanks, maybe you should add more text on this to get it clarified.

Cheers,
Jacni

---

From: Rémi Després <[email-masked]>
Date: Wed, 20 Jul 2011 11:45:22 +0200

Hi, Jacni,

> Please correct me if I missed something. :-)

In addition to Satoru's answer, an ISP that has many IPv4 prefixes can:
- use only a few, or even only one, of its shortest IPv4 prefixes, and
- use IPv4 address sharing to support as many CE's as needed. 

Example: an ISP has a /10, a /11, another /11, a /14, a /15, and a /16 (a real example I met).
It can:
- use three domains (the /10 and the two /11's), or
- use only the /10, extending Port-set ID by one bit to support as many CE's
In both cases, no entropy due to the fragmented IPv4 space needs to be exported to the IPv6 addressing plan.

Leftover IPv4 prefixes can then be returned to the community (for free... or for a price, whatever applies).
  
Regards,
RD

> 
> 
> Cheers,
> Jacni
> 
> _______________________________________________
> Softwires mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/softwires

---

From: Jacni Qin <[email-masked]>
Date: Thu, 21 Jul 2011 12:09:12 +0800

Hi Remi,

Thanks, inline please,

> exported to the IPv6 addressing plan.

Jacni>: Ok, I got you point,
Another question is to make sure that continuous IPv6 pools (with EA) are
assigned on multiple Access Gateways (BNG) within the same 4rd domain.

Plus, the reality is even more complicated,
For example, there are group/HQ and branches. The shorter prefixes are
probably held by the group level, and several/many 4rd domains (according to
the sizes of cities under given branch) will be maintained by the branches
who can only get fragmented spaces, since a large amount of these spaces
come from leftover prefixes returned.

Cheers,
Jacni

---

From: Rémi Després <[email-masked]>
Date: Thu, 21 Jul 2011 09:13:01 +0200

Le 21 juil. 2011 à 06:09, Jacni Qin a écrit :

> Hi Remi,
> 
> Thanks, inline please,
> 
> On Wed, Jul 20, 2011 at 5:45 PM, Rémi Després <[email-masked]> wrote:
> Hi, Jacni,
> 
> ...
> 

Thanks.

> Another question is to make sure that continuous IPv6 pools (with EA) are assigned on multiple Access Gateways (BNG) within the same 4rd domain.

I don't understand the question.
Could you clarify?

> For example, there are group/HQ and branches. The shorter prefixes are probably held by the group level, and several/many 4rd domains (according to the sizes of cities under given branch) will be maintained by the branches who can only get fragmented spaces, since a large amount of these spaces come from leftover prefixes returned.

Again, not sure to get the question.
The simple approach is "one IPv6 prefix" => "one 4rd prefix" (no fragmented spaces).
Changing the length of one changes the length of the other.

Cheers,
RD

---

From: Jacni Qin <[email-masked]>
Date: Sun, 24 Jul 2011 13:32:00 +0800

Hi Remi,

> Changing the length of one changes the length of the other.

Jacni>: Yes, one IPv6 prefix to one 4rd domain, then the Access Gateway has
to serve multiple domains, with hundreds of users each (according to the
length of IPv4 prefix available). In this case, it's better to embed the BR
function in the Gateway, otherwise the topology will be weird.

Cheers,
Jacni