Subject: Re: [Softwires] Why not use AFTR IPv6 address for the new DHCPv6 option?

From: [email-masked]
Date: Sun, 3 Jul 2011 02:12:04 +0800

Thanks, Washam, I got the intense debate.

But for 6rd, the IPv4 address of the BR is recommended to use in the DHCP option. Thus, different options are recommended for different technologies. I want to know the reason. Using the similar method to do the similar thing is better, isn't it? So, shall we modify the specification of 6rd to use a FQDN for the BR configuration on CEs?

Best Regards,
Zhenqiang Li
2011-07-03 

----- Original Message ----- 
From: Washam Fan 
Sent: 2011-07-01  13:04:46 
To: [email-masked] 
CC: [email-masked] 
Subject: Re: [Softwires] Why not use AFTR IPv6 address for the new DHCPv6 option? 
 
Hi,

There was a debate between ip literal v.s. fqdn for this issue. Please
search the old mail archive to check it out. If I recall correctly, a
major argument would be, many ISPs prefer dns server to do load
balancing over dhcp server.

Thanks,
washam

2011/6/30   <[email-masked] >:
> Hi All,
>
> One question about the new DHCPv6 option for AFTR discovery. Maybe I missed the previous discussion. Sorry for that.
> According to draft-ietf-softwire-ds-lite-tunnel-option, a FQDN is suggested to be deliveried in the new DHCPv6 option to the B4. When receiving the FQDN, B4 has to do the DNS resolution to get the AFTR IPv6 address. The FQDN of the AFTR has to be configured in the DNS server. So, I think delivering the IPv6 address of the AFTR directly to the B4 is better. We can use DHCPv6 option to do this. The address of the AFTR only needs to be configured in the DHCPv6 server.
>
> Best Regards,
> Zhenqiang Li
> 2011-06-30
> _______________________________________________
> Softwires mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/softwires
>

---

From: Washam Fan <[email-masked]>
Date: Sun, 3 Jul 2011 12:02:01 +0800

Hi Zhenqiang,

6rd is stateless, so anycast address might be used for BR
loadbalancing. I guess, that might be the reason why IP literal is
prefered over fqdn for 6rd case.

THanks,
washam

---

From: "Lee, Yiu" <[email-masked]>
Date: Mon, 4 Jul 2011 00:00:31 +0000

Few operators like to use fqdn for dslite for redundancy (multiple
a-records). 6rd is stateless and can use anycast address for redundancy.
This is why they are different.

On 7/2/11 2:12 PM, "[email-masked]"
<[email-masked]> wrote:

>ut for 6rd, the IPv4 address of the BR is recommended to use in the DHCP
>option.