Subject: [Softwires] DMR in map-T ; draft-ietf-softwire-map-t-00

From: "Poscic, Kristian (Kristian)" <[email-masked]>
Date: Wed, 17 Oct 2012 22:17:59 +0000

Need a quick clarification in regards to DMR in map-t:

-          In map-E the BR addresses is part of DMR. So the packet will be sent directly to the BR IPv6 address. Dest IPv4 as originated by the CE doesn't have to be encoded in IPv6 dest addr since the BR can figure out the dest IPv4 from the encapsulated IPv4 packet. Consequently the de-capsulated IPv4 packet will be forwarded to the IPv4 network.

-          But in map-T the DMR does not contain the DR IPv6 add but instead the prefix. Since the IPv4 dest will be encoded in the dest IPv6 address, the BR must now accept all possible IPv6 addresses as long as the prefix matches that of the BR. Since the original IPv4 packet is not encapsulated in map-t, the BR will look at the dest IPv4 encoded in IPv6 dest address, assuming that the BR terminates the prefix now and not the IP addr itself. Is this how this is envisioned, that in map-T the BR terminates the prefix instead of an addr?
Thanks,
Kris

---

From: Leaf yeh <[email-masked]>
Date: Thu, 18 Oct 2012 02:13:16 +0000

Kris  - map-T the BR terminates the prefix instead of an addr?

Yes, that is also my read from the drafts of MAP.

Best Regards,
Leaf

From: [email-masked] [mailto:[email-masked]] On Behalf Of Poscic, Kristian (Kristian)
Sent: Thursday, October 18, 2012 6:18 AM
To: [email-masked]
Subject: [Softwires] DMR in map-T ; draft-ietf-softwire-map-t-00