Subject: [Softwires] I-D Action: draft-ietf-softwire-multicast-prefix-option-02.txt

From: [email-masked]
Date: Tue, 16 Oct 2012 08:03:23 -0700

A New Internet-Draft is available from the on-line Internet-Drafts directories.
 This draft is a work item of the Softwires Working Group of the IETF.

	Title           : DHCPv6 Option for IPv4-Embedded Multicast and Unicast IPv6 Prefixes
	Author(s)       : Mohamed Boucadair
                          Jacni Qin
                          Tina Tsou
                          Xiaohong Deng
	Filename        : draft-ietf-softwire-multicast-prefix-option-02.txt
	Pages           : 7
	Date            : 2012-10-16

Abstract:
   This document defines Dynamic Host Configuration Protocol version 6
   (DHCPv6) Option for multicast transition solutions, aiming to convey
   the IPv6 prefixes to be used to build unicast and multicast IPv4-
   embedded IPv6 addresses.

The IETF datatracker status page for this draft is:
https://datatracker.ietf.org/doc/draft-ietf-softwire-multicast-prefix-option

There's also a htmlized version available at:
http://tools.ietf.org/html/draft-ietf-softwire-multicast-prefix-option-02

A diff from the previous version is available at:
http://www.ietf.org/rfcdiff?url2=draft-ietf-softwire-multicast-prefix-option-02

Internet-Drafts are also available by anonymous FTP at:
ftp://ftp.ietf.org/internet-drafts/

---

From: <[email-masked]>
Date: Thu, 18 Oct 2012 07:37:48 +0200

Dear all,

A new version was submitted with the following change:

* Remove a normative reference. 

We believe this version is ready for a WGLC.

Cheers,
Med

>-----Message d'origine-----
>De : [email-masked] 
>[mailto:[email-masked]] De la part de 
>[email-masked]
>Envoyé : mardi 16 octobre 2012 17:03
>À : [email-masked]
>Cc : [email-masked]
>Objet : [Softwires] I-D Action: 
>draft-ietf-softwire-multicast-prefix-option-02.txt
>
>
>	Filename        : 
>draft-ietf-softwire-multicast-prefix-option-02.txt
>	Pages           : 7
>	Date            : 2012-10-16
>
>Abstract:
>_______________________________________________
>Softwires mailing list
>[email-masked]
>https://www.ietf.org/mailman/listinfo/softwires
>

---

From: Ted Lemon <[email-masked]>
Date: Thu, 18 Oct 2012 12:51:05 +0000

In review in the DHC working group (which just started!), Bernie Volz pointed out that you've defined yet another format for IPv6 prefixes in DHCPv6 options, and requests that you use one of the two existing formats.

I also notice that it appears that you have a fixed-format option, but some parts of the option may or may not appear depending on server configuration, and that if they do not appear, the option merely has a shorter length.   This is contrary to the way things are normally done in DHCP servers, and will require special UI or configuration file tweaks to get right.

It would be better if each of the three optional fields in the option were simply its own option.   Is there some strong reason why all three of these fields need to be in the same DHCP option?

---

From: <[email-masked]>
Date: Thu, 18 Oct 2012 14:59:33 +0200

Dear Ted,

Please see inline.
Cheers,
Med

>De : Ted Lemon [mailto:[email-masked]] 
>Envoyé : jeudi 18 octobre 2012 14:51
>À : BOUCADAIR Mohamed OLNC/OLN
>Cc : [email-masked]
>Objet : Re: [Softwires] I-D Action: 
>In review in the DHC working group (which just started!), 

Med: As a reminder, I have sent a notification to DHC to review this draft (April 2012). Please refer to http://www.ietf.org/mail-archive/web/dhcwg/current/msg12575.html. 

>Bernie Volz pointed out that you've defined yet another format 
>for IPv6 prefixes in DHCPv6 options, and requests that you use 
>one of the two existing formats.
>
>I also notice that it appears that you have a fixed-format 
>option, but some parts of the option may or may not appear 
>depending on server configuration, and that if they do not 
>appear, the option merely has a shorter length.   This is 
>contrary to the way things are normally done in DHCP servers, 
>and will require special UI or configuration file tweaks to get right.

Med: I can change this easily if you think we need to do so. We use a fixed length because:

* SSM_PREFIX64 and ASM_PREFIX64 are /96
* U_PREFIX64 follows RFC6052; it may have variable length with a maximum being /96.

>
>It would be better if each of the three optional fields in the 
>option were simply its own option.   Is there some strong 
>reason why all three of these fields need to be in the same 
>DHCP option?

Med: I have provided an answer to this question here (http://www.ietf.org/mail-archive/web/dhcwg/current/msg12577.html; and given I didn't received an answer from your side I thought you were fine with my explanation.

---

From: Ted Lemon <[email-masked]>
Date: Thu, 18 Oct 2012 17:48:33 +0000

> Med: I have provided an answer to this question here (http://www.ietf.org/mail-archive/web/dhcwg/current/msg12577.html; and given I didn't received an answer from your side I thought you were fine…

Yes, thanks for the reminder.   That does make sense.