Subject: [Softwires] I-D Action: draft-ietf-softwire-dslite-multicast-04.txt

From: [email-masked]
Date: Wed, 17 Oct 2012 22:35:17 -0700

A New Internet-Draft is available from the on-line Internet-Drafts directories.
 This draft is a work item of the Softwires Working Group of the IETF.

	Title           : Delivery of IPv4 Multicast Services to IPv4 Clients over an IPv6 Multicast Network
	Author(s)       : Jacni Qin
                          Mohamed Boucadair
                          Christian Jacquenet
                          Yiu L. Lee
                          Qian Wang
	Filename        : draft-ietf-softwire-dslite-multicast-04.txt
	Pages           : 20
	Date            : 2012-10-17

Abstract:
   This document specifies a solution for the delivery of IPv4 multicast
   services to IPv4 clients over an IPv6 multicast network.  The
   solution relies upon a stateless IPv4-in-IPv6 encapsulation scheme
   and uses the IPv6 multicast distribution tree to deliver IPv4
   multicast traffic.  The solution is particularly useful for the
   delivery of multicast service offerings to DS-Lite serviced
   customers.

The IETF datatracker status page for this draft is:
https://datatracker.ietf.org/doc/draft-ietf-softwire-dslite-multicast

There's also a htmlized version available at:
http://tools.ietf.org/html/draft-ietf-softwire-dslite-multicast-04

A diff from the previous version is available at:
http://www.ietf.org/rfcdiff?url2=draft-ietf-softwire-dslite-multicast-04

Internet-Drafts are also available by anonymous FTP at:
ftp://ftp.ietf.org/internet-drafts/

---

From: <[email-masked]>
Date: Thu, 18 Oct 2012 07:50:46 +0200

Dear all,

We submitted an updated version to resolve one open issue for the draft. The main changes are:

* Remove a normative reference
* Add a new section to describe how address translation is done.
* Updated the examples to make use of the IPv6 address block defined in RFC6676.

A detailed diff is available at: http://www.ietf.org/rfcdiff?url2=draft-ietf-softwire-dslite-multicast-04.

As suggested by Stig, a message was sent to mboned ML (http://www.ietf.org/mail-archive/web/mboned/current/msg01725.html).

We believe this version solves the technical comments raised during WGLC and also against -03.

There was a request from Behcet to add some normative references to the draft but this was not accepted (see the mailing list archives). 

Cheers,
Med

>-----Message d'origine-----
>De : [email-masked] 
>[mailto:[email-masked]] De la part de 
>[email-masked]
>Envoyé : jeudi 18 octobre 2012 07:35
>À : [email-masked]
>Cc : [email-masked]
>Objet : I-D Action: draft-ietf-softwire-dslite-multicast-04.txt
>
>
>	Title           : Delivery of IPv4 Multicast Services 
>to IPv4 Clients over an IPv6 Multicast Network
>	Author(s)       : Jacni Qin
>                          Mohamed Boucadair
>                          Christian Jacquenet
>                          Yiu L. Lee
>                          Qian Wang
>_______________________________________________
>I-D-Announce mailing list
>[email-masked]
>https://www.ietf.org/mailman/listinfo/i-d-announce
>Internet-Draft directories: http://www.ietf.org/shadow.html
>or ftp://ftp.ietf.org/ietf/1shadow-sites.txt
>

---

From: Behcet Sarikaya <[email-masked]>
Date: Thu, 18 Oct 2012 14:40:16 -0500

Hi all,

> There was a request from Behcet to add some normative references to the draft but this was not accepted (see the mailing list archives).

I don't remember what this refers to.

But I do remember that this draft does not consider a very significant
case: IPv6 network may not be multicast enabled.

If this issue is resolved (it could be resolved by accepting another
solution, because more than one solution may be accepted for a given
problem/charter item) then my issues with this draft will be resolved.

Regards,

Behcet

---

From: <[email-masked]>
Date: Fri, 19 Oct 2012 07:45:35 +0200

Behcet,

Please see inline.

Cheers,
Med 

>De : Behcet Sarikaya [mailto:[email-masked]] 
>Envoyé : jeudi 18 octobre 2012 21:40
>À : BOUCADAIR Mohamed OLNC/OLN
>Cc : [email-masked]
>Objet : Re: [Softwires] I-D Action: 
>draft-ietf-softwire-dslite-multicast-04.txt
>
>Hi all,
>
>
>> A detailed diff is available at: 
>http://www.ietf.org/rfcdiff?url2=draft-ietf-softwire-dslite-mul
>ticast-04.
>>
>> As suggested by Stig, a message was sent to mboned ML 
>(http://www.ietf.org/mail-archive/web/mboned/current/msg01725.html).
>>
>> There was a request from Behcet to add some normative 
>references to the draft but this was not accepted (see the 
>mailing list archives).
>>
>
>

Med: I'm referring to this http://www.ietf.org/mail-archive/web/softwires/current/msg04766.html when you asked

"
and I would like this be a normative reference.
"

>case: IPv6 network may not be multicast enabled.

Med: This draft assumes multicast capabilities are enabled in the network. For the case you are referring to, you can use some existing tools (e.g., AMT).

>problem/charter item) then my issues with this draft will be resolved.

Med: This point was discussed several times (e.g., http://www.ietf.org/mail-archive/web/softwires/current/msg04767.html).

---

From: Behcet Sarikaya <[email-masked]>
Date: Fri, 19 Oct 2012 10:23:58 -0500

Dear Med,

Please do not take my comments personal. How many times I said this.
Nothing personal, nothing against you or your coauthors, your drafts.

Please kindly see inline.

> and I would like this be a normative reference.

Please see further below.

> Med: This draft assumes multicast capabilities are enabled in the network. For the case you are referring to, you can use some existing tools (e.g., AMT).

Or RFC 6224.

> Med: This point was discussed several times (e.g., http://www.ietf.org/mail-archive/web/softwires/current/msg04767.html).

Med, this issue was discussed in the context of having a merged draft
as I claimed that previous chair, Alain Durant requested it.

Please, please pay attention to what I am saying now. As Softwire WG
has already done in relation to 4rd, more than one drafts can be
accepted corresponding to one charter item, I am kindly suggesting we
do the same in DS-Lite multicast case as well. No problem with your
draft but Softwire may progress another draft such as
draft-sarikaya-softwire-dslitemulticast-01.txt.

Please support this.

Regards,

Behcet