Subject: [Softwires] Comments on draft-hu-softwire-multicast-radius-ext

From: "Hao Wang"<[email-masked]>
Date: Wed, 24 Sep 2014 12:46:22 +0800

Dear *,

I've read this document and think it provides a good method by using AAA-server and radius to store and provision v6-prefix in IPv6 multicast scenario. Some comments on this draft:

Section 1:
  * The name of new DHCPv6 option has turned into 'OPTION_V6_PREFIX64' in the latest [I-D.ietf-softwire-multicast-prefix-option].

Section 3:
  * What does it mean by 'based on the sending client'?
  * If mB4 using DHCPv6 Solicit just for lease query, instead of IP address, the access request will always be send to AAA-server? AAA-server receives any access request from NAS will always be send Multicast-Prefixes-64 attribute back to NAS?
  * In Lightweight 4over6 scenario, lwB4 ([I-D.ietf-softwire-lw4over6]) as the client of DHCPv6 and DCHPv4o6 to request it's IPv6 & IPv4 address respectively. How the AAA-server to mantain the binding relationships with these two DHCP servers which as the part of NAS.

Section 4.1:
  * The priority of Multicast-Prefixes-64 in Access-Accept message is higher than pre-provisioned?

Best Regards,
Hao Wang

Hao Wang，[email-masked]
2014/9/24

---

From: [email-masked]
Date: Thu, 25 Sep 2014 16:40:38 +0800

Hi Hao,

  Thanks for your review. Please see inline.

Thanks,
Wei

"Softwires" <[email-masked]> 写于 2014/09/24 12:46:22:

> Dear *,
> 
> I've read this document and think it provides a good method by using
> AAA-server and radius to store and provision v6-prefix in IPv6 
> multicast scenario. Some comments on this draft:
> 
> Section 1:
>   * The name of new DHCPv6 option has turned into 
> 'OPTION_V6_PREFIX64' in the latest [I-D.ietf-softwire-multicast-
> prefix-option].

[wei] Got it.

>   * What does it mean by 'based on the sending client'?

[Wei] In the draft, I mean the AAA server compares the recieved message
with the database to verify the legitimate user.
Modifying this to "it validates the sending client" should be better.

>   * If mB4 using DHCPv6 Solicit just for lease query, instead of IP 
> address, the access request will always be send to AAA-server? AAA-
> server receives any access request from NAS will always be send 
> Multicast-Prefixes-64 attribute back to NAS?

[Wei]: IMO, in NAS, the recieved DHCPv6 solicit message will trigger
the RADIUS request and then get all attributes including 
Multicast-Prefixes-64
from AAA server. NAS will save them locally.
   If mB4 using DHCPv6 Solicit just for lease query(I'm not sure DHCPv6 
Solicit 
can be used for lease query according to rfc5007), NAS will not send 
RADIUS request because
it had saved these attributes before.

>   * In Lightweight 4over6 scenario, lwB4 ([I-D.ietf-softwire-
> lw4over6]) as the client of DHCPv6 and DCHPv4o6 to request it's IPv6
> & IPv4 address respectively. How the AAA-server to mantain the 
> binding relationships with these two DHCP servers which as the part of 
NAS.

[Wei]: So far, this does not take into consideration about what will occur 
between 
NAS & AAA server under the scenario of two different DHCP-servers co-exist 
at the same time.
  I'm glad to take further consideration and solicit your proposal. 

> is higher than pre-provisioned?

[Wei]: This proposal is tendency, not absolute.

> 2014/9/24 _______________________________________________
> Softwires mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/softwires