Subject: [Stox] OTR encryption between SIP and XMPP

From: Adrian Georgescu <[email-masked]>
Date: Fri, 13 Sep 2013 09:42:28 -0300

Hello,

I am not sure if this is relevant to any of the deliverables of the working group, but just in case it is, we were able to create end-to-end encryption for chat sessions using OTR protocol http://www.cypherpunks.ca/otr/  between a SIP client using MSRP (that is Blink) and XMPP client (Jitsi).

The implementation is described here:

http://projects.ag-projects.com/projects/blinkc/wiki/OTR

Regards,
Adrian

---

From: Peter Saint-Andre <[email-masked]>
Date: Wed, 18 Sep 2013 08:15:20 -0600

On 9/13/13 6:42 AM, Adrian Georgescu wrote:
> Hello,
> 
> I am not sure if this is relevant to any of the deliverables of the
> working group, but just in case it is, we were able to create
> end-to-end encryption for chat sessions using OTR protocol
> http://www.cypherpunks.ca/otr/  between a SIP client using MSRP
> (that is Blink) and XMPP client (Jitsi).
> 

Cool!

Given that OTR is an "over-the-top" encryption method that's agnostic
about the underlying messaging transport, it does seem like a
reasonable approach. I'm not sure whether we need or want to say
anything about that in draft-ietf-stox-chat.

Peter

- -- 
Peter Saint-Andre
https://stpeter.im/