Subject: [Stox] current status

From: Peter Saint-Andre <[email-masked]>
Date: Thu, 05 Sep 2013 20:59:31 -0600

Folks, as far as I can tell I've addressed all feedback sent so far on
the -core, -presence, and -im documents. I'll try to do the same for
the -chat document by the end of next week. I'll also talk with Saúl
about setting a schedule for the -groupchat document (perhaps also by
the end of next week).

Peter

- -- 
Peter Saint-Andre
https://stpeter.im/

---

From: <[email-masked]>
Date: Fri, 6 Sep 2013 13:25:43 +0000

Hi,

There have been a fair number of comments on -core, -im and -presence since the Berlin IETF. Please take a look at the new versions
http://tools.ietf.org/id/draft-ietf-stox-core-04.txt
http://tools.ietf.org/id/draft-ietf-stox-im-02.txt
http://tools.ietf.org/id/draft-ietf-stox-presence-04.txt
and see if your issues have been properly addressed, and/or whether you want to still raise any new issues.

If nothing specific comes up, the chairs will consider starting WG LC on these documents in the near future. 

One thing that I wonder about -core is whether it is a good idea to stabilize or last call it yet at this point, since there have been some issues raised about -media that might have impact to -core, such as dealing with SIP side forking or loop detection. So is it better to wait with -core until -media is more stable?

But let's move forward with -im and -presence unless there are issues left. 

Markus 

> -----Original Message-----
> From: [email-masked] [mailto:[email-masked]] On Behalf Of
> ext Peter Saint-Andre
> Sent: 06 September, 2013 06:00
> To: [email-masked]
> Subject: [Stox] current status
> 
> -----BEGIN PGP SIGNED MESSAGE-----
> Hash: SHA1
> 
> Folks, as far as I can tell I've addressed all feedback sent so far on the -core, -
> presence, and -im documents. I'll try to do the same for the -chat document
> by the end of next week. I'll also talk with Saúl about setting a schedule for
> the -groupchat document (perhaps also by the end of next week).
> 
> Peter
> 
> - --
> Peter Saint-Andre
> https://stpeter.im/
> 
> 
> -----BEGIN PGP SIGNATURE-----
> Version: GnuPG/MacGPG2 v2.0.19 (Darwin)
> Comment: GPGTools - http://gpgtools.org
> Comment: Using GnuPG with Thunderbird - http://www.enigmail.net/
> 
> iQIcBAEBAgAGBQJSKUUTAAoJEOoGpJErxa2pyaQQAIQfLAoR2/DUKBXni7q1E
> UlT
> 2j+xIFz98hBvKvCtgKruj8/v3ld1AML4XN7HWBOQVfGnP9ynda/Mdv/mofmqU
> dZL
> ACyPK21W30dADMf+sCmz0k63dtIUUPhxJ859GpKDmFydPfrDGcx4ELz7UXMB
> fENb
> qNXgHNSUlikg89Eb3herB8NuIVmm3G1zRREI6QbwtVbySCEj7YGeaTYDsdIBIA
> pC
> eg5mX6nUk+8OY5uxOBEJtLGU9osBAS3XuW6cFvw0RPdFeCVw1SlZrJzhnScT
> WMBe
> SMPhkQzwX3ZWz7CxapiXXoRc3doeRc2gc1ockoiclYVyeCjvCJv3LarxBDE/DDdV
> uSRuPgZFlfZDFCHcejlyD1QeW89hq9TuPphspNT9q0yunivZZuxhIePOd0o8Stvc
> 65pzu27oAaSxHZY8o7YsNsKEPLdixoTZYLrnE1Y+i7hFDkcviDA2IBiKU8JNRdtS
> WIlKUlN9ZGQg2Q3YKkWU7ukfZLM/MD2nngZlYkih43x108f8cf2P0NjBKLonSHu
> 7
> e6oCfnJ8Ld2xlDfTh4ZHtpFBjMBqwvTR9ipMc5ymDyNNe/4jM8TcPRd4NCO6O
> spB
> h+CIkWHSTVt33GNKkcYpRph7fjy3iWWXBKCj0wh7b36hvILCPVWtBrpBfPY/K5
> cv
> scrES7EtSBCFXNCxwgvb
> =6eKJ
> -----END PGP SIGNATURE-----
> _______________________________________________
> stox mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/stox

---

From: Saúl Ibarra Corretgé <[email-masked]>
Date: Fri, 6 Sep 2013 18:16:34 +0200

> One thing that I wonder about -core is whether it is a good idea to stabilize or last call it yet at this point, since there have been some issues raised about -media that might have impact to -cor…

At some point we agreed that those issues would be handled in -media, because in other cases (chat, presence, im) the gateway is itself the endpoint and handles all the "media", so those didn't seem to apply.

--
Saúl Ibarra Corretgé
AG Projects

---

From: Peter Saint-Andre <[email-masked]>
Date: Fri, 06 Sep 2013 10:35:54 -0600

On 9/6/13 10:16 AM, Saúl Ibarra Corretgé wrote:
>> There have been a fair number of comments on -core, -im and 
>> -presence since the Berlin IETF. Please take a look at the new 
>> versions http://tools.ietf.org/id/draft-ietf-stox-core-04.txt 
>> http://tools.ietf.org/id/draft-ietf-stox-presence-04.txt and see
>> if your issues have been properly addressed, and/or whether you
>> want to still raise any new issues.
>> 
>> If nothing specific comes up, the chairs will consider starting
>> WG LC on these documents in the near future.
>> 
>> One thing that I wonder about -core is whether it is a good idea
>> to stabilize or last call it yet at this point, since there have
>> been some issues raised about -media that might have impact to
>> -core, such as dealing with SIP side forking or loop detection.
>> So is it better to wait with -core until -media is more stable?
>> 
> 
> At some point we agreed that those issues would be handled in
> -media, because in other cases (chat, presence, im) the gateway is
> itself the endpoint and handles all the "media", so those didn't
> seem to apply.

That is my recollection, too.

Thus I'd be in favor of stabilizing the -core spec, and hanlding the
forking issues in the -media spec.

Peter

- -- 
Peter Saint-Andre
https://stpeter.im/

---

From: Mary Barnes <[email-masked]>
Date: Fri, 6 Sep 2013 11:42:33 -0500

> That is my recollection, too.
 [MB] That was also what I thought when I reviewed -core. [/MB]

> forking issues in the -media spec.
[MB] I agree. [/MB]

> iQIcBAEBAgAGBQJSKgRqAAoJEOoGpJErxa2p4GUP/2bzG8+WbRPcn0JpREhws+T5
> m3WBrq0OoJryDzxaA2HmBq15TBawWzsVce5dp4oOY73G9HsPxCyDHrPYiN/SBxhK
> VTSrIid3GCd9s0uTNEgPIwcQ6DFJy5f3nxdo2YWgmm+ncJ7hvuSXSGoDCammAyX0
> nGci5VPoesbj+LZaebSPgFDHX7jtVElqloR2wpHYxmTh+P34sXGuKneQH43wYdM7
> seOMpsD8yyfwRUqvhglUf4H46maQvYENTDCFsk5XjbcWoJLK52+N+Pwkw9ofr6DZ
> no/j5xPLY1mr3FTE0MTgMn0Nq3YSCD4M3jLrsjjdudvlQvLcItWIK4x9OO8JaaFx
> 5+AWtrCjn6yu/NKLgY8M5zhju51T8/srn1sBzxCQNkj5dNykbhp2W/Qo2Y+eahF1
> cZEOhmTTALEpbqvtGxZBg/p9kSugwk3q4oAlP875JlBS+VLiiFXc6MIeXqWHS9yf
> X2KXJj3xNrh1Esp/Z2FG/W5+uz+e9tT2IlevhKcNozFs+gyJHeD/KwZZ3Oc3/Hqj
> 4RkFcLW+8iXFqH1EozpYFcr7WOhNRlh2KtbBON/w9o7481i35HRG8cR0TtFZ//By
> pqTdVWZhwYH3PR9B4+6cY53Lk5aWoL5RGX5DYMPluHuJGcPW99VORRE8RRo4eepC
> nTGO/i5/5W8SC+EE3hO7
> =6RTC

---

From: <[email-masked]>
Date: Wed, 18 Sep 2013 11:16:12 +0000

Hi,

There have been no further comments on this, so I think we can declare it decided that we won't expand the scope of -core with topics like forking, but leave that to the -media to handle.

My proposed plan for the next steps of the WG is:

-          Before Vancouver: Issue WG Last Calls on -core, -im, and -presence and see if they indeed are mature enough to be delivered forward.

-          For Vancouver: Get updated versions of especially -media, and possibly -chat and -groupchat, and collect the open issues about them.

-          In Vancouver: Discuss the open issues about -media, and if needed -chat and -groupchat.

-          After Vancouver: Depending on the maturity and issues raised, schedule WG Last Calls for the remaining deliverables.

Let the chairs (Yana and me) know if you have issues with this plan or even better, suggestions how to improve it.

Markus

From: ext Mary Barnes [mailto:[email-masked]]
Sent: 06 September, 2013 19:43
To: Peter Saint-Andre
Cc: Saúl Ibarra Corretgé; [email-masked]; Isomaki Markus (Nokia-CIC/Espoo)
Subject: Re: [Stox] current status

On Fri, Sep 6, 2013 at 11:35 AM, Peter Saint-Andre <[email-masked]<mailto:[email-masked]>> wrote:
On 9/6/13 10:16 AM, Saúl Ibarra Corretgé wrote:
>
> On Sep 6, 2013, at 3:25 PM, <[email-masked]<mailto:[email-masked]>>
> <[email-masked]<mailto:[email-masked]>> wrote:
>
>> Hi,
>>

Peter

- --
Peter Saint-Andre
https://stpeter.im/

_______________________________________________
stox mailing list
[email-masked]<mailto:[email-masked]>
https://www.ietf.org/mailman/listinfo/stox

---

From: Peter Saint-Andre <[email-masked]>
Date: Wed, 18 Sep 2013 06:55:51 -0600

On 9/18/13 5:16 AM, [email-masked] wrote:
> Hi,
> 
> 
> 
> There have been no further comments on this, so I think we can
> declare it decided that we won?t expand the scope of ?core with
> topics like forking, but leave that to the ?media to handle.
> 
> 
> 
> -          Before Vancouver: Issue WG Last Calls on ?core, -im,
> and ?presence and see if they indeed are mature enough to be
> delivered forward.
> 
> -          For Vancouver: Get updated versions of especially
> ?media, and possibly ?chat and ?groupchat, and collect the open
> issues about them.
> 
> -          In Vancouver: Discuss the open issues about ?media, and
> if needed ?chat and ?groupchat.
> 
> -          After Vancouver: Depending on the maturity and issues
> raised, schedule WG Last Calls for the remaining deliverables.

That all sounds good. I will work to update at least the -chat draft
very soon, and work with Saúl on the groupchat draft too.

Peter

- -- 
Peter Saint-Andre
https://stpeter.im/