Subject: Re: [tcpm] I-D ACTION:draft-ietf-tcpm-tcp-uto-03.txt

From: Lars Eggert <[email-masked]>
Date: Wed, 13 Sep 2006 13:40:45 +0200

Hi,

On Jul 20, 2006, at 0:50, <[email-masked]> <Internet- 
[email-masked]> wrote:
> 	Title		: TCP User Timeout Option
> 	Author(s)	: L. Eggert, F. Gont
> 	Filename	: draft-ietf-tcpm-tcp-uto-03.txt

we haven't received any comments on this last version, which attempts  
to address the review comments from Gorry and others on -02.

Could I ask the WG to take a look and see if it is happy with this  
revision?

Thanks,
Lars

ID: http://tools.ietf.org/wg/tcpm/draft-ietf-tcpm-tcp-uto/draft-ietf- 
tcpm-tcp-uto-03.txt
Diff: http://tools.ietf.org/wg/tcpm/draft-ietf-tcpm-tcp-uto/draft- 
ietf-tcpm-tcp-uto-03-from-02.diff.html
-- 
Lars Eggert                                     NEC Network Laboratories

_______________________________________________
tcpm mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/tcpm

---

From: "Caitlin Bestler" <[email-masked]>
Date: Wed, 13 Sep 2006 14:18:09 -0700

Lars Eggert wrote:
> Hi,
> 
> On Jul 20, 2006, at 0:50, <[email-masked]>
> <Internet- [email-masked]> wrote:
> we haven't received any comments on this last version, which
> attempts to address the review comments from Gorry and others on -02.
> 
> Could I ask the WG to take a look and see if it is happy with
> this revision?
> 

At the time that the passive side responds to a SYN request
the allocated resource, if any, might not be capable of recording
the remote peer's hint.

A statement that the passive side MAY ignore the UTO option on
a SYN is of course unneeded, since the draft is quite clear
that either side MAY ignore the UTO option on any packet.

But it might be useful to suggest that the active side
SHOULD provide the initial UTO in the first non-SYN
rather than assuming it was remembered from the SYN.

---

From: Fernando Gont <[email-masked]>
Date: Fri, 15 Sep 2006 05:39:17 -0300

>the allocated resource, if any, might not be capable of recording

You mean, eg., an implementation of SYN cookies?

>rather than assuming it was remembered from the SYN.

Makes sense to me. (I was just about to say that with SYN cookies in 
place, there are lots of enhancements that are lost... but I just 
read Andre's post, so... ;-) )

Kindest regards,

--
Fernando Gont
e-mail: [email-masked] || [email-masked]
PGP Fingerprint: 7809 84F5 322E 45C7 F1C9 3945 96EE A9EF D076 FFF1

---

From: "Caitlin Bestler" <[email-masked]>
Date: Fri, 15 Sep 2006 08:55:08 -0700

Fernando Gont wrote:
>> At the time that the passive side responds to a SYN request the
>> allocated resource, if any, might not be capable of recording the
>> remote peer's hint.
> 

The passive side naturally seeks economy in the representation
of potential-connection state in response to a single SYN
packet that has not yet been otherwise validated.

SYN Cookies are just one method of doing so.

Whatever method is used, it is preferable from a protocol
viewpoint to minimize adding to the information that should
be retained in this state.

---

From: Fernando Gont <[email-masked]>
Date: Mon, 18 Sep 2006 17:31:00 -0300

>packet that has not yet been otherwise validated.

I think this is a good principle to follow. However, I'm not sure 
this principle is currently followed by TCP, though.

Kindest regards,