Subject: [tcpm] RE: TAKE TWO: Unified ICMP processing: A straw man

From: "Mahdavi, Jamshid" <[email-masked]>
Date: Thu, 7 Dec 2006 07:29:12 -0800

Joe Touch wrote:

> I think some of the points are correct, but others have far-reaching
> ramifications. If all ICMPs are advisory, e.g., then some things we rely
> on for correct operation would silently fail (redirects, in particular).

I think that ICMP redirects are absolutely advisory.  We have lots of 
cases where people ignore redirects, disable sending them, or periodically
clear the list of redirect learned routes.  I'm not sure what could be
more advisory than that.

--J

_______________________________________________
tcpm mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/tcpm

---

From: Joe Touch <[email-masked]>
Date: Thu, 07 Dec 2006 07:59:47 -0800

> clear the list of redirect learned routes.  I'm not sure what could be

Maybe I'm misunderstanding advisory. I thought it implied "SHOULD
ignore". If it implies "MAY ignore", that seems fine.

Joe

---

From: "Mahdavi, Jamshid" <[email-masked]>
Date: Thu, 7 Dec 2006 08:29:35 -0800

That (MAY ignore) has always been my understanding of advisory.

--J

-----Original Message-----
From: Joe Touch [mailto:[email-masked]] 
Sent: Thursday, December 07, 2006 8:00 AM
To: Mahdavi, Jamshid
Cc: [email-masked]
Subject: Re: [tcpm] RE: TAKE TWO: Unified ICMP processing: A straw man

Joe