Subject: RE: [tcpm] FW: I-D Action:draft-schuetz-tcpm-tcp-rlci-02.txt

From: "Henderson, Thomas R" <[email-masked]>
Date: Tue, 4 Dec 2007 13:36:04 -0800

> -----Original Message-----
> From: Simon Schuetz [mailto:[email-masked]] 
> Sent: Monday, November 26, 2007 3:14 AM
> To: [email-masked]
> Cc: [email-masked]
> Subject: [tcpm] FW: I-D Action:draft-schuetz-tcpm-tcp-rlci-02.txt 
> 
> Hi,
> 
> We submitted a revision of the TCP RLCI draft.
> 
> Major changes/improvements:
> - state machine now implements 3-way handshake to guarantee 
> delivery of connectivity-change indication
> - better "stale ack" detection
> - improved handling in case of out-of-order delivery
> 
> Comments welcome,
> Simon
> 

Simon,
I was curious whether you or anyone on the list knows of a Linux
implementation of any portions of the above draft.

Thanks,
Tom

_______________________________________________
tcpm mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/tcpm

---

From: Lars Eggert <[email-masked]>
Date: Tue, 4 Dec 2007 17:03:14 -0800

> implementation of any portions of the above draft.

We have ns2 code that we'll make available in a few weeks.

There is no Linux implementation for RLCI. There was some Linux code  
for the earlier drafts of which RLCI is a merge. But RLCI is now very  
different from those, so that code is not very useful anymore.

Lars