Subject: [Teas-ns-dt] FW: New Version Notification for draft-nsdt-teas-transport-slice-definition-00.txt

From: "Rokui, Reza (Nokia - CA/Ottawa)" <[email-masked]>
Date: Sun, 3 Nov 2019 15:20:59 +0000

All,

As per our discussion during the network slicing DT meeting on Oct 31, the first version of draft "IETF Definition of Transport Slice" has been submitted. Authors have incorporated the comments.

Please review. Any other comments are welcome.

Cheers,

Reza

On 2019-11-03, 10:13 AM, "[email-masked]" <[email-masked]> wrote:

    A new version of I-D, draft-nsdt-teas-transport-slice-definition-00.txt

    has been successfully submitted by Reza Rokui and posted to the

    IETF repository.

    Name:            draft-nsdt-teas-transport-slice-definition

    Revision:  00

    Title:           IETF Definition of Transport Slice

    Document date:    2019-11-02

    Group:           Individual Submission

    Pages:           15

    URL:            https://www.ietf.org/internet-drafts/draft-nsdt-teas-transport-slice-definition-00.txt

    Status:         https://datatracker.ietf.org/doc/draft-nsdt-teas-transport-slice-definition/

    Htmlized:       https://tools.ietf.org/html/draft-nsdt-teas-transport-slice-definition-00

    Htmlized:       https://datatracker.ietf.org/doc/html/draft-nsdt-teas-transport-slice-definition

    Abstract:

       This document describes the definition of transport slice in IETF and

       considerations on implementation (realization) of transport slice.

       This work is part of work on TEAS WG network slicing Design Team.

    Please note that it may take a couple of minutes from the time of submission

    until the htmlized version and diff are available at tools.ietf.org.

    The IETF Secretariat

---

From: Eric Gray <[email-masked]>
Date: Wed, 13 Nov 2019 00:58:25 +0000

Reza,

              Is there any way that you could provide some description of how the comments were addressed, as opposed to the statement that they were?

--
Eric

From: Teas-ns-dt <[email-masked]> On Behalf Of Rokui, Reza (Nokia - CA/Ottawa)
Sent: Sunday, November 3, 2019 10:21 AM
To: Kiran Makhijani <[email-masked]>; Shunsuke Homma <[email-masked]>; Jari Arkko <[email-masked]>; [email-masked]
Cc: Rokui, Reza (Nokia - CA/Ottawa) <[email-masked]>
Subject: [Teas-ns-dt] FW: New Version Notification for draft-nsdt-teas-transport-slice-definition-00.txt

All,

Cheers,

Reza

On 2019-11-03, 10:13 AM, "[email-masked]<mailto:[email-masked]>" <[email-masked]<mailto:[email-masked]>> wrote:

    IETF repository.

    Revision:  00

    Pages:           15

    Abstract:

    The IETF Secretariat

---

From: "Rokui, Reza (Nokia - CA/Ottawa)" <[email-masked]>
Date: Wed, 13 Nov 2019 01:09:13 +0000

Eric,

Thanks for your comments. I am reading your comments which was attached to your previous email.
Since your previous comments were based on the word document not the draft itself, I will address them in the updated draft and send you the new one.

Reza

From: Eric Gray <[email-masked]>
Date: Wednesday, November 13, 2019 at 7:58 AM
To: Reza Rokui <[email-masked]>, Kiran Makhijani <[email-masked]>, Shunsuke Homma <[email-masked]>, Jari Arkko <[email-masked]>, "[email-masked]" <[email-masked]>
Subject: RE: New Version Notification for draft-nsdt-teas-transport-slice-definition-00.txt

Reza,

--
Eric

All,

Cheers,

Reza

    IETF repository.

    Revision:  00

    Pages:           15

    Abstract:

    The IETF Secretariat

---

From: Eric Gray <[email-masked]>
Date: Wed, 13 Nov 2019 01:17:19 +0000

Reza,

The word document was what you had shared with us earlier, asking for comments.  Most of my comments are actually in the word document itself, with only the general comments in the E-Mail itself.

If you need me to forward the earlier E-Mail – so that you can see the comments in the Word document – please let me know.

By the way, perhaps you should not be in such a rush to produce a new version for everyone to review that you don’t actually get around to the comments from their last review.

--
Eric

From: Rokui, Reza (Nokia - CA/Ottawa) <[email-masked]>
Sent: Tuesday, November 12, 2019 8:09 PM
To: Eric Gray <[email-masked]>; Kiran Makhijani <[email-masked]>; Shunsuke Homma <[email-masked]>; Jari Arkko <[email-masked]>; [email-masked]
Cc: Rokui, Reza (Nokia - CA/Ottawa) <[email-masked]>
Subject: Re: New Version Notification for draft-nsdt-teas-transport-slice-definition-00.txt
Importance: High

Eric,

Reza

From: Eric Gray <[email-masked]<mailto:[email-masked]>>
Date: Wednesday, November 13, 2019 at 7:58 AM
To: Reza Rokui <[email-masked]<mailto:[email-masked]>>, Kiran Makhijani <[email-masked]<mailto:[email-masked]>>, Shunsuke Homma <[email-masked]<mailto:[email-masked]>>, Jari Arkko <[email-masked]<mailto:[email-masked]>>, "[email-masked]<mailto:[email-masked]>" <[email-masked]<mailto:[email-masked]>>
Subject: RE: New Version Notification for draft-nsdt-teas-transport-slice-definition-00.txt

Reza,

--
Eric

From: Teas-ns-dt <[email-masked]<mailto:[email-masked]>> On Behalf Of Rokui, Reza (Nokia - CA/Ottawa)
Sent: Sunday, November 3, 2019 10:21 AM
To: Kiran Makhijani <[email-masked]<mailto:[email-masked]>>; Shunsuke Homma <[email-masked]<mailto:[email-masked]>>; Jari Arkko <[email-masked]<mailto:[email-masked]>>; [email-masked]<mailto:[email-masked]>
Cc: Rokui, Reza (Nokia - CA/Ottawa) <[email-masked]<mailto:[email-masked]>>
Subject: [Teas-ns-dt] FW: New Version Notification for draft-nsdt-teas-transport-slice-definition-00.txt

All,

Cheers,

Reza

    IETF repository.

    Revision:  00

    Pages:           15

    Abstract:

    The IETF Secretariat

---

From: "Rokui, Reza (Nokia - CA/Ottawa)" <[email-masked]>
Date: Wed, 13 Nov 2019 01:43:58 +0000

Eric,

I also referred to the word document which was attached to your email. I have your emai.
I update the draft-00 and send it for review. I will also update the word and send it to you.

Reza

From: Eric Gray <[email-masked]>
Date: Wednesday, November 13, 2019 at 8:17 AM
To: Reza Rokui <[email-masked]>, Kiran Makhijani <[email-masked]>, Shunsuke Homma <[email-masked]>, Jari Arkko <[email-masked]>, "[email-masked]" <[email-masked]>
Subject: RE: New Version Notification for draft-nsdt-teas-transport-slice-definition-00.txt

Reza,

--
Eric

Eric,

Reza

Reza,

--
Eric

All,

Cheers,

Reza

    IETF repository.

    Revision:  00

    Pages:           15

    Abstract:

    The IETF Secretariat

---

From: Eric Gray <[email-masked]>
Date: Wed, 13 Nov 2019 01:52:59 +0000

Reza,

              Thanks.

              Typically, in other IETF work I have been involved in, the draft authors/editors would list the comments in some form and say something about how they will be (or are) addressed.

              Updating the draft and asking people to review it to see if their comments are addressed is something of a less review-friendly approach.

              This is very much less review friendly if the folks on the design team have to send the draft out for review by the relevant experts – especially if there are multiple disciplines involved (as in this case).

--
Eric

From: Rokui, Reza (Nokia - CA/Ottawa) <[email-masked]>
Sent: Tuesday, November 12, 2019 8:44 PM
To: Eric Gray <[email-masked]>; Kiran Makhijani <[email-masked]>; Shunsuke Homma <[email-masked]>; Jari Arkko <[email-masked]>; [email-masked]
Subject: Re: New Version Notification for draft-nsdt-teas-transport-slice-definition-00.txt
Importance: High

Eric,

Reza

Reza,

--
Eric

From: Rokui, Reza (Nokia - CA/Ottawa) <[email-masked]<mailto:[email-masked]>>
Sent: Tuesday, November 12, 2019 8:09 PM
To: Eric Gray <[email-masked]<mailto:[email-masked]>>; Kiran Makhijani <[email-masked]<mailto:[email-masked]>>; Shunsuke Homma <[email-masked]<mailto:[email-masked]>>; Jari Arkko <[email-masked]<mailto:[email-masked]>>; [email-masked]<mailto:[email-masked]>
Cc: Rokui, Reza (Nokia - CA/Ottawa) <[email-masked]<mailto:[email-masked]>>
Subject: Re: New Version Notification for draft-nsdt-teas-transport-slice-definition-00.txt
Importance: High

Eric,

Reza

Reza,

--
Eric

All,

Cheers,

Reza

    IETF repository.

    Revision:  00

    Pages:           15

    Abstract:

    The IETF Secretariat

---

From: Uma Chunduri <[email-masked]>
Date: Wed, 13 Nov 2019 12:14:21 -0800

Hi Reza,

Thanks for the 00 document put forth. This is useful.

I recently joined this list and missed the original document where Eric's
comments/feedback was given (I did see the archive, but couldn't find it) .
It would be nice to share the same and respond what has been addressed (if
any).

Cheers!

--
Uma C.

On Tue, Nov 12, 2019 at 5:53 PM Eric Gray <eric.gray=
[email-masked]> wrote:

> Reza,
>
>
>
>               Thanks.
>
>
>
>               Typically, in other IETF work I have been involved in, the
> draft authors/editors would list the comments in some form and say
> something about how they will be (or are) addressed.
>
>
>
>               Updating the draft and asking people to review it to see if
> their comments are addressed is something of a less review-friendly
> approach.
>
>
>
>               This is very much less review friendly if the folks on the
> design team have to send the draft out for review by the relevant experts –
> especially if there are multiple disciplines involved (as in this case).
>
>
>
> --
>
> Eric
>
>
>
> *From:* Rokui, Reza (Nokia - CA/Ottawa) <[email-masked]>
> *Sent:* Tuesday, November 12, 2019 8:44 PM
> *To:* Eric Gray <[email-masked]>; Kiran Makhijani <
> [email-masked]>; Shunsuke Homma <[email-masked]>;
> Jari Arkko <[email-masked]>; [email-masked]
> *Subject:* Re: New Version Notification for
> draft-nsdt-teas-transport-slice-definition-00.txt
> *Importance:* High
>
>
>
> Eric,
>
>
>
> *From: *Eric Gray <[email-masked]>
> *Date: *Wednesday, November 13, 2019 at 8:17 AM
> *To: *Reza Rokui <[email-masked]>, Kiran Makhijani <
> [email-masked]>, Shunsuke Homma <[email-masked]>,
> Jari Arkko <[email-masked]>, "[email-masked]" <
> [email-masked]>
> *Subject: *RE: New Version Notification for
> draft-nsdt-teas-transport-slice-definition-00.txt
>
>
>
> Reza,
>
>
>
> The word document was what you had shared with us earlier, asking for
> comments.  Most of my comments are actually in the word document itself,
> with only the general comments in the E-Mail itself.
>
>
>
> If you need me to forward the earlier E-Mail – so that you can see the
> comments in the Word document – please let me know.
>
>
>
> By the way, perhaps you should not be in such a rush to produce a new
> version for everyone to review that you don’t actually get around to the
> comments from their last review.
>
>
>
> --
>
> Eric
>
>
>
> *From:* Rokui, Reza (Nokia - CA/Ottawa) <[email-masked]>
> *Sent:* Tuesday, November 12, 2019 8:09 PM
> *To:* Eric Gray <[email-masked]>; Kiran Makhijani <
> [email-masked]>; Shunsuke Homma <[email-masked]>;
> Jari Arkko <[email-masked]>; [email-masked]
> *Cc:* Rokui, Reza (Nokia - CA/Ottawa) <[email-masked]>
> *Subject:* Re: New Version Notification for
> draft-nsdt-teas-transport-slice-definition-00.txt
> *Importance:* High
>
>
>
> Eric,
>
>
>
> Since your previous comments were based on the word document not the draft
> itself, I will address them in the updated draft and send you the new one.
>
>
>
> Reza
>
>
>
>
>
>
>
>
>
> *From: *Eric Gray <[email-masked]>
> *Date: *Wednesday, November 13, 2019 at 7:58 AM
> *To: *Reza Rokui <[email-masked]>, Kiran Makhijani <
> [email-masked]>, Shunsuke Homma <[email-masked]>,
> Jari Arkko <[email-masked]>, "[email-masked]" <
> [email-masked]>
> *Subject: *RE: New Version Notification for
> draft-nsdt-teas-transport-slice-definition-00.txt
>
>
>
> Reza,
>
>
>
>               Is there any way that you could provide some description of
> how the comments were addressed, as opposed to the statement that they were?
>
>
>
> --
>
> Eric
>
>
>
> *From:* Teas-ns-dt <[email-masked]> *On Behalf Of *Rokui,
> Reza (Nokia - CA/Ottawa)
> *Sent:* Sunday, November 3, 2019 10:21 AM
> *To:* Kiran Makhijani <[email-masked]>; Shunsuke Homma <
> [email-masked]>; Jari Arkko <[email-masked]>;
> [email-masked]
> *Cc:* Rokui, Reza (Nokia - CA/Ottawa) <[email-masked]>
> *Subject:* [Teas-ns-dt] FW: New Version Notification for
> draft-nsdt-teas-transport-slice-definition-00.txt
>
>
>
> All,
>
>
>
> As per our discussion during the network slicing DT meeting on Oct 31, the
> first version of draft "*IETF Definition of Transport Slice"* has been
> submitted. Authors have incorporated the comments.
>
>     URL:
> https://www.ietf.org/internet-drafts/draft-nsdt-teas-transport-slice-definition-00.txt
>
>     Status:
> https://datatracker.ietf.org/doc/draft-nsdt-teas-transport-slice-definition/
>
>     Htmlized:
> https://tools.ietf.org/html/draft-nsdt-teas-transport-slice-definition-00
>
>     Htmlized:
> https://datatracker.ietf.org/doc/html/draft-nsdt-teas-transport-slice-definition
>
>
>
>
>
>     Abstract:
>
> Teas-ns-dt mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/teas-ns-dt
>

---

From: "Rokui, Reza (Nokia - CA/Ottawa)" <[email-masked]>
Date: Thu, 14 Nov 2019 01:03:18 +0000

Sure Uma. I will share them in next couple of days.
It will be nice to see you in person next week.

Cheers,
Reza

From: Uma Chunduri <[email-masked]>
Date: Thursday, November 14, 2019 at 3:14 AM
To: Eric Gray <eric.gray=[email-masked]>
Cc: Reza Rokui <[email-masked]>, Kiran Makhijani <[email-masked]>, Shunsuke Homma <[email-masked]>, Jari Arkko <[email-masked]>, "[email-masked]" <[email-masked]>
Subject: Re: [Teas-ns-dt] New Version Notification for draft-nsdt-teas-transport-slice-definition-00.txt

Hi Reza,

I recently joined this list and missed the original document where Eric's comments/feedback was given (I did see the archive, but couldn't find it) . It would be nice to share the same and respond what has been addressed (if any).

Cheers!

--
Uma C.

On Tue, Nov 12, 2019 at 5:53 PM Eric Gray <eric.gray=[email-masked]<mailto:[email-masked]>> wrote:
Reza,

              Thanks.

--
Eric

Eric,

Reza

Reza,

--
Eric

Eric,

Reza

Reza,

--
Eric

All,

Cheers,

Reza

    IETF repository.

    Revision:  00

    Pages:           15

    Abstract:

    until the htmlized version and diff are available at tools.ietf.org<http://tools.ietf.org>.

    The IETF Secretariat

--
Teas-ns-dt mailing list
[email-masked]<mailto:[email-masked]>
https://www.ietf.org/mailman/listinfo/teas-ns-dt

---

From: Eric Gray <[email-masked]>
Date: Fri, 15 Nov 2019 01:27:12 +0000

Draft authors,

Some comments on the -00 version of this ID are provided below.

As a couple of general observations:

  1.  This is a specification – hence precision is very important.
  2.  If you would like to use “transport slice” to mean “transport network slice” – you need to explicitly say that.

Major comments:

Minor comments:

The “Abstract” is awkward; I suggest rewording along the following lines…
    “This document provides a definition of transport network slicing in IETF, and describes
      considerations for realization of transport network slices.”

Justification: Definitions are typically not “described” (a description lists characteristics of a thing).  We should not refer to the design team’s role in writing this draft in the Abstract (note – the last sentence of the Abstract is deliberately omitted in the text I suggest for replacing the Abstract).  While we don’t usually include who is doing the work associated with a draft in the Abstract, the point to this effort is to define “transport network slices” (or “slicing”), not “transport slices.”  Also, I have already said that we should not conflate “implementation” with “realization.”

The first paragraph in the Introduction attempts to “define” network slicing.  In doing so, it is missing a lot.  I suggest replacing the entire paragraph (sans bullets) with:

    “Network slicing is a phrase that can be used to generically describe virtualization
      of network resources.  This phrase, therefore, is considered very useful by many
      people (and for many applications) because of the need to describe generically a
      diversity of services and related resource requirements that can then be applied to
      any of a number of proposed, implemented or deployed technology and associated
      devices.

    “Some key applications which might benefit from the use of network slicing include:”

<The bullet list provided is fine, with “NIT” exception listed below, but could include other applications.>

Justification:  The attraction for many in the use of the phrase “network slicing” is that it avoids including technology specifics that are pre-associated with existing technology approaches used for virtual networking, and associated terms/phrases/acronyms.  In a single phrase (“network slicing”) we include every technology that might be used to provide virtual networks (unlike VPN, VLAN, any of the many forms of traffic multiplexing, etc.).

Because “network slicing” can be used to generically describe any form of network virtualization, it naturally includes any form of traffic “separation,” “priority,” “differentiated services,” specialized queuing behaviors, etc. – that might be included in any technology that supports virtualization of networks.

Replace the last sentence in the Introduction (as proposed for the Abstract) with the following:
    “This document provides a definition of transport network slicing in IETF, and describes
      considerations for realization of transport network slices.”

In addition to the many NITs with the first sentence (mentioned below) of the first paragraph of section 2, it is a subjective statement that the network shown in figure 1 is “typical.”  It is a use case example that we want to include, but there may be many actual deployments that are simpler.

Figure 1 makes no reference to “operator-Y.”

In addition, it is very difficult to parse the second sentence in the first paragraph of section 2.  A network necessarily includes multiple nodes (not one or more).  The opening phrase ends with a preposition (“of”).  It is not at all clear that you are trying to include network functions, PNFs (?) and VNFs (?) as examples of “nodes” – if that is what you are trying to do.  I assume that PNF = physical network function, and VNF = virtual network function – but the sentence is too busy to just stick that in here.  And the phrase “which have various capabilities and technologies such as” does not seem to have enough value to be worth complicating the sentence.

The node examples are a mixed bag and it is not clear why this set provides a reasonable set of examples for the technologies already listed.

Also, you add in “aka” in several places, apparently with the meaning “includes.”  That is not what AKA means (it is the acronym for “also known as” – and you use this in cases where equivalency is not the case); as far as I am aware, there is no English word “aka” and – if there is – I don’t think it means “includes.”

I would suggest replacing the first two paragraphs (including the bullets in between) with the following:
   “To illustrate the IETF definitions of both E2E network slice and transport network slice,
     consider the network shown in Figure 1, where a network operator has an E2E network
     slice that traverses multiple technology-specific networks.

    “Each of these networks might use any of a number of technologies, including IP, MPLS,
      Fiber-Optics (e.g. – WDM, DWDM), Passive Optical Networking (PON), Microwave, etc.

    “Each of these networks also includes multiple (physical or virtual) nodes and might provide
      network functions beyond simply carrying of technology-specific protocol data units.

    “The types of nodes used in any of these networks may include:

  *   Packet Switches (e.g. – Routers, Bridges)
  *   Application servers
  *   Firewalls
  *   Radio Access Network (RAN) components
  *   Microwave transceivers
  *   Optical repeaters
  *   etc.

    “Each node in the network might support multiple technologies among those listed above.”

    “As an example combination of networks:”

<Again, the bullet list provided is fine, with “NIT” exception listed below>

In the second sentence after Figure 1, the adjectives “separate” and “independent” are ambiguous and add no value.  They should be omitted.

In the second paragraph after Figure 1, the second and third sentences are not consistent with each other.  An E2E slice is associated [with] “a customer” (singular), yet there is only a single E2E context between the two users EU-x and EU-y.  What are you trying to say?

Also, in the same paragraph, you still are abusing the acronym “SLA.”  Reword the afflicted sentence as:
    “… with a resource requirement for bandwidth greater than 10Mbps.”

Note that this appears to make the probably unreasonable assumption that the connection in this example from each CCTV camera to a central collection/observation facility is something that the operator can provide as a fully-connected hub and spoke network.  But the example is extremely ambiguous, because it is as likely to be interpreted as a fully-connected mesh network.

Whatever the use case really is, it is likely that the actual requirement is for some minimum bandwidth to be available for carrying video signal from a CCTV to some recording and/or observation facility – however that might be provided by the operator.

NITs:
In Introduction, first bullet “slicig” --> “slicing”
Second paragraph, “parts such as” --> “parts, such as”
Same paragraph, “established on” --> “established for”
Last paragraph in introduction (if not replaced as suggested above),

  *   “transport slice” --> “a transport network slice”
  *   “from IETF aspect” --> “from an IETF perspective,” (include the comma)
  *   “on their realization” --> “for transport network slice realization” (“their” is ambiguous)

In section 2, “illustrate” (or “depict”) would be better than “demonstrate” and it looks like there are two things being defined, hence “definition” should probably be plural – also you need to use either “an” or “the” in front of “IETF.”

In the bullet list toward the bottom of page 3, why are the numbered networks not listed in order?

In Figure 1, “Legends” --> “Legend” and “End-2-end” --> “End-to-end” – also, do we need to add EU-y?

In the first sentence after Figure 1, the Figure does not identify the operator; also in the text around the figure, it is not clear that there is any implication that there is more than one operator – hence a label is not needed.

In the second sentence after the figure, “its” is ambiguous – replace with “the operator’s.”  And “for specific service” --> “for a specific service.”

First sentence of the second paragraph after Figure 1, omit “As shown” at the beginning of the sentence, “logical” --> “logically” and “i ndependent” --> “independent.”

Second sentence, same paragraph – “associated to” --> “associated with”

Last paragraph on page 4, “associate to” --> “associated with”

I have other things I need to do, in spite of the importance of this work, so I will have to stop at the end of page 4.  I took a quick look and it seems to me that I had made a number of other comments using the Word version – which, if addressed, will likely clear up a number of the remaining issues with this document.

---

From: "Rokui, Reza (Nokia - CA/Ottawa)" <[email-masked]>
Date: Fri, 15 Nov 2019 22:48:04 +0000

Eric,

First off, I would like to thank you for your thorough review of our draft. Your comments are greatly appreciated.

I have included all of your comments in a single word document along with our responses. See attached document. The updated version of the draft will be submitted soon. Please see review our responses and we can discuss them further f2f this week.

Cheers,

Reza

From: Eric Gray <[email-masked]>
Date: Friday, November 15, 2019 at 8:27 AM
To: Reza Rokui <[email-masked]>, Kiran Makhijani <[email-masked]>, Shunsuke Homma <[email-masked]>, Jari Arkko <[email-masked]>
Cc: "[email-masked]" <[email-masked]>
Subject: RE: New Version Notification for draft-nsdt-teas-transport-slice-definition-00.txt

Draft authors,

Major comments:

Minor comments:

NITs:

---

From: Jari Arkko <[email-masked]>
Date: Sun, 17 Nov 2019 08:07:17 +0000

Thanks for the discussion.

I reviewed the definition again today, and have some comments/suggestions.

First off, there’s overall quite a bit of material in the draft overall. Sometimes it is useful to nail down a concept in few words familiar to networking geeks even outside the mobile network space, and leave examples and use cases and mapping to interesting other things (such as 5G) to other documents. That might benefit understanding from others… we can talk about how we want to convey the final definitions once we’re done.

Secondly, I’d still love to polish the compactness of the definition a bit, to base it on fundamental concept. How about this:

OLD:

A Transport Slice is an abstract network topology connecting different network functions (NFs) with appropriate isolation and a specific Service Level Agreement (SLA) described in terms of shared or dedicated network resources. In other words, a transport slice is a group of connections that connect various NFs in the network to achieve some specific SLA for a customer as shown in Figure-2.

NEW:

A Transport Slice is an abstract network topology connecting different network functions (NFs) with a specific Service Level Agreement (SLA) described in terms of expected network service. The SLA can include characteristics such as guaranteed bandwidth or latency, requirements on the use of physically separate equipment, etc.

Jari

---

From: Eric Gray <[email-masked]>
Date: Mon, 18 Nov 2019 11:02:08 +0000

The biggest issue I have with the use of SLA is that – from my understanding of the work in the IETF to date – the concept of a “service level agreement” is quite foreign.  It represents a contract for a service between a service provider and a service consumer (or subscriber).

We could spend quite a lot of time – time better used in other (more IETF-relevant) pursuits – on the finer details of this sort of contractual arrangement.

From the perspective of the folks who are defining both the technology, and its control, what we are more likely to be concerned with is the parameters that make up the relevant service details – not the instrument that gives both a subscriber and a provider legal recourse to recover perceived damages as a result of a failure to provide working technology and controls.

From: Teas-ns-dt <[email-masked]> On Behalf Of Jari Arkko
Sent: Sunday, November 17, 2019 3:07 AM
To: Rokui, Reza (Nokia - CA/Ottawa) <[email-masked]>
Cc: [email-masked]
Subject: Re: [Teas-ns-dt] New Version Notification for draft-nsdt-teas-transport-slice-definition-00.txt

OLD:

NEW:

Jari

---

From: Eric Gray <[email-masked]>
Date: Tue, 19 Nov 2019 18:18:27 +0000

On reflection, following the meeting of the other day, I don’t dislike Jeff’s suggestion to use “SLO.”

It seems that the “level” part comes from the fact that the term is meant to include the measurable performance parameters part of an SLA (in other words, not the part of an SLA that I was arguing is irrelevant to the work we might do in the IETF).

SLO is tied to SLA.  I think a number of people were looking for that.

I don’t exactly love it either, because there is no requirement that a transport slice must actually be a discrete business agreement, rather than a set of service parameters required of the transport slice to meet the end to end SLO.

Which makes using SLO a reasonable compromise.  😊

From: Teas-ns-dt <[email-masked]> On Behalf Of Eric Gray
Sent: Monday, November 18, 2019 6:02 AM
To: Jari Arkko <jari.arkko=[email-masked]>; Rokui, Reza (Nokia - CA/Ottawa) <[email-masked]>
Cc: [email-masked]
Subject: Re: [Teas-ns-dt] New Version Notification for draft-nsdt-teas-transport-slice-definition-00.txt

From: Teas-ns-dt <[email-masked]<mailto:[email-masked]>> On Behalf Of Jari Arkko
Sent: Sunday, November 17, 2019 3:07 AM
To: Rokui, Reza (Nokia - CA/Ottawa) <[email-masked]<mailto:[email-masked]>>
Cc: [email-masked]<mailto:[email-masked]>
Subject: Re: [Teas-ns-dt] New Version Notification for draft-nsdt-teas-transport-slice-definition-00.txt

OLD:

NEW:

Jari