Subject: [Teas-ns-dt] Isolation text in appendix of definition draft

From: Eric Gray <[email-masked]>
Date: Thu, 25 Jun 2020 16:19:31 +0000

Folks,

I had a plan to suggest for this text, but I think there was not overwhelming interest in moving this to the Framework draft.  Plus we ran out of time.

If we were going to move it, my suggestion was to add a new subsection in the Framework draft under the current section 2 (Transport Slice Objectives) - probably with the heading "2.1 Isolation" that includes the agreed text from the current appendix in the definition draft.  In the definition draft, we would then remove the appendix entirely, and add a new paragraph to current section 4.1.2 (Other Objectives) that says "Also, isolation objectives (see [I-D.nsdt-teas-ns-framework] for more information) may also be necessary to meet some Transport Slice requests."

I have a very slight issue with leaving an appendix in the definitions draft, because it may leave some readers with the impression that this is an open issue.  But I am essentially okay if we decide to leave it as is.  I would suggest - if we do that - that we add a similar new paragraph to section 4.1.2 that points to the appendix.

--
Eric

---

From: Kiran Makhijani <[email-masked]>
Date: Thu, 25 Jun 2020 16:23:58 +0000

Hi Eric,
If you don’t mind I can work with you to bringing it in framework and I anyway intended to glue the orphaned Appendix to Realization section but 4.1.2 is also a good place.

Regards
Kiran

________________________________
From: Teas-ns-dt <[email-masked]> on behalf of Eric Gray <eric.gray=[email-masked]>
Sent: Thursday, June 25, 2020 9:19:31 AM
To: [email-masked] <[email-masked]>
Subject: [Teas-ns-dt] Isolation text in appendix of definition draft

Folks,

If we were going to move it, my suggestion was to add a new subsection in the Framework draft under the current section 2 (Transport Slice Objectives) – probably with the heading “2.1 Isolation” that includes the agreed text from the current appendix in the definition draft.  In the definition draft, we would then remove the appendix entirely, and add a new paragraph to current section 4.1.2 (Other Objectives) that says “Also, isolation objectives (see [I-D.nsdt-teas-ns-framework] for more information) may also be necessary to meet some Transport Slice requests.”

I have a very slight issue with leaving an appendix in the definitions draft, because it may leave some readers with the impression that this is an open issue.  But I am essentially okay if we decide to leave it as is.  I would suggest – if we do that – that we add a similar new paragraph to section 4.1.2 that points to the appendix.

--

Eric

---

From: "Dongjie (Jimmy)" <[email-masked]>
Date: Sun, 28 Jun 2020 03:27:34 +0000

Hi Eric, Kiran and all,

For the definition draft I tend to agree to move the isolation text from appendix to the subsection "other objectives". Depending on whether "other objectives" can be considered as part of the SLO characteristics, the "other objectives" subsection may also be listed as a subsection in parallel with section 4.1 "SLO characteristics", e.g. make it subsection 4.2?

As for the framework draft, I'm willing to work on the description about this. Also note that section 2 of framework draft refers to the requirement section of the enhanced VPN framework, in which isolation is further described.

Best regards,
Jie

From: Teas-ns-dt [mailto:[email-masked]] On Behalf Of Kiran Makhijani
Sent: Friday, June 26, 2020 12:24 AM
To: Eric Gray <eric.gray=[email-masked]>; [email-masked]
Subject: Re: [Teas-ns-dt] Isolation text in appendix of definition draft

Hi Eric,
If you don't mind I can work with you to bringing it in framework and I anyway intended to glue the orphaned Appendix to Realization section but 4.1.2 is also a good place.

Regards
Kiran

________________________________
From: Teas-ns-dt <[email-masked]<mailto:[email-masked]>> on behalf of Eric Gray <eric.gray=[email-masked]<mailto:eric.gray=[email-masked]>>
Sent: Thursday, June 25, 2020 9:19:31 AM
To: [email-masked]<mailto:[email-masked]> <[email-masked]<mailto:[email-masked]>>
Subject: [Teas-ns-dt] Isolation text in appendix of definition draft

Folks,

--

Eric

---

From: Eric Gray <[email-masked]>
Date: Mon, 29 Jun 2020 13:01:28 +0000

Jie,

              Clearly this represents a strong potential misunderstanding of what was being discussed.

              Nobody was discussing moving the text in the definitions appendix to section 4.1.2.  For a number of us, that would be a step backwards and away from convergence on the content for the draft.

              What is being discussed is whether or not to move the text in the definitions draft appendix to the Framework draft (specifically to section 2, in a new subsection 2.1).

              Where the confusion may have come up is that we (Kiran and I) discussed - whether or not we move the text in the appendix - we should add a _reference_ to it (where ever it ends up) in section 4.1.2 ("Other Objectives").

              Hope that clears things up...

--
Eric

From: Teas-ns-dt <[email-masked]> On Behalf Of Dongjie (Jimmy)
Sent: Saturday, June 27, 2020 11:28 PM
To: Kiran Makhijani <[email-masked]>; Eric Gray <eric.gray=[email-masked]>; [email-masked]
Subject: Re: [Teas-ns-dt] Isolation text in appendix of definition draft

Hi Eric, Kiran and all,

Best regards,
Jie

From: Teas-ns-dt [mailto:[email-masked]] On Behalf Of Kiran Makhijani
Sent: Friday, June 26, 2020 12:24 AM
To: Eric Gray <eric.gray=[email-masked]<mailto:eric.gray=[email-masked]>>; [email-masked]<mailto:[email-masked]>
Subject: Re: [Teas-ns-dt] Isolation text in appendix of definition draft

Hi Eric,

Regards
Kiran

Folks,

--

Eric