Subject: Re: [Teas-ns-dt] REMINDER: TEAS NS design team Thursday call

From: Jari Arkko <[email-masked]>
Date: Thu, 11 Jun 2020 16:11:19 +0000

Notes from today: 
https://github.com/teas-wg/teas-ns-dt/blob/master/notes/notes-2020-06-11.md

Jari

---

From: Shunsuke Homma <[email-masked]>
Date: Fri, 12 Jun 2020 12:15:11 +0900

Hi all,

I uploaded copy of the latest Google Docs as below:
https://github.com/teas-wg/teas-ns-dt/blob/master/definitions/12062020-googledocs-draft-nsdt-teas-transport-slice-definition.docx

Best regards,

Shunsuke

2020年6月12日(金) 1:11 Jari Arkko <jari.arkko=[email-masked]>:

> --
> Teas-ns-dt mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/teas-ns-dt
>

---

From: Eric Gray <[email-masked]>
Date: Fri, 12 Jun 2020 14:12:36 +0000

Shunsuke,

              Thanks!  I will use this draft as a starting point in making suggestions about a small set of proposed changes, including (mostly) how to deal with the subject of “isolation” based on the discussion in yesterday’s meeting.

              At a high-level, my understanding of what is required is that we need to agree on the text to be left in the definitions draft on the topic of isolation – which should be mostly a reference to the text to be included in the framework draft.  At the same time, I will obviously have to propose the text that we will be adding to the framework draft (that the definitions draft would refer to) that describes the dimensions of “isolation” that we have discussed as part of the background to be considered in subsequent specification (of the TSC NBI, for instance).

              Just to reiterate, this is necessary primarily because the definitions draft needs to restrict itself to providing just the set of definitions on which we can all agree (while making it clear that further definitions and explanation may be provided separately).

--
Eric

From: Teas-ns-dt <[email-masked]> On Behalf Of Shunsuke Homma
Sent: Thursday, June 11, 2020 11:15 PM
To: Jari Arkko <jari.arkko=[email-masked]>
Cc: [email-masked]
Subject: Re: [Teas-ns-dt] REMINDER: TEAS NS design team Thursday call

Hi all,

I uploaded copy of the latest Google Docs as below:
https://github.com/teas-wg/teas-ns-dt/blob/master/definitions/12062020-googledocs-draft-nsdt-teas-transport-slice-definition.docx<https://protect2.fireeye.com/v1/url?k=d5433500-8be39bcd-d543759b-86073b36ea28-459d27a8d3d299e9&q=1&e=b0b472a7-eedd-45e9-baae-86ec0ca969b7&u=https%3A%2F%2Fgithub.com%2Fteas-wg%2Fteas-ns-dt%2Fblob%2Fmaster%2Fdefinitions%2F12062020-googledocs-draft-nsdt-teas-transport-slice-definition.docx>

Best regards,

Shunsuke

2020年6月12日(金) 1:11 Jari Arkko <jari.arkko=[email-masked]<mailto:[email-masked]>>:
Notes from today:
https://github.com/teas-wg/teas-ns-dt/blob/master/notes/notes-2020-06-11.md<https://protect2.fireeye.com/v1/url?k=61b3eeba-3f134077-61b3ae21-86073b36ea28-44e39db047a90225&q=1&e=b0b472a7-eedd-45e9-baae-86ec0ca969b7&u=https%3A%2F%2Fgithub.com%2Fteas-wg%2Fteas-ns-dt%2Fblob%2Fmaster%2Fnotes%2Fnotes-2020-06-11.md>

Jari

--
Teas-ns-dt mailing list
[email-masked]<mailto:[email-masked]>
https://www.ietf.org/mailman/listinfo/teas-ns-dt

---

From: Eric Gray <[email-masked]>
Date: Fri, 12 Jun 2020 16:09:17 +0000

Shunsuke, et al,

              To illustrate the type of issue that comes up without effective issues tracking, the latest Word version (of the Google-Doc version – posted by Shunsuke) includes an annotation from Luis that says “I propose to substitute all of this by the text in my email.”

            I believe that “this” refers to the entirety of section 10.1 (Appendix A) on pages 16 and 17 – based on the highlighting of the text selected in making the annotation.  What I cannot determine is if the highlighted text is from before or after Luis’ substitution – and this is made worse by the fact that I don’t seem to have received any mail from Luis that provides the substitution text.

            This is a very substantive amount of text, on a highly controversial topic.  With respect to this text, Jari had raised an issue that this text is no longer consistent with the preceding content of the draft (which is obviously the case, given that it self-describes as “further discussion” of a topic that has not been discussed at this point in the draft) and suggests that the entire Appendix could be removed as a quicker way to gain consensus.

            Also, while it is difficult to be sure, I don’t think that the highlighted text in this version is the same text we were looking at during the meeting yesterday.

            I need to discover what the case is because it is the text that was in this section that I believe we were talking about relocating to the framework draft and I need to be sure that this is that text.

--
Eric

From: Eric Gray
Sent: Friday, June 12, 2020 10:13 AM
To: Shunsuke Homma <[email-masked]>; Jari Arkko <jari.arkko=[email-masked]>
Cc: [email-masked]
Subject: RE: [Teas-ns-dt] REMINDER: TEAS NS design team Thursday call

Shunsuke,

--
Eric

From: Teas-ns-dt <[email-masked]<mailto:[email-masked]>> On Behalf Of Shunsuke Homma
Sent: Thursday, June 11, 2020 11:15 PM
To: Jari Arkko <jari.arkko=[email-masked]<mailto:jari.arkko=[email-masked]>>
Cc: [email-masked]<mailto:[email-masked]>
Subject: Re: [Teas-ns-dt] REMINDER: TEAS NS design team Thursday call

Hi all,

Best regards,

Shunsuke

Jari

---

From: Shunsuke Homma <[email-masked]>
Date: Sun, 14 Jun 2020 00:39:37 +0900

Hi Eric,

Sorry for confusing you...

The editing team has internal email threads, and the email from Luis is one
in a thread.  Before I proposed to use google docs, editors mainly used
email  and xml for discussion and update, and the google docs was derived
from xml at that time.

As you guess, the comment of Luis refers to the entirety of the appendix,
and I assume that the appendix text  has not been modified. (In my memory,
the text was provided by Kiran with following Jari's advice.)

Also, you are correct, what was discussed relocation in the last meeting is
this appendix. As Reza mentioned, unfortunately the latest is xml on  NS-DT
github, and this google docs has not been synced yet. In the latest text, a
subsection about "level of confidence" is added in the appendix.
# I suggested to discuss on google docs before reflecting changes on xml,
but some editors seem preferring  to use xml...

> other editors
If there is something wrong, please point it.

Regards,

Shunsuke

2020年6月13日(土) 1:09 Eric Gray <[email-masked]>:

> Shunsuke, et al,
>
>
>
>               To illustrate the type of issue that comes up without
> effective issues tracking, the latest Word version (of the Google-Doc
> version – posted by Shunsuke) includes an annotation from Luis that says “I
> propose to substitute all of this by the text in my email.”
>
>
>
>             I believe that “this” refers to the entirety of section 10.1
> (Appendix A) on pages 16 and 17 – based on the highlighting of the text
> selected in making the annotation.  What I cannot determine is if the
> highlighted text is from before or after Luis’ substitution – and this is
> made worse by the fact that I don’t seem to have received any mail from
> Luis that provides the substitution text.
>
>
>
>             This is a very substantive amount of text, on a highly
> controversial topic.  With respect to this text, Jari had raised an issue
> that this text is no longer consistent with the preceding content of the
> draft (which is obviously the case, given that it self-describes as
> “further discussion” of a topic that has not been discussed at this point
> in the draft) and suggests that the entire Appendix could be removed as a
> quicker way to gain consensus.
>
>
>
>             Also, while it is difficult to be sure, I don’t think that the
> highlighted text in this version is the same text we were looking at during
> the meeting yesterday.
>
>
>
>             I need to discover what the case is because it is the text
> that was in this section that I believe we were talking about relocating to
> the framework draft and I need to be sure that this is that text.
>
>
>
> --
>
> Eric
>
>
>
> *From:* Eric Gray
> *Sent:* Friday, June 12, 2020 10:13 AM
> *To:* Shunsuke Homma <[email-masked]>; Jari Arkko <jari.arkko=
> [email-masked]>
> *Cc:* [email-masked]
> *Subject:* RE: [Teas-ns-dt] REMINDER: TEAS NS design team Thursday call
>
>
>
> Shunsuke,
>
>
>
>               Thanks!  I will use this draft as a starting point in making
> suggestions about a small set of proposed changes, including (mostly) how
> to deal with the subject of “isolation” based on the discussion in
> yesterday’s meeting.
>
>
>
>               At a high-level, my understanding of what is required is
> that we need to agree on the text to be left in the definitions draft on
> the topic of isolation – which should be mostly a reference to the text to
> be included in the framework draft.  At the same time, I will obviously
> have to propose the text that we will be adding to the framework draft
> (that the definitions draft would refer to) that describes the dimensions
> of “isolation” that we have discussed as part of the background to be
> considered in subsequent specification (of the TSC NBI, for instance).
>
>
>
>               Just to reiterate, this is necessary primarily because the
> definitions draft needs to restrict itself to providing just the set of
> definitions on which we can all agree (while making it clear that further
> definitions and explanation may be provided separately).
>
>
>
> --
>
> Eric
>
>
>
> *From:* Teas-ns-dt <[email-masked]> *On Behalf Of *Shunsuke
> Homma
> *Sent:* Thursday, June 11, 2020 11:15 PM
> *To:* Jari Arkko <jari.arkko=[email-masked]>
> *Cc:* [email-masked]
> *Subject:* Re: [Teas-ns-dt] REMINDER: TEAS NS design team Thursday call
>
>
>
> Hi all,
>
>
>
> <https://protect2.fireeye.com/v1/url?k=d5433500-8be39bcd-d543759b-86073b36ea28-459d27a8d3d299e9&q=1&e=b0b472a7-eedd-45e9-baae-86ec0ca969b7&u=https%3A%2F%2Fgithub.com%2Fteas-wg%2Fteas-ns-dt%2Fblob%2Fmaster%2Fdefinitions%2F12062020-googledocs-draft-nsdt-teas-transport-slice-definition.docx>
>
>
>
> Best regards,
>
>
>
> Shunsuke
>
>
>
>
>
> <https://protect2.fireeye.com/v1/url?k=61b3eeba-3f134077-61b3ae21-86073b36ea28-44e39db047a90225&q=1&e=b0b472a7-eedd-45e9-baae-86ec0ca969b7&u=https%3A%2F%2Fgithub.com%2Fteas-wg%2Fteas-ns-dt%2Fblob%2Fmaster%2Fnotes%2Fnotes-2020-06-11.md>
>
> Jari
>
>
> --
> Teas-ns-dt mailing list
> [email-masked]

---

From: Kiran Makhijani <[email-masked]>
Date: Sun, 14 Jun 2020 22:03:19 +0000

Hi Eric and all,
Preserving comments from one doc format and editing another xml format is not perfect. We will have to work through it.

Along with your comments some additional improvements were also made. That is why the document is a bit inconsistent, we are in the process of fixing it.

I will go back to your earlier comments to check (by EoB Monday) which ones were taken in and also the one we missed.

More importantly, please raise any concerns on parts of the document other than the comments we received from last teas meeting. Do we need to improve other sections or are they ok?
Thanks
Kiran

Regards,
Kiran
________________________________
From: Teas-ns-dt <[email-masked]> on behalf of Shunsuke Homma <[email-masked]>
Sent: Saturday, June 13, 2020 8:39:37 AM
To: Eric Gray <[email-masked]>
Cc: Jari Arkko <jari.arkko=[email-masked]>; [email-masked] <[email-masked]>
Subject: Re: [Teas-ns-dt] REMINDER: TEAS NS design team Thursday call

Hi Eric,

The editing team has internal email threads, and the email from Luis is one in a thread.  Before I proposed to use google docs, editors mainly used email  and xml for discussion and update, and the google docs was derived from xml at that time.

As you guess, the comment of Luis refers to the entirety of the appendix, and I assume that the appendix text  has not been modified. (In my memory, the text was provided by Kiran with following Jari's advice.)

Also, you are correct, what was discussed relocation in the last meeting is this appendix. As Reza mentioned, unfortunately the latest is xml on  NS-DT github, and this google docs has not been synced yet. In the latest text, a subsection about "level of confidence" is added in the appendix.
# I suggested to discuss on google docs before reflecting changes on xml, but some editors seem preferring  to use xml...

Regards,

Shunsuke

2020年6月13日(土) 1:09 Eric Gray <[email-masked]<mailto:[email-masked]>>:

Shunsuke, et al,

--

Eric

From: Eric Gray
Sent: Friday, June 12, 2020 10:13 AM
To: Shunsuke Homma <[email-masked]<mailto:[email-masked]>>; Jari Arkko <jari.arkko=[email-masked]<mailto:[email-masked]>>
Cc: [email-masked]<mailto:[email-masked]>
Subject: RE: [Teas-ns-dt] REMINDER: TEAS NS design team Thursday call

Shunsuke,

--

Eric

Hi all,

https://github..com/teas-wg/teas-ns-dt/blob/master/definitions/12062020-googledocs-draft-nsdt-teas-transport-slice-definition.docx<https://nam11.safelinks.protection.outlook.com/?url=https%3A%2F%2Fprotect2.fireeye.com%2Fv1%2Furl%3Fk%3Dd5433500-8be39bcd-d543759b-86073b36ea28-459d27a8d3d299e9%26q%3D1%26e%3Db0b472a7-eedd-45e9-baae-86ec0ca969b7%26u%3Dhttps%253A%252F%252Fgithub.com%252Fteas-wg%252Fteas-ns-dt%252Fblob%252Fmaster%252Fdefinitions%252F12062020-googledocs-draft-nsdt-teas-transport-slice-definition.docx&data=02%7C01%7Ckiranm%40futurewei.com%7Cd390e6c778ec478f260b08d80fb00500%7C0fee8ff2a3b240189c753a1d5591fedc%7C1%7C0%7C637276595981336062&sdata=545XP%2BBeYDE9sID0w%2F6os4YheyERKnN1KHTlbNQ6Z%2FA%3D&reserved=0>

Best regards,

Shunsuke

Notes from today:
https://github.com/teas-wg/teas-ns-dt/blob/master/notes/notes-2020-06-11.md<https://nam11.safelinks.protection.outlook.com/?url=https%3A%2F%2Fprotect2.fireeye.com%2Fv1%2Furl%3Fk%3D61b3eeba-3f134077-61b3ae21-86073b36ea28-44e39db047a90225%26q%3D1%26e%3Db0b472a7-eedd-45e9-baae-86ec0ca969b7%26u%3Dhttps%253A%252F%252Fgithub.com%252Fteas-wg%252Fteas-ns-dt%252Fblob%252Fmaster%252Fnotes%252Fnotes-2020-06-11.md&data=02%7C01%7Ckiranm%40futurewei.com%7Cd390e6c778ec478f260b08d80fb00500%7C0fee8ff2a3b240189c753a1d5591fedc%7C1%7C0%7C637276595981336062&sdata=p3t%2Fn%2FHvuQ9Bmy2yI%2BONJXDtEd2oS7zoN6aDEUxrlJs%3D&reserved=0>

Jari

--
Teas-ns-dt mailing list
[email-masked]<mailto:[email-masked]>
https://www.ietf.org/mailman/listinfo/teas-ns-dt<https://nam11.safelinks.protection.outlook.com/?url=https%3A%2F%2Fwww.ietf.org%2Fmailman%2Flistinfo%2Fteas-ns-dt&data=02%7C01%7Ckiranm%40futurewei.com%7Cd390e6c778ec478f260b08d80fb00500%7C0fee8ff2a3b240189c753a1d5591fedc%7C1%7C1%7C637276595981346050&sdata=O%2BUPPBT73CpKWmFk8kgIhG8kuCzK7HXDSYK9ts1x58o%3D&reserved=0>