Subject: Re: [Terminology] Client/Server

From: Phillip Hallam-Baker <[email-masked]>
Date: Mon, 1 Mar 2021 15:20:21 -0500

On Sun, Feb 28, 2021 at 3:39 PM Brian E Carpenter <
[email-masked]> wrote:

> On 01-Mar-21 08:03, Phillip Hallam-Baker wrote:
> ...
> > I find it better to use the terms initiator and responder to describe
> session establishment because what is important in that relationship is
> that the responder role is distinguished by the fact that the initiator has
> to discover it.
>
> You are absolutely correct. In the GRASP design we used the terms
> initiator and responder, and counterpart or peer once a negotiation starts.
> Negotiation is essentially a symmetric process, so it's confusing to use
> asymmetric terminology.
>
> This is another case where a human can fix suspect text, but an algorithm
> really can't.
>

Another process question, how do we expect to roll out removal of
problematic terminology?

1) Go through every RFC and replace all those with problematic language.

2) Attempt to fix terminology when new documents are published.

I am pretty sure we are looking at (2) but...

---

From: Brian E Carpenter <[email-masked]>
Date: Tue, 2 Mar 2021 09:53:58 +1300

On 02-Mar-21 09:20, Phillip Hallam-Baker wrote:
> 
> 
> On Sun, Feb 28, 2021 at 3:39 PM Brian E Carpenter <[email-masked] <mailto:[email-masked]>> wrote:
> 
>     > I find it better to use the terms initiator and responder to describe session establishment because what is important in that relationship is that the responder role is distinguished by the fact that the initiator has to discover it.
> 
>     You are absolutely correct. In the GRASP design we used the terms initiator and responder, and counterpart or peer once a negotiation starts. Negotiation is essentially a symmetric process, so it's confusing to use asymmetric terminology.
> 
>     This is another case where a human can fix suspect text, but an algorithm really can't.
> 
> 
> Another process question, how do we expect to roll out removal of problematic terminology?
> 

Never. RFCs are never edited in place; they are the archive. As I already suggested indirectly, we'd have to bowdlerise right back to RFC 1. Not going to happen.

> 2) Attempt to fix terminology when new documents are published.

3) Attempt to fix it *before* new documents are approved. Just part of our normal review process, and should mainly happen in the WG, as early as possible.

   Brian

---

From: Phillip Hallam-Baker <[email-masked]>
Date: Mon, 1 Mar 2021 16:14:02 -0500

On Mon, Mar 1, 2021 at 3:54 PM Brian E Carpenter <
[email-masked]> wrote:

> [email-masked] <mailto:[email-masked]>> wrote:
> >
> >     > I find it better to use the terms initiator and responder to
> describe session establishment because what is important in that
> relationship is that the responder role is distinguished by the fact that
> the initiator has to discover it.
> >
> Never. RFCs are never edited in place; they are the archive. As I already
> suggested indirectly, we'd have to bowdlerise right back to RFC 1. Not
> going to happen.
>

Wasn't suggesting changing the old RFCs, people might expect us to issue a
brand new one... I think that would be a bad idea particularly for
protocols like NNTP which at this point are really not worth fixin'

> 3) Attempt to fix it *before* new documents are approved. Just part of our
> normal review process, and should mainly happen in the WG, as early as
> possible.
>

With the understanding this is likely to be caught by GenART review if
people don't take note.

I am iffy about adding it to the ID nits tool because crypto has a
pre-existing set of characters, Alice, Bob, etc. which are very much
gendered so we don't want to flag he/she as a nit

Can catch terms like Master/Slave but these may be used in reference to
other specs and in particular to back references.

---

From: "Salz, Rich" <[email-masked]>
Date: Mon, 1 Mar 2021 21:24:08 +0000

>    Never. RFCs are never edited in place; they are the archive. As I already suggested indirectly, we'd have to bowdlerise right back to RFC 1. Not going to happen.

I think the term Bowdlerized (or ised, whatever) is bad.  The original work was intended to make things "more appropriate than the original" for 19th century women and children.  Is there a dictionary you can point to that doesn't include the concept of simplification, distorting, or weakening the original in its definition?

---

From: "Rodney W. Grimes" <[email-masked]>
Date: Tue, 2 Mar 2021 05:49:10 -0800 (PST)

> 3) Attempt to fix it *before* new documents are approved. Just part of our normal review process, and should mainly happen in the WG, as early as possible.

IMHO, the ulitimate goal for when bad terminology gets corrected is
before it is ever submitted, aka BEFORE the document goes to a WG
by providing guidance to authors on TERMinology.

Having an authors work mangled by the WG because of bad terminolgy
could be construid/warped/twisted into exclusive/non-inclusive
behavior.

-- 
Rod Grimes                                                 [email-masked]

---

From: "Rodney W. Grimes" <[email-masked]>
Date: Tue, 2 Mar 2021 06:02:33 -0800 (PST)

> gendered so we don't want to flag he/she as a nit

Actually, again IMHO, he/she should already be a nit, these are words
that can lead to mistaken understanding as it is not possible to know
exactly which "he" or "she" they may refer to if there is more than
one possiblity:
	Bob and Mike went to the grocery store, Mike was busy looking
at soda, while Bob headed to the backery isle.  He found a nice bargin.

Which "he" does that refer to ?  These are SO easy to fix, as they
almost always resolve to a deterministic named entity and though
repeatitive make the prose exact.

> other specs and in particular to back references.

Another caustion here is if you replace old words with new words it
is possible that the new words start to take on the same stigma
that the old words had.  I have not seen any discussion on this
matter, and it would probably take a good etymologist to find
some existing cases.

Simply put in 20 years primary may carry the same stigma as master :-(
Though I do not agree the word master itself carries the stigma,
it is the context in which it is used that leads to issues.

---

From: Brian E Carpenter <[email-masked]>
Date: Wed, 3 Mar 2021 09:00:51 +1300

> I think the term Bowdlerized (or ised, whatever) is bad.  The original work was intended to make things "more appropriate than the original" for 19th century women and children.  Is there a diction…

I looked in my grandfather's 1920 edition of Webster and found this: "To expurgate, as a book, by omitting or modifying parts considered indelicate or offensive." 

Merriam-Webster online has:
"1 literature : to expurgate (something, such as a book) by omitting or modifying parts considered vulgar
2 : to modify by abridging, simplifying, or distorting in style or content"

I suggest that in 1818 when Bowdler published his Shakespeare, and apparently still in 1920, simplification and distortion were not really part of the meaning. What this illustrates is what others have said: the secondary or implied meanings of words change over time.

I didn't use the word in sense 2. But indeed, there's a risk that changes made on principle or automatically can distort meaning.

    Brian