Subject: Re: [Terminology] WG Review: Effective Terminology in IETF Documents (term)

From: Carsten Bormann <[email-masked]>
Date: Tue, 6 Apr 2021 07:03:55 +0200

On 6. Apr 2021, at 06:08, John C Klensin <[email-masked]> wrote:
> 
> establish specific directions

Wikipedia has a category of content called “original research” (which is ruled out in Wikipedia articles).
This was established to keep a lid on what is best described as “crackpot science”.
It is now a more general guideline that sometimes gets in the way (2 * 2 = 4 is not really “original research”), but overall has served Wikipedia well.
It seems to me the current charter proposal text is trying to go into a similar direction, which might help a lot with keeping rough consensus attainable.
(And, of course, promptly it is attempted to weaken those guide rails...)

Grüße, Carsten

---

From: Jari Arkko <[email-masked]>
Date: Tue, 6 Apr 2021 23:00:37 +0300

> It seems to me the current charter proposal text is trying to go into a similar direction, which might help a lot with keeping rough consensus attainable.

I agree.

For what it is worth, I’m supportive of creating this working group. Of course it is only one effort among many things — most of them technical — and the terminology questions are one concern among dozens or hundreds of other issues. Internet has many issues. This doesn’t mean we shouldn’t address these questions or the other issues.

I believe the right way to approach this particular issue in the IETF is largely at the grass root level and focusing on improvements more than mandates. That is, we do useful things at the working groups and by individuals who should decide what they need to do with their documents; they are the experts, they own the problem space, etc. In some cases good terms can be found that are better and more descriptive than some previously used terms; we should opt to use those. And, change is a long-term process. I can maybe have an effect on the terminology in the next iteration of my working group’s spec. Or perhaps only the next protocol.

The above doesn’t mean the IETF shouldn't keep this issue in mind, or that no working group is needed. As (for instance) draft-gondwana-effective-terminology put it, “engineering takes priority; decentralised control; centralized knowledge”. I would be happy for us to state something like that, and keep pointing to resources where WGs can look up various best practices regarding terminology.

I think the proposed charter is doing largely what I describe above. A very minimal approach. Although perhaps it could say more clearly that the WGs are in charge and that whatever the proposed WG produces is advisory in nature. I do believe however that over time, WGs will adopt useful improvements.

Jari