Subject: Re: [Terminology] WG Review: Effective Terminology in IETF Documents (term)

From: Carsten Bormann <[email-masked]>
Date: Mon, 5 Apr 2021 16:26:44 +0200

Sorry I didn’t pay attention to this discussion yet.
I don’t think the IETF should become creative in what terminology it wants to shun.
The proposed charter text was exactly right as it was.

Grüße, Carsten

> On 2021-03-30, at 22:55, Mallory Knodel <[email-masked]> wrote:
> 
> Sure, change this sentence:
> 
> The WG will identify and recommend an external, independently-updated resource containing examples of potentially problematic terms and potential alternatives to IETF participants, in order to align its efforts with broader activities by the technology industry.
> 
> To:
> 
> The WG will identify and recommend language resources on inclusive terminology and potential alternatives to problematic terms to IETF participants, in order to align its efforts with broader activities by the technology industry.
> 
> Best,
> -Mallory
> 
> On Monday, March 29, 2021, Lars Eggert <[email-masked]> wrote:
> Hi Mallory,
> 
> thanks for the feedback!
> 
> On 2021-3-26, at 19:11, Mallory Knodel <[email-masked]> wrote:
> > 2) Acknowledge that in some cases it will make sense for the IETF to be the authority on certain terminology as it relates to the IETF mandate, whereas others will need to be external given the mandates of other bodies. In other words, I don't think the IETF should abdicate all of its responsibility for setting standards with the best terminology, as it sees fit.
> 
> Could you make a suggestion for what text changes you'd like to see to address this?
> 
> Thanks,
> Lars
> 
> 
> 
> -- 
> Mallory Knodel
> CTO, Center for Democracy and Technology
> gpg fingerprint :: E3EB 63E0 65A3 B240 BCD9 B071 0C32 A271 BD3C C780
> 
>

---

From: Mallory Knodel <[email-masked]>
Date: Mon, 5 Apr 2021 10:34:57 -0400

I removed restrictions to the text. Your point about IETF creativity on 
these terms may be right 99% of the time, and suggest that this be a 
major consideration whenever recommendations are made. But to restrict 
the charter at this stage seems like it would be unhelpful possibly in 
the future.

-Mallory

---

From: Carsten Bormann <[email-masked]>
Date: Mon, 5 Apr 2021 16:40:32 +0200

On 2021-04-05, at 16:34, Mallory Knodel <[email-masked]> wrote:
> 
> I removed restrictions to the text. Your point about IETF creativity on these terms may be right 99% of the time, and suggest that this be a major consideration whenever recommendations are made. But to restrict the charter at this stage seems like it would be unhelpful possibly in the future.

Hi Mallory,

the whole point of the charter is to restrict the WG.

The main reason for putting in a restriction in a charter is to save the WG some time discussing something that they shouldn’t be doing anyway.

If it actually ever turns out we do need to get creative, we can always recharter.

(The other restriction is the number of external resources, and I agree 1 may ultimately be too restrictive.  But this should not become a shopping list either, because as an author I need a single resource or a *very* small pool of resources I can rely on.)

Grüße, Carsten

---

From: Mallory Knodel <[email-masked]>
Date: Mon, 5 Apr 2021 10:44:45 -0400

> The main reason for putting in a restriction in a charter is to save the WG some time discussing something that they shouldn’t be doing anyway.
The metric is there-- to be in alignment with the industry. That's the 
part that matters.
> If it actually ever turns out we do need to get creative, we can always recharter.

It's just not necessary to create this hurdle. Leave out the word 
"external" and it's simpler for the people doing the work.

-Mallory

---

From: Carsten Bormann <[email-masked]>
Date: Mon, 5 Apr 2021 16:57:38 +0200

On 2021-04-05, at 16:44, Mallory Knodel <[email-masked]> wrote:
> 
> It's just not necessary to create this hurdle. Leave out the word "external" and it's simpler for the people doing the work.

I think we can agree to disagree here.
As I have said in other venues before, I positively, strongly don’t want the WG to do *that* work, so making that clear in the charter tremendously will simplify doing its actual work.

Grüße, Carsten

---

From: Eliot Lear <[email-masked]>
Date: Tue, 6 Apr 2021 07:01:53 +0200

The whole point of that text, as far as I am concerned, was to keep engineers from trying to get into language games, for which not one of us is equipped to properly answer.  If anything, to me the original text isn’t restrictive enough, because almost nobody else in the industry is properly equipped to answer the question being asked.  The compromise is that we have one, and not multiple, arguments about which list to use.  Perhaps we can even find one or two people who know what they are talking about when they create such a thing.

Eliot

> On 5 Apr 2021, at 16:34, Mallory Knodel <[email-masked]> wrote:
> 
> Terminology mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/terminology

---

From: Mallory Knodel <[email-masked]>
Date: Tue, 6 Apr 2021 08:52:43 -0400

Hi,

On 4/6/21 1:01 AM, Eliot Lear wrote:
> The whole point of that text, as far as I am concerned, was to keep 
> engineers from trying to get into language games, for which not one of 
> us is equipped to properly answer.  If anything, to me the original 
> text isn’t restrictive enough, because almost nobody else in the 
> industry is properly equipped to answer the question being asked. 
>  The compromise is that we have *one*, and not *multiple*, arguments 
> about which list to use.  Perhaps we can even find one or two people 
> who know what they are talking about when they create such a thing.
>
>> On 5 Apr 2021, at 16:34, Mallory Knodel <[email-masked] 
>> <mailto:[email-masked]>> wrote:
>>
>> I removed restrictions to the text. Your point about IETF creativity 
>> on these terms may be right 99% of the time, and suggest that this be 
>> a major consideration whenever recommendations are made. But to 
>> restrict the charter at this stage seems like it would be unhelpful 
>> possibly in the future.
>>

I don't see why the IETF shouldn't demonstrate leadership, where needed. 
In the case of the draft Niels and I wrote, we didn't come up with those 
arguments or the term pairs and their replacements. Other people did 
that. But what we did was coalesce research and draw conclusions in the 
form of arguments tailored to the IETF. Is that external?

See also: https://github.com/ietf/terminology

This is really useful, even if it might eventually prove to be 
duplicative effort. In the beginning, it was the right step because as 
an exercise it demonstrated scale to the IETF audience. Other groups are 
doing the same thing, but it's not always clear what will emerge in 
perpetuity (independently updated). Something like the Inclusive Naming 
Initiative cites our draft, so is that objectionably self-referential?

It is the TERM group who should be grappling with these questions 
through it's /work/, not the wider group's discussion of the charter.

-Mallory

>>>
>>>
>>>> On 2021-03-30, at 22:55, Mallory Knodel <[email-masked] 
>>>> <mailto:[email-masked]>> wrote:
>>>>
>>>> The WG will identify and recommend an external, 
>>>> independently-updated resource containing examples of potentially 
>>>> problematic terms and potential alternatives to IETF participants, 
>>>> in order to align its efforts with broader activities by the 
>>>> technology industry.
>>>>
>>>> To:
>>>>
>>>> The WG will identify and recommend language resources on inclusive 
>>>> terminology and potential alternatives to problematic terms to IETF 
>>>> participants, in order to align its efforts with broader activities 
>>>> by the technology industry.
>>>>
>>>> Best,
>>>> -Mallory
>>>>
>>>> On Monday, March 29, 2021, Lars Eggert <[email-masked] 
>>>> <mailto:[email-masked]>> wrote:
>>>> Hi Mallory,
>>>>
>>>> thanks for the feedback!
>>>>
>>>> On 2021-3-26, at 19:11, Mallory Knodel <[email-masked] 
>>>> <mailto:[email-masked]>> wrote:
>>>>> 2) Acknowledge that in some cases it will make sense for the IETF 
>>>>> to be the authority on certain terminology as it relates to the 
>>>>> IETF mandate, whereas others will need to be external given the 
>>>>> mandates of other bodies. In other words, I don't think the IETF 
>>>>> should abdicate all of its responsibility for setting standards 
>>>>> with the best terminology, as it sees fit.
>> [email-masked] <mailto:[email-masked]>

---

From: Eliot Lear <[email-masked]>
Date: Tue, 6 Apr 2021 16:12:52 +0200

Hi,

As the IETF we are supposed to be speaking as individuals, but in this case, because Cisco’s name is mentioned in an external reference, I feel the need to make that explicit: I speak only for myself here, and for nobody else.  Please see below.

> On 6 Apr 2021, at 14:52, Mallory Knodel <[email-masked]> wrote:
> 
> Hi,
> 
>>> On 5 Apr 2021, at 16:34, Mallory Knodel <[email-masked] <mailto:[email-masked]>> wrote:
>>> 
> I don't see why the IETF shouldn't demonstrate leadership, where needed. In the case of the draft Niels and I wrote, we didn't come up with those arguments or the term pairs and their replacements. Other people did that. But what we did was coalesce research and draw conclusions in the form of arguments tailored to the IETF. Is that external?
> 
Mallory, you have to ask yourself: how many anthropological linguists, professional philosophers, and sociologists do we really have in the IETF to review such work?

If that sounds like a punt… it is.  But in the meantime, we can suffer through with some actionable advice.  But that means not having a lengthy treatise on the value of different lists.
> See also: https://github.com/ietf/terminology <https://github.com/ietf/terminology>
> This is really useful, even if it might eventually prove to be duplicative effort. In the beginning, it was the right step because as an exercise it demonstrated scale to the IETF audience. Other groups are doing the same thing, but it's not always clear what will emerge in perpetuity (independently updated). Something like the Inclusive Naming Initiative cites our draft, so is that objectionably self-referential?
> 
> 

Is it objectionably self-referential?  I don’t know.  If the basis for their decision is the basis for our decision is the basis for their decision, I suppose it would be.  Mostly that hasn’t been my concern, tho.  What I have seen is a lot of the industry pointing to your draft, something that we are ill equipped to review.

Returning to the charter, choosing one list will be hard enough for the WG to accomplish.   And establishing the well-studied and researched principles the charter mentions will also be difficult.  The best we do is to articulate some lay principles, as Bron did.  If anyone on the IESG doubts that, please imagine  how you would apply the expertise that brought you to your position to scrutinize language usage.

In summary, Carsten is right: the less original work we do here, the better.

On the other hand, the INI might provide a locus to attract the sort of professionals I mentioned.  I’d like that because there are some big name companies who might fund some research.  Who knows?  [Again, speaking only for myself here.]

Eliot

---

From: "Bron Gondwana" <[email-masked]>
Date: Wed, 07 Apr 2021 23:31:38 +1000

On Wed, Apr 7, 2021, at 00:12, Eliot Lear wrote:
> [not on behalf of Cisco]

> 
> Is it *objectionably* self-referential?  I don’t know.  If the basis for their decision is the basis for our decision is the basis for their decision, I suppose it would be.  Mostly that hasn’t been my concern, tho.  What I have seen is a lot of the industry pointing to your draft, something that we are ill equipped to review.

It's definitely self-referential, and my personal opinion is that the whole language debate across the tech industry is objectionably self referential and most of the evidence just references other efforts rather than underlying data  - BUT, that may not be disqualifying in this case.

When I did my science degree I learned "the plural of anecdote is not data", but anecdote has re-branded as "lived experience" which is a much more evocative name than the archaic "anecdote", and you don't even need to pluralise it to reach capital-T Truth which is much more powerful than the old fashioned "data".

This is a problem in sciences that interact with the observable world, because it both expands from one's experience to a general experience for all, and also takes the observed symptoms and elevates a presumed cause for those symptoms as if said cause had also been observed and measured rather than merely guessed or pattern matched.  The failure mode here when the presumptions of cause don't match actual cause is that the model drifts away from reality - the map no longer matches the terrain, if you will - and science becomes less effective when that happens.

Having said that - terminology lives in a landscape which is not objective and measurable.  The response to language is an entirely human phenomenon which exists in the realm of perception - and perception is based on pre-conceptions, which are built on previous experience.  So if enough people believe something to be offensive and damaging, then it is prima-facie offensive, purely because people believe it to be so.

You can measure in a point in time, but you can also morph the system in a somewhat unbounded way when it comes to offensive words, because new words become offensive all the time, purely through their use as offensive words.

So a self-referential process can live in the language landscape, because it's a closed system.  If we says so, then it is so, and if it is so, so it is.

Regards,

Bron.

--
  Bron Gondwana, CEO, Fastmail Pty Ltd
  [email-masked]

---

From: Corinne Cath <[email-masked]>
Date: Wed, 7 Apr 2021 16:56:57 +0300

[snip]

Mallory, you have to ask yourself: how many anthropological linguists,
> professional philosophers, and sociologists do we really have in the IETF
> to review such work?
>
> At least one: 🙋‍♀️ and I have some experience with writing about the
effects of language and culture in the IETF-- but if you see options for
companies to support more such qualitative researchers to help out with
these efforts, that would be a step forward.

https://hackcur.io/whats-wrong-with-loud-men-talking-loudly-the-ietfs-culture-wars/

> If that sounds like a punt… it is.  But in the meantime, we can suffer
> through with some actionable advice.  But that means not having a lengthy
> treatise on the value of different lists.
>
> This is really useful, even if it might eventually prove to be duplicative
> effort. In the beginning, it was the right step because as an exercise it
> demonstrated scale to the IETF audience. Other groups are doing the same
> thing, but it's not always clear what will emerge in perpetuity
> (independently updated). Something like the Inclusive Naming Initiative
> cites our draft, so is that objectionably self-referential?
>
>
> Is it *objectionably* self-referential?  I don’t know.  If the basis for
> their decision is the basis for our decision is the basis for their
> decision, I suppose it would be.  Mostly that hasn’t been my concern, tho.
> What I have seen is a lot of the industry pointing to your draft, something
> that we are ill equipped to review.
>
> Returning to the charter, choosing one list will be hard enough for the WG
> to accomplish.   And establishing the well-studied and researched
> principles the charter mentions will also be difficult.  The best we do is
> to articulate some lay principles, as Bron did.  If anyone on the IESG
> doubts that, please imagine  how you would apply the expertise that brought
> you to your position to scrutinize language usage.
>
> On the other hand, the INI might provide a locus to attract the sort of
> professionals I mentioned.  I’d like that because there are some big name
> companies who might fund some research.  Who knows?  [Again, speaking only
> for myself here.]
>
> Eliot
>
> --
> Terminology mailing list
> [email-masked]

-- 
Corinne Cath - Speth
Ph.D. Candidate, Oxford Internet Institute & Alan Turing Institute

Web: www.oii.ox.ac.uk/people/corinne-cath
Email: [email-masked] & [email-masked]
Twitter: @C_CS