Subject: [Tls-reg-review] Request to register value in TLS Certificate Types

From: Mounira Msahli <[email-masked]>
Date: Wed, 7 Nov 2018 05:20:14 +0100 (CET)

Dear Sir, 

We would like to reserve one value for new certificates types to extend TLS protocol. In fact, we already published an IETF draft : 
https://tools.ietf.org/html/draft-tls-certieee1609-02
We describe the extension of TLS to support one new certificate type:IEEE/ETSI certificate. 
We would like to assign the value 3 for IEEE/ETSI certificate. 
Our assignment concerns Transport Layer Security (TLS) Extensions and specially TLS Certificate Types. 

Best regards 
Mounira MSAHLI

---

From: "Amanda Baber via RT" <[email-masked]>
Date: Wed, 07 Nov 2018 18:26:41 +0000

Dear TLS experts,

If you want to copy IANA on your messages about this request, please include the string [IANA #1130014] in the subject line.

Alternatively, we could close this ticket and wait for a new message from an expert upon approval.

If this is approved, please let us know how to mark the "Recommended" column.

Best regards,

Amanda Baber
Lead IANA Services Specialist

On Wed Nov 07 04:20:52 2018, [email-masked] wrote:
> 
> Dear Sir,
> 
> 
> We would like to reserve one value for new certificates types to
> extend TLS protocol. In fact, we already published an IETF draft :

---

From: "Salz, Rich" <[email-masked]>
Date: Thu, 8 Nov 2018 00:11:02 +0000

I am in favor of giving them a certificate type number, and NOT recommended.

---

From: Yoav Nir <[email-masked]>
Date: Thu, 8 Nov 2018 08:53:29 +0700

+1

> On 8 Nov 2018, at 7:11, Salz, Rich <[email-masked]> wrote:
> 
> _______________________________________________
> tls-reg-review mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/tls-reg-review

---

From: Nick Sullivan <[email-masked]>
Date: Thu, 8 Nov 2018 08:59:31 +0700

Agreed.

---

From: Yoav Nir <[email-masked]>
Date: Thu, 8 Nov 2018 09:04:28 +0700

Then we’re unanimous. 

Amanda: please proceed with the assignment.

Thanks,

Yoav

> On 8 Nov 2018, at 8:59, Nick Sullivan <[email-masked]> wrote:
> 
> Agreed.
> 
> On Thu, Nov 8, 2018 at 8:53 AM Yoav Nir <[email-masked] <mailto:[email-masked]>> wrote:
> +1
> 
> > On 8 Nov 2018, at 7:11, Salz, Rich <[email-masked] <mailto:[email-masked]>> wrote:
> > 
> > [email-masked] <mailto:[email-masked]>
> > https://www.ietf.org/mailman/listinfo/tls-reg-review <https://www.ietf.org/mailman/listinfo/tls-reg-review>
> 
> [email-masked] <mailto:[email-masked]>
> https://www.ietf.org/mailman/listinfo/tls-reg-review <https://www.ietf.org/mailman/listinfo/tls-reg-review>

---

From: "Amanda Baber via RT" <[email-masked]>
Date: Thu, 08 Nov 2018 19:31:25 +0000

Dear Mounira,

In accordance with instructions from the reviewers, we've added the following entry to the TLS Certificate Types registry:

Value: 3
Extension Name: 1609Dot2
Recommended: N
Reference: [draft-tls-certieee1609]

https://www.iana.org/assignments/tls-extensiontype-values

We'll update the reference when the IESG notifies us that they've approved the document and when the RFC Editor notifies us that they've assigned an RFC number.

Best regards,

Amanda Baber

---

From: Mounira Msahli <[email-masked]>
Date: Fri, 9 Nov 2018 05:56:21 +0100 (CET)

Dear all, 

Thank you very much for your quick reaction. 

Kind Regards 
Mounira MSAHLI

----- Mail original -----
De: "iana-prot-param" <[email-masked]>
À: "Mounira Msahli" <[email-masked]>
Cc: "tls-reg-review" <[email-masked]>
Envoyé: Jeudi 8 Novembre 2018 20:31:25
Objet: [IANA #1130014] Request to register value in TLS Certificate Types

Dear Mounira, 

Value: 3 
Extension Name: 1609Dot2 
Recommended: N 

Best regards, 

Amanda Baber