Subject: Re: [Tls-reg-review] [IANA #1141082] Fwd: Early code-point assignment request for draft-ietf-tls-dtls-connection-id

From: Joseph Salowey <[email-masked]>
Date: Thu, 23 May 2019 09:21:01 -0700

I haven't seen the messages appear in the tls-reg-review archives so I'm
cc'ing them on this email to see if its stuck somewhere.   The version of
draft that I am preparing to send to the IESG is here
https://tools.ietf.org/html/draft-ietf-tls-dtls-connection-id-05.  The
authors have requested early code point assignment and that requires expert
approval.

Thanks,

Joe

On Thu, May 23, 2019 at 8:09 AM Sabrina Tanamal via RT <[email-masked]>
wrote:

> Hi Joe,
>
> We've sent this request to the experts at [email-masked] on 8
> May 2019, and we pinged them again yesterday. We haven't heard back from
> the experts regarding this request, could you let us know if you still
> don't see it in the archives?
>
> Thank you,
> Sabrina
>
> On Thu May 23 05:27:22 2019, [email-masked] wrote:
> > Hi Sabrina,
> >
> > Am I supposed to ask the experts for a review or will IANA initiate
> > this?
> > I don't think I've seen a request for review appear in the archives
> > for the
> > [email-masked] yet.
> >
> > Thanks,
> >
> > Joe
> >
> > On Wed, May 8, 2019 at 2:54 PM Sabrina Tanamal via RT <iana-
> > [email-masked]>
> > wrote:
> >
> > > Hi Joe,
> > >
> > > We can make the ContentType registration in Section 8 now, but we
> > > need to
> > > ask you how to fill in the "DTLS-OK" column.
> > >
> > > Because the registration procedure for the ExtensionType Values is
> > > Specification Required, we need to ask the designated experts to
> > > review and
> > > approve the ExtensionType Value registration before we can make an
> > > early
> > > allocation.
> > >
> > > Thanks,
> > >
> > > Sabrina Tanamal
> > > Senior IANA Services Specialist
> > >
> > > On Wed May 08 14:25:55 2019, [email-masked] wrote:
> > > > Hi Michelle,
> > > >
> > > > Yes, this is a request for both.
> > > >
> > > > Thanks,
> > > >
> > > > Joe
> > > >
> > > > On Wed, May 8, 2019 at 6:51 AM Michelle Cotton via RT <
> > > [email-masked]>
> > > > wrote:
> > > >
> > > > > Hello Joe,
> > > > >
> > > > > Apologies for the delay in my response.  I hope you are doing
> > > > > well.
> > > > >
> > > > > Quick question for your request below.  In the document there are
> > > > > 2
> > > > > requests for parameter registrations.  Are you requesting early
> > > allocation
> > > > > for both?
> > > > >
> > > > > Thanks in advance.
> > > > >
> > > > > --Michelle
> > > > >
> > > > > On Tue Apr 23 04:51:06 2019, [email-masked] wrote:
> > > > > > Hi IANA,
> > > > > >
> > > > > > We have received a request for  early code point assignment for
> > > > > > draft-ietf-tls-dtls-connection-id-04.  The chairs believe that
> > > > > > the
> > > draft
> > > > > is
> > > > > > stable.  Our AD, Ben also approves this early assignment.
> > > > > > Please
> > > let me
> > > > > > know if you need more information or have any questions.
> > > > > >
> > > > > > Thanks,
> > > > > >
> > > > > > Joe
> > > > > >
> > > > > > ---------- Forwarded message ---------
> > > > > > From: Benjamin Kaduk <[email-masked]>
> > > > > > Date: Fri, Apr 19, 2019 at 7:12 PM
> > > > > > Subject: Re: Early code-point assignment request for
> > > > > > draft-ietf-tls-dtls-connection-id
> > > > > > To: Joseph Salowey <[email-masked]>
> > > > > > Cc: tls-chairs <[email-masked]>, <[email-masked]>
> > > > > >
> > > > > >
> > > > > > On Sun, Apr 14, 2019 at 10:32:00PM -0700, Joseph Salowey wrote:
> > > > > > > Hi Ben,
> > > > > > >
> > > > > > > We have a request for early code point assignment
> > > > > > > for draft-ietf-tls-dtls-connection-id.  We believe the draft
> > > > > > > is
> > > stable
> > > > > and
> > > > > > > no one has objected to the early code point announcement on
> > > > > > > the
> > > list.
> > > > > > >
> > > > > > > Let me know if you have any questions or need more
> > > > > > > information.
> > > > > >
> > > > > > I'm happy to see this go forward.
> > > > > > (You will send the actual request to IANA, not me, right?)
> > > > > >
> > > > > > Thanks, and sorry for the slow response,
> > > > > >
> > > > > > Ben
> > > > >
> > > > >
> > >
> > >
>
>

---

From: "Salz, Rich" <[email-masked]>
Date: Thu, 23 May 2019 16:35:20 +0000

I don’t recall seeing this until now.  Explicitly copying Yoav and Nick.

I’m one of three and I support this.   Does this work?
                Value 53
                TLS 1.3 –
                Recommended Y
                RFC TBD

From: Joseph Salowey <[email-masked]>
Date: Thursday, May 23, 2019 at 12:23 PM
To: "[email-masked]" <[email-masked]>, "[email-masked]" <[email-masked]>
Cc: Benjamin Kaduk <[email-masked]>, "[email-masked]" <[email-masked]>
Subject: Re: [Tls-reg-review] [IANA #1141082] Fwd: Early code-point assignment request for draft-ietf-tls-dtls-connection-id

I haven't seen the messages appear in the tls-reg-review archives so I'm cc'ing them on this email to see if its stuck somewhere.   The version of draft that I am preparing to send to the IESG is here https://tools.ietf.org/html/draft-ietf-tls-dtls-connection-id-05<https://urldefense.proofpoint.com/v2/url?u=https-3A__tools.ietf.org_html_draft-2Dietf-2Dtls-2Ddtls-2Dconnection-2Did-2D05&d=DwMFaQ&c=96ZbZZcaMF4w0F4jpN6LZg&r=4LM0GbR0h9Fvx86FtsKI-w&m=AFFRssmLkZuplUd1HVENEAI4HsfgSfv353Ivwszsxwc&s=6AXFN925MRdSclV8uo2RFkWtrlWPoTZdLcXbR6fzS8g&e=>.  The authors have requested early code point assignment and that requires expert approval.

Thanks,

Joe

On Thu, May 23, 2019 at 8:09 AM Sabrina Tanamal via RT <[email-masked]<mailto:[email-masked]>> wrote:
Hi Joe,

We've sent this request to the experts at [email-masked]<mailto:[email-masked]> on 8 May 2019, and we pinged them again yesterday. We haven't heard back from the experts regarding this request, could you let us know if you still don't see it in the archives?

Thank you,
Sabrina

On Thu May 23 05:27:22 2019, [email-masked]<mailto:[email-masked]> wrote:
> [email-masked]<mailto:[email-masked]> yet.
>
> Thanks,
>
> Joe
>
> [email-masked]<mailto:[email-masked]>>
> wrote:
>
> > Hi Joe,
> >
> > On Wed May 08 14:25:55 2019, [email-masked]<mailto:[email-masked]> wrote:
> > > Hi Michelle,
> > >
> > [email-masked]<mailto:[email-masked]>>
> > > wrote:
> > >
> > > > Hello Joe,
> > > >
> > > > On Tue Apr 23 04:51:06 2019, [email-masked]<mailto:[email-masked]> wrote:
> > > > > Hi IANA,
> > > > >
> > > > > From: Benjamin Kaduk <[email-masked]<mailto:[email-masked]>>
> > > > > To: Joseph Salowey <[email-masked]<mailto:[email-masked]>>
> > > > > Cc: tls-chairs <[email-masked]<mailto:[email-masked]>>, <[email-masked]<mailto:[email-masked]>>
> > > > >
> > > > >

---

From: Nick Sullivan <[email-masked]>
Date: Thu, 23 May 2019 10:59:46 -0700

This sounds good to me. However, there doesn't seem to be a way to indicate
that this extension is for DTLS only and not TLS. I don't think that's an
issue, but I'm interested to hear if anyone else has an objection.

On Thu, May 23, 2019 at 9:35 AM Salz, Rich <[email-masked]> wrote:

> *From: *Joseph Salowey <[email-masked]>
> *Date: *Thursday, May 23, 2019 at 12:23 PM
> *To: *"[email-masked]" <[email-masked]>, "
> [email-masked]" <[email-masked]>
> *Cc: *Benjamin Kaduk <[email-masked]>, "[email-masked]" <
> [email-masked]>
> *Subject: *Re: [Tls-reg-review] [IANA #1141082] Fwd: Early code-point
> assignment request for draft-ietf-tls-dtls-connection-id
>
>
>
> https://tools.ietf.org/html/draft-ietf-tls-dtls-connection-id-05
> <https://urldefense.proofpoint.com/v2/url?u=https-3A__tools.ietf.org_html_draft-2Dietf-2Dtls-2Ddtls-2Dconnection-2Did-2D05&d=DwMFaQ&c=96ZbZZcaMF4w0F4jpN6LZg&r=4LM0GbR0h9Fvx86FtsKI-w&m=AFFRssmLkZuplUd1HVENEAI4HsfgSfv353Ivwszsxwc&s=6AXFN925MRdSclV8uo2RFkWtrlWPoTZdLcXbR6fzS8g&e=>.
> The authors have requested early code point assignment and that requires
> expert approval.
>
>
>
> Thanks,
>
>
>
> Joe
>
>
>
>
>
> On Thu, May 23, 2019 at 8:09 AM Sabrina Tanamal via RT <
> [email-masked]> wrote:
>
> Hi Joe,
>

---

From: "Christopher Wood" <[email-masked]>
Date: Mon, 27 May 2019 11:59:07 -0700

I’ve no strong objections, though erring on the side of clarity is probably best. How difficult would it be to add a field to distinguish between the two?

Best,
Chris

On Thu, May 23, 2019, at 11:00 AM, Nick Sullivan wrote:
> This sounds good to me. However, there doesn't seem to be a way to indicate that this extension is for DTLS only and not TLS. I don't think that's an issue, but I'm interested to hear if anyone else has an objection.
> 
> > __ __
> > I don’t recall seeing this until now. Explicitly copying Yoav and Nick.____
> 
> > __ __
> 
> > I’m one of three and I support this. Does this work?____
> 
> > Value 53____
> 
> > TLS 1.3 –____
> 
> > Recommended Y____
> 
> > RFC TBD____
> 
> > __ __
> 
> > *To: *"[email-masked]" <[email-masked]>, "[email-masked]" <[email-masked]>
> > *Cc: *Benjamin Kaduk <[email-masked]>, "[email-masked]" <[email-masked]>
> > *Subject: *Re: [Tls-reg-review] [IANA #1141082] Fwd: Early code-point assignment request for draft-ietf-tls-dtls-connection-id____
> 
> > __ __
> 
> > I haven't seen the messages appear in the tls-reg-review archives so I'm cc'ing them on this email to see if its stuck somewhere. The version of draft that I am preparing to send to the IESG is here https://tools.ietf.org/html/draft-ietf-tls-dtls-connection-id-05 <https://urldefense.proofpoint.com/v2/url?u=https-3A__tools.ietf.org_html_draft-2Dietf-2Dtls-2Ddtls-2Dconnection-2Did-2D05&d=DwMFaQ&c=96ZbZZcaMF4w0F4jpN6LZg&r=4LM0GbR0h9Fvx86FtsKI-w&m=AFFRssmLkZuplUd1HVENEAI4HsfgSfv353Ivwszsxwc&s=6AXFN925MRdSclV8uo2RFkWtrlWPoTZdLcXbR6fzS8g&e=>. The authors have requested early code point assignment and that requires expert approval. ____
> 
> > __ __
> 
> > Thanks,____
> 
> > __ __
> 
> > Joe____
> 
> > __ __
> 
> > __ __
> 
> > On Thu, May 23, 2019 at 8:09 AM Sabrina Tanamal via RT <[email-masked]> wrote:____
> 
> >> Hi Joe, 
> >> 
> >> We've sent this request to the experts at [email-masked] on 8 May 2019, and we pinged them again yesterday. We haven't heard back from the experts regarding this request, could you let us know if you still don't see it in the archives? 
> >> 
> >> Thank you,
> >> Sabrina
> >> 
> >> > >____