Subject: [Tls-reg-review] [IANA #1152216] Request for Assignment (tls-parameters, draft-yang-tls-tls13-sm-suites)

From: "Amanda Baber via RT" <[email-masked]>
Date: Wed, 18 Sep 2019 22:18:24 +0000

Hi Rich, all,

As it appears that Yoav and Rich have both approved these registrations on the mailing list, should we move ahead with these registrations, with the additional information proposed by Rich? Specifically:

=====

Looking at https://tools.ietf.org/html/draft-yang-tls-tls13-sm-suites-00, the IANA considerations in particular, I suggest the following:

             +-------+-----------------+---------+-----------+
             | Value | Description     | DTLS-OK | Reference |
             +-------+-----------------+---------+-----------+
             |  TBD1 | TLS_SM4_GCM_SM3 | No      | this RFC  |
             |       |                 |         |           |
             |  TBD2 | TLS_SM4_CCM_SM3 | No      | this RFC  |
             +-------+-----------------+---------+-----------+
Update the TLS Cipher Suites table to include
TBD1 is 0x00,0xC6
TBD2 is 0x00,0xC7
Note to the draft authors: This table is missing the “Recommended” column.  It should be filled in with “N”

               +-------+-------------+---------+-----------+
               | Value | Description | DTLS-OK | Reference |
               +-------+-------------+---------+-----------+
               |  TBD3 | sm2sig_sm3  | No      | this RFC  |
               +-------+-------------+---------+-----------+
TBD3 is 0x0708
Note to the draft authors: This table is missing the “Recommended” column. It should be filled in with “N”

        +-------+-------------+---------+-------------+-----------+
        | Value | Description | DTLS-OK | Recommended | Reference |
        +-------+-------------+---------+-------------+-----------+
        |  TBD4 | curveSM2    | No      | No          | this RFC  |
        +-------+-------------+---------+-------------+-----------+
TBD4 is 224
Note to the draft authors: This table should NOT have the “Recommended” column.

=====

I saw that the requester was asked to contact us, but our understanding from RFC 8447 is that registration requests should actually be sent to us by the reviewers (upon approval) rather than the requesters. We do need to contact the list when a draft is up for IESG Approval, if the registrations in the document are still pending expert approval.

thanks,
Amanda

On Wed Sep 18 05:12:47 2019, [email-masked] wrote:
> 
> Contact Name:
> Paul Yang
> 
> Contact Email:
> [email-masked]
> 
> Type of Assignment:
> I request to assign a set of TLS parameters including two TLS cipher
> suites, one signature scheme and one supported group entry.
> 
> Registry:
> Those numbers are assigned in "TLS Cipher Suites", "TLS Supported
> Groups" and "TLS SignatureScheme" registries.
> 
> Description:
> We are trying to standardize the use of Chinese SM algorithms into
> TLSv1.3 and we also need to have an early implementation of the draft
> for a validation purpose, so we need to get those numbers assigned by
> IANA.
> 
> Additional Info:
> The I-D has been submitted to: https://tools.ietf.org/html/draft-yang-
> tls-tls13-sm-suites-00

---

From: "Salz, Rich" <[email-masked]>
Date: Thu, 19 Sep 2019 01:10:35 +0000

I am okay with this, of course :)  I'd like Yoav (or Nick) to sanity-check.

On 9/18/19, 6:18 PM, "Amanda Baber via RT" <[email-masked]> wrote:

    Hi Rich, all,

    =====

    
    =====

    thanks,
    Amanda

---

From: Yoav Nir <[email-masked]>
Date: Thu, 19 Sep 2019 06:48:27 +0300

Looks good to me

> On 19 Sep 2019, at 4:10, Salz, Rich <[email-masked]> wrote:
>

---

From: "Sabrina Tanamal via RT" <[email-masked]>
Date: Mon, 23 Sep 2019 16:48:15 +0000

Hi all, 

We've completed the registrations for draft-yang-tls-tls13-sm-suites. 

TLS Cipher Suites: 

0x00,0xC6	TLS_SM4_GCM_SM3	N	N	[draft-yang-tls-tls13-sm-suites]
0x00,0xC7	TLS_SM4_CCM_SM3	N	N	[draft-yang-tls-tls13-sm-suites]

TLS SignatureScheme: 

0x0708	sm2sig_sm3	N	[draft-yang-tls-tls13-sm-suites]

TLS Supported Groups

41	curveSM2	N	N	[draft-yang-tls-tls13-sm-suites]

Please see
https://www.iana.org/assignments/tls-parameters

Best regards, 

Sabrina Tanamal
Senior IANA Services Specialist

---

From: Paul Yang <[email-masked]>
Date: Tue, 24 Sep 2019 00:53:01 +0800

Wow, many thanks for all the help!

> On Sep 24, 2019, at 12:48 AM, Sabrina Tanamal via RT <[email-masked]> wrote:
> 
> Hi all,
> 

Regards,

Paul Yang