Subject: Re: [Tls-reg-review] [TLS] (offline) Re: Draft for SM cipher suites used in TLS1.3

From: Paul Yang <[email-masked]>
Date: Tue, 10 Sep 2019 00:03:39 +0800

Hi guys

Is there any update on the code points assignment so far? It’s very appreciated if you could assign the numbers, thus we can do some implementations for the draft.

Thanks!

Regards,

Paul Yang

> On Aug 26, 2019, at 12:24 PM, Paul Yang <[email-masked]> wrote:
> 
> Thanks Yoav, so I assume the progress could be moved a bit further now?
> 
>> On Aug 26, 2019, at 3:35 AM, Yoav Nir <[email-masked] <mailto:[email-masked]>> wrote:
>> 
>> It seems fine to me. That’s exactly the way it was with Russian ciphers in the past.
>> 
>>> On 22 Aug 2019, at 19:14, Salz, Rich <[email-masked] <mailto:[email-masked]>> wrote:
>>> 
>>> Can we assign codepoints?  The draft is here: https://tools.ietf.org/id/draft-yang-tls-tls13-sm-suites-00.html <https://tools.ietf.org/id/draft-yang-tls-tls13-sm-suites-00.html>
>>> As you can see from the mail below, they made the SM specs available in English.
>>> 
>>> I don’t want to be the first one to approve this, because Paul is a pal and I helped him through the process, but I will +1 if either of you two folks are okay with it.
>>> 
>>> From: Paul Yang <kaishen.yy=[email-masked] <mailto:kaishen.yy=[email-masked]>>
>>> Date: Thursday, August 22, 2019 at 12:09 PM
>>> To: Uri Blumenthal <[email-masked] <mailto:[email-masked]>>
>>> Cc: "[email-masked] <mailto:[email-masked]>" <[email-masked] <mailto:[email-masked]>>
>>> Subject: Re: [TLS] (offline) Re: Draft for SM cipher suites used in TLS1.3
>>> 
>>> Hi there,
>>> 
>>> Just to keep the it consistent with what previous email said - the Markdown file of the draft has been pushed to the repo:
>>> 
>>> https://github.com/alipay/tls13-sm-spec <https://github.com/alipay/tls13-sm-spec>
>>> 
>>> Please check:
>>> 
>>> https://github.com/alipay/tls13-sm-spec/blob/master/BUILD.md <https://github.com/alipay/tls13-sm-spec/blob/master/BUILD.md>
>>> 
>>> for detailed information.
>>> 
>>> Thanks.
>>> 
>>> 
>>>> On Aug 19, 2019, at 10:57 PM, Blumenthal, Uri - 0553 - MITLL <[email-masked] <mailto:[email-masked]>> wrote:
>>>> 
>>>> >  A side note: we will also upload the Markdown file of this draft into the same git
>>>>         >  repository at https://github.com/alipay/tls13-sm-spec <https://github.com/alipay/tls13-sm-spec> later to make it a totally
>>>>         >  public involved progress.
>>>> 
>>>> I think this is exactly what was needed/asked-for. Thank you!
>>>> 
>>>> 
>>>> 
>>>>> On Aug 19, 2019, at 7:51 PM, Kepeng Li <[email-masked] <mailto:[email-masked]>> wrote:
>>>>> 
>>>>> Currently, we uploaded some of the referenced documents here:
>>>>> https://github.com/alipay/tls13-sm-spec <https://github.com/alipay/tls13-sm-spec>
>>>>> 
>>>>> @Rene, Parts 1 and 3 can be found in the link above.
>>>>> 
>>>>> Hope it helps.
>>>>> 
>>>>> Thanks,
>>>>> 
>>>>> Kind Regards
>>>>> Kepeng
>>>>> 
>>>>>> ------------------------------------------------------------------
>>>>>> 发件人：李克鹏(易深) <[email-masked] <mailto:[email-masked]>>
>>>>>> 发送时间：2019年8月19日(星期一) 17:38
>>>>>> 收件人：sean+ietf <[email-masked] <mailto:[email-masked]>>; joe <[email-masked] <mailto:[email-masked]>>; caw <[email-masked] <mailto:[email-masked]>>
>>>>>> 抄　送：[email-masked] <mailto:[email-masked]> <[email-masked] <mailto:[email-masked]>>; "Blumenthal, Uri - 0553 - MITLL" <[email-masked] <mailto:[email-masked]>>; Paul Yang <kaishen.yy=[email-masked] <mailto:kaishen.yy=[email-masked]>>
>>>>>> 主　题：Re: [TLS] (offline) Re: Draft for SM cipher suites used in TLS1.3
>>>>>> 
>>>>>> Hi WG chairs,
>>>>>> 
>>>>>> Can we place the referenced documents in the TLS WG GitHub?
>>>>>> https://github.com/tlswg <https://github.com/tlswg>
>>>>>> 
>>>>>> According to the discussion below, this can help people to read and understand the referenced specifications.
>>>>>> 
>>>>>> Thanks,
>>>>>> 
>>>>>> Kind Regards
>>>>>> Kepeng
>>>>>> 
>>>>>> 发件人: TLS <[email-masked] <mailto:[email-masked]>> 代表 "Blumenthal, Uri - 0553 - MITLL" <[email-masked] <mailto:[email-masked]>>
>>>>>> 日期: 2019年8月18日 星期日 22:08
>>>>>> 收件人: Paul Yang <kaishen.yy=[email-masked] <mailto:kaishen.yy=[email-masked]>>
>>>>>> 抄送: "[email-masked] <mailto:[email-masked]>" <[email-masked] <mailto:[email-masked]>>
>>>>>> 主题: Re: [TLS] (offline) Re: Draft for SM cipher suites used in TLS1.3
>>>>>> 
>>>>>> IMHO, placing the documents on GitHub would be perfect, and quite sufficient.
>>>>>> 
>>>>>> Please make sure to post the name of the repo here. ;/)
>>>>>> 
>>>>>> I leave it to others to decide whether they'd want copies of today PDF files sent to the mailing list directly.
>>>>>> 
>>>>>> Regards,
>>>>>> Uri
>>>>>> 
>>>>>> Sent from my iPhone
>>>>>> 
>>>>>> On Aug 17, 2019, at 01:03, Paul Yang <kaishen.yy=[email-masked] <mailto:kaishen.yy=[email-masked]>> wrote:
>>>>>> 
>>>>>> Good points.
>>>>>> 
>>>>>> The good news is that we have found some English PDFs of SM2, including the missing part 1 and part 3. Will continue to find English translations of other SM standards mentioned in the draft.
>>>>>> 
>>>>>> So, if we host a free website, say on Github or so, to provide those docs, is it convenient for you guys? Or should we just drop the   PDF files to this mailing list as attachments?
>>>>>> 
>>>>>> 
>>>>>> On Aug 16, 2019, at 10:58 PM, Rene Struik <[email-masked] <mailto:[email-masked]>> wrote:
>>>>>> 
>>>>>> Arguably, "national" crypto specifications garnish more stature if these are made available to the pubic by that standard-setting body itself (who, thereby, acts as its authoritative source), without deference to a third party (that may, independently from the originator, enforce document control [e.g., by effectuating technical changes or enforcing controlled dissemination]).
>>>>>> 
>>>>>> Since your draft introducing SM cipher suites with TLS1.3 appeals to the authority of a standard-setting authority, easy availability of the full and accredited technical documentation to the IETF community helps in scrutiny and, e.g., evaluating claims in the security considerations section.
>>>>>> 
>>>>>> On 8/16/2019 3:06 AM, Kepeng Li wrote:
>>>>>> Hi Rene and all,
>>>>>> 
>>>>>> > Since the ISO documents are not available to the general
>>>>>> > public without payment, it would be helpful to have a freely available
>>>>>> > document (in English) from an authoritative source. Having such a
>>>>>> > reference available would be helpful to the IETF community (and
>>>>>> > researchers).
>>>>>> About the references to ISO documens, I think it is a general issue for IETF drafts.
>>>>>> 
>>>>>> How does the other IETF drafts make the references to ISO documents? ISO documents are often referenced by IETF drafts.
>>>>>> 
>>>>>> Thanks,
>>>>>> 
>>>>>> Kind Regards
>>>>>> Kepeng
>>>>>> ——————————————————————————————————————————————————————————————————
>>>>>> Re: [TLS] Draft for SM cipher suites used in TLS1.3
>>>>>> 
>>>>>> Rene Struik <[email-masked] <mailto:[email-masked]>> Thu, 15 August 2019 15:34 UTCShow header <https://mailarchive.ietf.org/arch/browse/tls/?index=NHbHOGtsR1S5cCr9nWN9_sdyTgg&gbt=1>
>>>>>> Hi Paul:
>>>>>> 
>>>>>> I tried and look up the documents GMT.0009-2012 and GBT.32918.5-2016 on
>>>>>> the (non-secured) websites you referenced, but only found Chinese
>>>>>> versions (and Chinese website navigation panels [pardon my poor language
>>>>>> skills here]). Since the ISO documents are not available to the general
>>>>>> public without payment, it would be helpful to have a freely available
>>>>>> document (in English) from an authoritative source. Having such a
>>>>>> reference available would be helpful to the IETF community (and
>>>>>> researchers). Please note that BSI provides its specifications in German
>>>>>> and English, so as to foster use/study by the community. If the Chinese
>>>>>> national algorithms would be available in similar form, this would serve
>>>>>> a similar purpose.
>>>>>> 
>>>>>> FYI - I am interested in full details and some time last year I tried to
>>>>>> download specs, but only Parts 2, 4, and 5 were available [1], [2], [3],
>>>>>> not Parts 1 and 3.
>>>>>> 
>>>>>> Best regards, Rene
>>>>>> 
>>>>>> [1] China ECC - Public Key Cryptographic Algorithm SM2 Based on ECC -
>>>>>> Part 5 - Parameter Definition (SEMB, July 24, 2018)
>>>>>> [2] China ECC - Public Key Cryptographic Algorithm SM2 Based on ECC -
>>>>>> Part 2 - Digital Signature Algorithm (SEMB, July 24, 2018)
>>>>>> [3] China ECC - Public Key Cryptographic Algorithm SM2 Based on ECC -
>>>>>> Part 4 - Public Key Encryption Algorithm (SEMB, July 24, 2018)
>>>>>> 
>>>>>> On 8/15/2019 10:16 AM, Paul Yang wrote:
>>>>>> > Hi all,
>>>>>> >
>>>>>> > I have submitted a new internet draft to introduce the SM cipher
>>>>>> > suites into TLS 1.3 protocol.
>>>>>> >
>>>>>> > https://tools.ietf.org/html/draft-yang-tls-tls13-sm-suites-00 <https://tools.ietf.org/html/draft-yang-tls-tls13-sm-suites-00>
>>>>>> >
>>>>>> > SM cryptographic algorithms are originally a set of Chinese national
>>>>>> > algorithms and now have been (or being) accepted by ISO as
>>>>>> > international standards, including SM2 signature algorithm, SM3 hash
>>>>>> > function and SM4 block cipher. These algorithms have already been
>>>>>> > supported some time ago by several widely used open source
>>>>>> > cryptographic libraries including OpenSSL, BouncyCastle, Botan, etc.
>>>>>> >
>>>>>> > Considering TLS1.3 is being gradually adopted in China's internet
>>>>>> > industry, it's important to have a normative definition on how to use
>>>>>> > the SM algorithms with TLS1.3, especially for the mobile internet
>>>>>> > scenario. Ant Financial is the company who develops the market leading
>>>>>> > mobile app 'Alipay' and supports payment services for Alibaba
>>>>>> > e-commerce business. We highly are depending on the new TLS1.3
>>>>>> > protocol for both performance and security purposes. We expect to have
>>>>>> > more deployment of TLS1.3 capable applications in China's internet
>>>>>> > industry by this standardization attempts.
>>>>>> >
>>>>>> > It's very appreciated to have comments from the IETF TLS list :-)
>>>>>> >
>>>>>> > Many thanks!
>>>>>> >
>>>>>> > _______________________________________________
>>>>>> > TLS mailing list
>>>>>> > [email-masked] <mailto:[email-masked]>
>>>>>> > https://www.ietf.org/mailman/listinfo/tls <https://www.ietf.org/mailman/listinfo/tls>
>>>>>> 
>>>>>> 
>>>>>> --
>>>>>> email: [email-masked] <mailto:[email-masked]> | Skype: rstruik
>>>>>> cell: +1 (647) 867-5658 | US: +1 (415) 690-7363
>>>>>> _______________________________________________
>>>>>> TLS mailing list
>>>>>> [email-masked] <mailto:[email-masked]>
>>>>>> https://www.ietf.org/mailman/listinfo/tls <https://www.ietf.org/mailman/listinfo/tls>
>>>>>> 
>>>>>> 
>>>>>> Regards,
>>>>>> 
>>>>>> Paul Yang
>>>>>> 
>>>>>> _______________________________________________
>>>>>> TLS mailing list
>>>>>> [email-masked] <mailto:[email-masked]>
>>>>>> https://www.ietf.org/mailman/listinfo/tls <https://www.ietf.org/mailman/listinfo/tls>
>>>>>> _______________________________________________ TLS mailing list [email-masked] <mailto:[email-masked]> https://www.ietf.org/mailman/listinfo/tls <https://www.ietf.org/mailman/listinfo/tls>
>>>> 
>>>> 
>>>> Regards,
>>>> 
>>>> Paul Yang
>>> 
>>> 
>>> 
>>> Regards,
>>> 
>>> Paul Yang
>>> 
>>> _______________________________________________
>>> tls-reg-review mailing list
>>> [email-masked] <mailto:[email-masked]>
>>> https://www.ietf.org/mailman/listinfo/tls-reg-review <https://www.ietf.org/mailman/listinfo/tls-reg-review>
>> 
> 
> 
> Regards,
> 
> Paul Yang
>

---

From: Benjamin Kaduk <[email-masked]>
Date: Fri, 13 Sep 2019 20:01:29 -0500

Hi all,

It looks like we have a +1 from Yoav and an "I don't want to be the first
+1" from Rich.  Rich, do you want to make good on that, or does Nick want
to weigh in?

Thanks,

Ben

On Sun, Aug 25, 2019 at 10:35:03PM +0300, Yoav Nir wrote:
> > On 22 Aug 2019, at 19:14, Salz, Rich <[email-masked]> wrote:
> > 

> [email-masked]
> https://www.ietf.org/mailman/listinfo/tls-reg-review

---

From: "Salz, Rich" <[email-masked]>
Date: Sat, 14 Sep 2019 02:04:55 +0000

If it needs to be made more clear, sure: I second the +1.

Nick's probably off celebrating the IPO :)

On 9/13/19, 9:01 PM, "Benjamin Kaduk" <[email-masked]> wrote:

    Hi all,

    Thanks,
    
    Ben

---

From: Paul Yang <[email-masked]>
Date: Sat, 14 Sep 2019 11:06:49 +0800

Thanks Rich for the support!

CloudFlare goes IPO? That’s great (and breaking) news!

> On Sep 14, 2019, at 10:04 AM, Salz, Rich <[email-masked]> wrote:
> 

Regards,

Paul Yang

---

From: Paul Yang <[email-masked]>
Date: Tue, 17 Sep 2019 17:16:15 +0800

Hi there,

I am here to bug you guys again ;-). It seems all necessary requirements have been fulfilled for current stage, can we move a bit further now? (For instance, ask IANA to have a real assignment)

Thanks and regards,

Paul Yang

> On Sep 14, 2019, at 11:06 AM, Paul Yang <[email-masked]> wrote:
> 
>> On Sep 14, 2019, at 10:04 AM, Salz, Rich <[email-masked] <mailto:[email-masked]>> wrote:
>> 
>> On 9/13/19, 9:01 PM, "Benjamin Kaduk" <[email-masked] <mailto:[email-masked]>> wrote:
>> 
>>    Hi all,
>> 
>>>> Can we assign codepoints?  The draft is here: https://tools.ietf.org/id/draft-yang-tls-tls13-sm-suites-00.html <https://tools.ietf.org/id/draft-yang-tls-tls13-sm-suites-00.html> <https://tools.ietf.org/id/draft-yang-tls-tls13-sm-suites-00.html <https://tools.ietf.org/id/draft-yang-tls-tls13-sm-suites-00.html>>
>>>> From: Paul Yang <kaishen.yy=[email-masked] <mailto:kaishen.yy=[email-masked]> <mailto:kaishen.yy=[email-masked] <mailto:kaishen.yy=[email-masked]>>>
>>>> To: Uri Blumenthal <[email-masked] <mailto:[email-masked]> <mailto:[email-masked] <mailto:[email-masked]>>>
>>>> Cc: "[email-masked] <mailto:[email-masked]> <mailto:[email-masked] <mailto:[email-masked]>>" <[email-masked] <mailto:[email-masked]> <mailto:[email-masked] <mailto:[email-masked]>>>
>>>> https://github.com/alipay/tls13-sm-spec <https://github.com/alipay/tls13-sm-spec> <https://github.com/alipay/tls13-sm-spec <https://github.com/alipay/tls13-sm-spec>>
>>>> 
>>>> Please check:
>>>> 
>>>> https://github.com/alipay/tls13-sm-spec/blob/master/BUILD.md <https://github.com/alipay/tls13-sm-spec/blob/master/BUILD.md> <https://github.com/alipay/tls13-sm-spec/blob/master/BUILD.md <https://github.com/alipay/tls13-sm-spec/blob/master/BUILD.md>>
>>>> 
>>>>> On Aug 19, 2019, at 10:57 PM, Blumenthal, Uri - 0553 - MITLL <[email-masked] <mailto:[email-masked]> <mailto:[email-masked] <mailto:[email-masked]>>> wrote:
>>>>> 
>>>>>> repository at https://github.com/alipay/tls13-sm-spec <https://github.com/alipay/tls13-sm-spec> <https://github.com/alipay/tls13-sm-spec <https://github.com/alipay/tls13-sm-spec>> later to make it a totally
>>>>>> On Aug 19, 2019, at 7:51 PM, Kepeng Li <[email-masked] <mailto:[email-masked]> <mailto:[email-masked] <mailto:[email-masked]>>> wrote:
>>>>>> 
>>>>>> https://github.com/alipay/tls13-sm-spec <https://github.com/alipay/tls13-sm-spec> <https://github.com/alipay/tls13-sm-spec <https://github.com/alipay/tls13-sm-spec>>
>>>>>> 
>>>>>>> 发件人：李克鹏(易深) <[email-masked] <mailto:[email-masked]> <mailto:[email-masked] <mailto:[email-masked]>>>
>>>>>>> 收件人：sean+ietf <[email-masked] <mailto:[email-masked]> <mailto:[email-masked] <mailto:[email-masked]>>>; joe <[email-masked] <mailto:[email-masked]> <mailto:[email-masked] <mailto:[email-masked]>>>; caw <[email-masked] <mailto:[email-masked]> <mailto:[email-masked] <mailto:[email-masked]>>>
>>>>>>> 抄　送：[email-masked] <mailto:[email-masked]> <mailto:[email-masked] <mailto:[email-masked]>> <[email-masked] <mailto:[email-masked]> <mailto:[email-masked] <mailto:[email-masked]>>>; "Blumenthal, Uri - 0553 - MITLL" <[email-masked] <mailto:[email-masked]> <mailto:[email-masked] <mailto:[email-masked]>>>; Paul Yang <kaishen.yy=[email-masked] <mailto:kaishen.yy=[email-masked]> <mailto:kaishen.yy=[email-masked] <mailto:kaishen.yy=[email-masked]>>>
>>>>>>> https://github.com/tlswg <https://github.com/tlswg> <https://github.com/tlswg <https://github.com/tlswg>>
>>>>>>> 
>>>>>>> 发件人: TLS <[email-masked] <mailto:[email-masked]> <mailto:[email-masked] <mailto:[email-masked]>>> 代表 "Blumenthal, Uri - 0553 - MITLL" <[email-masked] <mailto:[email-masked]> <mailto:[email-masked] <mailto:[email-masked]>>>
>>>>>>> 日期: 2019年8月18日 星期日 22:08
>>>>>>> 收件人: Paul Yang <kaishen.yy=[email-masked] <mailto:kaishen.yy=[email-masked]> <mailto:kaishen.yy=[email-masked] <mailto:kaishen.yy=[email-masked]>>>
>>>>>>> 抄送: "[email-masked] <mailto:[email-masked]> <mailto:[email-masked] <mailto:[email-masked]>>" <[email-masked] <mailto:[email-masked]> <mailto:[email-masked] <mailto:[email-masked]>>>
>>>>>>> On Aug 17, 2019, at 01:03, Paul Yang <kaishen.yy=[email-masked] <mailto:kaishen.yy=[email-masked]> <mailto:kaishen.yy=[email-masked] <mailto:kaishen.yy=[email-masked]>>> wrote:
>>>>>>> 
>>>>>>> Good points.
>>>>>>> 
>>>>>>> On Aug 16, 2019, at 10:58 PM, Rene Struik <[email-masked] <mailto:[email-masked]> <mailto:[email-masked] <mailto:[email-masked]>>> wrote:
>>>>>>> 
>>>>>>> Rene Struik <[email-masked] <mailto:[email-masked]> <mailto:[email-masked] <mailto:[email-masked]>>> Thu, 15 August 2019 15:34 UTCShow header <https://mailarchive.ietf.org/arch/browse/tls/?index=NHbHOGtsR1S5cCr9nWN9_sdyTgg&gbt=1 <https://mailarchive.ietf.org/arch/browse/tls/?index=NHbHOGtsR1S5cCr9nWN9_sdyTgg&gbt=1>>
>>>>>>> Hi Paul:
>>>>>>> 
>>>>>>>> https://tools.ietf.org/html/draft-yang-tls-tls13-sm-suites-00 <https://tools.ietf.org/html/draft-yang-tls-tls13-sm-suites-00> <https://tools.ietf.org/html/draft-yang-tls-tls13-sm-suites-00 <https://tools.ietf.org/html/draft-yang-tls-tls13-sm-suites-00>>
>>>>>>>> 
>>>>>>>> [email-masked] <mailto:[email-masked]> <mailto:[email-masked] <mailto:[email-masked]>>
>>>>>>>> https://www.ietf.org/mailman/listinfo/tls <https://www.ietf.org/mailman/listinfo/tls> <https://www.ietf.org/mailman/listinfo/tls <https://www.ietf.org/mailman/listinfo/tls>>
>>>>>>> 
>>>>>>> 
>>>>>>> --
>>>>>>> email: [email-masked] <mailto:[email-masked]> <mailto:[email-masked] <mailto:[email-masked]>> | Skype: rstruik
>>>>>>> [email-masked] <mailto:[email-masked]> <mailto:[email-masked] <mailto:[email-masked]>>
>>>>>>> https://www.ietf.org/mailman/listinfo/tls <https://www.ietf.org/mailman/listinfo/tls> <https://www.ietf.org/mailman/listinfo/tls <https://www.ietf.org/mailman/listinfo/tls>>
>>>>>>> 
>>>>>>> 
>>>>>>> Regards,
>>>>>>> 
>>>>>>> Paul Yang
>>>>>>> 
>>>>>>> [email-masked] <mailto:[email-masked]> <mailto:[email-masked] <mailto:[email-masked]>>
>>>>>>> https://www.ietf.org/mailman/listinfo/tls <https://www.ietf.org/mailman/listinfo/tls> <https://www.ietf.org/mailman/listinfo/tls <https://www.ietf.org/mailman/listinfo/tls>>
>>>>>>> _______________________________________________ TLS mailing list [email-masked] <mailto:[email-masked]> <mailto:[email-masked] <mailto:[email-masked]>> https://www.ietf.org/mailman/listinfo/tls <https://www.ietf.org/mailman/listinfo/tls> <https://www.ietf.org/mailman/listinfo/tls <https://www.ietf.org/mailman/listinfo/tls>>
>>>>> 
>>>>> 
>>>>> Regards,
>>>>> 
>>>>> Paul Yang
>>>> 
>>>> 
>>>> 
>>>> Regards,
>>>> 
>>>> Paul Yang
>>>> 
>>>> [email-masked] <mailto:[email-masked]> <mailto:[email-masked] <mailto:[email-masked]>>
>>>> https://www.ietf.org/mailman/listinfo/tls-reg-review <https://www.ietf.org/mailman/listinfo/tls-reg-review> <https://www.ietf.org/mailman/listinfo/tls-reg-review <https://www.ietf.org/mailman/listinfo/tls-reg-review>>
>>> 
>>

---

From: Yoav Nir <[email-masked]>
Date: Tue, 17 Sep 2019 23:23:50 +0300

Hi, Paul.

Yes, please. Send an official request to IANA.

You can use the form: https://www.iana.org/form/protocol-assignment <https://www.iana.org/form/protocol-assignment> or just send an email.

Yoav

> On 17 Sep 2019, at 12:16, Paul Yang <[email-masked]> wrote:
> 
> Hi there,
> 
>> On Sep 14, 2019, at 11:06 AM, Paul Yang <[email-masked] <mailto:[email-masked]>> wrote:
>>

---

From: Paul Yang <[email-masked]>
Date: Wed, 18 Sep 2019 12:47:52 +0800

Okay, will submit the form

> On Sep 18, 2019, at 4:23 AM, Yoav Nir <[email-masked]> wrote:
> 
> Hi, Paul.
> 
>> On 17 Sep 2019, at 12:16, Paul Yang <[email-masked] <mailto:[email-masked]>> wrote:
>> 
>> Hi there,
>> 

Regards,

Paul Yang

---

From: Paul Yang <[email-masked]>
Date: Wed, 18 Sep 2019 16:38:52 +0800

Hi Yoav, the form has already been submitted.

Regards,

Paul Yang

---

From: "Salz, Rich" <[email-masked]>
Date: Wed, 18 Sep 2019 18:53:49 +0000

Looking at https://tools.ietf.org/html/draft-yang-tls-tls13-sm-suites-00, the IANA considerations in particular, I suggest the following:

             +-------+-----------------+---------+-----------+
             | Value | Description     | DTLS-OK | Reference |
             +-------+-----------------+---------+-----------+
             |  TBD1 | TLS_SM4_GCM_SM3 | No      | this RFC  |
             |       |                 |         |           |
             |  TBD2 | TLS_SM4_CCM_SM3 | No      | this RFC  |
             +-------+-----------------+---------+-----------+
Update the TLS Cipher Suites table to include
TBD1 is 0x00,0xC6
TBD2 is 0x00,0xC7
Note to the draft authors: This table is missing the “Recommended” column.  It should be filled in with “N”

               +-------+-------------+---------+-----------+
               | Value | Description | DTLS-OK | Reference |
               +-------+-------------+---------+-----------+
               |  TBD3 | sm2sig_sm3  | No      | this RFC  |
               +-------+-------------+---------+-----------+
TBD3 is 0x0708
Note to the draft authors: This table is missing the “Recommended” column. It should be filled in with “N”

        +-------+-------------+---------+-------------+-----------+
        | Value | Description | DTLS-OK | Recommended | Reference |
        +-------+-------------+---------+-------------+-----------+
        |  TBD4 | curveSM2    | No      | No          | this RFC  |
        +-------+-------------+---------+-------------+-----------+
TBD4 is 224
Note to the draft authors: This table should NOT have the “Recommended” column.

---

From: "Paul Yang" <[email-masked]>
Date: Thu, 19 Sep 2019 09:13:11 +0800

Thanks Rich for the suggestions, will update the draft. Actually there is a typo in the draft, the TBD4 should be in SupportedGroup registry instead of HashAgorithm. So I guess the nunber of TBD4 might be 41 and the Recommended still remians?

Regards,

Paul Yang------------------------------------------------------------------
Sender:Salz, Rich<[email-masked]>
Date:2019/09/19 02:53:49
Recipient:Michelle Cotton<[email-masked]>; Yoav Nir<[email-masked]>; Nick Sullivan<[email-masked]>
Cc:[email-masked]<[email-masked]>; [email-masked]<[email-masked]>; Paul Yang<[email-masked]>
Theme:Re: [Ext] Re: [Tls-reg-review] [TLS] (offline) Re: Draft for SM cipher suites used in TLS1.3

---

From: "Salz, Rich" <[email-masked]>
Date: Thu, 19 Sep 2019 01:17:57 +0000

Yes, you are completely correct.  TBD41 is 41 and, right, the Recommended column (with value N) stays.

From: Paul Yang <[email-masked]>
Date: Wednesday, September 18, 2019 at 9:13 PM
To: Rich Salz <[email-masked]>, Michelle Cotton <[email-masked]>, Yoav Nir <[email-masked]>, Nick Sullivan <[email-masked]>
Cc: "[email-masked]" <[email-masked]>, "[email-masked]" <[email-masked]>, Paul Yang <[email-masked]>
Subject: Re: [Ext] Re: [Tls-reg-review] [TLS] (offline) Re: Draft for SM cipher suites used in TLS1.3

Regards,

Paul Yang

Looking at https://tools.ietf.org/html/draft-yang-tls-tls13-sm-suites-00<https://urldefense.proofpoint.com/v2/url?u=https-3A__tools.ietf.org_html_draft-2Dyang-2Dtls-2Dtls13-2Dsm-2Dsuites-2D00&d=DwMGaQ&c=96ZbZZcaMF4w0F4jpN6LZg&r=4LM0GbR0h9Fvx86FtsKI-w&m=BOyJ17MYeXYNjETacf5xP3XcyBXx5ireIgTePS9A40g&s=0PAZs7PUEAldTXT2gjbpM-86LEmZjSBpbHIeb-lGAKA&e=>, the IANA considerations in particular, I suggest the following:

---

From: "Salz, Rich" <[email-masked]>
Date: Thu, 19 Sep 2019 01:31:31 +0000

TBD4 of course.  Typo, sigh :(

From: Rich Salz <[email-masked]>
Date: Wednesday, September 18, 2019 at 9:18 PM
To: Paul Yang <[email-masked]>, Michelle Cotton <[email-masked]>, Yoav Nir <[email-masked]>, Nick Sullivan <[email-masked]>
Cc: "[email-masked]" <[email-masked]>, "[email-masked]" <[email-masked]>
Subject: Re: [Tls-reg-review] [Ext] Re: [TLS] (offline) Re: Draft for SM cipher suites used in TLS1.3

Regards,

Paul Yang

---

From: "Paul Yang" <[email-masked]>
Date: Thu, 19 Sep 2019 09:36:21 +0800

Sure, no problem ;-)

Regards,

Paul Yang------------------------------------------------------------------
Sender:Salz, Rich<[email-masked]>
Date:2019/09/19 09:31:31
Recipient:Paul Yang<[email-masked]>; Michelle Cotton<[email-masked]>; Yoav Nir<[email-masked]>; Nick Sullivan<[email-masked]>
Cc:[email-masked]<[email-masked]>; [email-masked]<[email-masked]>
Theme:Re: [Tls-reg-review] [Ext] Re: [TLS] (offline) Re: Draft for SM cipher suites used in TLS1.3

  

Regards,

 Paul Yang

---

From: Paul Yang <[email-masked]>
Date: Thu, 19 Sep 2019 11:55:29 +0800

Hi there,

I have uploaded a new version of the draft which includes the code points suggested by Rich in previous email:

https://tools.ietf.org/html/draft-yang-tls-tls13-sm-suites-01 <https://tools.ietf.org/html/draft-yang-tls-tls13-sm-suites-01>

Along with other updates (official English references to Chinese algorithms, typos…)

> On Sep 19, 2019, at 9:36 AM, Paul Yang <[email-masked]> wrote:
> 
> Sure, no problem ;-)
> 
> 
> 
> 
> 
> Regards,
> 
> Paul Yang
> Sender:Salz, Rich<[email-masked] <mailto:[email-masked]>>
> Date:2019/09/19 09:31:31
> Recipient:Paul Yang<[email-masked] <mailto:[email-masked]>>; Michelle Cotton<[email-masked] <mailto:[email-masked]>>; Yoav Nir<[email-masked] <mailto:[email-masked]>>; Nick Sullivan<[email-masked] <mailto:[email-masked]>>
> Cc:[email-masked] <mailto:[email-masked]><[email-masked] <mailto:[email-masked]>>; [email-masked] <mailto:[email-masked]><[email-masked] <mailto:[email-masked]>>
> Looking at https://tools.ietf.org/html/draft-yang-tls-tls13-sm-suites-00 <https://urldefense.proofpoint.com/v2/url?u=https-3A__tools.ietf.org_html_draft-2Dyang-2Dtls-2Dtls13-2Dsm-2Dsuites-2D00&d=DwMGaQ&c=96ZbZZcaMF4w0F4jpN6LZg&r=4LM0GbR0h9Fvx86FtsKI-w&m=BOyJ17MYeXYNjETacf5xP3XcyBXx5ireIgTePS9A40g&s=0PAZs7PUEAldTXT2gjbpM-86LEmZjSBpbHIeb-lGAKA&e=>, the IANA considerations in particular, I suggest the following:
> 

Regards,

Paul Yang