Subject: [rbridge] L3 vs. L2 encapsulation

From: alper.yegin at samsung.com (Alper Yegin)
Date: Mon, 27 Jun 2005 15:40:27 -0700

One of the issues listed in draft-perlman-rbridge-03.txt is the choice
of encapsulation. See Section 5.5 for a detailed discussion. 

Can we close that issue agreeing to a L3 encapsulation? 

This does not prevent anyone designing a L2 encapsulated version by
reusing the base spec(s) as much as possible. That should be outside the
scope of the WG though.

Comments welcome.

Alper

---

From: Radia.Perlman at sun.com (Radia Perlman)
Date: Mon, 27 Jun 2005 15:58:53 -0700

We've been assuming an L2 encapsulation, and that's what I'd prefer. 
That not only saves room in the header, but
does not a priori require assigning L3 addresses, and also automatically 
supports both IPv4 and IPv6.

Radia

Alper Yegin wrote:

>_______________________________________________
>rbridge mailing list
>rbridge at postel.org
>http://www.postel.org/mailman/listinfo/rbridge
>  
>

---

From: touch at ISI.EDU (Joe Touch)
Date: Mon, 27 Jun 2005 20:02:51 -0700

The use of L2, L2+shim, or L3 encapsulation doesn't impact what
protocols can be included, It DOES impact the routing protocols in use,
however, so we probably ought to think about it a little.

Jeo

-------------- next part --------------
A non-text attachment was scrubbed...
Name: signature.asc
Type: application/pgp-signature
Size: 254 bytes
Desc: OpenPGP digital signature
Url : http://www.postel.org/pipermail/rbridge/attachments/20050627/5572950b/signature.bin

---

From: alper.yegin at samsung.com (Alper Yegin)
Date: Tue, 28 Jun 2005 13:34:26 -0700

The I-D recommends IS-IS, and this is aligned with the use of L2
encapsulation. As Radia brought up, not having to configure IP addresses
is another plus. I guess we could stick with the current default choices
made in the document.

Alper

> -----Original Message-----
> From: rbridge-bounces at postel.org [mailto:rbridge-bounces at postel.org]
On
> Behalf Of Joe Touch
> Sent: Monday, June 27, 2005 8:03 PM
> To: Developing a hybrid router/bridge.
> Subject: Re: [rbridge] L3 vs. L2 encapsulation
>