Subject: [rbridge] Distribution Tree and ECMP

From: Suresh Boddapati <[email-masked]>
Date: Mon, 23 Jun 2008 22:09:43 -0700 (PDT)

4.3.1 of the base protocol spec says: 

   "When a node RBn has two or more minimal equal cost
paths toward the Root RBi a deterministic tie-breaker
is needed to guarantee that all Rbridges calculate the
same distribution tree. This is obtained by selecting
the path that goes to the parent that has the lower
IS-IS System ID." 

This however does not cover the case when the ECMP
paths are through the same RBridge. For example, 

A ----- B ---------- C
          ----------

If B is the designated IS for both the links connected
to C for the tree rooted at A, it is possible that C
might compute the top link to be on the distribution
tree whereas B might compute the bottom one.

It seems to me that the algorithm will be more
deterministic if the LAN ID were to be used for
tie-breaking, when System IDs are the same. In this
case if the top link's LAN ID were to be B.01 and the
bottom link's were to be B.02, both could
deterministically decide that B.01 should be the link
on the distribution tree. 

Comments?

Suresh

_______________________________________________
rbridge mailing list
[email-masked]
http://mailman.postel.org/mailman/listinfo/rbridge

---

From: "Ayan Banerjee (ayabaner)" <[email-masked]>
Date: Tue, 24 Jun 2008 09:44:04 -0700

Suresh,

I agree with your observation and in the event these links are P2P we
should use the extended circuit-id to break the tie.

Thanks,
Ayan 

-----Original Message-----
From: [email-masked] [mailto:[email-masked]] On
Behalf Of Suresh Boddapati
Sent: Monday, June 23, 2008 10:10 PM
To: [email-masked]
Subject: [rbridge] Distribution Tree and ECMP

   "When a node RBn has two or more minimal equal cost paths toward the
Root RBi a deterministic tie-breaker is needed to guarantee that all
Rbridges calculate the same distribution tree. This is obtained by
selecting the path that goes to the parent that has the lower IS-IS
System ID." 

This however does not cover the case when the ECMP paths are through the
same RBridge. For example, 

A ----- B ---------- C
          ----------

If B is the designated IS for both the links connected to C for the tree
rooted at A, it is possible that C might compute the top link to be on
the distribution tree whereas B might compute the bottom one.

It seems to me that the algorithm will be more deterministic if the LAN
ID were to be used for tie-breaking, when System IDs are the same. In
this case if the top link's LAN ID were to be B.01 and the bottom link's
were to be B.02, both could deterministically decide that B.01 should be
the link on the distribution tree. 

Comments?

Suresh

---

From: "Eastlake III Donald-LDE008" <[email-masked]>
Date: Wed, 25 Jun 2008 17:11:41 -0400

Some of these cases may not occur due to link aggregation but when these
cases do occur, it certainly seems like you need a further tie breaker
and your suggestion sounds good to me.

Donald

-----Original Message-----
From: [email-masked] [mailto:[email-masked]] On
Behalf Of Ayan Banerjee (ayabaner)
Sent: Tuesday, June 24, 2008 12:44 PM
To: Suresh Boddapati; [email-masked]
Subject: Re: [rbridge] Distribution Tree and ECMP

Suresh,

Thanks,
Ayan 

-----Original Message-----

A ----- B ---------- C
          ----------

Comments?

Suresh

---

From: Radia Perlman <[email-masked]>
Date: Thu, 26 Jun 2008 16:14:42 -0700

Yup. I might have been the culprit who did that wording. At any rate, 
yeah -- it should be the "ID of
the parent node", so as you said, it should be the IS-IS 7-byte ID of
the node, whether the "parent" is a pseudonode or a regular node. 
"System ID" implies the 6 byte ID of a router,
and that is incorrect in this case, as you point out.

Thanks for catching that.

Radia