Subject: Re: [trill] draft-ietf-trill-channel-tunnel-05 - 2 week WG LC (5/29 to 6/12)

From: Mohammed Umair <[email-masked]>
Date: Fri, 5 Jun 2015 16:43:17 +0530

I am not aware of any IPR which needs to be disclosed for this draft.

Support this draft as co-author.

Regards,

Umair

*From:* trill [mailto:[email-masked]] *On Behalf Of *Susan Hares
*Sent:* Friday, May 29, 2015 6:08 PM
*To:* [email-masked]
*Cc:* 'Donald Eastlake'; [email-masked];
[email-masked]; [email-masked]; 'Jon
Hudson'
*Subject:* [trill] draft-ietf-trill-channel-tunnel-05 - 2 week WG LC (5/29
to 6/12)

This is to begin a 2 week WG LC for draft-ietf-trill-channel-tunnel-05
(5/29 to 6/12).  The authors (Donald, Mohammed, Yizhou) should send a note
to the list indicating whether they know if any IPR.

You can access the draft at:

http://datatracker.ietf.org/doc/draft-ietf-trill-channel-tunnel/

A summary of the document is:

   The IETF TRILL (Transparent Interconnection of Lots of Links)

   protocol includes an optional mechanism, called RBridge Channel, that

   is specified in RFC 7178, for the transmission of typed messages

   between TRILL switches in the same campus and between TRILL switches

   and end stations on the same link. This document specifies two

   optional extensions to the RBridge Channel protocol: (1) A standard

   method to tunnel a variety of payload types by encapsulating them in

   an RBridge Channel message; and (2) A method to support security

   facilities for RBridge Channel messages. This document updates RFC

   7178.

Please answer the following questions:

1)      Does this draft enhance RFC7178 and is it ready for WG LC?

2)      Do you have any concerns regarding the mechanisms?

Sue

-- 
.

---

From: Donald Eastlake <[email-masked]>
Date: Sat, 6 Jun 2015 23:20:25 -0400

Hi Gayle,

Thanks for these suggestions. They all look good to me.

Thanks,
Donald
=============================
 Donald E. Eastlake 3rd   +1-508-333-2270 (cell)
 155 Beaver Street, Milford, MA 01757 USA
 [email-masked]

On Mon, Jun 1, 2015 at 1:37 AM, gayle noble <[email-masked]> wrote:
>   TRILL: RBridge Channel Tunnel Protocol
> <draft-ietf-trill-channel-tunnel-05.txt>
>
> corrections::
> page 16 4.5 RFC 5310 Based Authentication
> ["or" should be "on"]
> (as written)
>   o RESV: Six bits that MUST be sent as zero and ignored or receipt.
> (should be)
>   o RESV: Six bits that MUST be sent as zero and ignored on receipt
> ---------------------------------------------------------
>
> page 17 4.5 RFC 5310 Based Authentication
> [second "that" probably should be "the" or not there at all]
> (as written)
> o Key ID: specifies the same keying value and authentication
>      algorithm that that Key ID specifies for TRILL IS-IS LSP [RFC5310]
>      Authentication TLVs.
> (probably should be)
> o Key ID: specifies the same keying value and authentication
>      algorithm that Key ID specifies for TRILL IS-IS LSP [RFC5310]
>      Authentication TLVs.
> (could be)
> o Key ID: specifies the same keying value and authentication
>      algorithm that the Key ID specifies for TRILL IS-IS LSP [RFC5310]
>      Authentication TLVs.
> ----------------------------------------------------
>
> page 22   7. Security Considerations  third paragraph first sentence
> ['taking" should be "taken"]
> (as written)
>   On the negative side, the optional ability to tunnel various payload
>   types and to tunnel them between TRILL switches and to and from end
>   stations can increase risk unless precautions are taking.
> (should be)
>   On the negative side, the optional ability to tunnel various payload
>   types and to tunnel them between TRILL switches and to and from end
>   stations can increase risk unless precautions are taken.
> ---------------------------------------------------------
>
> page 22 Security Considerations  third paragraph second sentence
> [sentence is a bit "run on". I'd at least add a comma if breaking it into
> two sentences doesn't appeal to you.
> (as written)
> The processing of decapsulating Tunnel Protocol payloads is not a good place
> to be liberal in what you accept as the tunneling facility makes it easier
> for unexpected messages to pop up in unexpected places in a TRILL campus due
> to accidents or the actions of an adversary.
> (could be)
> The processing of decapsulating Tunnel Protocol payloads is not a good place
> to be liberal in what you accept, as the tunneling facility makes it easier
> for unexpected messages to pop up in unexpected places in a TRILL campus due
> to accidents or the actions of an adversary.
> (maybe)
> The processing of decapsulating Tunnel Protocol payloads is not a good place
> to be liberal in what you accept. This is because the tunneling facility
> makes it easier for unexpected messages to pop up in unexpected places in a
> TRILL campus due to accidents or the actions of an adversary.
>
> ============================================
>
> Just a Note::
> Page 3
> CCM is defined as Continuity Check Message in other TRILL documents. It is
> defined Counter with CBC-MAC (Cypher Block Chaining - Message Authentication
> Code) in the draft.
>
> _______________________________________________
> trill mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/trill
>

---

From: Donald Eastlake <[email-masked]>
Date: Sat, 6 Jun 2015 23:26:07 -0400

This draft provides security for RBridge Channel messages, a feature
missing from RFC 7178 whose absence caused some difficulty in getting
RFC 7178 approved.

I support this as a co-author.

I am not aware of any IPR in this draft.

Thanks,
Donald

On Fri, May 29, 2015 at 8:37 AM, Susan Hares <[email-masked]> wrote:
> This is to begin a 2 week WG LC for draft-ietf-trill-channel-tunnel-05 (5/29
> to 6/12).  The authors (Donald, Mohammed, Yizhou) should send a note to the
> list indicating whether they know if any IPR.
>
>
>

---

From: gayle noble <[email-masked]>
Date: Sat, 06 Jun 2015 20:52:41 -0700

I support this
gayle

---

From: Liyizhou <[email-masked]>
Date: Mon, 15 Jun 2015 01:15:01 +0000

I do not know any IPR relating to this draft.

Thanks,

Yizhou

From: trill [mailto:[email-masked]] On Behalf Of Susan Hares
Sent: Friday, May 29, 2015 8:38 PM
To: [email-masked]
Cc: 'Donald Eastlake'; [email-masked]; [email-masked]; [email-masked]; 'Jon Hudson'
Subject: [trill] draft-ietf-trill-channel-tunnel-05 - 2 week WG LC (5/29 to 6/12)

This is to begin a 2 week WG LC for draft-ietf-trill-channel-tunnel-05 (5/29 to 6/12).  The authors (Donald, Mohammed, Yizhou) should send a note to the list indicating whether they know if any IPR.

Sue