Subject: [Tsv-art] Nomcom candidates (including Transport AD)

From: Martin Duke <[email-masked]>
Date: Tue, 1 Jun 2021 13:55:25 -0700

Hello Transport Area,

NomCom is currently accepting nominations for various 2022 leadership
positions, including my seat as AD. I am standing for another term.
However, it is always good for the IETF to have alternatives to the
incumbent AD, so please consider nominating other promising candidates
<https://datatracker.ietf.org/nomcom/2021/nominate/>, and accepting the
nomination if you receive one.

Standing for the position is not much work -- you fill out a questionnaire
and do a pretty-low pressure interview around IETF 112.

For the benefit of those who are considering going for AD of Transport or
any other area, here is the informal pitch I gave last year.

Thanks,
Martin

*TL;DR* being an AD is a professionally enriching and socially
rewarding experience. It takes time but it usually doesn't hurt to ask your
employer for that time. The procedural stuff is not hard at all. The most
challenging thing is getting up to speed on unfamiliar subjects, which also
probably has the biggest benefits.

Others can judge if I've been successful, but at no point have I been
overwhelmed or left without great advice and exceptional documentation on
how to do things.

*What's great about being an AD*:
- Having an important say in shaping the area and the IETF as a whole,
particularly by chartering groups and participating in IESG initiatives
that interest you
- Everyone has their examples of nonsense at the IETF but ADs are in a
position to do something about it.
- Working with some great WG chairs, and building our TSV community
- Learning much more about what's going on in other areas, to become a more
complete internet professional
- There's a lot of freedom to focus on what you find most interesting
- Meeting people from every corner of IETF - unfortunately I haven't gotten
the full in-person version of this, but it remains true.

*Time commitment*: This is the biggest reason not to pursue the position.
Like many things it depends on what you want to put into it, but it's not
like a chair position that can be done in the margins of your day job. I
would definitely arrange with your employer to lose no less than 1/4, and
probably half, of your current responsibilities.

This is a huge mental obstacle for many people, but if your boss can be
persuaded of the advantages for your organization, and that it will help
you be a satisfied employee, you may be able to jettison the less appealing
bits of your current work. That's how it turned out for me.

*What's the work*? There's an official job description here:
https://trac.ietf.org/trac/iesg/wiki/TransportExpertise

 In roughly declining order of time commitment:

1. IESG review: you should review a healthy majority of documents that pass
IETF Last Call. This can take a long time if you provide detailed reviews
of everything, or not as much if you focus on the transport aspects of
documents that have transport implications and lean on the area review team
to do their usual good job.

2. Weekly meetings: No more than 3 hours unless you volunteer for more.
Obviously, ramps up around IETF week.

3. AD Review: you should take a close look at the document output of your
WGLCs.

4. WG management: Chairs don't need to be micromanaged, but they'll
sometimes ask your opinion. You're also deeply involved in chartering,
finding chairs, and BOFs in your area but these are not terribly frequent
events.

5. IESG projects. This is purely optional, but you can take on a special
project. For example, I was deeply involved in figuring out the remote
meeting plan, and, well, you saw the result.

6. Miscellaneous: you will get random email about RFC errata, etc, and have
to deal with it. It's not a huge time sink.

I hope some of you will overcome the concern that you're "not ready" for
this position, and/or the hesitation to ask your employer to explore an
interesting opportunity.

I'm happy to discuss further with interested people, either via email or
using the chat or meeting technology of your choice. For a less conflicted
experience, I'm sure Zahed would be equally willing to share his thoughts.

---

From: Zaheduzzaman Sarker <[email-masked]>
Date: Wed, 2 Jun 2021 08:21:10 +0000

Thanks Martin for putting out your well compiled thoughts. It is even better that you are willing to standing for another term.

Even though my experience is short I could not agree more with your message here. (Let’s see what I say after me term ends 😊). Sure, I can also share my experience and discuss with any interested person.

BR
Zahed

On 2021-06-01, 22:55, "Martin Duke" <[email-masked]<mailto:[email-masked]>> wrote:

Hello Transport Area,

NomCom is currently accepting nominations for various 2022 leadership positions, including my seat as AD. I am standing for another term. However, it is always good for the IETF to have alternatives to the incumbent AD, so please consider nominating other promising candidates<https://datatracker.ietf.org/nomcom/2021/nominate/>, and accepting the nomination if you receive one.

Standing for the position is not much work -- you fill out a questionnaire and do a pretty-low pressure interview around IETF 112.

For the benefit of those who are considering going for AD of Transport or any other area, here is the informal pitch I gave last year.

Thanks,
Martin

TL;DR being an AD is a professionally enriching and socially rewarding experience. It takes time but it usually doesn't hurt to ask your employer for that time. The procedural stuff is not hard at all. The most challenging thing is getting up to speed on unfamiliar subjects, which also probably has the biggest benefits.

Others can judge if I've been successful, but at no point have I been overwhelmed or left without great advice and exceptional documentation on how to do things.

What's great about being an AD:
- Having an important say in shaping the area and the IETF as a whole, particularly by chartering groups and participating in IESG initiatives that interest you
- Everyone has their examples of nonsense at the IETF but ADs are in a position to do something about it.
- Working with some great WG chairs, and building our TSV community
- Learning much more about what's going on in other areas, to become a more complete internet professional
- There's a lot of freedom to focus on what you find most interesting
- Meeting people from every corner of IETF - unfortunately I haven't gotten the full in-person version of this, but it remains true.

Time commitment: This is the biggest reason not to pursue the position. Like many things it depends on what you want to put into it, but it's not like a chair position that can be done in the margins of your day job. I would definitely arrange with your employer to lose no less than 1/4, and probably half, of your current responsibilities.

This is a huge mental obstacle for many people, but if your boss can be persuaded of the advantages for your organization, and that it will help you be a satisfied employee, you may be able to jettison the less appealing bits of your current work. That's how it turned out for me.

What's the work? There's an official job description here: https://trac.ietf.org/trac/iesg/wiki/TransportExpertise

1. IESG review: you should review a healthy majority of documents that pass IETF Last Call. This can take a long time if you provide detailed reviews of everything, or not as much if you focus on the transport aspects of documents that have transport implications and lean on the area review team to do their usual good job.

2. Weekly meetings: No more than 3 hours unless you volunteer for more. Obviously, ramps up around IETF week.

3. AD Review: you should take a close look at the document output of your WGLCs.

4. WG management: Chairs don't need to be micromanaged, but they'll sometimes ask your opinion. You're also deeply involved in chartering, finding chairs, and BOFs in your area but these are not terribly frequent events.

5. IESG projects. This is purely optional, but you can take on a special project. For example, I was deeply involved in figuring out the remote meeting plan, and, well, you saw the result.

6. Miscellaneous: you will get random email about RFC errata, etc, and have to deal with it. It's not a huge time sink.

I hope some of you will overcome the concern that you're "not ready" for this position, and/or the hesitation to ask your employer to explore an interesting opportunity.

I'm happy to discuss further with interested people, either via email or using the chat or meeting technology of your choice. For a less conflicted experience, I'm sure Zahed would be equally willing to share his thoughts.

---

From: Spencer Dawkins at IETF <[email-masked]>
Date: Tue, 8 Jun 2021 18:31:50 -0500

On Wed, Jun 2, 2021 at 3:21 AM Zaheduzzaman Sarker <zaheduzzaman.sarker=
[email-masked]> wrote:

> Thanks Martin for putting out your well compiled thoughts. It is even
> better that you are willing to standing for another term.
>
>
>
> Even though my experience is short I could not agree more with your
> message here. (Let’s see what I say after me term ends 😊). Sure, I can
> also share my experience and discuss with any interested person.
>

"Term". He said, "term".

Who's going to tell him? :D

Best,

Spencer