Subject: [Tsvwg] what is a 'sufficiently' long idle period ?

From: Meyknecht Bernward <[email-masked]>
Date: Fri, 4 Jun 2004 17:50:32 +0200

Hi all,

in SCTP RFC and Implem. Guide there's a sentence telling me how to initialize the 
cwnd after a 'sufficiently' long idle period.

Does anyone have a proposal what could be a good value for 'sufficiently' ?
5, 10, 20 times RTO ? ....

Text from ch. 2.30 / implem. guide:
--------- New text: (Section 7.2.1) --------- o 
The initial cwnd before DATA transmission or after a sufficiently long idle period 
MUST be set to min (4*MTU, max (2*MTU, 4380 bytes)). 

--- --- ---

And how does this match ch. 2.14 from implem guide, where I'm told to set cwnd 
to 2*MTU after one RTO, which could be less than the value from above.
Does the formula from 2.30 replace the one from 2.14?

Text from ch. 2.14 / implem. guide:
--------- New text: (Section 7.2.1) --------- o 
When the association does not transmit data on a given transport address within an RTO, 
the cwnd of the transport address SHOULD be adjusted to 2*MTU. 

Maybe someone has some idea...

Best regards,

Bernward

_______________________________________________
tsvwg mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/tsvwg

---

From: "Randall R. Stewart (home)" <[email-masked]>
Date: Tue, 08 Jun 2004 07:28:12 -0500

Bernward:

IMO you really do not need to do the cwnd reduction if
you are applying a burst limit... this whole reduction thing (I think)
needs to be revisited with respect to burst limit and of course
how long it takes to degrade the cwnd...

R

-- 
Randall R. Stewart
815-477-2127 (office)
815-342-5222 (cell phone)