Subject: Re: Last Call: <draft-ietf-tsvwg-iana-ports-09.txt> (Internet Assigned Numbers Authority (IANA) Procedures for the Management of the Service Name and Transport Protocol Port Number Registry) to BCP

From: Alexey Melnikov <[email-masked]>
Date: Mon, 28 Mar 2011 14:14:08 +0200

Alexey Melnikov wrote:

> Peter Saint-Andre wrote:
>
>> Agreed, thanks to Paul for the proposed text.
>>
>> On 2/15/11 9:02 PM, Cullen Jennings wrote:
>>
>>> Paul's text is much better than mine. That was what I trying to get
>>> at.
>>
> Agreed, I will add this as an RFC Editor's note.
>
>>> On Feb 15, 2011, at 8:59 PM, Paul Hoffman wrote:
>>>
>>>> On 2/15/11 7:34 PM, Cullen Jennings wrote:
>>>>
>>>>> I propose some text for the draft near the bottom of this
>>>>> email.... For the user ports the document should have some text
>>>>> along the lines of:
>>>>>
>>>>> There is not IETF consensus on when it is appropriate to use a
>>>>> second port for a secure version of protocol therefor the export
>>>>> reviewer should not reject a request for a second port to run a
>>>>> secure variant of the protocol over.
>>>>
>>>> That feels close, but too prescriptive. Also, the requests are
>>>> usually for a protocol with two ports, not a later request for a
>>>> second port. How about:
>>>>
>>>> There is not IETF consensus on when it is appropriate to use a
>>>> second port for a secure version of protocol. Therefore, an expert
>>>> reviewer should not reject a proposal for a protocol that uses a
>>>> second part to run a secure variant for the sole reason that it
>>>> is using two ports.
>>>
After discussing this new text with IESG and some participants of the 
TSVWG, it became clear that while there is clear agreement for adding 
the first sentence quoted above ("There is no IETF consensus..."), there 
is no clear cut consensus for adding the second sentence ("Therefore, an 
expert reviewer should not reject a proposal").

After even further discussions with proponents of this text, with 
editors, IANA, etc., the proposal is to strike the second sentence, i.e. 
only the following sentence is going to be added to the document:

  There is no IETF consensus on when it is appropriate to use a second 
port for an insecure version of protocol.

The IESG is already alerted when there are problems with IANA 
registrations, so the requirement being removed is not needed.

If people have problems with this change, please send your objections by 
4pm Prague time on Wednesday, March 30th, as I would like to approve the 
document before my IESG term ends.

---

From: Lars Eggert <[email-masked]>
Date: Mon, 28 Mar 2011 14:46:18 +0200

As one of the authors/editors, I am fine with this change. Thanks!

On 2011-3-28, at 14:14, Alexey Melnikov wrote:
> After discussing this new text with IESG and some participants of the TSVWG, it became clear that while there is clear agreement for adding the first sentence quoted above ("There is no IETF consensus..."), there is no clear cut consensus for adding the second sentence ("Therefore, an expert reviewer should not reject a proposal").
> 
> After even further discussions with proponents of this text, with editors, IANA, etc., the proposal is to strike the second sentence, i.e. only the following sentence is going to be added to the document:
> 
> There is no IETF consensus on when it is appropriate to use a second port for an insecure version of protocol.
> 
> The IESG is already alerted when there are problems with IANA registrations, so the requirement being removed is not needed.
> 
> If people have problems with this change, please send your objections by 4pm Prague time on Wednesday, March 30th, as I would like to approve the document before my IESG term ends.

---

From: Joe Touch <[email-masked]>
Date: Mon, 28 Mar 2011 06:33:59 -0700

As one of the authors, I'm fine with this change too.

Joe

---

From: Magnus Westerlund <[email-masked]>
Date: Mon, 28 Mar 2011 15:46:59 +0200

> As one of the authors, I'm fine with this change too.

Me too,

Magnus Westerlund

---

From: Michelle Cotton <[email-masked]>
Date: Mon, 28 Mar 2011 06:52:34 -0700

+1 

Michelle

On 3/28/11 5:46 AM, "Lars Eggert" <[email-masked]> wrote:

>> After discussing this new text with IESG and some participants of the TSVWG,
>> it became clear that while there is clear agreement for adding the first
>> sentence quoted above ("There is no IETF consensus..."), there is no clear
>> cut consensus for adding the second sentence ("Therefore, an expert reviewer
>> should not reject a proposal").
>> 
>> After even further discussions with proponents of this text, with editors,
>> IANA, etc., the proposal is to strike the second sentence, i.e. only the
>> following sentence is going to be added to the document:
>> 
>> The IESG is already alerted when there are problems with IANA registrations,
>> so the requirement being removed is not needed.
>> 
>> If people have problems with this change, please send your objections by 4pm
>> Prague time on Wednesday, March 30th, as I would like to approve the document
>> before my IESG term ends.
>

---

From: Peter Saint-Andre <[email-masked]>
Date: Mon, 28 Mar 2011 14:41:09 +0200

> document before my IESG term ends.

As someone who was involved in formulating the two-sentence text and who
raised concerns about removing the second sentence within the IESG, I'd
like to publicly affirm that I find this resolution acceptable.

Peter

-- 
Peter Saint-Andre
https://stpeter.im/

---

From: Eliot Lear <[email-masked]>
Date: Tue, 29 Mar 2011 11:31:02 +0200

+1.

---

From: Markku Kojo <[email-masked]>
Date: Wed, 30 Mar 2011 18:07:38 +0300 (EEST)

+1

/Markku