Subject: [Editorial Errata Reported] RFC6056 (2750)

From: RFC Errata System <[email-masked]>
Date: Sun, 13 Mar 2011 11:49:54 -0700 (PDT)

The following errata report has been submitted for RFC6056,
"Recommendations for Transport-Protocol Port Randomization".

--------------------------------------
You may review the report below and at:
http://www.rfc-editor.org/errata_search.php?rfc=6056&eid=2750

--------------------------------------
Type: Editorial
Reported by: Bjoern A. Zeeb <[email-masked]>

Section: 3.3

Original Text
-------------
3.3.1.  Algorithm 1: Simple Port Randomization Algorithm

-           if(check_suitable_port(port))

3.3.2.  Algorithm 2: Another Simple Port Randomization Algorithm

-           if(check_suitable_port(port))

Corrected Text
--------------
3.3.1.  Algorithm 1: Simple Port Randomization Algorithm

+           if(check_suitable_port(next_ephemeral))

3.3.2.  Algorithm 2: Another Simple Port Randomization Algorithm

+           if(check_suitable_port(next_ephemeral))

Notes
-----
For neither Algorithm 1 or 2 the pseudo code defines "port" as a valid variable.
The variable passed to check_suitable_port() should be "next_ephemeral" in these cases.
It looks like a copy and paste error. The technical meaning is still clear.

Instructions:
-------------
This errata is currently posted as "Reported". If necessary, please
use "Reply All" to discuss whether it should be verified or
rejected. When a decision is reached, the verifying party (IESG)
can log in to change the status and edit the report, if necessary. 

--------------------------------------
RFC6056 (draft-ietf-tsvwg-port-randomization-09)
--------------------------------------
Title               : Recommendations for Transport-Protocol Port Randomization
Publication Date    : January 2011
Author(s)           : M. Larsen, F. Gont
Category            : BEST CURRENT PRACTICE
Source              : Transport Area Working Group
Area                : Transport
Stream              : IETF
Verifying Party     : IESG

---

From: Fernando Gont <[email-masked]>
Date: Mon, 28 Mar 2011 20:43:51 -0300

Folks,

This errata is correct. (FWIW, I screwed up during IESG review at the time).

Thanks!

Best regards,
Fernando

-- 
Fernando Gont
e-mail: [email-masked] || [email-masked]
PGP Fingerprint: 7809 84F5 322E 45C7 F1C9 3945 96EE A9EF D076 FFF1