Subject: Re: [dccp] WGLC for draft-ietf-dccp-udpencap

From: Cullen Jennings <[email-masked]>
Date: Wed, 2 Mar 2011 14:35:26 -0700

I'm wondering what would be the downside of saying the UDP source / dest port had to match the DCCP source and dest port?  This would make it much easier to figure out hot to integrate this into something like ICE or decide what UDP and DCCP ports one uses for a URL like sip:example.com:5060

On Feb 28, 2011, at 2:09 AM, Pasi Sarolahti wrote:

> Hello,
> 
> We just started DCCP WG last call on draft-ietf-dccp-udpencap that specifies UDP encapsulation for DCCP packets (see pointer below). The issue of UDP encapsulation was discussed earlier also on this list, so people might be interested to read the draft. Please send comments to the DCCP mailing list <[email-masked]> by March 11.
> 
> Thanks!
> 
> - Pasi
> 
> 
> Begin forwarded message:
> 
>> From: Pasi Sarolahti <[email-masked]>
>> Date: February 25, 2011 12:56:46 PM GMT+02:00
>> To: 'dccp' working group <[email-masked]>
>> Subject: [dccp] WGLC for draft-ietf-dccp-udpencap
>> 
>> Hi,
>> 
>> This mail starts a working group last call for the UDP encapsulation draft. The draft is available at http://tools.ietf.org/html/draft-ietf-dccp-udpencap-06 . Please read the draft and send any comments to the DCCP mailing list.
>> 
>> The WGLC lasts for two weeks, until March 11.
>> 
>> - Pasi
>> 
>

---

From: Randy Stewart <[email-masked]>
Date: Wed, 2 Mar 2011 21:55:54 -0500

Cullen:

(not having read the draft.. :0)

Your idea makes me wonder... would that not also pollute the UDP port space? After all then
you are burning a UDP port for every DCCP (or am I mis-understanding you)? If not this
seems a waste..

R

>>> The WGLC lasts for two weeks, until March 11.

-----
Randall Stewart
[email-masked]

---

From: Pasi Sarolahti <[email-masked]>
Date: Thu, 3 Mar 2011 11:48:43 +0200

Hi Cullen,

(cc:ing dccp mailing list as well)

The dccp/udp port issues were discussed in the DCCP WG some time ago. With the source port one problem is that a NAT could change the UDP port but not the inner DCCP port. There were opinions for keeping the two port spaces separate, to support tunneling scenarios through a well-known UDP port at the server end.

- Pasi

---

From: Cullen Jennings <[email-masked]>
Date: Tue, 8 Mar 2011 13:42:11 -0700

How about the destination ports need to match and we don't worry as much about the source ports? If we have to have specify both the udp and dccp destination port, I have no idea how existing applications are going to be able to easily use this. What would you even put in a DNS SRV record.