Subject: [tsvwg] TSVWG Interim: Mon 27th April 2020

From: Gorry Fairhurst <[email-masked]>
Date: Thu, 23 Apr 2020 13:21:07 +0100

The agenda for the next interim is here:

https://datatracker.ietf.org/doc/agenda-interim-2020-tsvwg-03-tsvwg-01/

The first item of the meeting will review the TSVWG milestones with 
reference to the L4S drafts.

We are going to review SCE and L4S comparing their usage of the ECT(1) 
codepoint and main features. This will use the slide deck that has been 
uploaded in the meeting materials. To start,  the Chairs will attempt a 
fast tour through these slides. We'll ask a few questions at the end.

We'll then revisit the topics - allowing some time to unpick the L4S or 
SCE viewpoint, and for people to ask and answer questions.

This meeting slot is scheduled for longer than we expect we will use - 
so do not expect the discussion will take the full slot.

The materials are here:

https://datatracker.ietf.org/meeting/interim-2020-tsvwg-03/session/tsvwg

Best wishes,

Gorry, Wes and David.

-- 
G. Fairhurst, School of Engineering

---

From: Sebastian Moeller <[email-masked]>
Date: Thu, 23 Apr 2020 14:55:58 +0200

> On Apr 23, 2020, at 14:21, Gorry Fairhurst <[email-masked]> wrote:
> 
> The first item of the meeting will review the TSVWG milestones with reference to the L4S drafts.
> 
> We are going to review SCE and L4S comparing their usage of the ECT(1) codepoint and main features. This will use the slide deck that has been uploaded in the meeting materials. To start,  the Chairs will attempt a fast tour through these slides. We'll ask a few questions at the end.
> 
> We'll then revisit the topics - allowing some time to unpick the L4S or SCE viewpoint, and for people to ask and answer questions.
> 
> This meeting slot is scheduled for longer than we expect we will use - so do not expect the discussion will take the full slot.
> 
> The materials are here:
> 

Question: 

Note I see the following in the slides:

	• All TSVWG open issues have been addressed

		• •  There are no remaining IPR concerns

		• •  Safe coexistence in RFC3168 ECN bottlenecks

		• •  RTT dependence

		• •  CE-ambiguity & Reordering

And I do emphatically do not agree that these issues have been sufficiently solved. For the last three I have seen very little data* supporting the hypothesis that these are solved, and I would also like to see how these are included into the respective RFC drafts. 
I might have missed it, but I do not remember that there were sufficiently in-depth discussions on the mailing list with real robust data. For RTT dependence I only remember the "demo" presentation at the last interim meeting, which was presented as an interim proof of principle, and I am still waiting for a presentation of the proper solution. Similar for RFC3168 coexistence, where also no data for a final implementation design has been presented yet. Especially about convergence times of the proposed solution and the likelihood of generating accidental (triple) dupACKs. 

And the fact that the dual queue coupled AQM does not work as advertised is completely ignored in the slides.... (IMHO requiring that all L4S compatible transports need to respond to congestion as if they had a minimum RTT of 15 ms is at best a work around, acceptable if an AQM had already been rolled out and can not be changed anymore, but NOT before deployment is actually started).

Puzzled Regards
	Sebastian

*) Has there been any real measurement data regarding the re-ordering issue? I only remember arguments based on first principles.

---

From: Sebastian Moeller <[email-masked]>
Date: Thu, 23 Apr 2020 15:15:46 +0200

I want to apologize to the list for my impolite tone.
I have been made aware that the slides are intended as documentation of opinions (of the two respective teams?) and not necessarily as statements of agreed on facts.

Regards
	Sebastian

> On Apr 23, 2020, at 14:55, Sebastian Moeller <[email-masked]> wrote:
> 
> 
>