Subject: [Uri-review] Review Request of new URI Scheme

From: Mirko Nosenzo <[email-masked]>
Date: Fri, 9 Aug 2013 12:25:04 +0200

Hello,
please review the following URI scheme:

-------------------------------------------------------------------
Resource Identifier (RI) Scheme name: feedready 

Status: provisional

Scheme syntax:
   feedready:<absolute_uri> or feedready://<hierarchical part>
   examples: feedready://example.com/rss.xml and feedready:https://example.com/rss.xml

Scheme semantics:
   FeedReady is a feed reader application developed by Incomedia.

Encoding considerations:
   Unknown, use with care.

Applications/protocols that use this scheme name:
   FeedReady application

Interoperability considerations:
   Unknown, use with care.
   May be unsuitable for open use on the public internet.
   
Security considerations:
   Unknown, use with care.
   
Contact:
   Registering party: Mirko Nosenzo <[email-masked]>
   Scheme creator: Incomedia
   
Author/Change controller:
   Either the registering party or someone who is verified to represent
   the scheme creator.  See previous answer.
   
References:
   http://feedready.com
-------------------------------------------------------------------

Thanks,
/*******************************************************************/
/*  Mirko Nosenzo   /   Software Architect   /   Incomedia             */
/*  [email-masked]   /   http://incomedia.eu                       */
/*******************************************************************/

---

From: Eric Johnson <[email-masked]>
Date: Fri, 9 Aug 2013 20:29:29 +0000

This doesn't strike me as a URI, so much as a string that follows - almost - the URI syntax.

In any event, the documentation below strikes me as insufficient. Especially the semantics part doesn't make it even the slightest bit clear as to why a new URI scheme might be useful, and if it is useful, how to use it. As near as I can tell, the "feedready:https://..." form contains exactly the same information and semantics as just doing "https://..."

Eric

Sent from my iPad

On Aug 9, 2013, at 3:25 AM, "Mirko Nosenzo" <[email-masked]> wrote:

> _______________________________________________
> Uri-review mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/uri-review

---

From: Mirko Nosenzo <[email-masked]>
Date: Tue, 13 Aug 2013 14:20:39 +0200

Hi Ted,
feedready:// uses http but by using feedready:<absolute_uri> the user can specify a different protocol.
Actually the app supports http and https only.

Since the resource is simply downloaded, the fragment is ignored.

Thanks,
Mirko

Il giorno 12/ago/2013, alle ore 19:31, Ted Hardie <[email-masked]> ha scritto:

> Howdy,
> 
> The core of the registration seems to be this
> 
> Scheme syntax:
> feedready as a scheme with a 3986 hierarchical part seems to be pretty easy to parse. I'm a little concerned, though, about the other form, which apparently takes an unescaped URI as an argument but is presented as if it were a hier-part.  Does this get used with anything other than http and https?  You're also sure that this can never be used with a fragment?
> 
> regards,
> 
> Ted

---

From: Larry Masinter <[email-masked]>
Date: Tue, 13 Aug 2013 07:34:50 -0700

With respect to the requested registration of "feedready:":

It's hard to distinguish this kind of registration from a "vanity publication". Making some simple substitutions, for example (I didn't make any significant changes to the submitted registration besides name substitution):

Resource Identifier (RI) Scheme name: larrymasinter 

Status: provisional

Scheme syntax:
   larrymasinter:<absolute_uri> or larrymasinter://<hierarchical part>
   examples: larrymasinter://example.com/rss.xml and larrymasinter:https://example.com/rss.xml

Scheme semantics:
   LarryMasinter is an imaginary application invented by Larry Masinter, seeking kickstarter funding!

Encoding considerations:
   Unknown, use with care.

Applications/protocols that use this scheme name:
   LarryMasinter application

Security considerations:
   Unknown, use with care.
   
Contact:
   Registering party: Larry Masinter [email-masked]

 Scheme creator: LarryMasinter

References:
   http://larry.masinter.net

---

From: Mark Baker <[email-masked]>
Date: Tue, 13 Aug 2013 12:58:29 -0400

I note that this is a provisional registration, so the "demonstrated
utility" requirement doesn't apply at the same strength as permanent
registration.

Following the provisional template, there's a few tidbits of
information that should be provided (security considerations, chief
amoungst them IMO). But I'm also personally of the opinion that any
form of provisional registration is better than none.

FWIW, I also note the similarity to the abandoned "feed" URI scheme
from Microsoft some years ago.

Mark.