Subject: Re: [weirds] [Jcardcal] LABEL parameter for ADR (Was: vcard example in http://tools.ietf.org/html/draft-ietf-weirds-json-response-03)

From: Pieter Vandepitte <[email-masked]>
Date: Thu, 13 Jun 2013 10:45:30 +0200

Sorry to come back on this one... I can't always keep up with all mails

I was currently changing my code to support vcardArray, but I think the
examples in draft-ietf-weirds-json-response-04 are wrong

Currently in the draft:

     "vcardArray":[
       "vcard",
       [ /* the vcard */ ]
     ]

so the vcard array is an array of 2 elements with vcardArray[0] ==
"vcard" and vcardArray[1] == the vcard itself?

What if multiple vcards are provided? How would it look then?

     /* silly */
     "vcardArray":[
       "vcard",
       [ /* the vcard 1 */ ],
       "vcard",
       [ /* the vcard 2 */ ],
     ]

or like this?
     "vcardArray":[
       "vcard", // <---- this is useless
       [ /* vcard 1 */ ],
       [ /* vcard 2 */ ],
     ]

Wouldn't it be better to completely follow jcard? i.e. make a 'stream'
of vcards (section 3.2) and perhaps call the property name 'vcards'
(ending with 's' like 'entities', 'roles', 'remarks', 'links',...)

   "vcards": ["vcardstream",
     ["vcard",
       [ /* properties */ ]
     ],
     ["vcard",
       [ /* properties */ ]
     ],
     ...
   ]

Pieter

On 05/08/2013 09:12 PM, Ernie Dainow wrote:
> 
> On 5/1/2013 8:38 PM, Michael Angstadt wrote:
>> @Pete: The syntax of the jCards in your examples aren't *quite*
>> correct.  The first element of the jCard array is the string "vcard".
>> The second element is an array which contains all of the property
>> arrays.  The "vcard" string is redundant in this context, since the
>> object field already uses this name, but I am just thinking that
>> parsers might have trouble parsing the jCard without it.  The examples
>> should look like this:
>>
>> {
>>    "handle" : "XXXX",
>>    "vCard" :
>>    [
>>      "vcard",
>>      [
>>        [ "version", {}, "text", "4.0" ],
>>        [ "fn", {}, "text", "Joe Bob, Inc." ],
>>        ...
>>      ]
>>    ]
>>
>> Thanks,
>> Mike
>>
> 
> For RDAP, this is confusing and prone to reversal and case errors. We
> should use a different name, as in
> 
> {
>   "handle" : "XXXX",
>   "vcardArray" :
>   [
>     "vcard",
>     [
> 
> 
> -Ernie
> 
> _______________________________________________
> weirds mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/weirds

-- 
*Pieter Vandepitte*
*Software Engineer*
+32 16 29 89 27
*www.dnsbelgium.be* <http://www.dnsbelgium.be/>

---

From: Simon Perreault <[email-masked]>
Date: Thu, 13 Jun 2013 11:36:53 +0200

>     "vcards": ["vcardstream",

yes, or allow either vcardstream or vcard:

"vcard": ["vcard", [ /*properties*/ ]],

or

"vcard": ["vcardstream", ["vcard", [ /*properties*/ ], ...]],

After all, the point of "vcard" vs "vcardstream" is precisely to be able 
to determine what comes next.

Simon

---

From: Andy Newton <[email-masked]>
Date: Thu, 13 Jun 2013 10:29:10 +0000

>Sorry to come back on this one... I can't always keep up with all mails

Better to get this hammered out now, right? :)

>What if multiple vcards are provided? How would it look then?

So the examples (and descriptive prose) aren't wrong, its just that the
draft only supports one vCard per entity. What is the use case for
multiple vCard's per entity? A vCard can already have multiple names,
multiple addresses, multiple phone numbers, multiple emails, etc. I would
think having multiple vCards is not necessary and could be a bit
confusing. Maybe Simon could tell us what the original intent is for vCard
streams. Is it so that multiple vCards can represent one person or org, or
was it just to have a way to serialize multiple vCards for such purposes
as transferring a contact database from one computer to another?

-andy

---

From: Simon Perreault <[email-masked]>
Date: Thu, 13 Jun 2013 13:36:16 +0200

Le 2013-06-13 12:29, Andy Newton a écrit :
> Maybe Simon could tell us what the original intent is for vCard

Philipp would be the best person to answer this question.

Simon

---

From: Philipp Kewisch <[email-masked]>
Date: Thu, 13 Jun 2013 14:31:41 +0200

> Philipp would be the best person to answer this question.
Sorry, seems I missed this mail. Its meant for the latter, serializing 
multiple vCards for transfer.

Philipp