Subject: [weirds] links type

From: Ernie Dainow <[email-masked]>
Date: Tue, 25 Jun 2013 13:21:23 -0400

The links type field is currently specified as optional 
(json-response-04, p.8). If the link is to an RDAP object and the client 
uses it without the correct media type, it may not get a json response. 
A client can generally assume a "self" link is to an RDAP object and 
include an Accept: header field with application/rdap+json, but wouldn't 
it minimize inter-op problems to require the type on links to RDAP 
objects, if not on all links.

-Ernie

---

From: Andy Newton <[email-masked]>
Date: Thu, 27 Jun 2013 11:58:03 +0000

>objects, if not on all links.

Ernie,

I agree and was thinking about proposing the same thing.

:)

-andy