Subject: [weirds] a couple of enhancements to json-response

From: Andy Newton <[email-masked]>
Date: Fri, 18 Apr 2014 16:54:17 +0000

During IETF 89, there were some private discussions regarding an RIR-scoped extension to json-response. Since we seem to be a little stalled, perhaps we should go ahead and put this is the next rev. given that this proposal adds no new object classes. Here’s what we are thinking:

1. Add “network” to domain for the representation of the IP network for which the domain exists in the reverse DNS. Both ARIN and RIPE do this today:

{
     "handle" : "XXX",
     "ldhName" : “123.in-addr.arpa",
     ...
     "nameServers" :
     [
       ...
     ],
     ...
     "entities" :
     [
       ...
     ],

     ...
     “network” :
     {
     ...
     }    
}

2. Add “domains” to IP network to represent the domains of the revers DNS upon which a network maps into. This is the converse of the above, and done by some RIRs today:

{
     "handle" : "XXX",
     ...
     "entities" :
     [
       ...
     ],
     …
     “domains” :
     [
        ….
     ]
}

3.  Add “networks” and “autnums” to entity, as some of the RIRs do this today.

Of course, this brings up this question: Should there be a “domains” for DNRs?

In both cases, it is quite possible to get an entity that exceeds a size policy limit. And for that, see #4

4. Change the “searchResultsTruncated” in Section 9 to a more general “resultsTruncated” applicable to both searches and lookups.

Comments, questions?

-andy

---

From: "John Levine" <[email-masked]>
Date: 20 Apr 2014 16:19:50 -0000

In article <[email-masked]> you write:
>During IETF 89, there were some private discussions regarding an RIR-scoped extension to json-response. Since we seem
>to be a little stalled, perhaps we should go ahead and put this is the next rev. given that this proposal adds no new
>object classes.

Keeping in mind that I'm not an RIR nor an RIR member so perhaps my
opinion is not of the greatest relevance, it looks at worst harmless,
so sure, go ahead.

>Of course, this brings up this question: Should there be a “domains” for DNRs?

The usual answer, not unless we have someone who plans to implement it.

R's,
John