Subject: Re: [weirds] #25 (rdap-query): Clarify what is done with unsupported queries

From: "Hollenbeck, Scott" <[email-masked]>
Date: Mon, 14 Apr 2014 10:57:08 +0000

> -----Original Message-----
> From: weirds issue tracker [mailto:[email-masked]]
> Sent: Monday, April 14, 2014 3:20 AM
> To: [email-masked]; [email-masked]
> Cc: [email-masked]
> Subject: [weirds] #25 (rdap-query): Clarify what is done with
> unsupported queries
> 
> #25: Clarify what is done with unsupported queries
> 
>  Issue raised in London:
> 
>  The query document should explain what a server does when it receives
> a
>  query it doesn't understand (unsupported query type?).

Would it be sufficient to provide a reference to this text from the using-http document?

"5.4.  Malformed Queries

   If a server receives a query which it cannot interpret as an RDAP
   query, it returns a 400 response code.  Optionally, it MAY include
   additional information regarding this negative answer in the HTTP
   entity body."

Scott

---

From: "Murray S. Kucherawy" <[email-masked]>
Date: Mon, 14 Apr 2014 11:05:26 -0700

On Mon, Apr 14, 2014 at 3:57 AM, Hollenbeck, Scott <[email-masked]
> wrote:

>    additional information regarding this negative answer in the HTTP

Does that include the unknown types?  I would think such a query is still
recognizable as an RDAP query, just with a type that isn't locally
supported.

-MSK

---

From: "Hollenbeck, Scott" <[email-masked]>
Date: Mon, 14 Apr 2014 19:00:49 +0000

From: Murray S. Kucherawy [mailto:[email-masked]]
Sent: Monday, April 14, 2014 2:05 PM
To: Hollenbeck, Scott
Cc: [email-masked]
Subject: Re: [weirds] #25 (rdap-query): Clarify what is done with unsupported queries

On Mon, Apr 14, 2014 at 3:57 AM, Hollenbeck, Scott <[email-masked]<mailto:[email-masked]>> wrote:
Would it be sufficient to provide a reference to this text from the using-http document?

"5.4.  Malformed Queries

Does that include the unknown types?  I would think such a query is still recognizable as an RDAP query, just with a type that isn't locally supported.
[SAH] It could include both unknown types and malformed query syntax, neither of which are valid queries because they can’t be interpreted. The text I add to rdap-query could make it clear that this is how to respond to all queries that can’t be recognized as one of the defined types.

Scott

---

From: "Murray S. Kucherawy" <[email-masked]>
Date: Mon, 14 Apr 2014 12:50:13 -0700

On Mon, Apr 14, 2014 at 12:00 PM, Hollenbeck, Scott <
[email-masked]> wrote:

>    *From:* Murray S. Kucherawy [mailto:[email-masked]]
> *Sent:* Monday, April 14, 2014 2:05 PM
> *To:* Hollenbeck, Scott
> *Cc:* [email-masked]
> *Subject:* Re: [weirds] #25 (rdap-query): Clarify what is done with
> unsupported queries
>
>
>
> On Mon, Apr 14, 2014 at 3:57 AM, Hollenbeck, Scott <
> [email-masked]> wrote:
>
> [SAH] It could include both unknown types and malformed query syntax,
> neither of which are valid queries because they can’t be interpreted. The
> text I add to rdap-query could make it clear that this is how to respond to
> all queries that can’t be recognized as one of the defined types.
>
>
>

That works if we're not interested in (i.e., there is no benefit to)
distinguishing between syntactically invalid queries vs. unsupported query
types.  Is that the case here?

I'm not trying to lead us in one direction or the other; I just want the
reasoning to be explicit.

-MSK

---

From: "John Levine" <[email-masked]>
Date: 14 Apr 2014 22:22:42 -0000

>recognizable as an RDAP query, just with a type that isn't locally

It seems unlikely that a server would know the difference between an
type that exists but it doesn't support and a random string,
particularly if new query types are added down the road.  Code 400
seems adequate for either.

If we're telling people what codes to use, from my reading of RFC
2616, a well formed query that the server can't answer, e.g., asking
about an entity handle that doesn't exist or a pattern that matches
nothing, gets a 404.

A query for something that needs authentication, e.g., registrant's address
and phone for registries that protect them, gets 401.

There might be a few others, maybe 416 for unsupported media type if
the query asks for XML and the server only does JSON and XML.

R's,
John

---

From: "Murray S. Kucherawy" <[email-masked]>
Date: Mon, 14 Apr 2014 17:15:44 -0700

> seems adequate for either.

I guess I'm envisioning a query that includes a string like
"...?type=foobar..." where the server receiving the query parses the URI
and doesn't understand what a "foobar" is, but the rest is valid.  To my
mind that's semantics, not syntax; "foobar" fits the ABNF, but isn't known.

---

From: "John Levine" <[email-masked]>
Date: 15 Apr 2014 02:03:20 -0000

>mind that's semantics, not syntax; "foobar" fits the ABNF, but isn't known.

For a query, it's the "type" the server has to understand, and
"foobar" is a search query.  But also remember that many (most?) web
servers parse up the query string and the application typically ignores
the fields it doesn't understand.  So if you send:

/search?pickle=dill

and there's no "pickle" search, it'll in effect see this:

/search

and that's just ill formed.

R's,
John