Subject: Re: [weirds] Inter-Op discrepancy with specs: Search patterns

From: "Murray S. Kucherawy" <[email-masked]>
Date: Mon, 14 Apr 2014 00:40:09 -0700

On Wed, Mar 19, 2014 at 12:37 AM, Hollenbeck, Scott <
[email-masked]> wrote:

> (Sorry for top posting)
>
> What Andy said below is correct.
>
> Scott
>
> > On Mar 19, 2014, at 10:03 AM, "Andy Newton" <[email-masked]> wrote:
> >
> > On 3/18/14, 8:49 PM, "John Levine" <[email-masked]> wrote:
> >
> >>> The spec gives an explicit example for xxx*:
> >>>     the search pattern "exam*" will match "example.com" and
> >>> "example.net".
> >>
> >> If that's what the spec says, the spec needs to be fixed.
> >>
> >> The intention is to match what current WHOIS servers do, which is a
> >> prefix match on whatever data the server handles.  Nobody expects it
> >> to go searching other servers.
> >
> > I don¹t think searching other servers was ever the intent. The purpose of
> > this is to allow one query to search both .com and .net (or whatever) if
> > that server handles both .com and .net (or whatever).
>

Is there a text change that needs to be made here to clarify this?  Or do
we agree it's fine as-is?

-MSK

---

From: "Hollenbeck, Scott" <[email-masked]>
Date: Mon, 14 Apr 2014 10:52:04 +0000

From: Murray S. Kucherawy [mailto:[email-masked]]
Sent: Monday, April 14, 2014 3:40 AM
To: Hollenbeck, Scott
Cc: Andy Newton; John Levine; [email-masked]
Subject: Re: [weirds] Inter-Op discrepancy with specs: Search patterns

On Wed, Mar 19, 2014 at 12:37 AM, Hollenbeck, Scott <[email-masked]<mailto:[email-masked]>> wrote:
(Sorry for top posting)

Scott

> On Mar 19, 2014, at 10:03 AM, "Andy Newton" <[email-masked]<mailto:[email-masked]>> wrote:
>
> On 3/18/14, 8:49 PM, "John Levine" <[email-masked]<mailto:[email-masked]>> wrote:
>
>>>     the search pattern "exam*" will match "example.com<http://example.com>" and
>>> "example.net<http://example.net>".
>>

Is there a text change that needs to be made here to clarify this?  Or do we agree it's fine as-is?
[SAH] I should probably change the text. I'll do that when I get in there to make the changes needed after the bootstrap document is updated to describe query patterns.

Scott