Subject: Re: [weirds] #12 (bootstrap): Bootstrap templates

From: "Murray S. Kucherawy" <[email-masked]>
Date: Sun, 13 Apr 2014 23:58:38 -0700

This ticket is (I believe) for settling the format of the deserialized IANA
registry content.

The last thing I had on the whiteboard in London looked like this:

{
    "weirds": {
        "DEFAULT": {
            "ip": "template-for-IP-query",
            "entity": "template-for-entity",
            "domain": "template-for-domain",
        },
        "ca": {
            "ip": null,
            "entity": "specific-template-for-ca-entity",
            "domain": "template-for-ca-domain",
        },
    },
}

So for a lookup matching ".ca" (anything in that zone, since there's
nothing more specific), a domain lookup would use the template
"template-for-ca-domain", and a lookup for an entity would use the template
"template-for-ca-entity"; a lookup for an IP address doesn't make sense
inside ".ca", so it's null here.  If any of those were undefined, it would
fall back to the corresponding entry in the DEFAULT record.

We would need to identify some number of substitution tokens to be used in
each type of query.  The obvious ones are "{domain}" for domain queries and
"{entity}" for entity queries.  The RIR folks will need to make some
suggestions about what lookup keys would look like for their RDAP servers
so they can be included.

Are there other query types we need to support?

Does this format look reasonable, or could it be optimized some other way?
I think there were some suggestions at the mic in London.

-MSK

---

From: "Hollenbeck, Scott" <[email-masked]>
Date: Mon, 14 Apr 2014 11:03:03 +0000

From: weirds [mailto:[email-masked]] On Behalf Of Murray S. Kucherawy
Sent: Monday, April 14, 2014 2:59 AM
To: [email-masked]
Subject: Re: [weirds] #12 (bootstrap): Bootstrap templates

This ticket is (I believe) for settling the format of the deserialized IANA registry content.

{
    "weirds": {
        "DEFAULT": {
            "ip": "template-for-IP-query",
            "entity": "template-for-entity",
            "domain": "template-for-domain",
        },
        "ca": {
            "ip": null,
            "entity": "specific-template-for-ca-entity",
            "domain": "template-for-ca-domain",
        },
    },
}
So for a lookup matching ".ca" (anything in that zone, since there's nothing more specific), a domain lookup would use the template "template-for-ca-domain", and a lookup for an entity would use the template "template-for-ca-entity"; a lookup for an IP address doesn't make sense inside ".ca", so it's null here.  If any of those were undefined, it would fall back to the corresponding entry in the DEFAULT record.
We would need to identify some number of substitution tokens to be used in each type of query.  The obvious ones are "{domain}" for domain queries and "{entity}" for entity queries.  The RIR folks will need to make some suggestions about what lookup keys would look like for their RDAP servers so they can be included.

Are there other query types we need to support?
[SAH] I'd much rather use "rdap" instead of the weirds working group name in the template.
The query types are listed in rdap-query: ip, autnum, domain, nameserver, entity, and help.
Scott

---

From: "John Levine" <[email-masked]>
Date: 14 Apr 2014 15:30:02 -0000

>suggestions about what lookup keys would look like for their RDAP servers

The keys are all in draft-ietf-weirds-rdap-query-10.

Lookup: ip autnum domain nameserver entity help

Search: domains nameservers entities

I'd suggest doing it this way:

{
        "DEFAULT": {
	    "prefix": "http://rdap.nic.{domain}",
            "lookup": "/{type}/{value}",
            "search": "/{type}?{subtype}={value}"
       },
       "ca": {
            "prefix": "http://rdap.cira.ca"
	    # uses the default paths
       },
       "hockey": {
	    # no prefix, included in the patterns
            "lookup": "http://rdap.donuts.co/hockey?{type}={value}",
            "search": "http://rdap.donuts.co/hockey/search/{type}?{subtype}={value}"
       },
}

There's a separate list of lookup and search types and subtypes:

Lookup types and values:
------------------------
ip		IP or CIDR
autnum		ASN
domain		Domain name
nameserver	Nameserver name
entity		Entity handle
help		Help text, value is optional

Search types, subtypes, and values:
-----------------------------------
domains	name	Search for domains by name prefix
nameservers	name	Search for nameservers by name prefix
nameservers	ip	Search for nameservers by IP
entities	fn	Search for entities by full name
entities	handle	Search for entities by handle

R's,
John

---

From: "John Levine" <[email-masked]>
Date: 20 Apr 2014 16:21:14 -0000

>This ticket is (I believe) for settling the format of the deserialized IANA

Both the format and the contents.

Who's holding the pen on this?  I'd have thought it was Marc.  If not,
I can do it but not right away.

R's,
John

---

From: Marc Blanchet <[email-masked]>
Date: Sun, 20 Apr 2014 16:07:38 -0400

Le 2014-04-20 à 12:21, John Levine <[email-masked]> a écrit :

> Who's holding the pen on this?  I'd have thought it was Marc.

yes. I have a local modified copy of the bootstrap that I shall publish soon. I had some variation of what Murray was suggesting.

Marc.

>  If not,
> _______________________________________________
> weirds mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/weirds