Subject: [Suit] Notes from Virtual Meeting on 19 Feb 2020

From: Russ Housley <[email-masked]>
Date: Wed, 19 Feb 2020 10:39:16 -0500

Chairs reminded participants of the NOTE WELL.

Brendan talked about a few manifest-related lessons from the Hackathon.  See slides.

- Attestations need to be defined, but they should be done in the RATS WG
- To assist with EdDSA and some post-quantum signatures, the signed portion of manifest payload will be an algorithm identifier and a hash value of the manifest contents
- Seems to be a need for a minimal loop operation

Emmanuel Baccelli talked about the Hackaton experience for the RIOT team.  See slides.

David Brown talked adding support for the SUIT manifest to MCUboot.  See info here: https://github.com/siot-hackathon/siot-hackathon.github.io/wiki/SUIT-and-MCUboot

Yuichi Takita talked about adding support for the SUIT manifest to a trusted execution environment.  See info here: https://github.com/siot-hackathon/siot-hackathon.github.io/wiki/SUIT-parser-running-on-OP%E2%80%90TEE

- A pseudo-TA was used, so the untrusted code and the trusted application code are delivered as one bundle

Emmanuel Baccelli (on behalf of Aydogan Ersoz) talked about the SUIT Integrate t_cose to RIOT OS.  See info here: https://github.com/siot-hackathon/siot-hackathon.github.io/wiki/SUIT---Integrate-t_cose-to-RIOT-OS

12  people plan to attend the IETF 107 Hackathon, and 4 plan to be at the SUIT table.

---

From: Emmanuel Baccelli <[email-masked]>
Date: Thu, 20 Feb 2020 11:47:04 +0100

Hi there,

> Emmanuel Baccelli talked about the Hackaton experience for the RIOT team.
To be precise: actually it was Kaspar Schleiser who talked, instead of me ;)
And for convenience: the contents of the slides are also mostly on the wiki
at
https://github.com/siot-hackathon/siot-hackathon.github.io/wiki/Update-SUIT-implementation-in-RIOT

>
> Emmanuel Baccelli (on behalf of Aydogan Ersoz) talked about the SUIT
> Integrate t_cose to RIOT OS.  See info here:
> https://github.com/siot-hackathon/siot-hackathon.github.io/wiki/SUIT---Integrate-t_cose-to-RIOT-OS
>
>
Same here: Kaspar talked, instead of me.

Cheers

Emmanuel